DCRF32: 首页

DCRF32
DCRF32 文档

关于

本接口用于支持多款型号的读写器，接口功能支持包含：
1、联机通讯部分 - 串口、USB、PCSC（自定义协议）、蓝牙等。
2、卡片部分 - 非接触卡（CPU卡、逻辑加密卡）、接触式卡（CPU卡、逻辑加密卡）、磁条卡、身份证卡等。
3、设备部分 - 蜂鸣器、液晶显示、蓝牙（单/双模）/GPRS/CDMA/WIFI/4G通讯、2.4G通讯、NFC通讯、设备存储、密码键盘等。

注意：
接口功能支持包含的部分不一定所有设备都支持，可能一些设备只支持接口功能的某一部分。


DCRF32: 安装/配置

安装/配置

目录

  • 在Windows平台下安装/配置
  • 在Linux平台下安装/配置

首先，请确保dcrf32库及其依赖库已经获取，不同平台下的库名称可能不同。

在Windows平台下安装/配置

使用引入库静态加载调用dcrf32.dll（只支持msvc编译器）：

  • 编译时需要使用dcrf32.h、dcrf32.lib。
  • 运行时请确保dcrf32.dll在库可被搜寻目录中。
  • 身份证相片解码库wltrs_getbmp.dll请放到库可被搜寻目录中或dcrf32.dll的工作目录中，此工作目录可以使用 LibMain 来指定，缺省为dcrf32.dll同一目录。

使用动态加载直接调用dcrf32.dll（支持多种编译器）：

  • 编译时需要参照dcrf32.h来声明用到的接口。
  • 运行时请确保dcrf32.dll在指定目录中，如果未指定目录，请确保dcrf32.dll在库可被搜寻目录中。
  • 身份证相片解码库wltrs_getbmp.dll请放到dcrf32.dll的工作目录中，此工作目录可以使用 LibMain 来指定，缺省为dcrf32.dll同一目录。

在Linux平台下安装/配置

使用编译指令静态加载调用libdcrf32.so：

  • 编译时需要使用dcrf32.h、libdcrf32.so。
  • 运行时请确保libdcrf32.so在库可被搜寻目录中。
  • 身份证相片解码库libwlt.so请放到库可被搜寻目录中或libdcrf32.so的工作目录中，此工作目录可以使用 LibMain 来指定，缺省为""。

使用代码调用动态加载直接调用libdcrf32.so（支持多种编译器）：

  • 编译时需要参照dcrf32.h来声明用到的接口。
  • 运行时请确保libdcrf32.so在指定目录中，如果未指定目录，请确保libdcrf32.so在库可被搜寻目录中。
  • 身份证相片解码库libwlt.so请放到libdcrf32.so的工作目录中，此工作目录可以使用 LibMain 来指定，缺省为""。


DCRF32: 开发指南

开发指南

目录

  • 设备打开和关闭操作
  • 设备基础功能操作
  • 设备指示灯操作
  • 设备蜂鸣器操作
  • 设备LED灯操作
  • 设备液晶显示操作
  • 接触式CPU卡操作
  • 射频复位操作
  • Type A非接触式CPU卡操作
  • Type B非接触式CPU卡操作
  • S50/S70卡操作
  • ULight/ULight C卡操作
  • DesFire卡操作
  • MIFAREPLUS卡操作
  • 身份证操作
  • 港澳台通行证操作
  • 磁条卡操作
  • 4442卡
  • 4428卡
  • 24C系列卡
  • 设备打印机操作
  • 内置二维码
  • 工具函数

本篇目标是针对常用功能作出一些开发的指引，更加细节描述可能需要参考相关的标准或规范性文件及其第三方资料。

设备打开和关闭操作

dc_init
dc_exit
示例：
HANDLE icdev;
icdev = dc_init(100, 115200);//打开usb端口设备，波特率设置无效
if ((int)icdev <= 0)
{
    MessageBox(0, "Init Com Error!", "", MB_OK);
    return;
}
else
{
    MessageBox(0, "Init Com OK!", "", MB_OK);
}
int st = -1;
st = dc_exit(icdev);
if (st != 0)
    MessageBox(_T("dc_exit Error!"));
else
    MessageBox(_T("dc_exit OK!"));

设备基础功能操作

dc_getver
dc_readdevsnr
dc_srd_eeprom
dc_swr_eeprom
示例：
int st = -1;
unsigned char buff[1024] = "\0";
char tmp[1024]= "\0";
st = dc_getver(icdev, buff);
if (st)
    MessageBox(_T("dc_getver Erro"));
else
{
    sprintf((char *)tmp, "读写器版本为:%s", buff);
    MessageBox(tmp);
}

memset(buff,0x00,sizeof(buff));
st = dc_readdevsnr(icdev, buff);
if (st)
    MessageBox(_T("dc_readdevsnr Erro"));
else
{
    MessageBox(buff);
}

memset(buff,0x00,sizeof(buff));
st = dc_srd_eeprom(icdev, 32, 50, buff);
if (st)
    MessageBox(_T("dc_srd_eeprom Erro"));
else
{
    MessageBox(buff);
}

memset(buff,0x00,sizeof(buff));
for(int i = 0 ; i < 50 ; i++)
    buff[i] = 0x30+i;
st = dc_swr_eeprom(icdev, 32, 50, buff);
if (st)
    MessageBox(_T("dc_swr_eeprom Erro"));
else
{
    MessageBox(_T("dc_swr_eeprom Ok"));
}

设备指示灯操作

dc_ctlled
示例：
int st = -1;
char tmp[1024]= "\0";
st = dc_ctlled(icdev, 0,0);
if (st)
    MessageBox(_T("dc_ctlled Erro"));
else
{
    MessageBox(_T("dc_ctlled Ok"));
}

设备蜂鸣器操作

dc_beep
示例：
int st = -1;
st = dc_beep(icdev, 10);
if (st)
{
    MessageBox(_T("dc_beep Error!"));
    return;
}
else
{
    MessageBox(_T("dc_beep Ok!"));
}

设备LED灯操作

dc_LedDisplay
dc_LedControl
示例：
int st = -1;
st = dc_LedDisplay(icdev, 5, 0, 3);
if (st != 0)
{
    MessageBox(_T("dc_LedDisplay Error!"));
    return;
}
else
{
    MessageBox(_T("dc_LedDisplay Ok!"));
}

st = dc_LedControl(icdev, 0);
if (st != 0)
{
    MessageBox(_T("dc_LedControl Error!"));
    return;
}
else
{
    MessageBox(_T("dc_LedControl Ok!"));
}

设备液晶显示操作

dc_lcdclrscrn
dc_dispinfo
dc_ctlbacklight
示例：
int st = -1;
st = dc_lcdclrscrn(icdev, 1);
if (st != 0)
{
    MessageBox(_T("dc_lcdclrscrn Error!"));
    return;
}
else
{
    MessageBox(_T("dc_lcdclrscrn Ok!"));
}

st = dc_dispinfo(icdev, 1, 0, "123456");
if (st != 0)
{
    MessageBox(_T("dc_dispinfo Error!"));
    return;
}
else
{
    MessageBox(_T("dc_dispinfo Ok!"));
}

st = dc_ctlbacklight(icdev, 0);
if (st != 0)
{
    MessageBox(_T("dc_ctlbacklight Error!"));
    return;
}
else
{
    MessageBox(_T("dc_ctlbacklight Ok!"));
}

接触式CPU卡操作

dc_setcpu
dc_cpureset
dc_cpuapduInt
示例：
int st = -1;
st = st = dc_setcpu(icdev, 0x0D);
if (st != 0)
{
    MessageBox(_T("dc_setcpu Error!"));
    return;
}
else
{
    MessageBox(_T("dc_setcpu Ok!"));
}

unsigned char rlen = 0;
unsigned char recdata[512] = "\0";
st = dc_cpureset(icdev, &rlen, recdata);
if (st != 0)
{
    MessageBox(_T("dc_cpureset Error!"));
    return;
}
else
{
    MessageBox(recdata);
}

unsigned int rlen1 = 0;
memset(recdata, 0x00, sizeof(recdata));
st = dc_cpuapduInt(icdev, 5, (unsigned char *)"\x00\x84\x00\x00\x08", &rlen1, recdata);
if (st != 0)
{
    MessageBox(_T("dc_cpuapduInt Error!"));
    return;
}
else
{
    MessageBox(recdata);
}

射频复位操作

dc_reset
示例：
int st = -1;
st = dc_reset(icdev, 1);
if (st)
{
    MessageBox(_T("dc_reset Error!"));
    return;
}
else
{
    MessageBox(_T("dc_reset Ok!"));
}

Type A非接触式CPU卡操作

dc_config_card
dc_card_n
dc_pro_resetInt
dc_pro_commandlinkInt
示例：
int st = -1;
st = dc_config_card(icdev, 'A');
if (st)
{
    MessageBox(_T("dc_config_card Error!"));
    return;
}
else
{
    MessageBox(_T("dc_config_card Ok!"));
}
unsigned char _Snr[100] = "\0";
unsigned int SnrLen = 0;
st = dc_card_n(icdev, 0, &SnrLen, _Snr);
if (st != 0)
{
    MessageBox(_T("dc_card_n Error!"));
}
else
{
    MessageBox(_Snr);
}
unsigned char rcardlen = 0;
unsigned int rlen = 0;
unsigned char databuffer[100] = "\0";
st = dc_pro_resetInt(icdev, &rcardlen, databuffer);
if (st != 0)
{
    MessageBox(_T("dc_pro_resetInt Error!"));
}
else
{
    MessageBox(databuffer);
}
st = dc_pro_commandlinkInt(icdev, 5, (unsigned char*)"\x00\x84\x00\x00\x08", &rlen, databuffer, 10);
if (st != 0)
{
    MessageBox(_T("dc_pro_commandlinkInt Error!"));
}
else
{
    MessageBox(databuffer);
}

Type B非接触式CPU卡操作

dc_config_card
dc_card_b
dc_pro_commandlinkInt
示例：
st = dc_config_card(icdev, 'B');
st = dc_card_b(icdev, _Snr);
if (st != 0)
{
    MessageBox(_T("dc_card_b Error!"));
}
else
{
    MessageBox(szSnr);
}
unsigned int rlen = 0;
unsigned char databuffer[100] = "\0";
st = dc_pro_commandlinkInt(icdev, 5, (unsigned char*)"\x00\x84\x00\x00\x08", &rlen, databuffer, 10);
if (st != 0)
{
    MessageBox("dc_pro_commandlinkInt Error!"));
}
else
{
    MessageBox(databufferhex);
}

S50/S70卡操作

dc_config_card
dc_card_n
dc_authentication_passaddr
dc_read
dc_write
dc_restore
dc_transfer
dc_increment
dc_decrement
dc_initval
dc_readval
示例：
int st = -1;
st = dc_config_card(icdev, 'A');
if (st)
{
    MessageBox(_T("dc_config_card Error!"));
    return;
}
else
{
    MessageBox(_T("dc_config_card Ok!"));
}
unsigned char _Snr[100] = "\0";
unsigned int SnrLen = 0;
st = dc_card_n(icdev, 0, &SnrLen, _Snr);
if (st != 0)
{
    MessageBox(_T("dc_card_n Error!"));
}
else
{
    MessageBox(_Snr);
}
st = dc_authentication_passaddr(icdev, 0, 7, (unsigned char *)"\xFF\xFF\xFF\xFF\xFF\xFF");
if (st != 0)
{
    MessageBox("dc_authentication_passaddr Error!"));
}
else
    MessageBox("dc_authentication_passaddr OK!");
//写扇区
st = dc_write(icdev, 4, (unsigned char*)"\x31\x32\x33\x34\x35\x36\x37\x38\x39\x30\x31\x32\x33\x34\x35\x36");
if (st != 0)
{
    MessageBox("dc_write Error!");
}
else
    MessageBox("dc_write OK!");
unsigned char rdata[100] = "\0";
//读扇区
st = dc_read(icdev, 4, rdata);
if (st != 0)
{
    MessageBox("dc_read Error!");
}
else
{
    MessageBox(rdata);
}

ULight/ULight C卡操作

dc_card_n
dc_read
dc_write
dc_auth_ulc
dc_changekey_ulc
示例：
int st = -1;
unsigned char _Snr[100] = "\0";
unsigned int SnrLen = 0;
st = dc_card_n(icdev, 0, &SnrLen, _Snr);
if (st != 0)
{
    MessageBox(_T("dc_card_n Error!"));
}
else
{
    MessageBox(_Snr);
}
st = dc_auth_ulc(icdev,(unsigned char *)"\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF");
if (st != 0)
{
    MessageBox("dc_auth_ulc Error!"));
}
else
    MessageBox("dc_auth_ulc OK!");
//写扇区
st = dc_write(icdev, 4, (unsigned char*)"\x31\x32\x33\x34");
if (st != 0)
{
    MessageBox("dc_write Error!");
}
else
    MessageBox("dc_write OK!");
unsigned char rdata[100] = "\0";
//读扇区
st = dc_read(icdev, 4, rdata);
if (st != 0)
{
    MessageBox("dc_read Error!");
}
else
{
    MessageBox(rdata);
}
st = dc_changekey_ulc(icdev,(unsigned char *)"\x31\x32\x33\x34\x35\x36\x37\x38\x39\x30\x31\x32\x33\x34\x35\x36");
if (st != 0)
{
    MessageBox("dc_changekey_ulc Error!"));
}
else
    MessageBox("dc_changekey_ulc OK!");

DesFire卡操作

dc_card_n
dc_pro_resetInt
dc_pro_commandlinkInt
示例：
int st = -1;
unsigned char _Snr[100] = "\0";
unsigned int SnrLen = 0;
st = dc_card_n(icdev, 0, &SnrLen, _Snr);
if (st != 0)
{
    MessageBox(_T("dc_card_n Error!"));
}
else
{
    MessageBox(_Snr);
}
unsigned char rcardlen = 0;
unsigned int rlen = 0;
unsigned char databuffer[100] = "\0";
st = dc_pro_resetInt(icdev, &rcardlen, databuffer);
if (st != 0)
{
    MessageBox(_T("dc_pro_resetInt Error!"));
}
else
{
    MessageBox(databuffer);
}
st = dc_pro_commandlinkInt(icdev, 5, (unsigned char*)"\x00\x84\x00\x00\x08", &rlen, databuffer, 10);
if (st != 0)
{
    MessageBox(_T("dc_pro_commandlinkInt Error!"));
}
else
{
    MessageBox(databuffer);
}

MIFAREPLUS卡操作

dc_card_n
dc_pro_resetInt
dc_MFPL0_writeperso
dc_MFPL0_commitperso
dc_MFPL1_authl1key
dc_MFPL1_switchtol2
dc_MFPL1_switchtol3
dc_MFPL2_switchtol3
dc_MFPL3_authl3key
dc_MFPL3_authl3sectorkey
dc_MFPL3_writeinplain
dc_MFPL3_readinplain
dc_MFPL3_writeencrypted
dc_MFPL3_readencrypted
dc_read
dc_write
示例：
int st = -1;
unsigned char _Snr[100] = "\0";
unsigned int SnrLen = 0;
st = dc_card_n(icdev, 0, &SnrLen, _Snr);
if (st != 0)
{
    MessageBox(_T("dc_card_n Error!"));
}
else
{
    MessageBox(_Snr);
}
unsigned char rcardlen = 0;
unsigned int rlen = 0;
unsigned char databuffer[100] = "\0";
st = dc_pro_resetInt(icdev, &rcardlen, databuffer);
if (st != 0)
{
    MessageBox(_T("dc_pro_resetInt Error!"));
}
else
{
    MessageBox(databuffer);
}
st = dc_MFPL0_writeperso(icdev, 0x9000, (unsigned char *)"\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF");
if (st)
{
    MessageBox(_T("dc_MFPL0_writeperso_hex ERRO!"));
}
else
{     MessageBox(_T("dc_MFPL0_writeperso_hex Ok!"));
}
//0到1级
st = dc_MFPL0_commitperso(icdev);
if (st != 0)
{
    MessageBox(_T("dc_MFPL0_commitperso Error!"));
}
else
{
    MessageBox(_T("dc_MFPL0_commitperso ok!"));
}
//验证一级密钥
st = dc_MFPL1_authl1key(icdev, (unsigned char *)"\xFF\xFF\xFF\xFF");
if (st != 0)
{
    MessageBox(_T("dc_MFPL1_authl1key Error!"));
}
else
{
    MessageBox(_T("dc_MFPL1_authl1key ok!"));
}
//1级升2级
st = dc_MFPL1_switchtol2(icdev);
if (st != 0)
{
    MessageBox(_T("dc_MFPL1_switchtol2 Error!"));
}
else
{
    MessageBox(_T("dc_MFPL1_switchtol2 ok!"));
}
//1级升3级
st = dc_MFPL1_switchtol3(icdev, (unsigned char *)"\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF");
if (st != 0)
{
    MessageBox(_T("dc_MFPL1_switchtol3 Error!"));
}
else
{
    MessageBox(_T("dc_MFPL1_switchtol3 ok!"));
}
//2级升3级
st = dc_MFPL2_switchtol3(icdev, (unsigned char *)"\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF");
if (st != 0)
{
    MessageBox(_T("dc_MFPL2_switchtol3 Error!"));
}
else
{
    MessageBox(_T("dc_MFPL2_switchtol3 ok!"));
}
st = dc_MFPL3_authl3key(icdev, 0x9000, (unsigned char *)"\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF\xFF");
if(st != 0)
{
    MessageBox(_T("dc_MFPL3_authl3key Error!"));
}
else
{
    MessageBox(_T("dc_MFPL3_authl3key ok!"));
}
st = dc_MFPL3_writeencrypted(icdev, m_uKeyIndex, 1, (unsigned char *)"\x31\x32\x33\x34\x35\x36\x37\x38\x39\x30\x31\x32\x33\x34\x35\x36", 0);
if(st != 0)
{
    MessageBox(_T("dc_MFPL3_writeencrypted Error!"));
}
else
{
    MessageBox(_T("dc_MFPL3_writeencrypted ok!"));
}
st = dc_MFPL3_authl3sectorkey(icdev, 0, 2, (unsigned char *)"\x31\x32\x33\x34\x35\x36\x37\x38\x39\x30\x31\x32\x33\x34\x35\x36");
if(st != 0)
{
    MessageBox(_T("dc_MFPL3_authl3sectorkey Error!"));
}
else
{
    MessageBox(_T("dc_MFPL3_authl3sectorkey ok!"));
}
st = dc_MFPL3_writeinplain(icdev, nStartAddr, nBlocks, "\x31\x32\x33\x34\x35\x36\x37\x38\x39\x30\x31\x32\x33\x34\x35\x36");
if(st != 0)
{
    MessageBox(_T("dc_MFPL3_writeinplain Error!"));
}
else
{
    MessageBox(_T("dc_MFPL3_writeinplain ok!"));
}
st = dc_MFPL3_readinplain(icdev, nStartAddr, nBlocks, rData);
if(st != 0)
{
    MessageBox(_T("dc_MFPL3_readinplain Error!"));
}
else
{
    MessageBox(_T("dc_MFPL3_readinplain ok!"));
}
st = dc_MFPL3_writeencrypted(icdev, nStartAddr, nBlocks, rData);
if(st != 0)
{
    MessageBox(_T("dc_MFPL3_writeencrypted Error!"));
}
else
{
    MessageBox(_T("dc_MFPL3_writeencrypted ok!"));
}
st = dc_MFPL3_readencrypted(icdev, nStartAddr, nBlocks, rData);
if(st != 0)
{
    MessageBox(_T("dc_MFPL3_readencrypted Error!"));
}
else
{
    MessageBox(_T("dc_MFPL3_readencrypted ok!"));
}

身份证操作

dc_SamAReadCardInfo
dc_ParseTextInfo
dc_ParseTextInfoForForeigner
dc_ParsePhotoInfo
dc_ParseOtherInfo
示例：
short st;
int text_len;
unsigned char text[256];
int photo_len;
unsigned char photo[1024];
int fingerprint_len;
unsigned char fingerprint[1024];
int extra_len;
unsigned char extra[70];
int type = 0;
char tempbuffer[1024] = "\0";
st = dc_SamAReadCardInfo(icdev, 3, &text_len, text, &photo_len, photo, &fingerprint_len, fingerprint, &extra_len, extra);
if (st != 0)
{
    MessageBox(_T("dc_SamAReadCardInfo error!\n"));
    return;
}
MessageBox(_T("dc_SamAReadCardInfo ok!\n"));
switch (text[248]) {
    case 'I':
    type = 1;
    break;
    case 'J':
    type = 2;
    break;
}
if (type == 0)
{
    unsigned char name[64];
    unsigned char sex[8];
    unsigned char nation[12];
    unsigned char birth_day[36];
    unsigned char address[144];
    unsigned char id_number[76];
    unsigned char department[64];
    unsigned char expire_start_day[36];
    unsigned char expire_end_day[36];
    unsigned char reserved[76];
    unsigned char info_buffer[64];
    MessageBox(_T("dc_ParseTextInfo ... \n"));
    st = dc_ParseTextInfo(icdev, 0, text_len, text, name, sex, nation, birth_day, address, id_number, department, expire_start_day, expire_end_day, reserved);
    if (st != 0)
    {
     MessageBox(_T("dc_ParseTextInfo error!\n"));
     return;
    }
    MessageBox(_T("dc_ParseTextInfo ok!\n"));
}
else if (type == 1)
{
    unsigned char english_name[244];
    unsigned char sex[8];
    unsigned char id_number[64];
    unsigned char citizenship[16];
    unsigned char chinese_name[64];
    unsigned char expire_start_day[36];
    unsigned char expire_end_day[36];
    unsigned char birth_day[36];
    unsigned char version_number[12];
    unsigned char department_code[20];
    unsigned char type_sign[8];
    unsigned char reserved[16];
    unsigned char info_buffer[64];
    MessageBox(_T("dc_ParseTextInfoForForeigner ... \n"));
    st = dc_ParseTextInfoForForeigner(icdev, 0, text_len, text, english_name, sex, id_number, citizenship, chinese_name, expire_start_day, expire_end_day, birth_day, version_number, department_code, type_sign, reserved);
    if (st != 0)
    {
     MessageBox(_T("dc_ParseTextInfoForForeigner error!\n"));
     return;
    }
    MessageBox(_T("dc_ParseTextInfoForForeigner ok!\n"));
}
MessageBox(_T("dc_ParsePhotoInfo ... \n"));
st = dc_ParsePhotoInfo(icdev, 0, photo_len, photo, 0, (unsigned char *)"me.bmp");
if (st != 0)
{
    MessageBox(_T("dc_ParsePhotoInfo error!\n"));
    return;
}
MessageBox(_T("dc_ParsePhotoInfo ok!\n"));

港澳台通行证操作

dc_SamAReadCardInfo
dc_ParseTextInfoForHkMoTw
dc_ParsePhotoInfo
示例：
short st;
int text_len;
unsigned char text[256];
int photo_len;
unsigned char photo[1024];
int fingerprint_len;
unsigned char fingerprint[1024];
int extra_len;
unsigned char extra[70];
int type = 0;
char tempbuffer[1024] = "\0";
st = dc_SamAReadCardInfo(icdev, 3, &text_len, text, &photo_len, photo, &fingerprint_len, fingerprint, &extra_len, extra);
if (st != 0)
{
    MessageBox(_T("dc_SamAReadCardInfo error!\n"));
    return;
}
MessageBox(_T("dc_SamAReadCardInfo ok!\n"));
switch (text[248]) {
    case 'I':
    type = 1;
    break;
    case 'J':
    type = 2;
    break;
}
if (type == 2)
{
    unsigned char name[64];
    unsigned char sex[8];
    unsigned char nation[12];
    unsigned char birth_day[36];
    unsigned char address[144];
    unsigned char id_number[76];
    unsigned char department[64];
    unsigned char expire_start_day[36];
    unsigned char expire_end_day[36];
    unsigned char reserved[76];
    unsigned char info_buffer[64];
    MessageBox(_T("dc_ParseTextInfoForHkMoTw ... \n"));
    st = dc_ParseTextInfoForHkMoTw(handle, 0, text_len, text, name, sex, reserved, birth_day, address, id_number, department, expire_start_day, expire_end_day, pass_number, sign_count, reserved2, type_sign, reserved3);
    if (st != 0)
    {
     MessageBox(_T("dc_ParseTextInfoForHkMoTw error!\n"));
     return;
    }
    MessageBox(_T("dc_ParseTextInfoForHkMoTw ok!\n"));
}
MessageBox(_T("dc_ParsePhotoInfo ... \n"));
st = dc_ParsePhotoInfo(icdev, 0, photo_len, photo, 0, (unsigned char *)"me.bmp");
if (st != 0)
{
    MessageBox(_T("dc_ParsePhotoInfo error!\n"));
    return;
}
MessageBox(_T("dc_ParsePhotoInfo ok!\n"));

磁条卡操作

dc_readmagcardall
示例：
short st = -1;
unsigned char t1[1024]={0}, t2[1024]={0}, t3[1024]={0};
unsigned int l1, l2, l3;
st = dc_readmagcardall(icdev, 30, t1, &l1, t2, &l2, t3, &l3);
if(st!=0)
{
    MessageBox(_T("dc_readmagcardall Error!"));
}
else
{
    MessageBox(_T("dc_readmagcardall Ok!"));
}

4442卡

dc_setcpu
dc_CheckCard
dc_verifypin_4442
dc_changepin_4442
dc_read_4442
dc_write_4442
dc_writeprotect_4442
dc_readwrotect_4442
dc_readpincount_4442
dc_readpin_4442
示例：
int st = -1;
st = dc_setcpu(icdev,0x0C);
if (st != 0)
{
    MessageBox("dc_setcpu Error!"));
}
else
    MessageBox("dc_setcpu OK!");
short cardtype = dc_CheckCard(icdev);
if (cardtype==8)
{
    MessageBox("dc_CheckCard OK!");
}
else
    MessageBox("dc_CheckCard Erro!");
st = dc_verifypin_4442(icdev,(unsigned char *)"\xFF\xFF\xFF");
if (st != 0)
{
    MessageBox("dc_verifypin_4442 Error!"));
}
else
    MessageBox("dc_verifypin_4442 OK!");
short icount = dc_readpincount_4442(icdev);
if (icount < 0)
{
    MessageBox("dc_readpincount_4442 Error!"));
}
else
    MessageBox("dc_readpincount_4442 OK!");
//写数据
st = dc_write_4442(icdev, 32, 4, (unsigned char*)"\x31\x32\x33\x34");
if (st != 0)
{
    MessageBox("dc_write_4442 Error!");
}
else
    MessageBox("dc_write_4442 OK!");
unsigned char rdata[100] = "\0";
//读数据
st = dc_readwrotect_4442(icdev, 32, 4, rdata);
if (st != 0)
{
    MessageBox("dc_readwrotect_4442 Error!");
}
else
{
    MessageBox(rdata);
}
//写保护数据
st = dc_writeprotect_4442(icdev, 32, 4, (unsigned char*)"\x31\x32\x33\x34");
if (st != 0)
{
    MessageBox("dc_writeprotect_4442 Error!");
}
else
    MessageBox("dc_writeprotect_4442 OK!");
unsigned char rdata[100] = "\0";
//读保护数据
st = dc_readwrotect_4442(icdev, 32, 4, rdata);
if (st != 0)
{
    MessageBox("dc_readwrotect_4442 Error!");
}
else
{
    MessageBox(rdata);
}
st = dc_changepin_4442(icdev,(unsigned char *)"\x31\x32\x33");
if (st != 0)
{
    MessageBox("dc_changepin_4442 Error!"));
}
else
    MessageBox("dc_changepin_4442 OK!");

4428卡

dc_setcpu
dc_CheckCard
dc_verifypin_4428
dc_changepin_4428
dc_read_4428
dc_write_4428
dc_writeprotect_4428
dc_readprotect_4428
dc_readpincount_4428
dc_readpin_4428
示例：
int st = -1;
st = dc_setcpu(icdev,0x0C);
if (st != 0)
{
    MessageBox("dc_setcpu Error!"));
}
else
    MessageBox("dc_setcpu OK!");
short cardtype = dc_CheckCard(icdev);
if (cardtype == 9)

{
    MessageBox("dc_CheckCard OK!");
}
else
    MessageBox("dc_CheckCard Erro!");
st = dc_verifypin_4428(icdev,(unsigned char *)"\xFF\xFF");
if (st != 0)
{
    MessageBox("dc_verifypin_4428 Error!"));
}
else
    MessageBox("dc_verifypin_4428 OK!");
short icount = dc_readpincount_4428(icdev);
if (icount < 0)
{
    MessageBox("dc_readpincount_4428 Error!"));
}
else
    MessageBox("dc_readpincount_4428 OK!");
//写数据
st = dc_write_4428(icdev, 32, 4, (unsigned char*)"\x31\x32\x33\x34");
if (st != 0)
{
    MessageBox("dc_write_4428 Error!");
}
else
    MessageBox("dc_write_4428 OK!");
unsigned char rdata[100] = "\0";
//读数据
st = dc_read_4428(icdev, 32, 4, rdata);
if (st != 0)
{
    MessageBox("dc_read_4428 Error!");
}
else
{
    MessageBox(rdata);
}
//写保护数据
st = dc_writeprotect_4428(icdev, 32, 2, (unsigned char*)"\x31\x32");
if (st != 0)
{
    MessageBox("dc_writeprotect_4428 Error!");
}
else
    MessageBox("dc_writeprotect_4428 OK!");
unsigned char rdata[100] = "\0";
//读保护数据
st = dc_readprotect_4428(icdev, 32, 2, rdata);
if (st != 0)
{
    MessageBox("dc_readprotect_4428 Error!");
}
else
{
    MessageBox(rdata);
}
st = dc_changepin_4428(icdev,(unsigned char *)"\x31\x32");
if (st != 0)
{
    MessageBox("dc_changepin_4428 Error!"));
}
else
    MessageBox("dc_changepin_4428 OK!");

24C系列卡

dc_setcpu
dc_CheckCard
dc_read_24c
dc_write_24c
示例：
int st = -1;
st = dc_setcpu(icdev,0x0C);
if (st != 0)
{
    MessageBox("dc_setcpu Error!"));
}
else
    MessageBox("dc_setcpu OK!");
short cardtype = dc_CheckCard(icdev);
if ((cardtype>20)&&(cardtype>27))
{
    MessageBox("dc_CheckCard OK!");
}
else
    MessageBox("dc_CheckCard Erro!");
unsigned char rdata[100] = "\0";
//读数据
st = dc_write_24c(icdev, 32, 4, "\x31\x32\x33\x34");
if (st != 0)
{
    MessageBox("dc_write_24c Error!");
}
else
{
    MessageBox("dc_write_24c OK!");
}
//读数据
st = dc_read_24c(icdev, 32, 4, rdata);
if (st != 0)
{
    MessageBox("dc_read_24c Error!");
}
else
{
    MessageBox(rdata);
}

设备打印机操作

dc_setprint
dc_checkprint
dc_printcharacter
dc_printOnedimensional
dc_printPicture
dc_printenter
dc_printstatus
示例：
int st = -1;
st = dc_setprint(m_icdev,0,0,0,0,0,0);
if(st != 0)
{
    MessageBox("dc_setprint Erro");
    return;
}
MessageBox("dc_setprint OK");
unsigned char fontsize = 0;
unsigned char alignment = 0;
unsigned char leftmargin = 0;
unsigned char rightmargin = 0;
unsigned char rowpitch = 0;
unsigned char PrintOutRate = 0;
st = dc_checkprint(m_icdev, &fontsize, &alignment,&leftmargin,&rightmargin,&rowpitch,&PrintOutRate);
if(st)
{
    MessageBox("dc_checkprint Erro");
    return;
}
MessageBox("dc_checkprint OK");
unsigned char paperstatus = 0;
unsigned char tempturestatus = 0;
unsigned char zkstatus = 0;
st = dc_printstatus(m_icdev,&paperstatus,&tempturestatus,&zkstatus);
if(st)
{
    MessageBox("打印机状态错误");
    return;
}
if(paperstatus)
{
    MessageBox("打印机缺纸");
    return;
}
if(tempturestatus)
{
    MessageBox("打印机温度过高");
    return;
}
switch(zkstatus)
{
case 1:
    MessageBox("打印机字库缺失");
    return;
case 2:
    MessageBox("三种字库都不存在");
    return;
case 3:
    MessageBox("只有8*16字符库");
    return;
case 4:
    MessageBox("只有12*24字符库");
    return;
case 5:
    MessageBox("只有16*32字符库");
    return;
case 6:
    MessageBox("有8*16和12*24字符库");
    return;
case 7:
    MessageBox("有8*16和16*32字符库");
    return;
case 8:
    MessageBox("有12*24和16*32字符库");
    return;
}
MessageBox("打印机状态正常");
st = dc_printcharacter(m_icdev,7,"ABCDef1");
if(st != 0)
{
    MessageBox("打印字符错误");
    return;
}
st = dc_printenter(m_icdev,120);
if(st != 0)
{
    MessageBox("打印回车错误");
    return;
}
st = dc_printOnedimensional(m_icdev,10,1,0,9,"abcED1234");
if(st != 0)
{
    MessageBox("打印一维码错误");
    return;
}
unsigned char picturedata1050[1000000]; st = dc_printPicture(m_icdev,20,50,01,20,20,500,picturedata1050);
if(st!= 0)
{
    MessageBox("打印图片错误");
    return;
}

内置二维码

dc_Scan2DBarcodeStart
dc_Scan2DBarcodeGetData
dc_Scan2DBarcodeExit
示例：
int result;
unsigned char buffer[8192], buffer2[8192 + 1];
int len;
int times = GetDlgItemInt(IDC_EDIT2, NULL, FALSE);
times *= 1000;
int ms;
result = dc_Scan2DBarcodeStart(icdev, 0x00);
if (result != 0)
{
    SetDlgItemText(IDC_EDIT1, (char *)"启动失败");
    return;
}
while (true)
{
    ms = GetTickCount();
    Sleep(10);
    result = dc_Scan2DBarcodeGetData(icdev, &len, buffer);
    if (result == 0)
    {
    break;
    }
    if ((times -= (GetTickCount() - ms)) <= 0)
    {
    result = -2;
    }
}
dc_Scan2DBarcodeExit(icdev);
if (result == 0)
{
    memcpy(buffer2, buffer, len);
    buffer2[len] = '\0';
    SetDlgItemText(IDC_EDIT1, (char *)buffer2);
}
else if (result == -2)
{
    SetDlgItemText(IDC_EDIT1, (char *)"超时");
}

工具函数

hex_a
a_hex
dc_des
dc_tripledes
示例：
int st = -1;
unsigned char rdata[100] = "\0";
hex_a("\x31\x32\x33\x34\x35\x36\x37\x38\x39\x30\x31\x32\x33\x34\x35\x36", rdatahex, 16);//rdatahex:31323334353637383930313233343536
unsigned char rdatahex[100] = "\0";
a_hex("31323334353637383930313233343536", rdatahex, 32);//rdatahex:1234567890123456

unsigned char desdata[100] = "\0";
st = dc_des("\x11\x22\x33\x44\x55\x66\x77\x88", "\x31\x32\x33\x34\x35\x36\x37\x38", desdata, 1);//加密
if(st == 0)
    MessageBox("dc_des加密成功");
st = dc_des("\x11\x22\x33\x44\x55\x66\x77\x88", "\x31\x32\x33\x34\x35\x36\x37\x38", desdata, 0);//解密
if(st == 0)
    MessageBox("dc_des解密成功");

unsigned char tripledes[100] = "\0";
st = dc_tripledes("\x11\x22\x33\x44\x55\x66\x77\x88\x88\x77\x66\x55\x44\x33\x22\x11", "\x31\x32\x33\x34\x35\x36\x37\x38", tripledes, 1);//加密
if(st == 0)
    MessageBox("dc_tripledes加密成功");
st = dc_tripledes"\x11\x22\x33\x44\x55\x66\x77\x88\x88\x77\x66\x55\x44\x33\x22\x11", "\x31\x32\x33\x34\x35\x36\x37\x38", tripledes, 0);//解密
if(st == 0)
    MessageBox("dc_tripledes解密成功");


DCRF32: 文件列表

文件列表
这里列出了所有文档化的文件，并附带简要说明:
dcrf32.h 读写器功能接口声明文件。


DCRF32: dcrf32.h 文件参考

函数
dcrf32.h 文件参考

读写器功能接口声明文件。 更多...

浏览源代码.

函数

void USER_API | LibMain (int flag, void *context)
库入口。 更多...
void USER_API | dc_config_port_name (short port, const char *name)
配置端口名称。 更多...
HANDLE USER_API | dc_init (short port, int baud)
打开设备。 更多...
HANDLE USER_API | dc_init_name (short port, int baud, const char *name)
打开设备。 更多...
short USER_API | dc_exit (HANDLE icdev)
关闭设备。 更多...
short USER_API | dc_getname (HANDLE icdev, char *name)
获取名称。 更多...
short USER_API | dc_config (HANDLE icdev, unsigned char _Mode, unsigned char _Baud)
保留。
short USER_API | dc_request (HANDLE icdev, unsigned char _Mode, unsigned short *TagType)
寻卡请求。 更多...
short USER_API | dc_anticoll (HANDLE icdev, unsigned char _Bcnt, unsigned int *_Snr)
防卡冲突。 更多...
short USER_API | dc_select (HANDLE icdev, unsigned int _Snr, unsigned char *_Size)
选卡操作。 更多...
short USER_API | dc_authentication (HANDLE icdev, unsigned char _Mode, unsigned char _SecNr)
验证M1卡密码。 更多...
short USER_API | dc_halt (HANDLE icdev)
终止卡操作。 更多...
short USER_API | dc_read (HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
读卡数据。 更多...
short USER_API | dc_read_hex (HANDLE icdev, unsigned char _Adr, char *_Data)
读卡数据。 更多...
short USER_API | dc_write (HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
写卡数据。 更多...
short USER_API | dc_write_hex (HANDLE icdev, unsigned char _Adr, char *_Data)
写卡数据。 更多...
short USER_API | dc_write_TS (HANDLE icdev)
保留。
short USER_API | dc_load_key (HANDLE icdev, unsigned char _Mode, unsigned char _SecNr, unsigned char *_NKey)
装载设备密码。 更多...
short USER_API | dc_load_key_hex (HANDLE icdev, unsigned char _Mode, unsigned char _SecNr, char *_NKey)
装载设备密码。 更多...
short USER_API | dc_card (HANDLE icdev, unsigned char _Mode, unsigned int *_Snr)
寻卡请求、防卡冲突、选卡操作。 更多...
short USER_API | dc_card_hex (HANDLE icdev, unsigned char _Mode, unsigned char *snrstr)
寻卡请求、防卡冲突、选卡操作。 更多...
short USER_API | dc_changeb3 (HANDLE icdev, unsigned char _SecNr, unsigned char *_KeyA, unsigned char _B0, unsigned char _B1, unsigned char _B2, unsigned char _B3, unsigned char _Bk, unsigned char *_KeyB)
M1卡密码配置块操作。 更多...
short USER_API | dc_changeb3_hex (HANDLE icdev, unsigned char _SecNr, const char *_KeyA, unsigned char _B0, unsigned char _B1, unsigned char _B2, unsigned char _B3, unsigned char _Bk, const char *_KeyB)
M1卡密码配置块操作。 更多...
short USER_API | dc_restore (HANDLE icdev, unsigned char _Adr)
M1卡值块回传。 更多...
short USER_API | dc_transfer (HANDLE icdev, unsigned char _Adr)
M1卡值块传递。 更多...
short USER_API | dc_increment (HANDLE icdev, unsigned char _Adr, unsigned int _Value)
M1卡值块加值。 更多...
short USER_API | dc_decrement (HANDLE icdev, unsigned char _Adr, unsigned int _Value)
M1卡值块减值。 更多...
short USER_API | dc_initval (HANDLE icdev, unsigned char _Adr, unsigned int _Value)
M1卡值块初始化。 更多...
short USER_API | dc_readval (HANDLE icdev, unsigned char _Adr, unsigned int *_Value)
M1卡值块读值。 更多...
short USER_API | dc_initval_ml (HANDLE icdev, unsigned short _Value)
ML卡值初始化。 更多...
short USER_API | dc_readval_ml (HANDLE icdev, unsigned short *_Value)
ML卡读值。 更多...
short USER_API | dc_decrement_ml (HANDLE icdev, unsigned short _Value)
ML卡减值。 更多...
short USER_API | dc_authentication_2 (HANDLE icdev, unsigned char _Mode, unsigned char KeyNr, unsigned char Adr)
验证M1卡密码。 更多...
short USER_API | dc_anticoll2 (HANDLE icdev, unsigned char _Bcnt, unsigned int *_Snr)
第二级防卡冲突。 更多...
short USER_API | dc_select2 (HANDLE icdev, unsigned int _Snr, unsigned char *_Size)
第二级选卡操作。 更多...
short USER_API | dc_HL_write (HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int *_Snr, unsigned char *_Data)
保留。
short USER_API | dc_HL_writehex (HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int *_Snr, unsigned char *_Data)
保留。
short USER_API | dc_HL_read (HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int _Snr, unsigned char *_Data, unsigned int *_NSnr)
保留。
short USER_API | dc_HL_readhex (HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int _Snr, unsigned char *_Data, unsigned int *_NSnr)
保留。
short USER_API | dc_HL_authentication (HANDLE icdev, unsigned char reqmode, unsigned int snr, unsigned char authmode, unsigned char secnr)
高层验证M1卡密码。 更多...
short USER_API | dc_check_write (HANDLE icdev, unsigned int Snr, unsigned char authmode, unsigned char Adr, unsigned char *_data)
检查之前写入的数据。 更多...
short USER_API | dc_check_writehex (HANDLE icdev, unsigned int Snr, unsigned char authmode, unsigned char Adr, unsigned char *_data)
检查之前写入的数据。 更多...
short USER_API | dc_getver (HANDLE icdev, unsigned char *sver)
获取设备版本。 更多...
short USER_API | dc_update (HANDLE icdev)
保留。
short USER_API | dc_clr_control_bit (HANDLE icdev, unsigned char _b)
保留。
short USER_API | dc_set_control_bit (HANDLE icdev, unsigned char _b)
保留。
short USER_API | dc_reset (HANDLE icdev, unsigned short _Msec)
复位射频。 更多...
short USER_API | dc_beep (HANDLE icdev, unsigned short _Msec)
设备蜂鸣。 更多...
short USER_API | dc_disp_str (HANDLE icdev, char *dispstr)
液晶显示。 更多...
short USER_API | dc_srd_eeprom (HANDLE icdev, short offset, short length, unsigned char *rec_buffer)
读EEPROM。 更多...
short USER_API | dc_swr_eeprom (HANDLE icdev, short offset, short length, unsigned char *send_buffer)
写EEPROM。 更多...
short USER_API | swr_alleeprom (HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写EEPROM。 更多...
short USER_API | srd_alleeprom (HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读EEPROM。 更多...
short USER_API | dc_srd_eepromhex (HANDLE icdev, short offset, short length, unsigned char *rec_buffer)
读EEPROM。 更多...
short USER_API | dc_swr_eepromhex (HANDLE icdev, short offset, short length, unsigned char *send_buffer)
写EEPROM。 更多...
short USER_API | dc_gettime (HANDLE icdev, unsigned char *time)
获取设备时间。 更多...
short USER_API | dc_gettimehex (HANDLE icdev, char *time)
获取设备时间。 更多...
short USER_API | dc_settime (HANDLE icdev, unsigned char *time)
设置设备时间。 更多...
short USER_API | dc_settimehex (HANDLE icdev, char *time)
设置设备时间。 更多...
short USER_API | dc_setbright (HANDLE icdev, unsigned char bright)
保留。
short USER_API | dc_ctl_mode (HANDLE icdev, unsigned char mode)
保留。
short USER_API | dc_disp_mode (HANDLE icdev, unsigned char mode)
保留。
short USER_API | dcdeshex (unsigned char *key, unsigned char *sour, unsigned char *dest, short m)
单DES加解密。 更多...
short USER_API | dcdes (unsigned char *key, unsigned char *sour, unsigned char *dest, short m)
单DES加解密。 更多...
short USER_API | dc_light (HANDLE icdev, unsigned short _OnOff)
指示灯点亮/熄灭。 更多...
short USER_API | dc_high_disp (HANDLE icdev, unsigned char offset, unsigned char displen, unsigned char *dispstr)
液晶显示。 更多...
short USER_API | dc_setcpu (HANDLE icdev, unsigned char _Byte)
设置当前接触式卡座。 更多...
short USER_API | dc_cpureset (HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡复位。 更多...
short USER_API | dc_cpuapdusource (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapdu (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpureset_hex (HANDLE icdev, unsigned char *rlen, char *databuffer)
接触式CPU卡复位。 更多...
short USER_API | dc_cpuapdusource_hex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapdu_hex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapdurespon (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapdurespon_hex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpudown (HANDLE icdev)
接触式CPU卡下电。 更多...
short USER_API | dc_set_addr (unsigned char saddr)
保留。
HANDLE USER_API | dc_init_485 (short port, int baud)
保留。
short USER_API | dc_changebaud_485 (HANDLE icdev, int baud)
保留。
short USER_API | dc_change_addr (HANDLE icdev, unsigned char saddr)
保留。
short USER_API | dc_pro_reset (HANDLE icdev, unsigned char *rlen, unsigned char *receive_data)
非接触式CPU卡复位。 更多...
short USER_API | dc_pro_command (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_resethex (HANDLE icdev, unsigned char *rlen, char *receive_data)
非接触式CPU卡复位。 更多...
short USER_API | dc_pro_resetInt (HANDLE icdev, unsigned char *rlen, unsigned char *receive_data)
非接触式CPU卡复位。 更多...
short USER_API | dc_pro_resetInt_hex (HANDLE icdev, unsigned char *rlen, char *receive_data)
非接触式CPU卡复位。 更多...
short USER_API | dc_pro_commandhex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandsource (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandsourcehex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandsource_int (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_halt (HANDLE icdev)
终止非接触式CPU卡操作。 更多...
short USER_API | dc_request_shc1102 (HANDLE icdev, unsigned char _Mode, unsigned short *TagType)
SHC1102卡寻卡请求。 更多...
short USER_API | dc_auth_shc1102 (HANDLE icdev, unsigned char *_Data)
验证SHC1102卡密码。 更多...
short USER_API | dc_read_shc1102 (HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
读SHC1102卡。 更多...
short USER_API | dc_write_shc1102 (HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
写SHC1102卡。 更多...
short USER_API | dc_halt_shc1102 (HANDLE icdev)
终止SHC1102卡操作。 更多...
short USER_API | hex_a (unsigned char *hex, unsigned char *a, short length)
数据转换。 更多...
short USER_API | a_hex (unsigned char *a, unsigned char *hex, short len)
数据转换。 更多...
short USER_API | dc_config_card (HANDLE icdev, unsigned char cardtype)
配置非接触卡类型。 更多...
short USER_API | dc_request_b (HANDLE icdev, unsigned char _Mode, unsigned char AFI, unsigned char N, unsigned char *ATQB)
寻卡请求。 更多...
short USER_API | dc_slotmarker (HANDLE icdev, unsigned char N, unsigned char *ATQB)
管道标记。 更多...
short USER_API | dc_attrib (HANDLE icdev, unsigned char *PUPI, unsigned char CID)
激活卡片。 更多...
short USER_API | dc_open_door (HANDLE icdev, unsigned char cflag)
保留。
short USER_API | dc_open_timedoor (HANDLE icdev, unsigned short utime)
保留。
short USER_API | dc_read_random (HANDLE icdev, unsigned char *data)
保留。
short USER_API | dc_write_random (HANDLE icdev, short length, unsigned char *data)
保留。
short USER_API | dc_read_random_hex (HANDLE icdev, unsigned char *data)
保留。
short USER_API | dc_write_random_hex (HANDLE icdev, short length, unsigned char *data)
保留。
short USER_API | dc_erase_random (HANDLE icdev, short length)
保留。
short USER_API | dc_mfdes_auth (HANDLE icdev, unsigned char keyno, unsigned char keylen, unsigned char *authkey, unsigned char *randAdata, unsigned char *randBdata)
Mifare Desfire卡认证。 更多...
short USER_API | dc_authentication_pass (HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff)
验证M1卡密码。 更多...
short USER_API | dc_disp_neg (HANDLE icdev, char *dispstr)
高层液晶显示。 更多...
short USER_API | dc_pro_commandlink (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandlink_hex (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_card_double (HANDLE icdev, unsigned char _Mode, unsigned char *_Snr)
寻卡请求、防卡冲突、选卡操作。 更多...
short USER_API | dc_card_double_hex (HANDLE icdev, unsigned char _Mode, unsigned char *_Snr)
寻卡请求、防卡冲突、选卡操作。 更多...
short USER_API | dc_read_idcard (HANDLE icdev, unsigned char times, unsigned char *_Data)
读ID卡。 更多...
short USER_API | dc_read_idcard_hex (HANDLE icdev, unsigned char times, unsigned char *_Data)
读取id卡。 更多...
short USER_API | dc_authentication_pass_hex (HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff)
验证M1卡密码。 更多...
short USER_API | dc_setcpupara (HANDLE icdev, unsigned char cputype, unsigned char cpupro, unsigned char cpuetu)
设置接触式CPU卡参数。 更多...
short USER_API | dc_command (HANDLE icdev, unsigned char cmd, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
保留。
short USER_API | dc_command_hex (HANDLE icdev, unsigned char cmd, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
保留。
short USER_API | dc_creat_mac (unsigned char KeyLen, unsigned char *Key, unsigned short DataLen, unsigned char *Data, unsigned char *InitData, unsigned char AutoFixFlag, unsigned char FixChar, unsigned char *MacData)
保留。
short USER_API | dc_creat_mac_hex (unsigned char KeyLen, unsigned char *Key, unsigned short DataLen, unsigned char *Data, unsigned char *InitData, unsigned char AutoFixFlag, unsigned char FixChar, unsigned char *MacData)
保留。
short USER_API | dc_creat_mac2 (HANDLE icdev, unsigned short DataLen, unsigned char *Data, unsigned char *MacData, unsigned char flag)
保留。
short USER_API | dc_creat_mac2_hex (HANDLE icdev, unsigned short DataLen, unsigned char *Data, unsigned char *MacData, unsigned char flag)
保留。
short USER_API | dc_encrypt (char *key, char *ptrSource, unsigned short msgLen, char *ptrDest)
保留。
short USER_API | dc_decrypt (char *key, char *ptrSource, unsigned short msgLen, char *ptrDest)
保留。
short USER_API | dc_encrypt_hex (char *key, char *ptrSource, unsigned short msgLen, char *ptrDest)
保留。
short USER_API | dc_decrypt_hex (char *key, char *ptrSource, unsigned short msgLen, char *ptrDest)
保留。
short USER_API | dc_HL_write_hex (HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int *_Snr, unsigned char *_Data)
保留。
short USER_API | dc_HL_read_hex (HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int _Snr, unsigned char *_Data, unsigned int *_NSnr)
保留。
short USER_API | dc_check_write_hex (HANDLE icdev, unsigned int Snr, unsigned char authmode, unsigned char Adr, unsigned char *_data)
检查之前写入的数据。 更多...
short USER_API | dc_srd_eeprom_hex (HANDLE icdev, short offset, short length, unsigned char *rec_buffer)
读EEPROM。 更多...
short USER_API | dc_swr_eeprom_hex (HANDLE icdev, short offset, short length, unsigned char *send_buffer)
写EEPROM。 更多...
short USER_API | dc_gettime_hex (HANDLE icdev, char *time)
获取设备时间。 更多...
short USER_API | dc_settime_hex (HANDLE icdev, char *time)
设置设备时间。 更多...
short USER_API | dc_des_hex (unsigned char *key, unsigned char *sour, unsigned char *dest, short m)
单DES加解密。 更多...
short USER_API | dc_des (unsigned char *key, unsigned char *sour, unsigned char *dest, short m)
单DES加解密。 更多...
short USER_API | dc_pro_reset_hex (HANDLE icdev, unsigned char *rlen, char *receive_data)
非接触式CPU卡复位。 更多...
short USER_API | dc_pro_command_hex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandsource_hex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_switch_unix (HANDLE icdev, int baud)
保留。
short USER_API | dc_authentication_passaddr (HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff)
验证M1卡密码。 更多...
short USER_API | dc_authentication_passaddr_hex (HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff)
验证M1卡密码。 更多...
short USER_API | dc_card_fm11rf005 (HANDLE icdev, unsigned char _Mode, unsigned int *_Snr)
寻FM11RF005卡。 更多...
short USER_API | dc_setusbtimeout (unsigned char ntimes)
保留。
short USER_API | dc_mfdes_baud (HANDLE icdev, unsigned char _Mode, unsigned char para)
保留。
short USER_API | dc_tripledes (unsigned char *key, unsigned char *src, unsigned char *dest, short m)
三DES加解密。 更多...
short USER_API | dc_tripledes_hex (unsigned char *key, unsigned char *src, unsigned char *dest, short m)
三DES加解密。 更多...
short USER_API | dc_mfdes_auth_hex (HANDLE icdev, unsigned char keyno, unsigned char keylen, unsigned char *authkey, unsigned char *randAdata, unsigned char *randBdata)
Mifare Desfire卡认证。 更多...
short USER_API | dc_pro_sendcommandsource (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char timeout)
保留。
short USER_API | dc_pro_receivecommandsource (HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
保留。
short USER_API | dc_inventory (HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char masklen, unsigned char *rlen, unsigned char *rbuffer)
保留。
short USER_API | dc_inventory_hex (HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char masklen, unsigned char *rlen, unsigned char *rbuffer)
保留。
short USER_API | dc_stay_quiet (HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
short USER_API | dc_stay_quiet_hex (HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
short USER_API | dc_select_uid (HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
short USER_API | dc_select_uid_hex (HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
short USER_API | dc_reset_to_ready (HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
short USER_API | dc_reset_to_ready_hex (HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
short USER_API | dc_readblock (HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
short USER_API | dc_readblock_hex (HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
short USER_API | dc_writeblock (HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char wlen, unsigned char *wbuffer)
保留。
short USER_API | dc_writeblock_hex (HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char wlen, unsigned char *wbuffer)
保留。
short USER_API | dc_lock_block (HANDLE icdev, unsigned char flags, unsigned char block, unsigned char *UID)
保留。
short USER_API | dc_lock_block_hex (HANDLE icdev, unsigned char flags, unsigned char block, unsigned char *UID)
保留。
short USER_API | dc_write_afi (HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID)
保留。
short USER_API | dc_write_afi_hex (HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID)
保留。
short USER_API | dc_lock_afi (HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID)
保留。
short USER_API | dc_lock_afi_hex (HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID)
保留。
short USER_API | dc_write_dsfid (HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID)
保留。
short USER_API | dc_write_dsfid_hex (HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID)
保留。
short USER_API | dc_lock_dsfid (HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID)
保留。
short USER_API | dc_lock_dsfid_hex (HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID)
保留。
short USER_API | dc_get_systeminfo (HANDLE icdev, unsigned char flags, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
short USER_API | dc_get_systeminfo_hex (HANDLE icdev, unsigned char flags, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
short USER_API | dc_get_securityinfo (HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
short USER_API | dc_get_securityinfo_hex (HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
short USER_API | dc_getsnr_fm11rf005 (HANDLE icdev, unsigned int *_Snr)
获取FM11RF005卡序列号。 更多...
short USER_API | dc_getsnr_fm11rf005_hex (HANDLE icdev, unsigned char *snrstr)
获取FM11RF005卡序列号。 更多...
short USER_API | dc_write_fm11rf005 (HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
写FM11RF005卡。 更多...
short USER_API | dc_read_fm11rf005 (HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
读FM11RF005卡。 更多...
short USER_API | dc_read_fm11rf005_hex (HANDLE icdev, unsigned char _Adr, char *_Data)
读FM11RF005卡。 更多...
short USER_API | dc_write_fm11rf005_hex (HANDLE icdev, unsigned char _Adr, char *_Data)
写FM11RF005卡。 更多...
short USER_API | DCDEV_CommandMcu (HANDLE icdev, unsigned char ctimeout, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
保留。
short USER_API | DCDEV_CommandMcu_Hex (HANDLE icdev, unsigned char ctimeout, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
保留。
short USER_API | dc_displcd (HANDLE icdev, unsigned char flag)
保留。
short USER_API | dc_getinputpass (HANDLE icdev, unsigned char ctime, unsigned char *rlen, unsigned char *cpass)
键盘密码输入。 更多...
short USER_API | dc_GetInputPass (HANDLE icdev, unsigned char ctime, unsigned char *rlen, unsigned char *cpass)
键盘密码输入。 更多...
short USER_API | dc_readmagcard (HANDLE icdev, unsigned char ctime, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len)
读磁条卡。 更多...
short USER_API | dc_writemagcard (HANDLE icdev, unsigned char ctime, unsigned char *pTrack1Data, unsigned char pTrack1Len, unsigned char *pTrack2Data, unsigned char pTrack2Len, unsigned char *pTrack3Data, unsigned char pTrack3Len)
写磁条卡。 更多...
short USER_API | dc_testdevicecomm (HANDLE icdev)
测试设备通讯。 更多...
short USER_API | dc_dispmainmenu (HANDLE icdev)
显示主界面。 更多...
short USER_API | dc_setdevicetime (HANDLE icdev, unsigned char year, unsigned char month, unsigned char date, unsigned char hour, unsigned char minute, unsigned char second)
设置设备时间。 更多...
short USER_API | dc_getdevicetime (HANDLE icdev, unsigned char *year, unsigned char *month, unsigned char *date, unsigned char *hour, unsigned char *minute, unsigned char *second)
获取设备时间。 更多...
short USER_API | dc_dispinfo (HANDLE icdev, unsigned char line, unsigned char offset, char *data)
液晶显示。 更多...
short USER_API | dc_dispmaininfo (HANDLE icdev, unsigned char offset, char *data)
液晶显示。 更多...
short USER_API | dc_posbeep (HANDLE icdev, unsigned char beeptime)
设备蜂鸣。 更多...
short USER_API | dc_ctlbacklight (HANDLE icdev, unsigned char cOpenFlag)
LCD背光控制。 更多...
short USER_API | dc_ctlled (HANDLE icdev, unsigned char cLed, unsigned char cOpenFlag)
指示灯控制。 更多...
short USER_API | dc_lcdclrscrn (HANDLE icdev, unsigned char cLine)
LCD清屏。 更多...
short USER_API | dc_passin (HANDLE icdev, unsigned char ctime)
进入读键盘模式。 更多...
short USER_API | dc_PassIn (HANDLE icdev, unsigned char ctime)
进入读键盘模式。 更多...
short USER_API | dc_passin2 (HANDLE icdev, unsigned char ctime, unsigned char ucmode, unsigned char *cardno)
进入读键盘模式。 更多...
short USER_API | dc_PassIn2 (HANDLE icdev, unsigned char ctime, unsigned char ucmode, unsigned char *cardno)
进入读键盘模式。 更多...
short USER_API | dc_passget (HANDLE icdev, unsigned char *rlen, unsigned char *cpass)
获取键盘数据。 更多...
short USER_API | dc_PassGet (HANDLE icdev, unsigned char *rlen, unsigned char *cpass)
获取键盘数据。 更多...
short USER_API | dc_passcancel (HANDLE icdev)
退出读键盘模式。 更多...
short USER_API | dc_PassCancel (HANDLE icdev)
退出读键盘模式。 更多...
short USER_API | dc_getinputkey (HANDLE icdev, unsigned char disptype, unsigned char line, unsigned char ctime, unsigned char *rlen, unsigned char *ckeydata)
获取键盘输入。 更多...
short USER_API | dc_displcd_ext (HANDLE icdev, unsigned char flag, unsigned char row, unsigned char offset)
保留。
short USER_API | dc_readmagcardall (HANDLE icdev, unsigned char ctime, unsigned char *pTrack1Data, unsigned int *pTrack1Len, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len)
读磁条卡。 更多...
short USER_API | dc_readdevsnr (HANDLE icdev, unsigned char *snr)
获取设备序列号。 更多...
short USER_API | dc_readreadersnr (HANDLE icdev, unsigned char *snr)
获取设备序列号。 更多...
short USER_API | dc_resetdevice (HANDLE icdev)
复位设备。 更多...
short USER_API | dc_setdevicebaud (HANDLE icdev, unsigned char baud)
设置串口设备通讯波特率。 更多...
short USER_API | dc_read_4442 (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡。 更多...
short USER_API | dc_read_4442_hex (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡。 更多...
short USER_API | dc_write_4442 (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4442卡。 更多...
short USER_API | dc_write_4442_hex (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4442卡。 更多...
short USER_API | dc_verifypin_4442 (HANDLE icdev, unsigned char *passwd)
验证4442卡密码。 更多...
short USER_API | dc_verifypin_4442_hex (HANDLE icdev, unsigned char *passwd)
验证4442卡密码。 更多...
short USER_API | dc_readpin_4442 (HANDLE icdev, unsigned char *passwd)
读4442卡密码。 更多...
short USER_API | dc_readpin_4442_hex (HANDLE icdev, unsigned char *passwd)
读4442卡密码。 更多...
short USER_API | dc_readpincount_4442 (HANDLE icdev)
读4442卡密码计数。 更多...
short USER_API | dc_changepin_4442 (HANDLE icdev, unsigned char *passwd)
修改4442卡密码。 更多...
short USER_API | dc_changepin_4442_hex (HANDLE icdev, unsigned char *passwd)
修改4442卡密码。 更多...
short USER_API | dc_readwrotect_4442 (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡保护位。 更多...
short USER_API | dc_readwrotect_4442_hex (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡保护位。 更多...
short USER_API | dc_readprotect_4442 (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡保护位。 更多...
short USER_API | dc_readprotect_4442_hex (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡保护位。 更多...
short USER_API | dc_writeprotect_4442 (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4442卡保护位。 更多...
short USER_API | dc_writeprotect_4442_hex (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4442卡保护位。 更多...
short USER_API | dc_write_24c (HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写24C系列卡。 更多...
short USER_API | dc_write_24c_hex (HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写24C系列卡。 更多...
short USER_API | dc_write_24c64 (HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写24C64系列卡。 更多...
short USER_API | dc_write_24c64_hex (HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写24C64系列卡。 更多...
short USER_API | dc_read_24c (HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读24C系列卡。 更多...
short USER_API | dc_read_24c_hex (HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读24C系列卡。 更多...
short USER_API | dc_read_24c64 (HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读24C64系列卡。 更多...
short USER_API | dc_read_24c64_hex (HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读24C64系列卡。 更多...
short USER_API | dc_read_4428 (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4428卡。 更多...
short USER_API | dc_read_4428_hex (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4428卡。 更多...
short USER_API | dc_write_4428 (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4428卡。 更多...
short USER_API | dc_write_4428_hex (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4428卡。 更多...
short USER_API | dc_verifypin_4428 (HANDLE icdev, unsigned char *passwd)
验证4428卡密码。 更多...
short USER_API | dc_verifypin_4428_hex (HANDLE icdev, unsigned char *passwd)
验证4428卡密码。 更多...
short USER_API | dc_readpin_4428 (HANDLE icdev, unsigned char *passwd)
读4428卡密码。 更多...
short USER_API | dc_readpin_4428_hex (HANDLE icdev, unsigned char *passwd)
读4428卡密码。 更多...
short USER_API | dc_readpincount_4428 (HANDLE icdev)
读4428卡密码计数。 更多...
short USER_API | dc_changepin_4428 (HANDLE icdev, unsigned char *passwd)
修改4428卡密码。 更多...
short USER_API | dc_changepin_4428_hex (HANDLE icdev, unsigned char *passwd)
修改4428卡密码。 更多...
short USER_API | dc_readprotect_4428 (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4428卡保护位。 更多...
short USER_API | dc_readprotect_4428_hex (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4428卡保护位。 更多...
short USER_API | dc_writeprotect_4428 (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4428卡保护位。 更多...
short USER_API | dc_writeprotect_4428_hex (HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4428卡保护位。 更多...
short USER_API | dc_Check_4442 (HANDLE icdev)
检测4442卡。 更多...
short USER_API | dc_Check_4428 (HANDLE icdev)
检测4428卡。 更多...
short USER_API | dc_Check_24C01 (HANDLE icdev)
检测24C01卡。 更多...
short USER_API | dc_Check_24C02 (HANDLE icdev)
检测24C02卡。 更多...
short USER_API | dc_Check_24C04 (HANDLE icdev)
检测24C04卡。 更多...
short USER_API | dc_Check_24C08 (HANDLE icdev)
检测24C08卡。 更多...
short USER_API | dc_Check_24C16 (HANDLE icdev)
检测24C16卡。 更多...
short USER_API | dc_Check_24C64 (HANDLE icdev)
检测24C64卡。 更多...
short USER_API | dc_Check_CPU (HANDLE icdev)
检测CPU卡。 更多...
short USER_API | dc_CheckCard (HANDLE icdev)
检测卡。 更多...
short USER_API | dc_getrcinfo (HANDLE icdev, unsigned char *info)
保留。
short USER_API | dc_getrcinfo_hex (HANDLE icdev, unsigned char *info)
保留。
short USER_API | dc_getlongver (HANDLE icdev, unsigned char *sver)
获取设备长版本。 更多...
short USER_API | dc_cardstr (HANDLE icdev, unsigned char _Mode, char *Strsnr)
寻卡请求、防卡冲突、选卡操作。 更多...
short USER_API | dc_cardAB (HANDLE icdev, unsigned char *rlen, unsigned char *rbuf, unsigned char *type)
寻Type A或Type B卡并激活。 更多...
short USER_API | dc_card_b (HANDLE icdev, unsigned char *rbuf)
寻Type B卡并激活。 更多...
short USER_API | dc_card_b_hex (HANDLE icdev, char *rbuf)
寻Type B卡并激活。 更多...
short USER_API | dc_dispinfo_T8 (HANDLE icdev, unsigned char line, unsigned char offset, char *data)
液晶显示。 更多...
short USER_API | dc_dispinfo_pro_T8 (HANDLE icdev, unsigned char offset, char *data)
液晶显示。 更多...
short USER_API | dc_clearlcd_T8 (HANDLE icdev, unsigned char line)
LCD清屏。 更多...
short USER_API | dc_led_T8 (HANDLE icdev, unsigned char cled, unsigned char cflag)
指示灯点亮/熄灭。 更多...
short USER_API | dc_dispmap_T8 (HANDLE icdev, unsigned char *mapdata)
保留。
short USER_API | dc_displow_T8 (HANDLE icdev, unsigned char rs, unsigned char cdata)
保留。
short USER_API | dc_rw_rfreg (HANDLE icdev, unsigned char flag, unsigned char _Adr, unsigned char *_Data)
读/写射频寄存器。 更多...
short USER_API | dc_rw_rfreg_hex (HANDLE icdev, unsigned char flag, unsigned char _Adr, unsigned char *_Data)
读/写射频寄存器。 更多...
short USER_API | dc_mulrequest_b (HANDLE icdev, unsigned char _Mode, unsigned char AFI, unsigned char *cardnum, unsigned char *mulATQB)
保留。
short USER_API | dc_hltb (HANDLE icdev, unsigned char *PUPI)
保留。
short USER_API | dc_set_poweroff (HANDLE icdev, unsigned int MsTimes, unsigned char TimerClock, unsigned char TimerReload)
保留。
short USER_API | dc_pro_commandsourceCRC (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char CRCSTU)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandsourceCRChex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout, unsigned char CRCSTU)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_MFPL0_writeperso (HANDLE icdev, unsigned int BNr, unsigned char *dataperso)
Mifare Plus卡设置个人化数据（0级）。 更多...
short USER_API | dc_MFPL0_writeperso_hex (HANDLE icdev, unsigned int BNr, unsigned char *dataperso)
Mifare Plus卡设置个人化数据（0级）。 更多...
short USER_API | dc_MFPL0_commitperso (HANDLE icdev)
Mifare Plus卡提交个人化数据（0级）。 更多...
short USER_API | dc_MFPL1_authl1key (HANDLE icdev, unsigned char *authkey)
验证Mifare Plus卡状态密码（1级）。 更多...
short USER_API | dc_MFPL1_authl1key_hex (HANDLE icdev, unsigned char *authkey)
验证Mifare Plus卡状态密码（1级）。 更多...
short USER_API | dc_MFPL1_switchtol2 (HANDLE icdev, unsigned char *authkey)
升级Mifare Plus卡状态到2级（1级）。 更多...
short USER_API | dc_MFPL1_switchtol3 (HANDLE icdev, unsigned char *authkey)
升级Mifare Plus卡状态到3级（1级）。 更多...
short USER_API | dc_MFPL2_switchtol3 (HANDLE icdev, unsigned char *authkey)
升级Mifare Plus卡状态到3级（2级）。 更多...
short USER_API | dc_MFPL3_authl3key (HANDLE icdev, unsigned int keyBNr, unsigned char *authkey)
验证Mifare Plus卡状态密码（3级）。 更多...
short USER_API | dc_MFPL3_authl3key_hex (HANDLE icdev, unsigned int keyBNr, unsigned char *authkey)
验证Mifare Plus卡状态密码（3级）。 更多...
short USER_API | dc_MFPL3_authl3sectorkey (HANDLE icdev, unsigned char mode, unsigned int sectorBNr, unsigned char *authkey)
验证Mifare Plus卡状态密码（3级）。 更多...
short USER_API | dc_MFPL3_authl3sectorkey_hex (HANDLE icdev, unsigned char mode, unsigned int sectorBNr, unsigned char *authkey)
验证Mifare Plus卡状态密码（3级）。 更多...
short USER_API | dc_MFPL3_readinplain (HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata)
读Mifare Plus卡数据（3级）。 更多...
short USER_API | dc_MFPL3_readinplain_hex (HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata)
读Mifare Plus卡数据（3级）。 更多...
short USER_API | dc_MFPL3_readencrypted (HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata, unsigned char flag)
加密模式读Mifare Plus卡数据（3级）。 更多...
short USER_API | dc_MFPL3_readencrypted_hex (HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata, unsigned char flag)
加密模式读Mifare Plus卡数据（3级）。 更多...
short USER_API | dc_MFPL3_writeinplain (HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata)
写Mifare Plus卡数据（3级）。 更多...
short USER_API | dc_MFPL3_writeinplain_hex (HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata)
写Mifare Plus卡数据（3级）。 更多...
short USER_API | dc_MFPL3_writeencrypted (HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata, unsigned char flag)
加密模式写Mifare Plus卡数据（3级）。 更多...
short USER_API | dc_MFPL3_writeencrypted_hex (HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata, unsigned char flag)
加密模式写Mifare Plus卡数据（3级）。 更多...
short USER_API | dc_auth_ulc (HANDLE icdev, unsigned char *key)
验证Mifare Ultralight C卡密码。 更多...
short USER_API | dc_auth_ulc_hex (HANDLE icdev, unsigned char *key)
验证Mifare Ultralight C卡密码。 更多...
short USER_API | dc_changekey_ulc (HANDLE icdev, unsigned char *newkey)
修改Mifare Ultralight C卡密码。 更多...
short USER_API | dc_changekey_ulc_hex (HANDLE icdev, unsigned char *newkey)
修改Mifare Ultralight C卡密码。 更多...
short USER_API | dc_getcpupara (HANDLE icdev, unsigned char cputype, unsigned char *cpupro, unsigned char *cpuetu)
获取接触式CPU卡参数。 更多...
short USER_API | dc_cpuapdusourceEXT (HANDLE icdev, short slen, unsigned char *sendbuffer, short *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapdusourceEXT_hex (HANDLE icdev, short slen, char *sendbuffer, short *rlen, char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapduEXT (HANDLE icdev, short slen, unsigned char *sendbuffer, short *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapduEXT_hex (HANDLE icdev, short slen, char *sendbuffer, short *rlen, char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapduInt (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapduInt_hex (HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandlinkEXT (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandlinkEXT_hex (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandlinkInt (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_pro_commandlinkInt_hex (HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_exchangeblock (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
short USER_API | dc_exchangeblock_hex (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
short USER_API | dc_write1024 (HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writebuffer)
保留。
short USER_API | dc_write1024_hex (HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writebuffer)
保留。
short USER_API | dc_read1024 (HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *databuffer)
保留。
short USER_API | dc_read1024_hex (HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *databuffer)
保留。
short USER_API | dc_switch_linux (HANDLE icdev)
保留。
short USER_API | dc_cpuhotreset (HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡复位。 更多...
short USER_API | dc_cpuhotreset_hex (HANDLE icdev, unsigned char *rlen, char *databuffer)
接触式CPU卡复位。 更多...
short USER_API | dc_card_exist (HANDLE icdev, unsigned char *flag)
检测多卡状态。 更多...
short USER_API | dc_card_status (HANDLE icdev)
检测接触式卡存在。 更多...
short USER_API | dc_typeab_card_status (HANDLE icdev)
身份证、Type A CPU卡、Type B CPU卡检测。 更多...
short USER_API | dc_card_n (HANDLE icdev, unsigned char _Mode, unsigned int *SnrLen, unsigned char *_Snr)
寻卡请求、防卡冲突、选卡操作。 更多...
short USER_API | dc_card_n_hex (HANDLE icdev, unsigned char _Mode, unsigned int *SnrLen, unsigned char *_Snr)
寻卡请求、防卡冲突、选卡操作。 更多...
short USER_API | dc_card_n_number (HANDLE icdev, unsigned char _Mode, char *_Snr)
保留。
short USER_API | dc_pass_key_value (HANDLE icdev, unsigned char timeout, char *value)
获取单个按键值。 更多...
short USER_API | dc_play_voice (HANDLE icdev, unsigned char mode)
播放语音。 更多...
short USER_API | dc_playvoice (HANDLE icdev, unsigned char mode)
播放语音。 更多...
short USER_API | dc_load_voice (HANDLE icdev, int flag, int slen, const unsigned char *sdata)
装载语音。 更多...
short USER_API | dc_setmag (HANDLE icdev, unsigned char mode, unsigned char track1, unsigned char track2, unsigned char track3)
磁条卡参数配置。 更多...
short USER_API | dc_setprint (HANDLE icdev, unsigned char FontSize, unsigned char Alignment, unsigned char LeftMargin, unsigned char RightMargin, unsigned char RowPitch, unsigned char PrintOutRate)
设置打印机参数。 更多...
short USER_API | dc_checkprint (HANDLE icdev, unsigned char *FontSize, unsigned char *Alignment, unsigned char *LeftMargin, unsigned char *RightMargin, unsigned char *RowPitch, unsigned char *PrintOutRate)
查询打印机参数。 更多...
short USER_API | dc_printcharacter (HANDLE icdev, unsigned short length, unsigned char *character)
打印字符。 更多...
short USER_API | dc_printOnedimensional (HANDLE icdev, unsigned char hight, unsigned char displayflag, unsigned char FontSize, unsigned short length, unsigned char *Onedimensional)
打印一维码。 更多...
short USER_API | dc_printPicture (HANDLE icdev, unsigned char length, unsigned char height, unsigned char Alignment, unsigned char LeftMargin, unsigned char RightMargin, unsigned short size, unsigned char *Picture)
打印图片。 更多...
short USER_API | dc_printenter (HANDLE icdev, unsigned char RowPitch)
进纸。 更多...
short USER_API | dc_printstatus (HANDLE icdev, unsigned char *paperstatus, unsigned char *tempturestatus, unsigned char *zkstatus)
获取打印机状态。 更多...
short USER_API | dc_set2dot4Gbaund (HANDLE icdev, unsigned char baund)
设置2.4G模块波特率。 更多...
short USER_API | dc_check2dot4Gbaund (HANDLE icdev, unsigned char *baund)
查询2.4G模块波特率。 更多...
short USER_API | dc_2dot4_reset (HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
2.4G复位。 更多...
short USER_API | dc_2dot4_resethex (HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
2.4G复位。 更多...
short USER_API | dc_2dot4_command (HANDLE icdev, unsigned int slen, unsigned char *senddata, unsigned int *rlen, unsigned char *recvbuffer, unsigned char timeout)
2.4G指令交互。 更多...
short USER_API | dc_2dot4_command_hex (HANDLE icdev, unsigned int slen, unsigned char *senddata, unsigned int *rlen, unsigned char *recvbuffer, unsigned char timeout)
2.4G指令交互。 更多...
short USER_API | dc_check_102 (HANDLE icdev)
检测102卡。 更多...
short USER_API | dc_down_102 (HANDLE icdev)
102卡下电。 更多...
short USER_API | dc_read_102 (HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *readdata)
读102卡。 更多...
short USER_API | dc_read_102_hex (HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *readdata)
读102卡。 更多...
short USER_API | dc_write_102 (HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *writedata)
写102卡。 更多...
short USER_API | dc_write_102_hex (HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *writedata)
写102卡。 更多...
short USER_API | dc_checkpass_102 (HANDLE icdev, short zone, unsigned char *password)
验证102卡密码。 更多...
short USER_API | dc_checkpass_102_hex (HANDLE icdev, short zone, unsigned char *password)
验证102卡密码。 更多...
short USER_API | dc_changepass_102 (HANDLE icdev, short zone, unsigned char *password)
修改102卡密码。 更多...
short USER_API | dc_changepass_102_hex (HANDLE icdev, short zone, unsigned char *password)
修改102卡密码。 更多...
short USER_API | dc_readcount_102 (HANDLE icdev, short zone)
读102卡密码计数。 更多...
short USER_API | dc_fuse_102 (HANDLE icdev)
102卡熔丝。 更多...
short USER_API | dc_check_1604 (HANDLE icdev)
检测1604卡。 更多...
short USER_API | dc_down_1604 (HANDLE icdev)
1604卡下电。 更多...
short USER_API | dc_read_1604 (HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *readdata)
读1604卡。 更多...
short USER_API | dc_read_1604_hex (HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *readdata)
读1604卡。 更多...
short USER_API | dc_write_1604 (HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writedata)
写1604卡。 更多...
short USER_API | dc_write_1604_hex (HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writedata)
写1604卡。 更多...
short USER_API | dc_checkpass_1604 (HANDLE icdev, short zone, unsigned char *password)
验证1604卡密码。 更多...
short USER_API | dc_checkpass_1604_hex (HANDLE icdev, short zone, unsigned char *password)
验证1604卡密码。 更多...
short USER_API | dc_changepass_1604 (HANDLE icdev, short zone, unsigned char *password)
修改1604卡密码。 更多...
short USER_API | dc_changepass_1604_hex (HANDLE icdev, short zone, unsigned char *password)
修改1604卡密码。 更多...
short USER_API | dc_readcount_1604 (HANDLE icdev, short zone)
读1604卡密码计数。 更多...
short USER_API | dc_fuse_1604 (HANDLE icdev)
1604卡熔丝。 更多...
short USER_API | dc_down_4428 (HANDLE icdev)
4428卡下电。 更多...
short USER_API | dc_down_4442 (HANDLE icdev)
4442卡下电。 更多...
short USER_API | dc_flash_card (HANDLE icdev)
保留。
short USER_API | dc_read_walletbalance (HANDLE icdev, unsigned char *walletvalue)
保留。
short USER_API | dc_consume_wallet (HANDLE icdev, unsigned char *walletvalue, unsigned char *secret)
保留。
short USER_API | dc_transfer_wallet (HANDLE icdev, unsigned char *walletvalue)
保留。
short USER_API | dc_authentication_key (HANDLE icdev, unsigned char *data, unsigned char *desdata)
保留。
short USER_API | dc_set_terminalnumber (HANDLE icdev, unsigned char length, unsigned char *serieldata)
保留。
short USER_API | dc_get_terminalnumber (HANDLE icdev, unsigned char length, unsigned char *serieldata)
保留。
short USER_API | dc_set_trademerchantcode (HANDLE icdev, unsigned char length, unsigned char *merchantcode)
保留。
short USER_API | dc_get_trademerchantcode (HANDLE icdev, unsigned char length, unsigned char *merchantcode)
保留。
short USER_API | dc_set_transactiontype (HANDLE icdev, unsigned char typecode)
保留。
short USER_API | dc_get_transactiontype (HANDLE icdev, unsigned char *typecode)
保留。
short USER_API | dc_set_tradesecretkey (HANDLE icdev, unsigned char *secretkey)
保留。
short USER_API | dc_get_tradesecretkey (HANDLE icdev, unsigned char *secretkey)
保留。
short USER_API | dc_set_hardwareserialnumber (HANDLE icdev, unsigned char length, unsigned char *hardwareserial)
保留。
short USER_API | dc_get_hardwareserialnumber (HANDLE icdev, unsigned char length, unsigned char *hardwareserial)
保留。
short USER_API | dc_reset_factory (HANDLE icdev)
保留。
short USER_API | dc_get_signmessageparameters (HANDLE icdev, unsigned char length, unsigned char *parameters)
保留。
short USER_API | dc_get_record (HANDLE icdev, unsigned char tablenumber, unsigned char recordnumber, unsigned char *recordquantity, unsigned char *recorddata)
保留。
short USER_API | dc_startreadmag (HANDLE icdev)
启动读磁条卡。 更多...
short USER_API | dc_stopreadmag (HANDLE icdev)
停止读磁条卡。 更多...
short USER_API | dc_readmag (HANDLE icdev, unsigned char *pTrack1Data, unsigned int *pTrack1Len, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len)
获取磁条卡数据。 更多...
short USER_API | dc_readmagcardallA (HANDLE icdev, unsigned char ctime, unsigned char *pTrack1Data, unsigned int *pTrack1Len, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len)
自动获取磁条卡数据。 更多...
short USER_API | dc_InstallKbKey (HANDLE icdev, unsigned char flag, unsigned char keylen, unsigned char *keydata, unsigned char mode)
设置密码键盘密钥。 更多...
short USER_API | dc_SetKbKeyID (HANDLE icdev, unsigned char keyID)
设置当前密钥组。 更多...
short USER_API | dc_GetEnPass (HANDLE icdev, unsigned char ctime, unsigned char panlen, unsigned char *pandata, unsigned char *rlen, unsigned char *cpass)
获取加密按键数据。 更多...
short USER_API | dc_get55data (HANDLE icdev, unsigned int slen, unsigned char *sdata, unsigned char *PacketType, unsigned int *rlen, unsigned char *rdata)
保留。
short USER_API | dc_CardIssuingScript (HANDLE icdev, unsigned int slen, unsigned char *sdata, unsigned char *TransactionIsInterrupted, unsigned char *TradingResult)
保留。
short USER_API | dc_SetEMVPara (HANDLE icdev, unsigned int slen, unsigned char *sdata)
保留。
short USER_API | dc_CalculateMACCheck (HANDLE icdev, unsigned char keyindex, unsigned char macmode, unsigned int datalen, unsigned char *srcdata, unsigned char *macdata)
保留。
short USER_API | dc_CalculateDes (HANDLE icdev, unsigned char keyindex, unsigned char enmode, unsigned short datalen, unsigned char *srcdata, unsigned char *desdata)
保留。
short USER_API | dc_CalculateSm4 (HANDLE icdev, unsigned char keyindex, unsigned char enmode, unsigned short datalen, unsigned char *srcdata, unsigned char *sm4data)
保留。
short USER_API | dc_CreatDesData (HANDLE icdev, unsigned char keytype, unsigned char enmode, unsigned char *sourcedata, unsigned char *retdata)
用工作密钥加解密。 更多...
short USER_API | dc_CreatSm4Data (HANDLE icdev, unsigned char keytype, unsigned char enmode, unsigned char *sourcedata, unsigned char *retdata)
用工作密钥加解密。 更多...
short USER_API | dc_CreatDesDataECB (HANDLE icdev, unsigned char keytype, unsigned char enmode, int slen, unsigned char *sourcedata, int *rlen, unsigned char *retdata)
用工作密钥加解密。 更多...
short USER_API | dc_CreatSm4DataECB (HANDLE icdev, unsigned char keytype, unsigned char enmode, int slen, unsigned char *sourcedata, int *rlen, unsigned char *retdata)
用工作密钥加解密。 更多...
short USER_API | dc_CreatMacDataECB (HANDLE icdev, unsigned char keytype, unsigned char enmode, int slen, unsigned char *sourcedata, int *rlen, unsigned char *retdata)
用工作密钥算MAC。 更多...
short USER_API | dc_writeSD (HANDLE icdev, int offset, int length, unsigned char *writebuffer)
写SD存储。 更多...
short USER_API | dc_readSD (HANDLE icdev, int offset, int length, unsigned char *readbuffer)
读SD存储。 更多...
short USER_API | dc_SetUsbMode (HANDLE icdev, unsigned char ucmode)
设置USB模式。 更多...
short USER_API | SD_InstallKey (HANDLE icdev, unsigned char ctime, unsigned char senlen, unsigned char *source, unsigned char *reclen, unsigned char *rdata)
外接密码键盘通讯。 更多...
short USER_API | SD_IFD_GetVersion (HANDLE icdev, char *version)
获取外接密码键盘的版本。 更多...
short USER_API | SD_IFD_PlayVoice (HANDLE icdev, unsigned char _playmode)
外接密码键盘播放语音。 更多...
short USER_API | SD_IFD_Init (HANDLE icdev)
外接密码键盘初始化。 更多...
short USER_API | SD_IFD_SetMainKey (HANDLE icdev, unsigned char keyset, unsigned char *oldkey, unsigned char *newkey)
设置外接密码键盘主密钥。 更多...
short USER_API | SD_IFD_SetWorkKey (HANDLE icdev, unsigned char keysetmain, unsigned char keysetwork, unsigned char *enkeywork)
设置外接密码键盘工作密钥。 更多...
short USER_API | SD_IFD_ActWorkKey (HANDLE icdev, unsigned char keysetmain, unsigned char keysetwork)
激活外接密码键盘工作密钥。 更多...
short USER_API | SD_IFD_SetKeyLength (HANDLE icdev, unsigned char keylength)
设置外接密码键盘最大输入长度。 更多...
short USER_API | SD_IFD_GetPIN (HANDLE icdev, char *szPasswd)
获取外接密码键盘明文数据。 更多...
short USER_API | SD_IFD_GetEnPIN (HANDLE icdev, char *szPasswd)
获取外接密码键盘密文数据。 更多...
short USER_API | SD_IFD_GetPINPro (HANDLE icdev, char *szPasswd, unsigned char yyflag, unsigned char timeout)
获取外接密码键盘明文数据。 更多...
short USER_API | SD_IFD_GetEnPINPro (HANDLE icdev, char *szPasswd, unsigned char yyflag, unsigned char modeflag, unsigned char timeout)
获取外接密码键盘密文数据。 更多...
short USER_API | SD_IFD_GetEnPINBlock (HANDLE icdev, char *szPasswd, unsigned char yyflag, unsigned char modeflag, unsigned char *cardno, unsigned char timeout)
获取外接密码键盘密文数据。 更多...
short USER_API | SD_IFD_SelecetDes (HANDLE icdev, unsigned char desmode)
设置外接密码键盘算法。 更多...
short USER_API | SD_IFD_LEDDisplay (HANDLE icdev, unsigned char line, unsigned char row, unsigned char *leddata, unsigned char timeout)
外接密码键盘液晶显示。 更多...
short USER_API | SD_IFD_DES (HANDLE icdev, unsigned char mode, unsigned char *srcdata, unsigned char *desdata)
用外接密码键盘工作密钥加解密。 更多...
short USER_API | SD_IFD_DesCaculate (HANDLE icdev, unsigned char srclen, unsigned char *srcdata, unsigned char *desdata, unsigned char flag)
用外接密码键盘工作密钥加解密。 更多...
short USER_API | SD_IFD_CreateMac (HANDLE icdev, unsigned char srclen, unsigned char *srcdata, unsigned char *macdata)
用外接密码键盘工作密钥算MAC。 更多...
short USER_API | SD_IFD_Scan2DBarcodeStart (HANDLE icdev, unsigned char mode)
外接密码键盘开始扫描二维码。 更多...
short USER_API | SD_IFD_Scan2DBarcodeGetData (HANDLE icdev, int *rlen, unsigned char *rdata)
外接密码键盘获取二维码数据。 更多...
short USER_API | SD_IFD_Scan2DBarcodeExit (HANDLE icdev)
外接密码键盘退出扫描二维码。 更多...
short USER_API | dc_find_i_d (HANDLE icdev)
查找身份证。 更多...
short USER_API | dc_find_i_d_2 (HANDLE icdev)
查找身份证。 更多...
short USER_API | dc_find_i_d_speed (HANDLE icdev)
查找身份证。 更多...
short USER_API | dc_get_i_d_raw_buffer (HANDLE icdev, unsigned char *rdata)
读身份证原始数据。 更多...
HANDLE USER_API | dc_start_i_d (HANDLE icdev)
读身份证。 更多...
HANDLE USER_API | dc_start_i_d_2 (HANDLE icdev)
读身份证。 更多...
char *USER_API | dc_i_d_query_name (HANDLE idhandle)
获取姓名。 更多...
short USER_API | dc_i_d_query_name_2 (HANDLE idhandle, char *name)
获取姓名。 更多...
char *USER_API | dc_i_d_query_sex (HANDLE idhandle)
获取性别。 更多...
short USER_API | dc_i_d_query_sex_2 (HANDLE idhandle, char *sex)
获取性别。 更多...
char *USER_API | dc_i_d_query_nation (HANDLE idhandle)
获取民族。 更多...
short USER_API | dc_i_d_query_nation_2 (HANDLE idhandle, char *nation)
获取民族。 更多...
char *USER_API | dc_i_d_query_birth (HANDLE idhandle)
获取生日。 更多...
short USER_API | dc_i_d_query_birth_2 (HANDLE idhandle, char *birth)
获取生日。 更多...
char *USER_API | dc_i_d_query_address (HANDLE idhandle)
获取住址。 更多...
short USER_API | dc_i_d_query_address_2 (HANDLE idhandle, char *address)
获取住址。 更多...
char *USER_API | dc_i_d_query_id_number (HANDLE idhandle)
获取公民身份号码。 更多...
short USER_API | dc_i_d_query_id_number_2 (HANDLE idhandle, char *id_number)
获取公民身份号码。 更多...
char *USER_API | dc_i_d_query_department (HANDLE idhandle)
获取签发机关。 更多...
short USER_API | dc_i_d_query_department_2 (HANDLE idhandle, char *department)
获取签发机关。 更多...
char *USER_API | dc_i_d_query_expire_day (HANDLE idhandle)
获取有效期限。 更多...
short USER_API | dc_i_d_query_expire_day_2 (HANDLE idhandle, char *expire_day)
获取有效期限。 更多...
unsigned char *USER_API | dc_i_d_query_photo (HANDLE idhandle)
获取相片原始数据。 更多...
short USER_API | dc_i_d_query_photo_2 (HANDLE idhandle, unsigned char *photo)
获取相片原始数据。 更多...
unsigned int USER_API | dc_i_d_query_photo_len (HANDLE idhandle)
获取相片原始数据长度。 更多...
short USER_API | dc_i_d_query_photo_file (HANDLE idhandle, const char *FileName)
生成相片图像文件。 更多...
short USER_API | dc_i_d_query_photo_bmp_buffer (HANDLE idhandle, unsigned char *BmpBuffer, unsigned int *BmpLength)
生成相片图像数据。 更多...
unsigned char *USER_API | dc_i_d_query_finger (HANDLE idhandle)
获取指纹原始数据。 更多...
short USER_API | dc_i_d_query_finger_2 (HANDLE idhandle, unsigned char *finger)
获取指纹原始数据。 更多...
unsigned int USER_API | dc_i_d_query_finger_len (HANDLE idhandle)
获取指纹原始数据长度。 更多...
short USER_API | dc_i_d_query_finger_file (HANDLE idhandle, const char *FileName)
保留。
short USER_API | dc_i_d_query_finger_bmp_buffer (HANDLE idhandle, unsigned char *BmpBuffer, unsigned int *BmpLength)
保留。
void USER_API | dc_end_i_d (HANDLE idhandle)
释放读身份证资源。 更多...
short USER_API | dc_getuid_i_d (HANDLE icdev, unsigned char *uid)
获取身份证UID。 更多...
short USER_API | dc_display_2dbarcode (HANDLE icdev, int point_x, int point_y, const char *info)
LCD显示二维码。 更多...
short USER_API | dc_getfingerdata (HANDLE icdev, int *length, unsigned char *data)
读身份证指纹。 更多...
short USER_API | dc_card_status2 (HANDLE icdev, unsigned char *pos)
检测卡片位置。 更多...
short USER_API | dc_card_make_and_lock (HANDLE icdev, unsigned char flag)
开卡与锁卡。 更多...
short USER_API | dc_send_sms (HANDLE icdev, const char *phone_no, const char *sms_content)
发送短信。 更多...
short USER_API | dc_fingerprint_io_control (HANDLE icdev, unsigned char ctime, const unsigned char *request, int request_len, unsigned char *response, int *response_len)
指纹模块通讯。 更多...
short USER_API | dc_keypad_io_control (HANDLE icdev, unsigned char ctime, const unsigned char *request, int request_len, unsigned char *response, int *response_len)
保留。
short USER_API | dc_keypad_ImportKey (HANDLE icdev, unsigned char *check_value, unsigned char check_mode, int key_index, int use_key_index, unsigned char enable, const unsigned char *key, int key_len)
保留。
short USER_API | dc_keypad_DeleteKey (HANDLE icdev, int key_index)
保留。
short USER_API | dc_keypad_SetButtonMark (HANDLE icdev, unsigned int mark_value, unsigned char use)
保留。
short USER_API | dc_keypad_Start (HANDLE icdev, unsigned char mode, int max_len, unsigned char auto_end, unsigned char enable_sound)
保留。
short USER_API | dc_keypad_End (HANDLE icdev)
保留。
short USER_API | dc_keypad_GetPressed (HANDLE icdev, int time_ms, unsigned char *value)
保留。
short USER_API | dc_keypad_GetPinBlock (HANDLE icdev, unsigned char mode, int key_index, const unsigned char *customer_data, int customer_data_len, unsigned char *out_data, int *out_data_len)
保留。
short USER_API | dc_keypad_GetRandomValue (HANDLE icdev, int length, unsigned char *value)
保留。
short USER_API | dc_keypad_GetEncryptDataOfCBC (HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
short USER_API | dc_keypad_GetDecryptDataOfCBC (HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
short USER_API | dc_keypad_GetEncryptDataOfECB (HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
short USER_API | dc_keypad_GetDecryptDataOfECB (HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
short USER_API | dc_keypad_GetMACDataOfCBC (HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
short USER_API | dc_RfGetCardType (HANDLE icdev)
获取非接触卡类型。 更多...
short USER_API | dc_RfWaveControl (HANDLE icdev, unsigned char mode)
保留。
short USER_API | dc_RfReadChipRegister (HANDLE icdev, unsigned char *register_data)
保留。
short USER_API | dc_RfSetChipRegister (HANDLE icdev, unsigned char register_type, unsigned char register_value)
保留。
short USER_API | dc_get_idsnr (HANDLE icdev, unsigned char *_Data)
获取身份证UID。 更多...
short USER_API | dc_get_idsnr_hex (HANDLE icdev, char *_Data)
获取身份证UID。 更多...
short USER_API | dc_PinpadCommunication (HANDLE icdev, int time_100ms, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata)
密码键盘模块通讯。 更多...
short USER_API | dc_ReadFlash (HANDLE icdev, int offset, int length, unsigned char *data_buffer)
读Flash。 更多...
short USER_API | dc_WriteFlash (HANDLE icdev, int offset, int length, const unsigned char *data_buffer)
写Flash。 更多...
short USER_API | dc_SelfServiceDeviceCardStatus (HANDLE icdev, unsigned char *pos)
检测卡位置状态。 更多...
short USER_API | dc_SelfServiceDeviceCardInject (HANDLE icdev, unsigned char time_s, unsigned char mode)
进入卡片。 更多...
short USER_API | dc_SelfServiceDeviceCardEject (HANDLE icdev, unsigned char time_s, unsigned char mode)
弹出卡片。 更多...
short USER_API | dc_SelfServiceDeviceCardMove (HANDLE icdev, unsigned char time_s, unsigned char mode)
移动卡片。 更多...
short USER_API | dc_SelfServiceDeviceSensorStatus (HANDLE icdev, unsigned char *value)
获取传感器状态。 更多...
short USER_API | dc_SelfServiceDeviceConfig (HANDLE icdev, unsigned char mode)
设置弹卡模式。 更多...
short USER_API | dc_SelfServiceDeviceConfigFront (HANDLE icdev, unsigned char mode)
设置前端进卡模式。 更多...
short USER_API | dc_SelfServiceDeviceConfigBack (HANDLE icdev, unsigned char mode)
设置后端进卡模式。 更多...
short USER_API | dc_SelfServiceDeviceConfigPlace (HANDLE icdev, unsigned char mode)
设置停卡位置。 更多...
short USER_API | dc_SelfServiceDeviceCheckCardType (HANDLE icdev)
检测卡类型。 更多...
short USER_API | dc_SelfServiceDeviceReset (HANDLE icdev)
复位自助设备。 更多...
short USER_API | dc_MulticardStatus (HANDLE icdev, unsigned char *type)
检测多卡状态。 更多...
short USER_API | dc_pass_key_value2 (HANDLE icdev, unsigned char ctime, unsigned char *rlen, unsigned char *cpass)
获取多个按键值。 更多...
short USER_API | dc_ReadOutEeprom (HANDLE icdev, int offset, int length, unsigned char *data_buffer)
读外部EEPROM。 更多...
short USER_API | dc_WriteOutEeprom (HANDLE icdev, int offset, int length, const unsigned char *data_buffer)
写外部EEPROM。 更多...
short USER_API | dc_ReadIdCardInfo (HANDLE icdev, int time_ms, int *rlen, unsigned char *rdata)
读ID卡。 更多...
short USER_API | dc_cpy_getkey (HANDLE icdev, unsigned char *respkey, int *resplen)
保留。
short USER_API | dc_cpy_setkey (HANDLE icdev, unsigned char *genkey, int keylen)
保留。
short USER_API | dc_cpy_cpuapdu (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
保留。
short USER_API | dc_cpy_cpuapdu_hex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
保留。
short USER_API | dc_cpy_cpuapduInt (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer)
保留。
short USER_API | dc_cpy_cpuapduInt_hex (HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer)
保留。
short USER_API | dc_cpy_procommand (HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
short USER_API | dc_cpy_procommand_hex (HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
保留。
short USER_API | dc_cpy_procommandInt (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
short USER_API | dc_cpy_procommandInt_hex (HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout)
保留。
short USER_API | dc_procommandInt (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_procommandInt_hex (HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。 更多...
short USER_API | dc_ReadRfCfgReg (HANDLE icdev, int type, int number, int *value)
保留。
short USER_API | dc_WriteRfCfgReg (HANDLE icdev, int type, int number, int value)
保留。
short USER_API | dc_NfcInit (HANDLE icdev)
初始化NFC。 更多...
short USER_API | dc_NfcActivate (HANDLE icdev, unsigned char *atr, int *atr_len)
激活NFC。 更多...
short USER_API | dc_NfcDeactivate (HANDLE icdev)
断开NFC。 更多...
short USER_API | dc_NfcPush (HANDLE icdev, const unsigned char *request, int request_len)
NFC点对点数据透传（推送服务端）。 更多...
short USER_API | dc_NfcService (HANDLE icdev, int flag)
NFC点对点数据透传（从服务端接收）。 更多...
short USER_API | dc_NfcFetch (HANDLE icdev, unsigned char *response, int *response_len, int time_ms)
接收NFC手机数据。 更多...
short USER_API | dc_NfcDataReceiver (HANDLE icdev, int time_ms, unsigned char *flag, unsigned char *response, int *response_len)
接收NFC手机数据。 更多...
short USER_API | dc_NfcSimulateCardConfig (HANDLE icdev, int mode)
NFC点对点数据透传（从服务端接收）。 更多...
short USER_API | dc_MagFormatConfig (HANDLE icdev, int mode)
磁条卡数据自动上传数据模式设置。 更多...
short USER_API | dc_ReadModuleMacAddress (HANDLE icdev, int type, char *value)
获取通讯模块MAC地址。 更多...
short USER_API | dc_WriteModuleMacAddress (HANDLE icdev, int type, const char *value)
设置通讯模块MAC地址。 更多...
short USER_API | dc_ReadRfTypeABATS (HANDLE icdev, int *ats_len, unsigned char *ats)
读取ATS数据。 更多...
short USER_API | dc_ReadRfTypeABATS_hex (HANDLE icdev, int *ats_len, char *ats)
读取ATS数据。 更多...
short USER_API | dc_RfFormatConfig (HANDLE icdev, int mode, int block_number, int offset, int length)
保留。
short USER_API | dc_FlashErase (HANDLE icdev, int sector)
Flash扇区擦除。 更多...
short USER_API | dc_BuzzerBeep (HANDLE icdev, unsigned short beep_time_ms, unsigned short interval_time_ms, unsigned short count)
设备蜂鸣。 更多...
short USER_API | dc_BtModeControl (HANDLE icdev, unsigned char mode)
蓝牙模式设置。 更多...
short USER_API | dc_BtBaudrateControl (HANDLE icdev, unsigned char flag, unsigned char *value)
蓝牙波特率查询/设置。 更多...
short USER_API | dc_BtPasswordControl (HANDLE icdev, unsigned char flag, char *value)
蓝牙连接密码查询/设置。 更多...
short USER_API | dc_BtAddressControl (HANDLE icdev, unsigned char flag, unsigned char *length, unsigned char *value)
蓝牙模块地址查询/设置。 更多...
short USER_API | dc_BtNameControl (HANDLE icdev, unsigned char flag, char *value)
蓝牙模块名称查询/设置。 更多...
short USER_API | dc_BtUserControl (HANDLE icdev, unsigned char flag, int offset, int length, unsigned char *value)
蓝牙用户自定义的配置命令。 更多...
short USER_API | dc_BtReset (HANDLE icdev)
蓝牙软件复位。 更多...
short USER_API | dc_BtCommunicationTest (HANDLE icdev, int length, const unsigned char *value)
蓝牙模块通讯测试。 更多...
short USER_API | dc_BtWithReaderBaudrateControl (HANDLE icdev, unsigned char flag, unsigned char *value)
蓝牙波特率查询/设置。 更多...
short USER_API | dc_BtCommand (HANDLE icdev, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata)
蓝牙模块通讯。 更多...
short USER_API | dc_BtSignalStrength (HANDLE icdev, unsigned char *state, short *value)
获取蓝牙信号强度。 更多...
short USER_API | dc_BtDataResponse (HANDLE icdev, int *length, unsigned char *value)
获取蓝牙响应。 更多...
short USER_API | dc_BtDataTransmit (HANDLE icdev, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata)
蓝牙数据透传。 更多...
short USER_API | dc_SamAControl (HANDLE icdev, int code, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata)
SAM_A模块指令交互。 更多...
short USER_API | dc_SamAReadCardInfo (HANDLE icdev, int type, int *text_len, unsigned char *text, int *photo_len, unsigned char *photo, int *fingerprint_len, unsigned char *fingerprint, int *extra_len, unsigned char *extra)
读身份证。 更多...
short USER_API | dc_ParseTextInfo (HANDLE icdev, int charset, int info_len, const unsigned char *info, unsigned char *name, unsigned char *sex, unsigned char *nation, unsigned char *birth_day, unsigned char *address, unsigned char *id_number, unsigned char *department, unsigned char *expire_start_day, unsigned char *expire_end_day, unsigned char *reserved)
解析文字信息。 更多...
short USER_API | dc_ParseTextInfoForForeigner (HANDLE icdev, int charset, int info_len, const unsigned char *info, unsigned char *english_name, unsigned char *sex, unsigned char *id_number, unsigned char *citizenship, unsigned char *chinese_name, unsigned char *expire_start_day, unsigned char *expire_end_day, unsigned char *birth_day, unsigned char *version_number, unsigned char *department_code, unsigned char *type_sign, unsigned char *reserved)
解析文字信息。 更多...
short USER_API | dc_ParseTextInfoForHkMoTw (HANDLE icdev, int charset, int info_len, const unsigned char *info, unsigned char *name, unsigned char *sex, unsigned char *reserved, unsigned char *birth_day, unsigned char *address, unsigned char *id_number, unsigned char *department, unsigned char *expire_start_day, unsigned char *expire_end_day, unsigned char *pass_number, unsigned char *sign_count, unsigned char *reserved2, unsigned char *type_sign, unsigned char *reserved3)
解析文字信息。 更多...
short USER_API | dc_ParsePhotoInfo (HANDLE icdev, int type, int info_len, const unsigned char *info, int *photo_len, unsigned char *photo)
解析相片信息。 更多...
short USER_API | dc_ParseOtherInfo (HANDLE icdev, int flag, const unsigned char *in_info, unsigned char *out_info)
解析其它信息。 更多...
short USER_API | dc_CpuCardStatus (HANDLE icdev)
检测接触式CPU卡。 更多...
short USER_API | dc_WakeDevice (HANDLE icdev)
唤醒设备。 更多...
short USER_API | dc_RestDevice (HANDLE icdev)
休眠设备。 更多...
short USER_API | dc_GetBatteryValue (HANDLE icdev, unsigned char *value)
获取电池电量。 更多...
short USER_API | dc_anticoll_mode (HANDLE icdev, unsigned char mode, unsigned char _Bcnt, unsigned int *_Snr)
防卡冲突。 更多...
short USER_API | dc_select_mode (HANDLE icdev, unsigned char mode, unsigned int _Snr, unsigned char *_Size)
选卡操作。 更多...
short USER_API | dc_attribInt (HANDLE icdev, unsigned char *PUPI, unsigned char CID)
激活卡片。 更多...
short USER_API | dc_rf_poweron (HANDLE icdev, unsigned char icc_slot_no, unsigned char *response)
卡上电。 更多...
short USER_API | dc_rf_poweroff (HANDLE icdev, unsigned char icc_slot_no)
卡下电。 更多...
short USER_API | dc_rf_getstatus (HANDLE icdev, unsigned char icc_slot_no)
获取卡状态。 更多...
short USER_API | dc_rf_application (HANDLE icdev, unsigned char icc_slot_no, int length_of_command_apdu, unsigned char *command_apdu, unsigned char *response_apdu)
卡指令交互。 更多...
short USER_API | dc_RequestMultiCard (HANDLE icdev, unsigned char *uid_data)
获取多张Type A卡UID。 更多...
short USER_API | dc_ActivateCard (HANDLE icdev, unsigned char uid_len, const unsigned char *uid)
选择一张Type A卡并激活。 更多...
short USER_API | dc_GetLastResponseCode (HANDLE icdev, unsigned int *code)
获取最后响应码。 更多...
short USER_API | dc_MultiFlashErase (HANDLE icdev, unsigned char type, unsigned int sector)
多个Flash扇区擦除。 更多...
short USER_API | dc_MultiFlashRead (HANDLE icdev, unsigned char type, unsigned int offset_h, unsigned int offset_l, unsigned int length_h, unsigned int length_l, unsigned char *data_buffer)
多个Flash读数据。 更多...
short USER_API | dc_MultiFlashWrite (HANDLE icdev, unsigned char type, unsigned int offset_h, unsigned int offset_l, unsigned int length_h, unsigned int length_l, const unsigned char *data_buffer)
多个Flash写数据。 更多...
short USER_API | dc_MultiFlashGetSize (HANDLE icdev, unsigned char type, unsigned int *length_h, unsigned int *length_l)
多个FLASH容量大小获取。 更多...
short USER_API | dc_RfMultiRequest (HANDLE icdev)
多重寻卡。 更多...
short USER_API | dc_TtsVoicePlay (HANDLE icdev, unsigned char type, const unsigned char *content, int content_len)
TTS语音播放。 更多...
short USER_API | dc_TtsVoiceConfig (HANDLE icdev, unsigned char type, unsigned char value)
TTS语音设置。 更多...
short USER_API | dc_Config2DBarcode (HANDLE icdev, const unsigned char *content, int content_len)
配置二维码工作模式。 更多...
short USER_API | dc_Scan2DBarcode (HANDLE icdev, unsigned short time_ms, char *message_data)
扫描二维码。 更多...
short USER_API | dc_KeypadOpen (HANDLE icdev, int number, char *version)
打开密码键盘。 更多...
short USER_API | dc_KeypadClose (HANDLE icdev, int number)
关闭密码键盘。 更多...
short USER_API | dc_KeypadLoadKey (HANDLE icdev, int number, int set_index, int sub_index, int type, int mode, const unsigned char *key_data, int key_len, int flag, unsigned char *ex_data, int *ex_len)
装载密钥。 更多...
short USER_API | dc_KeypadClearKey (HANDLE icdev, int number, int set_index, int sub_index)
清除密钥。 更多...
short USER_API | dc_KeypadGetKeyType (HANDLE icdev, int number, int set_index, int sub_index, int *type)
获取密钥类型。 更多...
short USER_API | dc_KeypadAlgorithm (HANDLE icdev, int number, int set_index, int sub_index, int flag, int mode, const unsigned char *in_data, int in_len, unsigned char *out_data, int *out_len)
数据加解密。 更多...
short USER_API | dc_KeypadStartInput (HANDLE icdev, int number, int mode, int set_index, int sub_index, const unsigned char *in_data, int in_len, int min_len, int max_len, int auto_end, int enable_beep, int time_s, unsigned char *out_data, int *out_len)
启动按键输入。 更多...
short USER_API | dc_KeypadGetKeyValue (HANDLE icdev, int number, unsigned char *value)
获取键值。 更多...
short USER_API | dc_KeypadExitAndGetInput (HANDLE icdev, int number, int mode, unsigned char *out_data, int *out_len)
退出并且获取密码数据。 更多...
short USER_API | dc_KeypadSetKeyValue (HANDLE icdev, int number, unsigned char value)
设置键值。 更多...
short USER_API | dc_GetDeviceUid (HANDLE icdev, char *uid)
获取设备唯一识别码。 更多...
short USER_API | dc_GetDeviceTradeNumber (HANDLE icdev, char *number)
获取设备商户号。 更多...
short USER_API | dc_GetDeviceTerminalNumber (HANDLE icdev, char *number)
获取设备终端号。 更多...
short USER_API | dc_ReadDeviceCustomInfo (HANDLE icdev, unsigned char *info)
读取设备自定义信息。 更多...
short USER_API | dc_WriteDeviceCustomInfo (HANDLE icdev, const unsigned char *info)
写入设备自定义信息。 更多...
short USER_API | dc_ReadDeviceTypeName (HANDLE icdev, char *name)
读取设备型号名称。 更多...
short USER_API | dc_WriteDeviceTypeName (HANDLE icdev, const char *name)
写入设备型号名称。 更多...
short USER_API | dc_WirelessPowerControl (HANDLE icdev, unsigned char value)
无线模块电源控制。 更多...
short USER_API | dc_WirelessTcpOpen (HANDLE icdev, unsigned char type, const char *network_address, const char *network_port)
打开TCP链接。 更多...
short USER_API | dc_WirelessTcpClose (HANDLE icdev)
关闭TCP链接。 更多...
short USER_API | dc_WirelessGetStatus (HANDLE icdev, unsigned char *value)
查询网络状态。 更多...
short USER_API | dc_WirelessSend (HANDLE icdev, unsigned char type, const unsigned char *data_buffer, int data_len)
发送数据到网络端。 更多...
short USER_API | dc_WirelessRecv (HANDLE icdev, unsigned char type, unsigned char mode, unsigned char time_100ms, unsigned char *data_buffer, int *data_len)
从网络端接收数据。 更多...
short USER_API | dc_WirelessWifiConfig (HANDLE icdev, unsigned char type, const char *ssid, const char *password)
配置WIFI参数。 更多...
short USER_API | dc_GpsGetInfo (HANDLE icdev, int time_ms, unsigned char *data_buffer, int *data_len)
获取GPS信息。 更多...
short USER_API | dc_SetCpuCard616C (HANDLE icdev, unsigned char value)
设置接触式CPU卡616C配置。 更多...
short USER_API | dc_GetCpuCard616C (HANDLE icdev, unsigned char *value)
获取接触式CPU卡616C配置。 更多...
short USER_API | dc_GetChipIdNumber (HANDLE icdev, char *number)
获取芯片唯一ID号。 更多...
short USER_API | dc_LedDisplay (HANDLE icdev, unsigned char number, unsigned char mode, unsigned char value)
数码管显示。 更多...
short USER_API | dc_LedControl (HANDLE icdev, unsigned char mode)
数码管显示设置。 更多...
short USER_API | dc_RfCrcModeConfig (HANDLE icdev, unsigned char tx_crc, unsigned char rx_crc)
透传CRC模式配置。 更多...
short USER_API | dc_TcpGetInfo (HANDLE icdev, unsigned char type, unsigned char *data_buffer, int *data_len)
获取TCP信息。 更多...
short USER_API | dc_RfMarch (HANDLE icdev)
射频天线打开。 更多...
short USER_API | dc_SelectAntenna (HANDLE icdev, unsigned char number)
选择天线。 更多...
short USER_API | dc_ReadNicMacAddress (HANDLE icdev, unsigned char *data_buffer, int *data_len)
读网卡MAC地址。 更多...
short USER_API | dc_WriteNicMacAddress (HANDLE icdev, const unsigned char *data_buffer, int data_len)
写网卡MAC地址。 更多...
short USER_API | dc_TestNic (HANDLE icdev, const unsigned char *data_buffer, int data_len)
测试网卡。 更多...
short USER_API | dc_TestUsb (HANDLE icdev, const unsigned char *data_buffer, int data_len)
测试USB。 更多...
short USER_API | dc_TestCom (HANDLE icdev, unsigned char number, const char *name, unsigned char *data_buffer, int *data_len)
测试串口。 更多...
short USER_API | dc_ConfigTempIpAddress (HANDLE icdev, const unsigned char *data_buffer, int data_len)
设定临时IP地址。 更多...
short USER_API | dc_GetMagFormat (HANDLE icdev, int *mode)
磁条卡数据自动上传数据模式获取。 更多...
short USER_API | dc_GetMag (HANDLE icdev, unsigned char *mode, unsigned char *track1, unsigned char *track2, unsigned char *track3)
磁条卡参数获取。 更多...
short USER_API | dc_GetDeviceBaud (HANDLE icdev, unsigned char *baud)
获取串口设备通讯波特率。 更多...
short USER_API | dc_GetUsbMode (HANDLE icdev, unsigned char *ucmode)
获取USB模式。 更多...
short USER_API | dc_cpuapduresponInt (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_cpuapduresponInt_hex (HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer)
接触式CPU卡指令交互。 更多...
short USER_API | dc_Scan2DBarcodeStart (HANDLE icdev, unsigned char mode)
开始扫描二维码。 更多...
short USER_API | dc_Scan2DBarcodeGetData (HANDLE icdev, int *rlen, unsigned char *rdata)
获取二维码数据。 更多...
short USER_API | dc_Scan2DBarcodeExit (HANDLE icdev)
退出扫描二维码。 更多...
short USER_API | dc_SelfServiceDeviceWriteMagConfig (HANDLE icdev, unsigned char mode)
写磁条卡参数设置。 更多...
short USER_API | dc_SelfServiceDeviceShakeConfig (HANDLE icdev, unsigned char mode)
抖动模式设置。 更多...
short USER_API | dc_VoicePlayAndDisplay (HANDLE icdev, unsigned char mode, unsigned char type)
语音播放及显示。 更多...
short USER_API | dc_SelfServiceDeviceSetFrontSwitch (HANDLE icdev, unsigned char mode)
前门电闸门设置。 更多...
short USER_API | dc_SelfServiceDeviceGetFrontSwitch (HANDLE icdev, unsigned char *mode)
前门电闸门获取。 更多...
short USER_API | dc_ClearDeviceConfig (HANDLE icdev)
清除设备配置。 更多...
short USER_API | dc_SetCpuCardPps (HANDLE icdev, unsigned char mode)
接触式CPU卡PPS配置设置。 更多...
short USER_API | dc_GetCpuCardPps (HANDLE icdev, unsigned char *mode)
接触式CPU卡PPS配置获取。 更多...
short USER_API | dc_checkcopy_m1 (HANDLE icdev, unsigned char mode)
保留。
short USER_API | dc_RefreshAndDisplayMainUI (HANDLE icdev)
刷新返回主界面。 更多...
short USER_API | dc_GlyProCommand (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
short USER_API | dc_GlyProCommand_hex (HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout)
保留。
short USER_API | dc_SamAReadSerialNumber (HANDLE icdev, char *number)
读取SAM_A模块序列号。 更多...
short USER_API | dc_2dot4Apdu (HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer)
2.4G APDU指令交互。 更多...
short USER_API | dc_2dot4Apdu_hex (HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer)
2.4G APDU指令交互。 更多...
short USER_API | dc_ScreenDisplayImage (HANDLE icdev, int x, int y, int w, int h, int time_s, const unsigned char *image_data)
显示图像。 更多...
short USER_API | dc_ScreenClearDisplay (HANDLE icdev, int x, int y, int w, int h, int time_s)
清除显示。 更多...
short USER_API | dc_ScreenLoadBgImage (HANDLE icdev, int number, const unsigned char *image_data)
装载背景图像。 更多...
short USER_API | dc_ScreenDisplayBgImage (HANDLE icdev, int number, int x, int y, int w, int h)
显示背景图像。 更多...
short USER_API | dc_ScreenDisplayGetConfig (HANDLE icdev, unsigned char tag, unsigned char *config_data)
获取显示配置。 更多...
short USER_API | dc_ScreenDisplaySetConfig (HANDLE icdev, unsigned char tag, const unsigned char *config_data)
设置显示配置。 更多...
short USER_API | dc_ScreenDisplayText (HANDLE icdev, unsigned char font_size, const unsigned char *fg_rgb, const unsigned char *bg_rgb, int x, int y, int time_s, unsigned char line_flag, unsigned char voice_flag, const char *text)
显示文字。 更多...
short USER_API | dc_ScreenDisplayBgImageByColor (HANDLE icdev, const unsigned char *rgb, int x, int y, int w, int h)
填充背景。 更多...
short USER_API | dc_NtagCommand (HANDLE icdev, unsigned char type, unsigned char mode, unsigned int slen, const unsigned char *sdata, unsigned int *rlen, unsigned char *rdata)
NTAG标签交互。 更多...
short USER_API | dc_SetCpuVoltage (HANDLE icdev, unsigned char voltage)
设置接触式CPU卡电压。 更多...
short USER_API | dc_LcdDisplayText (HANDLE icdev, unsigned char line, unsigned char offset, unsigned char mode, unsigned char charset, const unsigned char *text)
LCD显示文字。 更多...
short USER_API | dc_LcdDisplayTextFromData (HANDLE icdev, unsigned char line, unsigned char offset, unsigned char mode, unsigned char charset, const unsigned char *text, const unsigned char *data, int data_len)
LCD显示文字。 更多...
short USER_API | dc_DownloadFileData (HANDLE icdev, unsigned int file_type, unsigned int file_size, unsigned int flag, const unsigned char *data, unsigned int *data_size)
装载文件数据。 更多...
short USER_API | dc_check_1608 (HANDLE icdev)
检测1608卡。 更多...
short USER_API | dc_down_1608 (HANDLE icdev)
1608卡下电。 更多...
short USER_API | dc_read_1608 (HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata)
读1608卡。 更多...
short USER_API | dc_read_1608_hex (HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata)
读1608卡。 更多...
short USER_API | dc_write_1608 (HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata)
写1608卡。 更多...
short USER_API | dc_write_1608_hex (HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata)
写1608卡。 更多...
short USER_API | dc_checkpass_1608 (HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password)
验证1608卡密码。 更多...
short USER_API | dc_checkpass_1608_hex (HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password)
验证1608卡密码。 更多...
short USER_API | dc_init_auth_1608 (HANDLE icdev, unsigned char *databuffer)
初始化1608卡认证。 更多...
short USER_API | dc_init_auth_1608_hex (HANDLE icdev, unsigned char *databuffer)
初始化1608卡认证。 更多...
short USER_API | dc_check_auth_1608 (HANDLE icdev, unsigned char *databuffer)
核对1608卡认证。 更多...
short USER_API | dc_check_auth_1608_hex (HANDLE icdev, unsigned char *databuffer)
核对1608卡认证。 更多...
short USER_API | dc_write_fuse_1608 (HANDLE icdev, unsigned char value)
写1608卡熔丝。 更多...
short USER_API | dc_read_fuse_1608 (HANDLE icdev, unsigned char *value)
读1608卡熔丝。 更多...
short USER_API | dc_check_153 (HANDLE icdev)
检测153卡。 更多...
short USER_API | dc_down_153 (HANDLE icdev)
153卡下电。 更多...
short USER_API | dc_read_153 (HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata)
读153卡。 更多...
short USER_API | dc_read_153_hex (HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata)
读153卡。 更多...
short USER_API | dc_write_153 (HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata)
写153卡。 更多...
short USER_API | dc_write_153_hex (HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata)
写153卡。 更多...
short USER_API | dc_checkpass_153 (HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password)
验证153卡密码。 更多...
short USER_API | dc_checkpass_153_hex (HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password)
验证153卡密码。 更多...
short USER_API | dc_init_auth_153 (HANDLE icdev, unsigned char *databuffer)
初始化153卡认证。 更多...
short USER_API | dc_init_auth_153_hex (HANDLE icdev, unsigned char *databuffer)
初始化153卡认证。 更多...
short USER_API | dc_check_auth_153 (HANDLE icdev, unsigned char *databuffer)
核对153卡认证。 更多...
short USER_API | dc_check_auth_153_hex (HANDLE icdev, unsigned char *databuffer)
核对153卡认证。 更多...
short USER_API | dc_write_fuse_153 (HANDLE icdev, unsigned char value)
写153卡熔丝。 更多...
short USER_API | dc_read_fuse_153 (HANDLE icdev, unsigned char *value)
读153卡熔丝。 更多...
short USER_API | dc_MultiAntennaStartOrStop (HANDLE icdev, unsigned char flag, unsigned int *mask)
多天线启动或停止。 更多...
short USER_API | dc_MultiAntennaGetCardStatus (HANDLE icdev, int *rlen, unsigned char *rdata)
多天线获取卡状态。 更多...
short USER_API | dc_SetPinpadWithReaderBaudrate (HANDLE icdev, unsigned char value)
设置reader与密码键盘串口波特率。 更多...
short USER_API | dc_CheckPinpadWithReaderBaudrate (HANDLE icdev, unsigned char *value)
查询reader与密码键盘串口波特率。 更多...
short USER_API | dc_IdCardReadCardInfo (HANDLE icdev, unsigned char mode, unsigned char type, int *text_len, unsigned char *text, int *photo_len, unsigned char *photo, int *fingerprint_len, unsigned char *fingerprint, int *extra_len, unsigned char *extra)
读身份证。 更多...
short USER_API | dc_LcdDisplay (HANDLE icdev, unsigned char line, unsigned char offset, unsigned char mode, const char *data)
液晶显示。 更多...
short USER_API | dc_ReadDeviceCustomSerialNumber (HANDLE icdev, unsigned char number, char *data)
读设备定制序列号。 更多...
short USER_API | dc_WriteDeviceCustomSerialNumber (HANDLE icdev, unsigned char number, const char *data)
写设备定制序列号。 更多...
short USER_API | dc_SelfServiceDeviceRecoverError (HANDLE icdev, unsigned char type)
错误恢复。 更多...
short USER_API | dc_GetBankAccountNumber (HANDLE icdev, int type, char *number)
获取银行卡帐户号码。 更多...
short USER_API | dc_GetBankMagInfo (HANDLE icdev, int type, char *track1, char *track2, char *track3)
获取银行卡磁条信息。 更多...
short USER_API | dc_IdCardImageBuild (HANDLE icdev, int type, int text_len, const unsigned char *text, int photo_len, const unsigned char *photo, const char *front_file, const char *back_file)
生成身份证正面和背面图像。 更多...
short USER_API | dc_CvLibLoad (HANDLE icdev)
摄像视觉库加载。 更多...
short USER_API | dc_CvLibUnload (HANDLE icdev)
摄像视觉库卸载。 更多...
short USER_API | dc_CvOpen (HANDLE icdev, int number)
开启摄像头。 更多...
short USER_API | dc_CvClose (HANDLE icdev, int number)
关闭摄像头。 更多...
short USER_API | dc_CvCapture (HANDLE icdev, int number, int mode, const char *file_name)
拍照。 更多...

详细描述

读写器功能接口声明文件。

作者
Wei Yang wstcr.nosp@m.eato.nosp@m.r@hot.nosp@m.mail.nosp@m..com
日期
Tue Dec 20 11:42:16 2016

函数说明

§ LibMain()

void USER_API LibMain | ( | int | flag,
 |  | void * | context
 | ) |  |

库入口。

说明：
可以获取或设置一些库相关参数，此接口可不掉用，如需调用必须放在所有其它接口之前调用。
参数
[in] flag 标记，用于决定 context 的类型和含义。
0 - 表示获取库版本， context 类型为char *，请至少分配8个字节。
1 - 表示设置库的工作目录， context 类型为const char *。
2 - 表示设置库调用者的工作目录， context 类型为const char *。
3 - 保留内部使用，表示设置辅助接口上下文， context 类型为自定义结构指针。
4 - 保留内部使用，表示获取辅助接口上下文， context 类型为自定义结构指针。
[in,out] context 参数实际类型和含义由 flag 的值来决定。

§ dc_config_port_name()

void USER_API dc_config_port_name | ( | short | port,
 |  | const char * | name
 | ) |  |

配置端口名称。

说明：
用于配置端口对应的物理名称，在调用 dc_init 之前可以使用此接口来改变端口号内部对应的默认物理名称，如Windows平台下0端口号对应的默认名称为"COM1"，Linux平台下0端口号对应的默认名称为"/dev/ttyS0"。
参数
[in] | port | 端口号，同 dc_init 的 port ，但仅支持串口模式和蓝牙模式的端口号，即：0~99、300~399。
[in] | name | 物理名称。

§ dc_init()

HANDLE USER_API dc_init | ( | short | port,
 |  | int | baud
 | ) |  |

打开设备。

说明：
建立设备的通讯并且分配相应的资源，大部分功能接口都需要在此过程后才能进行，在不需要使用设备后，必须使用 dc_exit 去关闭设备的通讯和释放资源。
参数
[in] port 端口号。
0~99 - 表示串口模式（编号物理对应），编号0表示第一个串口合法设备，编号1表示第二个串口合法设备，以此类推。
100~199 - 表示USB模式（编号逻辑对应），编号100表示第一个USB合法设备，编号1表示第二个USB合法设备，以此类推。
200~299 - 表示PCSC模式（编号逻辑对应），编号200表示第一个PCSC合法设备，编号201表示第二个PCSC合法设备，以此类推。
300~399 - 表示蓝牙模式（编号逻辑对应），编号300表示第一个蓝牙合法设备，编号301表示第二个蓝牙合法设备，以此类推。
[in] baud 波特率，只针对串口模式有效。
返回
<0表示失败，否则为设备标识符。

§ dc_init_name()

HANDLE USER_API dc_init_name | ( | short | port,
 |  | int | baud,
 |  | const char * | name
 | ) |  |

打开设备。

说明：
建立设备的通讯并且分配相应的资源，大部分功能接口都需要在此过程后才能进行，在不需要使用设备后，必须使用 dc_exit 去关闭设备的通讯和释放资源。
参数
[in] port 端口号。
0~99 - 表示串口模式（编号物理对应），编号0表示第一个串口合法设备，编号1表示第二个串口合法设备，以此类推。
100~199 - 表示USB模式（编号逻辑对应），编号100表示第一个USB合法设备，编号1表示第二个USB合法设备，以此类推。
200~299 - 表示PCSC模式（编号逻辑对应），编号200表示第一个PCSC合法设备，编号201表示第二个PCSC合法设备，以此类推。
300~399 - 表示蓝牙模式（编号逻辑对应），编号300表示第一个蓝牙合法设备，编号301表示第二个蓝牙合法设备，以此类推。
[in] | baud | 波特率，只针对串口模式有效。
[in] | name | 设备逻辑名称。
返回
<0表示失败，否则为设备标识符。

§ dc_exit()

short USER_API dc_exit ( HANDLE icdev )

关闭设备。

说明：
关闭设备的通讯和释放资源。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_getname()

short USER_API dc_getname | ( | HANDLE | icdev,
 |  | char * | name
 | ) |  |

获取名称。

说明：
此接口将获取一个用于识别当前打开设备与软件层对应的逻辑名称，获取的逻辑名称仅供内部使用。
参数
[in] | icdev | 设备标识符。
[out] | name | 返回的名称字符串，请至少分配64个字节。
返回
<0表示失败，==0表示成功。

§ dc_request()

short USER_API dc_request | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned short * | TagType
 | ) |  |

寻卡请求。

说明：
支持ISO 14443 Type A类型卡片的寻卡请求。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，0x00表示对空闲卡进行操作，0x01表示对所有卡操作。
[out] | TagType | 返回的ATQA值。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_anticoll()

short USER_API dc_anticoll | ( | HANDLE | icdev,
 |  | unsigned char | _Bcnt,
 |  | unsigned int * | _Snr
 | ) |  |

防卡冲突。

说明：
支持ISO 14443 Type A类型卡片的防卡冲突。
参数
[in] | icdev | 设备标识符。
[in] | _Bcnt | 保留，固定为0x00。
[out] | _Snr | 返回的卡序列号。
返回
<0表示失败，==0表示成功。

§ dc_select()

short USER_API dc_select | ( | HANDLE | icdev,
 |  | unsigned int | _Snr,
 |  | unsigned char * | _Size
 | ) |  |

选卡操作。

说明：
通过指定序列号，选取相应的卡片。
参数
[in] | icdev | 设备标识符。
[in] | _Snr | 卡片序列号。
[out] | _Size | 返回的SAK值。
返回
<0表示失败，==0表示成功。

§ dc_authentication()

short USER_API dc_authentication | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char | _SecNr
 | ) |  |

验证M1卡密码。

说明：
使用设备内部装载的密码来验证M1卡密码。
参数
[in] | icdev | 设备标识符。
[in] _Mode 模式。
0x00 - 表示用设备内部装载的第0套A密码来验证当前选取卡片的A密码。
0x01 - 表示用设备内部装载的第1套A密码来验证当前选取卡片的A密码。
0x02 - 表示用设备内部装载的第2套A密码来验证当前选取卡片的A密码。
0x04 - 表示用设备内部装载的第0套B密码来验证当前选取卡片的B密码。
0x05 - 表示用设备内部装载的第1套B密码来验证当前选取卡片的B密码。
0x06 - 表示用设备内部装载的第2套B密码来验证当前选取卡片的B密码。
[in] | _SecNr | 要验证密码的扇区号。
返回
<0表示失败，==0表示成功。

§ dc_halt()

short USER_API dc_halt ( HANDLE icdev )

终止卡操作。

说明：
使卡片进入终止状态，此时必须把卡移出感应区后再次放入感应区才能寻到这张卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_read()

short USER_API dc_read | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned char * | _Data
 | ) |  |

读卡数据。

说明：
读取卡内数据，对于M1卡，一次读取一个块的数据，为16个字节；对于ML卡，一次读取相同属性的两页，为8个字节。
参数
[in] | icdev | 设备标识符。
[in] _Adr 地址。
M1卡 - S50块地址（0~63），S70块地址（0~255）。
ML卡 - 页地址（0~11）。
[out] | _Data | 固定返回16个字节数据，真实数据可能小于16个字节。
返回
<0表示失败，==0表示成功。

§ dc_read_hex()

short USER_API dc_read_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | char * | _Data
 | ) |  |

读卡数据。

说明：
dc_read 的HEX形式接口，参数 _Data 为HEX格式。

§ dc_write()

short USER_API dc_write | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned char * | _Data
 | ) |  |

写卡数据。

说明：
写入数据到卡片内，对于M1卡，一次必须写入一个块的数据，为16个字节；对于ML卡，一次必须写入一个页的数据，为4个字节。
参数
[in] | icdev | 设备标识符。
[in] _Adr 地址。
M1卡 - S50块地址（1~63），S70块地址（1~255）。
ML卡 - 页地址（2~11）。
[out] | _Data | 固定传入16个字节数据，真实数据可能小于16个字节。
返回
<0表示失败，==0表示成功。

§ dc_write_hex()

short USER_API dc_write_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | char * | _Data
 | ) |  |

写卡数据。

说明：
dc_write 的HEX形式接口，参数 _Data 为HEX格式。

§ dc_load_key()

short USER_API dc_load_key | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char | _SecNr,
 |  | unsigned char * | _NKey
 | ) |  |

装载设备密码。

说明：
装载M1卡密码到设备内部，装载后可以在特定时候用 dc_authentication 来验证M1卡密码。注意：由于多次装载设备密码可能会受硬件存储寿命限制，此接口只用于密码相对固定，装载次数少的场合。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，同 dc_authentication 的 _Mode 。
[in] | _SecNr | 对应装载的扇区号。
[in] | _NKey | 写入设备中的卡密码，固定为6个字节。
返回
<0表示失败，==0表示成功。

§ dc_load_key_hex()

short USER_API dc_load_key_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char | _SecNr,
 |  | char * | _NKey
 | ) |  |

装载设备密码。

说明：
dc_load_key 的HEX形式接口，参数 _NKey 为HEX格式。

§ dc_card()

short USER_API dc_card | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned int * | _Snr
 | ) |  |

寻卡请求、防卡冲突、选卡操作。

说明：
内部包含了 dc_request dc_anticoll dc_select 的功能。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，同 dc_request 的 _Mode 。
[out] | _Snr | 返回的卡序列号。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_card_hex()

short USER_API dc_card_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char * | snrstr
 | ) |  |

寻卡请求、防卡冲突、选卡操作。

说明：
dc_card 的HEX形式接口，参数 snrstr 为HEX格式。

§ dc_changeb3()

short USER_API dc_changeb3 | ( | HANDLE | icdev,
 |  | unsigned char | _SecNr,
 |  | unsigned char * | _KeyA,
 |  | unsigned char | _B0,
 |  | unsigned char | _B1,
 |  | unsigned char | _B2,
 |  | unsigned char | _B3,
 |  | unsigned char | _Bk,
 |  | unsigned char * | _KeyB
 | ) |  |

M1卡密码配置块操作。

说明：
修改M1卡密码配置块数据，M1卡密码配置块也就是每个扇区的最后一块，包含密码A、控制字节、密码B数据。
参数
[in] | icdev | 设备标识符。
[in] | _SecNr | 扇区号。
[in] | _KeyA | 密码A，固定为6个字节。
[in] | _B0 | 块0控制字（当一扇区有16块时，对应为块0~4的控制字），低3位（D2D1D0）对应C10、C20、C30。
[in] | _B1 | 块1控制字（当一扇区有16块时，对应为块5~9的控制字），低3位（D2D1D0）对应C11、C21、C31。
[in] | _B2 | 块2控制字（当一扇区有16块时，对应为块10~14的控制字），低3位（D2D1D0）对应C12、C22、C32。
[in] | _B3 | 块3控制字（当一扇区有16块时，对应为块15的控制字），低3位（D2D1D0）对应C13、C23、C33。
[in] | _Bk | 保留，固定为0x00。
[in] | _KeyB | 密码B，固定为6个字节。
返回
<0表示失败，==0表示成功。

§ dc_changeb3_hex()

short USER_API dc_changeb3_hex | ( | HANDLE | icdev,
 |  | unsigned char | _SecNr,
 |  | const char * | _KeyA,
 |  | unsigned char | _B0,
 |  | unsigned char | _B1,
 |  | unsigned char | _B2,
 |  | unsigned char | _B3,
 |  | unsigned char | _Bk,
 |  | const char * | _KeyB
 | ) |  |

M1卡密码配置块操作。

说明：
dc_changeb3 的HEX形式接口，参数 _KeyA _KeyB 为HEX格式。

§ dc_restore()

short USER_API dc_restore | ( | HANDLE | icdev,
 |  | unsigned char | _Adr
 | ) |  |

M1卡值块回传。

说明：
用于把指定的值块内容暂存，后续可以使用 dc_transfer 将暂存值块内容传递到另一块中，实现块与块之间数值传送。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 要回传的块地址。
返回
<0表示失败，==0表示成功。

§ dc_transfer()

short USER_API dc_transfer | ( | HANDLE | icdev,
 |  | unsigned char | _Adr
 | ) |  |

M1卡值块传递。

说明：
用于把 dc_restore 暂存的值块内容传递到指定块中，实现块与块之间数值传送。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 要传递的块地址。
返回
<0表示失败，==0表示成功。

§ dc_increment()

short USER_API dc_increment | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned int | _Value
 | ) |  |

M1卡值块加值。

说明：
用于操作M1卡值块，使块值增加指定数值。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 块地址。
[in] | _Value | 要增加的数值。
返回
<0表示失败，==0表示成功。

§ dc_decrement()

short USER_API dc_decrement | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned int | _Value
 | ) |  |

M1卡值块减值。

说明：
用于操作M1卡值块，使块值减少指定数值。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 块地址。
[in] | _Value | 要减少的数值。
返回
<0表示失败，==0表示成功。

§ dc_initval()

short USER_API dc_initval | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned int | _Value
 | ) |  |

M1卡值块初始化。

说明：
用于操作M1卡，使得指定块为值块，并且初始化此值块为指定数值。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 块地址。
[in] | _Value | 初始化数值。
返回
<0表示失败，==0表示成功。

§ dc_readval()

short USER_API dc_readval | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned int * | _Value
 | ) |  |

M1卡值块读值。

说明：
用于读取M1卡值块数值。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 要读取的块地址。
[out] | _Value | 返回的数值。
返回
<0表示失败，==0表示成功。

§ dc_initval_ml()

short USER_API dc_initval_ml | ( | HANDLE | icdev,
 |  | unsigned short | _Value
 | ) |  |

ML卡值初始化。

说明：
用于操作ML卡，初始化卡内容为指定数值。
参数
[in] | icdev | 设备标识符。
[in] | _Value | 初始化数值。
返回
<0表示失败，==0表示成功。

§ dc_readval_ml()

short USER_API dc_readval_ml | ( | HANDLE | icdev,
 |  | unsigned short * | _Value
 | ) |  |

ML卡读值。

说明：
用于读取ML卡数值。
参数
[in] | icdev | 设备标识符。
[out] | _Value | 返回的数值。
返回
<0表示失败，==0表示成功。

§ dc_decrement_ml()

short USER_API dc_decrement_ml | ( | HANDLE | icdev,
 |  | unsigned short | _Value
 | ) |  |

ML卡减值。

说明：
用于操作ML卡值，使值减少指定数值。
参数
[in] | icdev | 设备标识符。
[in] | _Value | 要减少的数值。
返回
<0表示失败，==0表示成功。

§ dc_authentication_2()

short USER_API dc_authentication_2 | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char | KeyNr,
 |  | unsigned char | Adr
 | ) |  |

验证M1卡密码。

说明：
使用设备内部装载的密码来验证M1卡密码。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，同 dc_authentication 的 _Mode 。
[in] | KeyNr | 要验证密码的扇区号。
[in] | Adr | 要验证密码扇区中的块号，此块号非卡片绝对块号。
返回
<0表示失败，==0表示成功。

§ dc_anticoll2()

short USER_API dc_anticoll2 | ( | HANDLE | icdev,
 |  | unsigned char | _Bcnt,
 |  | unsigned int * | _Snr
 | ) |  |

第二级防卡冲突。

说明：
支持ISO 14443 Type A类型卡片的第二级防卡冲突。
参数
[in] | icdev | 设备标识符。
[in] | _Bcnt | 保留，固定为0x00。
[out] | _Snr | 返回的卡序列号。
返回
<0表示失败，==0表示成功。

§ dc_select2()

short USER_API dc_select2 | ( | HANDLE | icdev,
 |  | unsigned int | _Snr,
 |  | unsigned char * | _Size
 | ) |  |

第二级选卡操作。

说明：
通过指定序列号，选取相应的卡片。
参数
[in] | icdev | 设备标识符。
[in] | _Snr | 卡片序列号。
[out] | _Size | 返回的SAK值。
返回
<0表示失败，==0表示成功。

§ dc_HL_authentication()

short USER_API dc_HL_authentication | ( | HANDLE | icdev,
 |  | unsigned char | reqmode,
 |  | unsigned int | snr,
 |  | unsigned char | authmode,
 |  | unsigned char | secnr
 | ) |  |

高层验证M1卡密码。

说明：
内部包含了 dc_card dc_authentication 的功能。
参数
[in] | icdev | 设备标识符。
[in] | reqmode | 寻卡请求模式，同 dc_request 的 _Mode 。
[in] | snr | 保留，固定为0。
[in] | authmode | 验证模式，同 dc_authentication 的 _Mode 。
[in] | secnr | 要验证密码的扇区号。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_check_write()

short USER_API dc_check_write | ( | HANDLE | icdev,
 |  | unsigned int | Snr,
 |  | unsigned char | authmode,
 |  | unsigned char | Adr,
 |  | unsigned char * | _data
 | ) |  |

检查之前写入的数据。

说明：
内部包含了 dc_card dc_authentication dc_read 的功能，并且验证传入和读取的数据是否一致。
参数
[in] | icdev | 设备标识符。
[in] | Snr | 卡序列号，用于内部核对。
[in] | authmode | 验证模式，同 dc_authentication 的 _Mode 。
[in] | Adr | 块地址。
[in] | _data | 块数据，固定为16个字节。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_check_writehex()

short USER_API dc_check_writehex | ( | HANDLE | icdev,
 |  | unsigned int | Snr,
 |  | unsigned char | authmode,
 |  | unsigned char | Adr,
 |  | unsigned char * | _data
 | ) |  |

检查之前写入的数据。

说明：
dc_check_write 的HEX形式接口，参数 _data 为HEX格式。

§ dc_getver()

short USER_API dc_getver | ( | HANDLE | icdev,
 |  | unsigned char * | sver
 | ) |  |

获取设备版本。

说明：
获取设备内部固件代码的版本。
参数
[in] | icdev | 设备标识符。
[out] | sver | 返回的版本字符串，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_reset()

short USER_API dc_reset | ( | HANDLE | icdev,
 |  | unsigned short | _Msec
 | ) |  |

复位射频。

说明：
复位设备的射频，可以关闭，关闭并且启动。
参数
[in] | icdev | 设备标识符。
[in] | _Msec | 为0表示关闭射频，否则为复位时间，单位为10毫秒，一般调用建议值为10。
返回
<0表示失败，==0表示成功。

§ dc_beep()

short USER_API dc_beep | ( | HANDLE | icdev,
 |  | unsigned short | _Msec
 | ) |  |

设备蜂鸣。

说明：
设备蜂鸣器发出指定时间的蜂鸣声。
参数
[in] | icdev | 设备标识符。
[in] | _Msec | 蜂鸣时间，单位为10毫秒。
返回
<0表示失败，==0表示成功。

§ dc_disp_str()

short USER_API dc_disp_str | ( | HANDLE | icdev,
 |  | char * | dispstr
 | ) |  |

液晶显示。

说明：
显示指定字符串到液晶屏幕上。
参数
[in] | icdev | 设备标识符。
[in] | dispstr | 要显示的字符串。
返回
<0表示失败，==0表示成功。

§ dc_srd_eeprom()

short USER_API dc_srd_eeprom | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | rec_buffer
 | ) |  |

读EEPROM。

说明：
读取设备内部EEPROM中的数据，可以用作数据保存等。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移地址。
[in] | length | 读取长度。
[out] | rec_buffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_swr_eeprom()

short USER_API dc_swr_eeprom | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | send_buffer
 | ) |  |

写EEPROM。

说明：
写入数据到设备内部EEPROM中，可以用作数据保存等。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移地址。
[in] | length | 写入长度。
[in] | send_buffer | 传入数据。
返回
<0表示失败，==0表示成功。

§ swr_alleeprom()

short USER_API swr_alleeprom | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | snd_buffer
 | ) |  |

写EEPROM。

说明：
同 dc_swr_eeprom 。

§ srd_alleeprom()

short USER_API srd_alleeprom | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | receive_buffer
 | ) |  |

读EEPROM。

说明：
同 dc_srd_eeprom 。

§ dc_srd_eepromhex()

short USER_API dc_srd_eepromhex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | rec_buffer
 | ) |  |

读EEPROM。

说明：
dc_srd_eeprom 的HEX形式接口，参数 rec_buffer 为HEX格式。

§ dc_swr_eepromhex()

short USER_API dc_swr_eepromhex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | send_buffer
 | ) |  |

写EEPROM。

说明：
dc_swr_eeprom 的HEX形式接口，参数 send_buffer 为HEX格式。

§ dc_gettime()

short USER_API dc_gettime | ( | HANDLE | icdev,
 |  | unsigned char * | time
 | ) |  |

获取设备时间。

说明：
获取设备当前的时间。
参数
[in] | icdev | 设备标识符。
[out] | time | 返回的时间，长度为7个字节，格式为'年'、'星期'、'月'、'日'、'时'、'分'、'秒'。如：0x16,0x01,0x12,0x08,0x16,0x20,0x10表示2016年星期一12月8日16时20分10秒。
返回
<0表示失败，==0表示成功。

§ dc_gettimehex()

short USER_API dc_gettimehex | ( | HANDLE | icdev,
 |  | char * | time
 | ) |  |

获取设备时间。

说明：
dc_gettime 的HEX形式接口，参数 time 为HEX格式。

§ dc_settime()

short USER_API dc_settime | ( | HANDLE | icdev,
 |  | unsigned char * | time
 | ) |  |

设置设备时间。

说明：
设置设备的当前时间。
参数
[in] | icdev | 设备标识符。
[in] | time | 传入时间，长度为7个字节，格式为'年'、'星期'、'月'、'日'、'时'、'分'、'秒'。如：0x16,0x01,0x12,0x08,0x16,0x20,0x10表示2016年星期一12月8日16时20分10秒。
返回
<0表示失败，==0表示成功。

§ dc_settimehex()

short USER_API dc_settimehex | ( | HANDLE | icdev,
 |  | char * | time
 | ) |  |

设置设备时间。

说明：
dc_settime 的HEX形式接口，参数 time 为HEX格式。

§ dcdeshex()

short USER_API dcdeshex | ( | unsigned char * | key,
 |  | unsigned char * | sour,
 |  | unsigned char * | dest,
 |  | short | m
 | ) |  |

单DES加解密。

说明：
dcdes 的HEX形式接口，参数 key sour dest 为HEX格式。

§ dcdes()

short USER_API dcdes | ( | unsigned char * | key,
 |  | unsigned char * | sour,
 |  | unsigned char * | dest,
 |  | short | m
 | ) |  |

单DES加解密。

说明：
使用单DES算法对数据进行加密/解密。
参数
[in] | key | 8个字节密钥。
[in] | sour | 8个字节要做加密/解密的数据。
[out] | dest | 返回8个字节运算后的数据。
[in] | m | 模式，0-解密，1-加密。
返回
<0表示失败，==0表示成功。

§ dc_light()

short USER_API dc_light | ( | HANDLE | icdev,
 |  | unsigned short | _OnOff
 | ) |  |

指示灯点亮/熄灭。

说明：
点亮/熄灭设备的指示灯。
参数
[in] | icdev | 设备标识符。
[in] | _OnOff | 0-点亮，1-熄灭。
返回
<0表示失败，==0表示成功。

§ dc_high_disp()

short USER_API dc_high_disp | ( | HANDLE | icdev,
 |  | unsigned char | offset,
 |  | unsigned char | displen,
 |  | unsigned char * | dispstr
 | ) |  |

液晶显示。

说明：
显示指定数据到液晶屏幕上。
参数
[in] | icdev | 设备标识符。
[in] | offset | 屏幕偏移。
[in] | displen | 显示数据的长度。
[in] | dispstr | 显示数据。
返回
<0表示失败，==0表示成功。

§ dc_setcpu()

short USER_API dc_setcpu | ( | HANDLE | icdev,
 |  | unsigned char | _Byte
 | ) |  |

设置当前接触式卡座。

说明：
设置当前接触式卡座为指定卡座，用于多卡座切换卡操作。
参数
[in] icdev 设备标识符。
[in] _Byte 卡座编号。
0x0C - 附卡座/接触式CPU1卡座。
0x0B - 接触式CPU2卡座。
0x0D - SAM1卡座。
0x0E - SAM2卡座。
0x0F - SAM3卡座。
0x11 - SAM4卡座。
0x12 - SAM5卡座。
0x13 - SAM6卡座/ESAM芯片。
0x14 - SAM7卡座。
0x15 - SAM8卡座。
返回
<0表示失败，==0表示成功。

§ dc_cpureset()

short USER_API dc_cpureset | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

接触式CPU卡复位。

说明：
对当前卡座CPU卡进行复位操作，此复位为冷复位。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回复位信息的长度。
[out] | databuffer | 返回的复位信息，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_cpuapdusource()

short USER_API dc_cpuapdusource | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
对当前卡座CPU卡进行指令交互操作，注意此接口不封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_cpuapdu()

short USER_API dc_cpuapdu | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
对当前卡座CPU卡进行指令交互操作，注意此接口已封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_cpureset_hex()

short USER_API dc_cpureset_hex | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | char * | databuffer
 | ) |  |

接触式CPU卡复位。

说明：
dc_cpureset 的HEX形式接口，参数 databuffer 为HEX格式。

§ dc_cpuapdusource_hex()

short USER_API dc_cpuapdusource_hex | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
dc_cpuapdusource 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_cpuapdu_hex()

short USER_API dc_cpuapdu_hex | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
dc_cpuapdu 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_cpuapdurespon()

short USER_API dc_cpuapdurespon | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
对当前卡座CPU卡进行指令交互操作，注意此接口已封装卡协议部分，内部处理了SW1为0x61和0x6C的情况。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_cpuapdurespon_hex()

short USER_API dc_cpuapdurespon_hex | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
dc_cpuapdurespon 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_cpudown()

short USER_API dc_cpudown ( HANDLE icdev )

接触式CPU卡下电。

说明：
对当前卡座CPU卡进行下电操作。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_pro_reset()

short USER_API dc_pro_reset | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | unsigned char * | receive_data
 | ) |  |

非接触式CPU卡复位。

说明：
对感应区CPU卡进行复位操作。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回复位信息的长度。
[out] | receive_data | 返回的复位信息，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_pro_command()

short USER_API dc_pro_command | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
对感应区CPU卡进行指令交互操作，注意此接口已封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
[in] | timeout | 超时值，此值只在部分设备的底层使用，单位为250毫秒，一般调用建议值为7。
返回
<0表示失败，==0表示成功。

§ dc_pro_resethex()

short USER_API dc_pro_resethex | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | char * | receive_data
 | ) |  |

非接触式CPU卡复位。

说明：
dc_pro_reset 的HEX形式接口，参数 receive_data 为HEX格式。

§ dc_pro_resetInt()

short USER_API dc_pro_resetInt | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | unsigned char * | receive_data
 | ) |  |

非接触式CPU卡复位。

说明：
对感应区CPU卡进行复位操作。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回复位信息的长度。
[out] | receive_data | 返回的复位信息，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_pro_resetInt_hex()

short USER_API dc_pro_resetInt_hex | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | char * | receive_data
 | ) |  |

非接触式CPU卡复位。

说明：
dc_pro_resetInt 的HEX形式接口，参数 receive_data 为HEX格式。

§ dc_pro_commandhex()

short USER_API dc_pro_commandhex | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
dc_pro_command 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_pro_commandsource()

short USER_API dc_pro_commandsource | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
对感应区CPU卡进行指令交互操作，注意此接口不封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
[in] | timeout | 超时值，此值只在部分设备的底层使用，单位为250毫秒，一般调用建议值为7。
返回
<0表示失败，==0表示成功。

§ dc_pro_commandsourcehex()

short USER_API dc_pro_commandsourcehex | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
dc_pro_commandsource 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_pro_commandsource_int()

short USER_API dc_pro_commandsource_int | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
对感应区CPU卡进行指令交互操作，注意此接口不封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
[in] | timeout | 超时值，此值只在部分设备的底层使用，单位为250毫秒，一般调用建议值为7。
返回
<0表示失败，==0表示成功。

§ dc_pro_halt()

short USER_API dc_pro_halt ( HANDLE icdev )

终止非接触式CPU卡操作。

说明：
使非接触式CPU卡进入终止状态，此时必须把卡移出感应区后再次放入感应区才能寻到这张卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_request_shc1102()

short USER_API dc_request_shc1102 | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned short * | TagType
 | ) |  |

SHC1102卡寻卡请求。

说明：
支持SHC1102卡的寻卡请求。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，0x00表示对空闲卡进行操作，0x01表示对所有卡操作。
[out] | TagType | 返回的ATQA值。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_auth_shc1102()

short USER_API dc_auth_shc1102 | ( | HANDLE | icdev,
 |  | unsigned char * | _Data
 | ) |  |

验证SHC1102卡密码。

说明：
使用传入的密码来验证SHC1102卡密码。
参数
[in] | icdev | 设备标识符。
[in] | _Data | 密码，固定为4个字节。
返回
<0表示失败，==0表示成功。

§ dc_read_shc1102()

short USER_API dc_read_shc1102 | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned char * | _Data
 | ) |  |

读SHC1102卡。

说明：
读取SHC1102卡的数据。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 块地址（0~15）。
[out] | _Data | 返回的数据，固定为4个字节。
返回
<0表示失败，==0表示成功。

§ dc_write_shc1102()

short USER_API dc_write_shc1102 | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned char * | _Data
 | ) |  |

写SHC1102卡。

说明：
写入数据到SHC1102卡中。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 块地址（2~15）。
[in] | _Data | 传入数据，固定为4个字节。
返回
<0表示失败，==0表示成功。

§ dc_halt_shc1102()

short USER_API dc_halt_shc1102 ( HANDLE icdev )

终止SHC1102卡操作。

说明：
使SHC1102卡进入终止状态，此时必须把卡移出感应区后再次放入感应区才能寻到这张卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ hex_a()

short USER_API hex_a | ( | unsigned char * | hex,
 |  | unsigned char * | a,
 |  | short | length
 | ) |  |

数据转换。

说明：
普通数据换成十六进制字符串（短转长）。
参数
[in] | hex | 要转换的数据。
[out] | a | 转换后的字符串。
[in] | length | 要转换数据的长度。
返回
<0表示失败，==0表示成功。

§ a_hex()

short USER_API a_hex | ( | unsigned char * | a,
 |  | unsigned char * | hex,
 |  | short | len
 | ) |  |

数据转换。

说明：
十六进制字符数据转换为普通数据（长转短）。
参数
[in] | a | 要转换的数据。
[out] | hex | 转换后的数据。
[in] | len | 要转换数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_config_card()

short USER_API dc_config_card | ( | HANDLE | icdev,
 |  | unsigned char | cardtype
 | ) |  |

配置非接触卡类型。

说明：
配置需要操作什么类型的非接触式卡，设备上电后默认操作Type A卡，可以使用此接口来改变类型，一般在寻卡前调用此接口。
参数
[in] | icdev | 设备标识符。
[in] | cardtype | 类型，'A'表示Type A卡，'B'表示Type B卡。
返回
<0表示失败，==0表示成功。

§ dc_request_b()

short USER_API dc_request_b | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char | AFI,
 |  | unsigned char | N,
 |  | unsigned char * | ATQB
 | ) |  |

寻卡请求。

说明：
支持ISO 14443 Type B类型卡片的寻卡请求。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 保留，固定为0x00。
[in] | AFI | 应用族标识符。
[in] | N | 时间槽编号。
[out] | ATQB | 返回的ATQB值，请至少分配32个字节。
返回
<0表示失败，==0表示成功。

§ dc_slotmarker()

short USER_API dc_slotmarker | ( | HANDLE | icdev,
 |  | unsigned char | N,
 |  | unsigned char * | ATQB
 | ) |  |

管道标记。

说明：
支持ISO 14443 Type B类型卡片的管道标记。
参数
[in] | icdev | 设备标识符。
[in] | N | 时间槽编号。
[out] | ATQB | 返回的ATQB值，请至少分配32个字节。
返回
<0表示失败，==0表示成功。

§ dc_attrib()

short USER_API dc_attrib | ( | HANDLE | icdev,
 |  | unsigned char * | PUPI,
 |  | unsigned char | CID
 | ) |  |

激活卡片。

说明：
支持ISO 14443 Type B类型卡片的激活。
参数
[in] | icdev | 设备标识符。
[in] | PUPI | 伪唯一PICC标识符，固定为4个字节。
[in] | CID | 信道号。
返回
<0表示失败，==0表示成功。

§ dc_mfdes_auth()

short USER_API dc_mfdes_auth | ( | HANDLE | icdev,
 |  | unsigned char | keyno,
 |  | unsigned char | keylen,
 |  | unsigned char * | authkey,
 |  | unsigned char * | randAdata,
 |  | unsigned char * | randBdata
 | ) |  |

Mifare Desfire卡认证。

说明：
对Mifare Desfire卡进行认证。
参数
[in] | icdev | 设备标识符。
[in] | keyno | 密钥号。
[in] | keylen | 密钥数据的长度。
[in] | authkey | 密钥数据。
[in] | randAdata | 传入随机数A，8个字节。
[out] | randBdata | 返回的随机数B，8个字节。
返回
<0表示失败，==0表示成功。

§ dc_authentication_pass()

short USER_API dc_authentication_pass | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char | _Addr,
 |  | unsigned char * | passbuff
 | ) |  |

验证M1卡密码。

说明：
使用传入的密码来验证M1卡密码。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，0x00表示验证A密码，0x04表示验证B密码。
[in] | _Addr | 要验证密码的扇区号。
[in] | passbuff | 密码，固定为6个字节。
返回
<0表示失败，==0表示成功。

§ dc_disp_neg()

short USER_API dc_disp_neg | ( | HANDLE | icdev,
 |  | char * | dispstr
 | ) |  |

高层液晶显示。

说明：
显示指定数据到液晶屏幕上。
参数
[in] | icdev | 设备标识符。
[in] | dispstr | 显示字符串。
返回
<0表示失败，==0表示成功。

§ dc_pro_commandlink()

short USER_API dc_pro_commandlink | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout,
 |  | unsigned char | FG
 | ) |  |

非接触式CPU卡指令交互。

说明：
对感应区CPU卡进行指令交互操作，注意此接口已封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
[in] | timeout | 超时值，此值只在部分设备的底层使用，单位为250毫秒，一般调用建议值为7。
[in] | FG | 分割值，此值只在部分设备的底层使用，单位为字节，一般调用建议值为64。
返回
<0表示失败，==0表示成功。

§ dc_pro_commandlink_hex()

short USER_API dc_pro_commandlink_hex | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout,
 |  | unsigned char | FG
 | ) |  |

非接触式CPU卡指令交互。

说明：
dc_pro_commandlink 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_card_double()

short USER_API dc_card_double | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char * | _Snr
 | ) |  |

寻卡请求、防卡冲突、选卡操作。

说明：
内部包含了 dc_request dc_anticoll dc_select dc_anticoll2 dc_select2 的功能，此接口有设计缺陷，不能返回卡序列号实际长度，建议使用 dc_card_n 替代。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，同 dc_request 的 _Mode 。
[out] | _Snr | 返回的卡序列号，请至少分配8个字节。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_card_double_hex()

short USER_API dc_card_double_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char * | _Snr
 | ) |  |

寻卡请求、防卡冲突、选卡操作。

说明：
dc_card_double 的HEX形式接口，参数 _Snr 为HEX格式。

§ dc_read_idcard()

short USER_API dc_read_idcard | ( | HANDLE | icdev,
 |  | unsigned char | times,
 |  | unsigned char * | _Data
 | ) |  |

读ID卡。

说明：
读取ID卡数据。
参数
[in] | icdev | 设备标识符。
[in] | times | 设备超时值，单位为秒。
[out] | _Data | 返回的数据，固定为5个字节。
返回
<0表示失败，==0表示成功。

§ dc_read_idcard_hex()

short USER_API dc_read_idcard_hex | ( | HANDLE | icdev,
 |  | unsigned char | times,
 |  | unsigned char * | _Data
 | ) |  |

读取id卡。

说明：
dc_read_idcard 的HEX形式接口，参数 _Data 为HEX格式。

§ dc_authentication_pass_hex()

short USER_API dc_authentication_pass_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char | _Addr,
 |  | unsigned char * | passbuff
 | ) |  |

验证M1卡密码。

说明：
dc_authentication_pass 的HEX形式接口，参数 passbuff 为HEX格式。

§ dc_setcpupara()

short USER_API dc_setcpupara | ( | HANDLE | icdev,
 |  | unsigned char | cputype,
 |  | unsigned char | cpupro,
 |  | unsigned char | cpuetu
 | ) |  |

设置接触式CPU卡参数。

说明：
此接口可控制接触式CPU卡操作的行为，当不掉用时，设备将使用默认方式进行接触式CPU卡操作。
参数
[in] | icdev | 设备标识符。
[in] | cputype | 卡座编号，同 dc_setcpu 的 _Byte 。
[in] | cpupro | 卡协议编号，0x00表示T0，0x01表示T1，默认为0x00。
[in] | cpuetu | 卡复位波特率编号，0x5C表示9600，0x14表示38400.
返回
<0表示失败，==0表示成功。

§ dc_check_write_hex()

short USER_API dc_check_write_hex | ( | HANDLE | icdev,
 |  | unsigned int | Snr,
 |  | unsigned char | authmode,
 |  | unsigned char | Adr,
 |  | unsigned char * | _data
 | ) |  |

检查之前写入的数据。

说明：
dc_check_write 的HEX形式接口，参数 _data 为HEX格式。

§ dc_srd_eeprom_hex()

short USER_API dc_srd_eeprom_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | rec_buffer
 | ) |  |

读EEPROM。

说明：
dc_srd_eeprom 的HEX形式接口，参数 rec_buffer 为HEX格式。

§ dc_swr_eeprom_hex()

short USER_API dc_swr_eeprom_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | send_buffer
 | ) |  |

写EEPROM。

说明：
dc_swr_eeprom 的HEX形式接口，参数 send_buffer 为HEX格式。

§ dc_gettime_hex()

short USER_API dc_gettime_hex | ( | HANDLE | icdev,
 |  | char * | time
 | ) |  |

获取设备时间。

说明：
dc_gettime 的HEX形式接口，参数 time 为HEX格式。

§ dc_settime_hex()

short USER_API dc_settime_hex | ( | HANDLE | icdev,
 |  | char * | time
 | ) |  |

设置设备时间。

说明：
dc_settime 的HEX形式接口，参数 time 为HEX格式。

§ dc_des_hex()

short USER_API dc_des_hex | ( | unsigned char * | key,
 |  | unsigned char * | sour,
 |  | unsigned char * | dest,
 |  | short | m
 | ) |  |

单DES加解密。

说明：
dc_des 的HEX形式接口，参数 key sour dest 为HEX格式。

§ dc_des()

short USER_API dc_des | ( | unsigned char * | key,
 |  | unsigned char * | sour,
 |  | unsigned char * | dest,
 |  | short | m
 | ) |  |

单DES加解密。

说明：
使用单DES算法对数据进行加密/解密。
参数
[in] | key | 8个字节密钥。
[in] | sour | 8个字节要做加密/解密的数据。
[out] | dest | 返回8个字节运算后的数据。
[in] | m | 模式，0-解密，1-加密。
返回
<0表示失败，==0表示成功。

§ dc_pro_reset_hex()

short USER_API dc_pro_reset_hex | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | char * | receive_data
 | ) |  |

非接触式CPU卡复位。

说明：
dc_pro_reset 的HEX形式接口，参数 receive_data 为HEX格式。

§ dc_pro_command_hex()

short USER_API dc_pro_command_hex | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
dc_pro_command 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_pro_commandsource_hex()

short USER_API dc_pro_commandsource_hex | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
dc_pro_commandsource 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_authentication_passaddr()

short USER_API dc_authentication_passaddr | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char | _Addr,
 |  | unsigned char * | passbuff
 | ) |  |

验证M1卡密码。

说明：
使用传入的密码来验证M1卡密码。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，0x00表示验证A密码，0x04表示验证B密码。
[in] | _Addr | 要验证密码的块号。
[in] | passbuff | 密码，固定为6个字节。
返回
<0表示失败，==0表示成功。

§ dc_authentication_passaddr_hex()

short USER_API dc_authentication_passaddr_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned char | _Addr,
 |  | unsigned char * | passbuff
 | ) |  |

验证M1卡密码。

说明：
dc_authentication_passaddr 的HEX形式接口，参数 passbuff 为HEX格式。

§ dc_card_fm11rf005()

short USER_API dc_card_fm11rf005 | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned int * | _Snr
 | ) |  |

寻FM11RF005卡。

说明：
对FM11RF005卡进行寻卡操作。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，模式，同 dc_request 的 _Mode 。
[out] | _Snr | 返回的卡序列号。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_tripledes()

short USER_API dc_tripledes | ( | unsigned char * | key,
 |  | unsigned char * | src,
 |  | unsigned char * | dest,
 |  | short | m
 | ) |  |

三DES加解密。

说明：
使用三DES算法对数据进行加密/解密。
参数
[in] | key | 16个字节密钥。
[in] | src | 8个字节要做加密/解密的数据。
[out] | dest | 返回8个字节运算后的数据。
[in] | m | 模式，0-解密，1-加密。
返回
<0表示失败，==0表示成功。

§ dc_tripledes_hex()

short USER_API dc_tripledes_hex | ( | unsigned char * | key,
 |  | unsigned char * | src,
 |  | unsigned char * | dest,
 |  | short | m
 | ) |  |

三DES加解密。

说明：
dc_tripledes 的HEX形式接口，参数 key src dest 为HEX格式。

§ dc_mfdes_auth_hex()

short USER_API dc_mfdes_auth_hex | ( | HANDLE | icdev,
 |  | unsigned char | keyno,
 |  | unsigned char | keylen,
 |  | unsigned char * | authkey,
 |  | unsigned char * | randAdata,
 |  | unsigned char * | randBdata
 | ) |  |

Mifare Desfire卡认证。

说明：
dc_mfdes_auth 的HEX形式接口，参数 authkey randAdata randBdata 为HEX格式。

§ dc_getsnr_fm11rf005()

short USER_API dc_getsnr_fm11rf005 | ( | HANDLE | icdev,
 |  | unsigned int * | _Snr
 | ) |  |

获取FM11RF005卡序列号。

说明：
获取FM11RF005卡序列号。
参数
[in] | icdev | 设备标识符。
[out] | _Snr | 返回的卡序列号。
返回
<0表示失败，==0表示成功。

§ dc_getsnr_fm11rf005_hex()

short USER_API dc_getsnr_fm11rf005_hex | ( | HANDLE | icdev,
 |  | unsigned char * | snrstr
 | ) |  |

获取FM11RF005卡序列号。

说明：
dc_getsnr_fm11rf005 的HEX形式接口，参数 snrstr 为HEX格式。

§ dc_write_fm11rf005()

short USER_API dc_write_fm11rf005 | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned char * | _Data
 | ) |  |

写FM11RF005卡。

说明：
写入数据到FM11RF005卡中。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 块地址（2~15）。
[in] | _Data | 传入数据，固定为4个字节。
返回
<0表示失败，==0表示成功。

§ dc_read_fm11rf005()

short USER_API dc_read_fm11rf005 | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | unsigned char * | _Data
 | ) |  |

读FM11RF005卡。

说明：
读取FM11RF005卡的数据。
参数
[in] | icdev | 设备标识符。
[in] | _Adr | 块地址（0~15）。
[out] | _Data | 返回的数据，固定为4个字节。
返回
<0表示失败，==0表示成功。

§ dc_read_fm11rf005_hex()

short USER_API dc_read_fm11rf005_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | char * | _Data
 | ) |  |

读FM11RF005卡。

说明：
dc_read_fm11rf005 的HEX形式接口，参数 _Data 为HEX格式。

§ dc_write_fm11rf005_hex()

short USER_API dc_write_fm11rf005_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Adr,
 |  | char * | _Data
 | ) |  |

写FM11RF005卡。

说明：
dc_write_fm11rf005 的HEX形式接口，参数 _Data 为HEX格式。

§ dc_getinputpass()

short USER_API dc_getinputpass | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char * | rlen,
 |  | unsigned char * | cpass
 | ) |  |

键盘密码输入。

说明：
获取键盘按键，用于密码输入，不同的键盘装置可能有不同的效果，如不同的提示音或不同的显示。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[out] | rlen | 返回按键数据的长度，不含'\0'。
[out] | cpass | 返回的按键数据，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功，==0xA1表示取消输入，==0xA2表示输入超时。

§ dc_GetInputPass()

short USER_API dc_GetInputPass | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char * | rlen,
 |  | unsigned char * | cpass
 | ) |  |

键盘密码输入。

说明：
获取键盘按键，用于密码输入，不同的键盘装置可能有不同的效果，如不同的提示音或不同的显示。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[out] | rlen | 返回按键数据的长度，不含'\0'。
[out] | cpass | 返回的按键数据，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功，==0xA1表示取消输入，==0xA2表示输入超时。

§ dc_readmagcard()

short USER_API dc_readmagcard | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char * | pTrack2Data,
 |  | unsigned int * | pTrack2Len,
 |  | unsigned char * | pTrack3Data,
 |  | unsigned int * | pTrack3Len
 | ) |  |

读磁条卡。

说明：
读取磁条卡的数据，支持2、3轨道。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[out] | pTrack2Data | 返回的2轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack2Len | 返回2轨道数据的长度，不含'\0'。
[out] | pTrack3Data | 返回的3轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack3Len | 返回3轨道数据的长度，不含'\0'。
返回
<0表示失败，==0表示成功。

§ dc_writemagcard()

short USER_API dc_writemagcard | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char * | pTrack1Data,
 |  | unsigned char | pTrack1Len,
 |  | unsigned char * | pTrack2Data,
 |  | unsigned char | pTrack2Len,
 |  | unsigned char * | pTrack3Data,
 |  | unsigned char | pTrack3Len
 | ) |  |

写磁条卡。

说明：
写入数据到磁条卡中。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[in] | pTrack1Data | 传入1轨道数据。
[in] | pTrack1Len | 1轨道数据的长度。
[in] | pTrack2Data | 传入2轨道数据。
[in] | pTrack2Len | 2轨道数据的长度。
[in] | pTrack3Data | 传入3轨道数据。
[in] | pTrack3Len | 3轨道数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_testdevicecomm()

short USER_API dc_testdevicecomm ( HANDLE icdev )

测试设备通讯。

说明：
测试和设备之间是否可以正常通讯。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_dispmainmenu()

short USER_API dc_dispmainmenu ( HANDLE icdev )

显示主界面。

说明：
使设备屏幕上显示预置的主界面，不同设备的主界面不尽相同。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_setdevicetime()

short USER_API dc_setdevicetime | ( | HANDLE | icdev,
 |  | unsigned char | year,
 |  | unsigned char | month,
 |  | unsigned char | date,
 |  | unsigned char | hour,
 |  | unsigned char | minute,
 |  | unsigned char | second
 | ) |  |

设置设备时间。

说明：
设置设备的当前时间。
参数
[in] | icdev | 设备标识符。
[in] | year | 年（0~99）。
[in] | month | 月（1~12）。
[in] | date | 日（1~31）。
[in] | hour | 时（0~23）。
[in] | minute | 分（0~59）。
[in] | second | 秒（0~59）。
返回
<0表示失败，==0表示成功。

§ dc_getdevicetime()

short USER_API dc_getdevicetime | ( | HANDLE | icdev,
 |  | unsigned char * | year,
 |  | unsigned char * | month,
 |  | unsigned char * | date,
 |  | unsigned char * | hour,
 |  | unsigned char * | minute,
 |  | unsigned char * | second
 | ) |  |

获取设备时间。

说明：
获取设备当前的时间。
参数
[out] | icdev | 设备标识符。
[out] | year | 年（0~99）。
[out] | month | 月（1~12）。
[out] | date | 日（1~31）。
[out] | hour | 时（0~23）。
[out] | minute | 分（0~59）。
[out] | second | 秒（0~59）。
返回
<0表示失败，==0表示成功。

§ dc_dispinfo()

short USER_API dc_dispinfo | ( | HANDLE | icdev,
 |  | unsigned char | line,
 |  | unsigned char | offset,
 |  | char * | data
 | ) |  |

液晶显示。

说明：
显示指定字符串到液晶屏幕上。
参数
[in] | icdev | 设备标识符。
[in] | line | 行号。
[in] | offset | 偏移。
[in] | data | 要显示的字符串。
返回
<0表示失败，==0表示成功。

§ dc_dispmaininfo()

short USER_API dc_dispmaininfo | ( | HANDLE | icdev,
 |  | unsigned char | offset,
 |  | char * | data
 | ) |  |

液晶显示。

说明：
显示指定字符串到液晶屏幕上。
参数
[in] | icdev | 设备标识符。
[in] | offset | 屏幕偏移。
[in] | data | 要显示的字符串。
返回
<0表示失败，==0表示成功。

§ dc_posbeep()

short USER_API dc_posbeep | ( | HANDLE | icdev,
 |  | unsigned char | beeptime
 | ) |  |

设备蜂鸣。

说明：
设备蜂鸣器发出指定时间的蜂鸣声。
参数
[in] | icdev | 设备标识符。
[in] | beeptime | 蜂鸣时间，单位为50毫秒。
返回
<0表示失败，==0表示成功。

§ dc_ctlbacklight()

short USER_API dc_ctlbacklight | ( | HANDLE | icdev,
 |  | unsigned char | cOpenFlag
 | ) |  |

LCD背光控制。

说明：
控制设备的LCD背光。
参数
[in] | icdev | 设备标识符。
[in] | cOpenFlag | 0-开背光，1-关背光。
返回
<0表示失败，==0表示成功。

§ dc_ctlled()

short USER_API dc_ctlled | ( | HANDLE | icdev,
 |  | unsigned char | cLed,
 |  | unsigned char | cOpenFlag
 | ) |  |

指示灯控制。

说明：
控制设备的指示灯。
参数
[in] | icdev | 设备标识符。
[in] | cLed | 指示灯编号，0表示全部指示灯，1表示第一个指示灯，2表示第二个指示灯，以此类推。
[in] | cOpenFlag | 0-点亮，1-熄灭，2-闪烁。
返回
<0表示失败，==0表示成功。

§ dc_lcdclrscrn()

short USER_API dc_lcdclrscrn | ( | HANDLE | icdev,
 |  | unsigned char | cLine
 | ) |  |

LCD清屏。

说明：
清除LCD屏幕的显示内容。
参数
[in] | icdev | 设备标识符。
[in] | cLine | 需要清除的行号，编号从1开始。
返回
<0表示失败，==0表示成功。

§ dc_passin()

short USER_API dc_passin | ( | HANDLE | icdev,
 |  | unsigned char | ctime
 | ) |  |

进入读键盘模式。

说明：
使设备进入读取键盘的状态，接口本身会直接返回，而不会等待按键完成或设备超时。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
返回
<0表示失败，==0表示成功。

§ dc_PassIn()

short USER_API dc_PassIn | ( | HANDLE | icdev,
 |  | unsigned char | ctime
 | ) |  |

进入读键盘模式。

说明：
使设备进入读取键盘的状态，接口本身会直接返回，而不会等待按键完成或设备超时。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
返回
<0表示失败，==0表示成功。

§ dc_passin2()

short USER_API dc_passin2 | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char | ucmode,
 |  | unsigned char * | cardno
 | ) |  |

进入读键盘模式。

说明：
使设备进入读取键盘的状态，接口本身会直接返回，而不会等待按键完成或设备超时。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[in] | ucmode | 模式，0-带卡号，1-不带卡号。
[in] | cardno | 卡号字符串，只用于带卡号的模式。
返回
<0表示失败，==0表示成功。

§ dc_PassIn2()

short USER_API dc_PassIn2 | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char | ucmode,
 |  | unsigned char * | cardno
 | ) |  |

进入读键盘模式。

说明：
使设备进入读取键盘的状态，接口本身会直接返回，而不会等待按键完成或设备超时。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[in] | ucmode | 模式，0-带卡号，1-不带卡号。
[in] | cardno | 卡号字符串，只用于带卡号的模式。
返回
<0表示失败，==0表示成功。

§ dc_passget()

short USER_API dc_passget | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | unsigned char * | cpass
 | ) |  |

获取键盘数据。

说明：
获取设备已经读取到的键盘数据。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回按键数据的长度，不含'\0'。
[out] | cpass | 返回的按键数据，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功。

§ dc_PassGet()

short USER_API dc_PassGet | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | unsigned char * | cpass
 | ) |  |

获取键盘数据。

说明：
获取设备已经读取到的键盘数据。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回按键数据的长度，不含'\0'。
[out] | cpass | 返回的按键数据，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功。

§ dc_passcancel()

short USER_API dc_passcancel ( HANDLE icdev )

退出读键盘模式。

说明：
在设备进入读键盘模式后，设备会一直处于接收键盘输入的状态，这时只有按键完成、设备超时或调用此接口才能使得设备退出这种状态。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_PassCancel()

short USER_API dc_PassCancel ( HANDLE icdev )

退出读键盘模式。

说明：
在设备进入读键盘模式后，设备会一直处于接收键盘输入的状态，这时是只有按键完成、设备超时或调用此接口才能使得设备退出这种状态。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_getinputkey()

short USER_API dc_getinputkey | ( | HANDLE | icdev,
 |  | unsigned char | disptype,
 |  | unsigned char | line,
 |  | unsigned char | ctime,
 |  | unsigned char * | rlen,
 |  | unsigned char * | ckeydata
 | ) |  |

获取键盘输入。

说明：
获取键盘按键，同时设置输入时屏幕显示的信息。
参数
[in] | icdev | 设备标识符。
[in] | disptype | 显示类型，此类型与设备内置显示条目相关。
[in] | line | 行号，信息将会显示在此行号指定的行中。
[in] | ctime | 设备超时值，单位为秒。
[out] | rlen | 返回按键数据的长度，不含'\0'。
[out] | ckeydata | 返回的按键数据，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功。

§ dc_readmagcardall()

short USER_API dc_readmagcardall | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char * | pTrack1Data,
 |  | unsigned int * | pTrack1Len,
 |  | unsigned char * | pTrack2Data,
 |  | unsigned int * | pTrack2Len,
 |  | unsigned char * | pTrack3Data,
 |  | unsigned int * | pTrack3Len
 | ) |  |

读磁条卡。

说明：
读取磁条卡的数据，支持1、2、3轨道。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[out] | pTrack1Data | 返回的1轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack1Len | 返回1轨道数据的长度，不含'\0'。
[out] | pTrack2Data | 返回的2轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack2Len | 返回2轨道数据的长度，不含'\0'。
[out] | pTrack3Data | 返回的3轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack3Len | 返回3轨道数据的长度，不含'\0'。
返回
<0表示失败，==0表示成功。

§ dc_readdevsnr()

short USER_API dc_readdevsnr | ( | HANDLE | icdev,
 |  | unsigned char * | snr
 | ) |  |

获取设备序列号。

说明：
获取设备内部定制的序列号，设备默认序列号为空，只有预先定制的设备才会存在可用的序列号。
参数
[in] | icdev | 设备标识符。
[out] | snr | 返回的序列号字符串，请至少分配33个字节。
返回
<0表示失败，==0表示成功。

§ dc_readreadersnr()

short USER_API dc_readreadersnr | ( | HANDLE | icdev,
 |  | unsigned char * | snr
 | ) |  |

获取设备序列号。

说明：
获取设备内部定制的序列号，设备默认序列号为空，只有预先定制的设备才会存在可用的序列号。
参数
[in] | icdev | 设备标识符。
[out] | snr | 返回的序列号字符串，请至少分配17个字节。
返回
<0表示失败，==0表示成功。

§ dc_resetdevice()

short USER_API dc_resetdevice ( HANDLE icdev )

复位设备。

说明：
使设备进入上电初始状态。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_setdevicebaud()

short USER_API dc_setdevicebaud | ( | HANDLE | icdev,
 |  | unsigned char | baud
 | ) |  |

设置串口设备通讯波特率。

说明：
设置串口设备通讯波特率。
参数
[in] icdev 设备标识符。
[in] baud 波特率。
0x00 - 115200。
0x01 - 57600。
0x02 - 38400。
0x03 - 19200。
0x04 - 9600。
0x05 - 4800。
0x06 - 2400。
0x07 - 1200。
返回
<0表示失败，==0表示成功。

§ dc_read_4442()

short USER_API dc_read_4442 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4442卡。

说明：
读取4442卡的数据。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | data_buffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_read_4442_hex()

short USER_API dc_read_4442_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4442卡。

说明：
dc_read_4442 的HEX形式接口，参数 data_buffer 为HEX格式。

§ dc_write_4442()

short USER_API dc_write_4442 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

写4442卡。

说明：
写入数据到4442卡中。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | data_buffer | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_write_4442_hex()

short USER_API dc_write_4442_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

写4442卡。

说明：
dc_write_4442 的HEX形式接口，参数 data_buffer 为HEX格式。

§ dc_verifypin_4442()

short USER_API dc_verifypin_4442 | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

验证4442卡密码。

说明：
使用传入的密码来验证4442卡密码。
参数
[in] | icdev | 设备标识符。
[in] | passwd | 密码，固定为3个字节。
返回
<0表示失败，==0表示成功。

§ dc_verifypin_4442_hex()

short USER_API dc_verifypin_4442_hex | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

验证4442卡密码。

说明：
dc_verifypin_4442 的HEX形式接口，参数 passwd 为HEX格式。

§ dc_readpin_4442()

short USER_API dc_readpin_4442 | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

读4442卡密码。

说明：
读取4442卡的密码。
参数
[in] | icdev | 设备标识符。
[out] | passwd | 密码，固定为3个字节。
返回
<0表示失败，==0表示成功。

§ dc_readpin_4442_hex()

short USER_API dc_readpin_4442_hex | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

读4442卡密码。

说明：
dc_readpin_4442 的HEX形式接口，参数 passwd 为HEX格式。

§ dc_readpincount_4442()

short USER_API dc_readpincount_4442 ( HANDLE icdev )

读4442卡密码计数。

说明：
读取4442卡的密码计数，此计数值表示可以尝试验证密码的次数。
参数
[in] icdev 设备标识符。
返回
<0表示失败，否则为密码计数值。

§ dc_changepin_4442()

short USER_API dc_changepin_4442 | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

修改4442卡密码。

说明：
修改4442卡的密码。
参数
[in] | icdev | 设备标识符。
[in] | passwd | 密码，固定为3个字节。
返回
<0表示失败，==0表示成功。

§ dc_changepin_4442_hex()

short USER_API dc_changepin_4442_hex | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

修改4442卡密码。

说明：
dc_changepin_4442 的HEX形式接口，参数 passwd 为HEX格式。

§ dc_readwrotect_4442()

short USER_API dc_readwrotect_4442 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4442卡保护位。

说明：
读取4442卡的保护区中哪些位置已经被置保护。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | data_buffer | 返回的数据，数据中含有0x00字节的位置表示已经被置保护。
返回
<0表示失败，==0表示成功。

§ dc_readwrotect_4442_hex()

short USER_API dc_readwrotect_4442_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4442卡保护位。

说明：
dc_readwrotect_4442 的HEX形式接口，参数 data_buffer 为HEX格式。

§ dc_readprotect_4442()

short USER_API dc_readprotect_4442 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4442卡保护位。

说明：
读取4442卡的保护区中哪些位置已经被置保护。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | data_buffer | 返回的数据，数据中含有0x00字节的位置表示已经被置保护。
返回
<0表示失败，==0表示成功。

§ dc_readprotect_4442_hex()

short USER_API dc_readprotect_4442_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4442卡保护位。

说明：
dc_readprotect_4442 的HEX形式接口，参数 data_buffer 为HEX格式。

§ dc_writeprotect_4442()

short USER_API dc_writeprotect_4442 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

写4442卡保护位。

说明：
对4442卡的保护区中指定位置进行置保护。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | data_buffer | 传入数据，数据中和卡内原有数据相同的字节位置将被置保护。
返回
<0表示失败，==0表示成功。

§ dc_writeprotect_4442_hex()

short USER_API dc_writeprotect_4442_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

写4442卡保护位。

说明：
dc_writeprotect_4442 的HEX形式接口，参数 data_buffer 为HEX格式。

§ dc_write_24c()

short USER_API dc_write_24c | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | snd_buffer
 | ) |  |

写24C系列卡。

说明：
写入数据到24C系列卡中，支持24C01、24C02、24C04、24C08、24C16卡。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | snd_buffer | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_write_24c_hex()

short USER_API dc_write_24c_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | snd_buffer
 | ) |  |

写24C系列卡。

说明：
dc_write_24c 的HEX形式接口，参数 snd_buffer 为HEX格式。

§ dc_write_24c64()

short USER_API dc_write_24c64 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | snd_buffer
 | ) |  |

写24C64系列卡。

说明：
写入数据到24C64系列卡中，支持24C64、24C512、24C1024卡。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | snd_buffer | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_write_24c64_hex()

short USER_API dc_write_24c64_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | snd_buffer
 | ) |  |

写24C64系列卡。

说明：
dc_write_24c64 的HEX形式接口，参数 snd_buffer 为HEX格式。

§ dc_read_24c()

short USER_API dc_read_24c | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | receive_buffer
 | ) |  |

读24C系列卡。

说明：
读取24C系列卡的数据，支持24C01、24C02、24C04、24C08、24C16卡。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | receive_buffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_read_24c_hex()

short USER_API dc_read_24c_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | receive_buffer
 | ) |  |

读24C系列卡。

说明：
dc_read_24c 的HEX形式接口，参数 receive_buffer 为HEX格式。

§ dc_read_24c64()

short USER_API dc_read_24c64 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | receive_buffer
 | ) |  |

读24C64系列卡。

说明：
读取24C64系列卡的数据，支持24C64、24C512、24C1024卡。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | receive_buffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_read_24c64_hex()

short USER_API dc_read_24c64_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | receive_buffer
 | ) |  |

读24C64系列卡。

说明：
dc_read_24c64 的HEX形式接口，参数 receive_buffer 为HEX格式。

§ dc_read_4428()

short USER_API dc_read_4428 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4428卡。

说明：
读取4428卡的数据。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | data_buffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_read_4428_hex()

short USER_API dc_read_4428_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4428卡。

说明：
dc_read_4428 的HEX形式接口，参数 data_buffer 为HEX格式。

§ dc_write_4428()

short USER_API dc_write_4428 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

写4428卡。

说明：
写入数据到4428卡中。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | data_buffer | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_write_4428_hex()

short USER_API dc_write_4428_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

写4428卡。

说明：
dc_write_4428 的HEX形式接口，参数 data_buffer 为HEX格式。

§ dc_verifypin_4428()

short USER_API dc_verifypin_4428 | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

验证4428卡密码。

说明：
使用传入的密码来验证4428卡密码。
参数
[in] | icdev | 设备标识符。
[in] | passwd | 密码，固定为2个字节。
返回
<0表示失败，==0表示成功。

§ dc_verifypin_4428_hex()

short USER_API dc_verifypin_4428_hex | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

验证4428卡密码。

说明：
dc_verifypin_4428 的HEX形式接口，参数 passwd 为HEX格式。

§ dc_readpin_4428()

short USER_API dc_readpin_4428 | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

读4428卡密码。

说明：
读取4428卡的密码。
参数
[in] | icdev | 设备标识符。
[out] | passwd | 密码，固定为2个字节。
返回
<0表示失败，==0表示成功。

§ dc_readpin_4428_hex()

short USER_API dc_readpin_4428_hex | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

读4428卡密码。

说明：
dc_readpin_4428 的HEX形式接口，参数 passwd 为HEX格式。

§ dc_readpincount_4428()

short USER_API dc_readpincount_4428 ( HANDLE icdev )

读4428卡密码计数。

说明：
读取4428卡的密码计数，此计数值表示可以尝试验证密码的次数。
参数
[in] icdev 设备标识符。
返回
<0表示失败，否则为密码计数值。

§ dc_changepin_4428()

short USER_API dc_changepin_4428 | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

修改4428卡密码。

说明：
修改4428卡的密码。
参数
[in] | icdev | 设备标识符。
[in] | passwd | 密码，固定为2个字节。
返回
<0表示失败，==0表示成功。

§ dc_changepin_4428_hex()

short USER_API dc_changepin_4428_hex | ( | HANDLE | icdev,
 |  | unsigned char * | passwd
 | ) |  |

修改4428卡密码。

说明：
dc_changepin_4428 的HEX形式接口，参数 passwd 为HEX格式。

§ dc_readprotect_4428()

short USER_API dc_readprotect_4428 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4428卡保护位。

说明：
读取4428卡的保护区中哪些位置已经被置保护。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | data_buffer | 返回的数据，数据中含有0x00字节的位置表示已经被置保护。
返回
<0表示失败，==0表示成功。

§ dc_readprotect_4428_hex()

short USER_API dc_readprotect_4428_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读4428卡保护位。

说明：
dc_readprotect_4428 的HEX形式接口，参数 data_buffer 为HEX格式。

§ dc_writeprotect_4428()

short USER_API dc_writeprotect_4428 | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

写4428卡保护位。

说明：
对4428卡的保护区中指定位置进行置保护。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | data_buffer | 传入数据，数据中和卡内原有数据相同的字节位置将被置保护。
返回
<0表示失败，==0表示成功。

§ dc_writeprotect_4428_hex()

short USER_API dc_writeprotect_4428_hex | ( | HANDLE | icdev,
 |  | short | offset,
 |  | short | length,
 |  | unsigned char * | data_buffer
 | ) |  |

写4428卡保护位。

说明：
dc_writeprotect_4428 的HEX形式接口，参数 data_buffer 为HEX格式。

§ dc_Check_4442()

short USER_API dc_Check_4442 ( HANDLE icdev )

检测4442卡。

说明：
检测当前卡座中是否存在4442卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_Check_4428()

short USER_API dc_Check_4428 ( HANDLE icdev )

检测4428卡。

说明：
检测当前卡座中是否存在4428卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_Check_24C01()

short USER_API dc_Check_24C01 ( HANDLE icdev )

检测24C01卡。

说明：
检测当前卡座中是否存在24C01卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_Check_24C02()

short USER_API dc_Check_24C02 ( HANDLE icdev )

检测24C02卡。

说明：
检测当前卡座中是否存在24C02卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_Check_24C04()

short USER_API dc_Check_24C04 ( HANDLE icdev )

检测24C04卡。

说明：
检测当前卡座中是否存在24C04卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_Check_24C08()

short USER_API dc_Check_24C08 ( HANDLE icdev )

检测24C08卡。

说明：
检测当前卡座中是否存在24C08卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_Check_24C16()

short USER_API dc_Check_24C16 ( HANDLE icdev )

检测24C16卡。

说明：
检测当前卡座中是否存在24C16卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_Check_24C64()

short USER_API dc_Check_24C64 ( HANDLE icdev )

检测24C64卡。

说明：
检测当前卡座中是否存在24C64卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_Check_CPU()

short USER_API dc_Check_CPU ( HANDLE icdev )

检测CPU卡。

说明：
检测当前卡座中是否存在CPU卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在T=0的CPU卡，==1表示存在T=1的CPU卡。

§ dc_CheckCard()

short USER_API dc_CheckCard ( HANDLE icdev )

检测卡。

说明：
检测当前卡座中存在的卡类型。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在。
8 - 表示存在4442卡。
9 - 表示存在4428卡。
30 - 表示存在T=0的CPU卡。
31 - 表示存在T=1的CPU卡。
21 - 表示存在24C01卡。
22 - 表示存在24C02卡。
23 - 表示存在24C04卡。
24 - 表示存在24C08卡。
25 - 表示存在24C16卡。
26 - 表示存在24C64卡。

§ dc_getlongver()

short USER_API dc_getlongver | ( | HANDLE | icdev,
 |  | unsigned char * | sver
 | ) |  |

获取设备长版本。

说明：
获取设备内部固件代码的长版本，此长版本依赖设备内部固件代码的实现，有可能同设备版本一致。
参数
[in] | icdev | 设备标识符。
[out] | sver | 返回的版本字符串，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_cardstr()

short USER_API dc_cardstr | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | char * | Strsnr
 | ) |  |

寻卡请求、防卡冲突、选卡操作。

说明：
内部包含了 dc_request dc_anticoll dc_select 的功能。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，同 dc_request 的 _Mode 。
[out] | Strsnr | 返回的卡序列号，格式为数字字符串。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_cardAB()

short USER_API dc_cardAB | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | unsigned char * | rbuf,
 |  | unsigned char * | type
 | ) |  |

寻Type A或Type B卡并激活。

说明：
对Type A或Type B卡进行寻卡和激活。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回激活信息的长度。
[out] | rbuf | 返回的激活信息，请至少分配128个字节。
[out] | type | 类型，'A'表示Type A卡，'B'表示Type B卡。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_card_b()

short USER_API dc_card_b | ( | HANDLE | icdev,
 |  | unsigned char * | rbuf
 | ) |  |

寻Type B卡并激活。

说明：
对Type B卡进行寻卡和激活。
参数
[in] | icdev | 设备标识符。
[out] | rbuf | 返回的激活信息，请至少分配128个字节。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_card_b_hex()

short USER_API dc_card_b_hex | ( | HANDLE | icdev,
 |  | char * | rbuf
 | ) |  |

寻Type B卡并激活。

说明：
dc_card_b 的HEX形式接口，参数 rbuf 为HEX格式。

§ dc_dispinfo_T8()

short USER_API dc_dispinfo_T8 | ( | HANDLE | icdev,
 |  | unsigned char | line,
 |  | unsigned char | offset,
 |  | char * | data
 | ) |  |

液晶显示。

说明：
显示指定字符串到液晶屏幕上。
参数
[in] | icdev | 设备标识符。
[in] | line | 行号。
[in] | offset | 偏移。
[in] | data | 要显示的字符串。
返回
<0表示失败，==0表示成功。

§ dc_dispinfo_pro_T8()

short USER_API dc_dispinfo_pro_T8 | ( | HANDLE | icdev,
 |  | unsigned char | offset,
 |  | char * | data
 | ) |  |

液晶显示。

说明：
显示指定字符串到液晶屏幕上。
参数
[in] | icdev | 设备标识符。
[in] | offset | 屏幕偏移。
[in] | data | 要显示的字符串。
返回
<0表示失败，==0表示成功。

§ dc_clearlcd_T8()

short USER_API dc_clearlcd_T8 | ( | HANDLE | icdev,
 |  | unsigned char | line
 | ) |  |

LCD清屏。

说明：
清除LCD屏幕的显示内容。
参数
[in] | icdev | 设备标识符。
[in] | line | 需要清除的行号，编号从1开始。
返回
<0表示失败，==0表示成功。

§ dc_led_T8()

short USER_API dc_led_T8 | ( | HANDLE | icdev,
 |  | unsigned char | cled,
 |  | unsigned char | cflag
 | ) |  |

指示灯点亮/熄灭。

说明：
点亮/熄灭设备的指示灯。
参数
[in] | icdev | 设备标识符。
[in] | cled | 指示灯编号，0表示全部指示灯，1表示第一个指示灯，2表示第二个指示灯，以此类推。
[in] | cflag | 0-点亮，1-熄灭。
返回
<0表示失败，==0表示成功。

§ dc_rw_rfreg()

short USER_API dc_rw_rfreg | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | unsigned char | _Adr,
 |  | unsigned char * | _Data
 | ) |  |

读/写射频寄存器。

说明：
从射频寄存器读取值或写入值到射频寄存器中。
参数
[in] | icdev | 设备标识符。
[in] | flag | 读写标记，0x00表示读，0x01表示写。
[in] | _Adr | 寄存器地址。
[in,out] | _Data | 寄存器值，固定为1个字节。
返回
<0表示失败，==0表示成功。

§ dc_rw_rfreg_hex()

short USER_API dc_rw_rfreg_hex | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | unsigned char | _Adr,
 |  | unsigned char * | _Data
 | ) |  |

读/写射频寄存器。

说明：
dc_rw_rfreg 的HEX形式接口，参数 _Data 为HEX格式。

§ dc_pro_commandsourceCRC()

short USER_API dc_pro_commandsourceCRC | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout,
 |  | unsigned char | CRCSTU
 | ) |  |

非接触式CPU卡指令交互。

说明：
对感应区CPU卡进行指令交互操作，注意此接口不封装卡协议部分，带CRC。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
[in] | timeout | 超时值，此值只在部分设备的底层使用，单位为250毫秒，一般调用建议值为7。
[in] | CRCSTU | CRC值。
返回
<0表示失败，==0表示成功。

§ dc_pro_commandsourceCRChex()

short USER_API dc_pro_commandsourceCRChex | ( | HANDLE | icdev,
 |  | unsigned char | slen,
 |  | char * | sendbuffer,
 |  | unsigned char * | rlen,
 |  | char * | databuffer,
 |  | unsigned char | timeout,
 |  | unsigned char | CRCSTU
 | ) |  |

非接触式CPU卡指令交互。

说明：
dc_pro_commandsourceCRC 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_MFPL0_writeperso()

short USER_API dc_MFPL0_writeperso | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char * | dataperso
 | ) |  |

Mifare Plus卡设置个人化数据（0级）。

说明：
设置Mifare Plus卡的个人化数据。
参数
[in] | icdev | 设备标识符。
[in] | BNr | 要写入的个人化数据块号。
[in] | dataperso | 要写入的数据，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_MFPL0_writeperso_hex()

short USER_API dc_MFPL0_writeperso_hex | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char * | dataperso
 | ) |  |

Mifare Plus卡设置个人化数据（0级）。

说明：
dc_MFPL0_writeperso 的HEX形式接口，参数 dataperso 为HEX格式。

§ dc_MFPL0_commitperso()

short USER_API dc_MFPL0_commitperso ( HANDLE icdev )

Mifare Plus卡提交个人化数据（0级）。

说明：
提交Mifare Plus卡的个人化数据，提交成功后卡片进入1级状态。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_MFPL1_authl1key()

short USER_API dc_MFPL1_authl1key | ( | HANDLE | icdev,
 |  | unsigned char * | authkey
 | ) |  |

验证Mifare Plus卡状态密码（1级）。

说明：
验证Mifare Plus卡状态密码，用于在1级状态下实现严格的认证。
参数
[in] | icdev | 设备标识符。
[in] | authkey | 认证密码，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_MFPL1_authl1key_hex()

short USER_API dc_MFPL1_authl1key_hex | ( | HANDLE | icdev,
 |  | unsigned char * | authkey
 | ) |  |

验证Mifare Plus卡状态密码（1级）。

说明：
dc_MFPL1_authl1key 的HEX形式接口，参数 authkey 为HEX格式。

§ dc_MFPL1_switchtol2()

short USER_API dc_MFPL1_switchtol2 | ( | HANDLE | icdev,
 |  | unsigned char * | authkey
 | ) |  |

升级Mifare Plus卡状态到2级（1级）。

说明：
状态切换函数，执行该操作后，1级状态的卡片转换到2级。
参数
[in] | icdev | 设备标识符。
[in] | authkey | 升级密码，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_MFPL1_switchtol3()

short USER_API dc_MFPL1_switchtol3 | ( | HANDLE | icdev,
 |  | unsigned char * | authkey
 | ) |  |

升级Mifare Plus卡状态到3级（1级）。

说明：
状态切换函数，执行该操作后，1级状态的卡片转换到3级。
参数
[in] | icdev | 设备标识符。
[in] | authkey | 升级密码，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_MFPL2_switchtol3()

short USER_API dc_MFPL2_switchtol3 | ( | HANDLE | icdev,
 |  | unsigned char * | authkey
 | ) |  |

升级Mifare Plus卡状态到3级（2级）。

说明：
状态切换函数，执行该操作后，2级状态的卡片转换到3级。
参数
[in] | icdev | 设备标识符。
[in] | authkey | 升级密码，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_MFPL3_authl3key()

short USER_API dc_MFPL3_authl3key | ( | HANDLE | icdev,
 |  | unsigned int | keyBNr,
 |  | unsigned char * | authkey
 | ) |  |

验证Mifare Plus卡状态密码（3级）。

说明：
执行3级状态卡片认证，根据密码块号的不同，验证不同的密码。
参数
[in] | icdev | 设备标识符。
[in] | keyBNr | 密码块号。
[in] | authkey | 认证密码，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_MFPL3_authl3key_hex()

short USER_API dc_MFPL3_authl3key_hex | ( | HANDLE | icdev,
 |  | unsigned int | keyBNr,
 |  | unsigned char * | authkey
 | ) |  |

验证Mifare Plus卡状态密码（3级）。

说明：
dc_MFPL3_authl3key 的HEX形式接口，参数 authkey 为HEX格式。

§ dc_MFPL3_authl3sectorkey()

short USER_API dc_MFPL3_authl3sectorkey | ( | HANDLE | icdev,
 |  | unsigned char | mode,
 |  | unsigned int | sectorBNr,
 |  | unsigned char * | authkey
 | ) |  |

验证Mifare Plus卡状态密码（3级）。

说明：
执行3级状态卡片认证，根据密码扇区号的不同，验证不同的密码。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0x00表示验证A密码，内部用0x4000+sectorBNr*2计算密码块，0x04表示验证B密码，内部用0x4000+sectorBNr*2+1计算密码块。
[in] | sectorBNr | 密码扇区号。
[in] | authkey | 认证密码，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_MFPL3_authl3sectorkey_hex()

short USER_API dc_MFPL3_authl3sectorkey_hex | ( | HANDLE | icdev,
 |  | unsigned char | mode,
 |  | unsigned int | sectorBNr,
 |  | unsigned char * | authkey
 | ) |  |

验证Mifare Plus卡状态密码（3级）。

说明：
dc_MFPL3_authl3key 的HEX形式接口，参数 authkey 为HEX格式。

§ dc_MFPL3_readinplain()

short USER_API dc_MFPL3_readinplain | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char | Numblock,
 |  | unsigned char * | readdata
 | ) |  |

读Mifare Plus卡数据（3级）。

说明：
在3级状态下读取Mifare Plus卡数据，可以连续读多块，每块16字节。
参数
[in] | icdev | 设备标识符。
[in] | BNr | 起始块地址。
[in] | Numblock | 块数目，一般不大于6块。
[out] | readdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_MFPL3_readinplain_hex()

short USER_API dc_MFPL3_readinplain_hex | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char | Numblock,
 |  | unsigned char * | readdata
 | ) |  |

读Mifare Plus卡数据（3级）。

说明：
dc_MFPL3_readinplain 的HEX形式接口，参数 readdata 为HEX格式。

§ dc_MFPL3_readencrypted()

short USER_API dc_MFPL3_readencrypted | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char | Numblock,
 |  | unsigned char * | readdata,
 |  | unsigned char | flag
 | ) |  |

加密模式读Mifare Plus卡数据（3级）。

说明：
在3级状态下用加密模式读取Mifare Plus卡数据，可以连续读多块，每块16字节。
参数
[in] | icdev | 设备标识符。
[in] | BNr | 起始块地址。
[in] | Numblock | 块数目，一般不大于6块。
[out] | readdata | 返回的数据。
[in] | flag | 标记，0x00表示加密数据内部解密后再返回，0x01表示加密数据直接返回。
返回
<0表示失败，==0表示成功。

§ dc_MFPL3_readencrypted_hex()

short USER_API dc_MFPL3_readencrypted_hex | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char | Numblock,
 |  | unsigned char * | readdata,
 |  | unsigned char | flag
 | ) |  |

加密模式读Mifare Plus卡数据（3级）。

说明：
dc_MFPL3_readencrypted 的HEX形式接口，参数 readdata 为HEX格式。

§ dc_MFPL3_writeinplain()

short USER_API dc_MFPL3_writeinplain | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char | Numblock,
 |  | unsigned char * | writedata
 | ) |  |

写Mifare Plus卡数据（3级）。

说明：
在3级状态下写入数据到Mifare Plus卡中，可以连续写多块，每块16字节。
参数
[in] | icdev | 设备标识符。
[in] | BNr | 起始块地址。
[in] | Numblock | 块数目，一般不大于6块。
[in] | writedata | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_MFPL3_writeinplain_hex()

short USER_API dc_MFPL3_writeinplain_hex | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char | Numblock,
 |  | unsigned char * | writedata
 | ) |  |

写Mifare Plus卡数据（3级）。

说明：
dc_MFPL3_writeinplain 的HEX形式接口，参数 writedata 为HEX格式。

§ dc_MFPL3_writeencrypted()

short USER_API dc_MFPL3_writeencrypted | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char | Numblock,
 |  | unsigned char * | writedata,
 |  | unsigned char | flag
 | ) |  |

加密模式写Mifare Plus卡数据（3级）。

说明：
在3级状态下用加密模式写入数据到Mifare Plus卡中，可以连续写多块，每块16字节。注意：写密码时，必须使用此函数并且块数目只能为1。
参数
[in] | icdev | 设备标识符。
[in] | BNr | 起始块地址。
[in] | Numblock | 块数目，一般不大于6块。
[in] | writedata | 传入数据。
[in] | flag | 标记，0x00表示传入数据需内部加密后再使用，0x01表示传入数据直接使用。
返回
<0表示失败，==0表示成功。

§ dc_MFPL3_writeencrypted_hex()

short USER_API dc_MFPL3_writeencrypted_hex | ( | HANDLE | icdev,
 |  | unsigned int | BNr,
 |  | unsigned char | Numblock,
 |  | unsigned char * | writedata,
 |  | unsigned char | flag
 | ) |  |

加密模式写Mifare Plus卡数据（3级）。

说明：
dc_MFPL3_writeencrypted 的HEX形式接口，参数 writedata 为HEX格式。

§ dc_auth_ulc()

short USER_API dc_auth_ulc | ( | HANDLE | icdev,
 |  | unsigned char * | key
 | ) |  |

验证Mifare Ultralight C卡密码。

说明：
使用传入的密码来验证Mifare Ultralight C卡密码。
参数
[in] | icdev | 设备标识符。
[in] | key | 密码，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_auth_ulc_hex()

short USER_API dc_auth_ulc_hex | ( | HANDLE | icdev,
 |  | unsigned char * | key
 | ) |  |

验证Mifare Ultralight C卡密码。

说明：
dc_auth_ulc 的HEX形式接口，参数 key 为HEX格式。

§ dc_changekey_ulc()

short USER_API dc_changekey_ulc | ( | HANDLE | icdev,
 |  | unsigned char * | newkey
 | ) |  |

修改Mifare Ultralight C卡密码。

说明：
修改Mifare Ultralight C卡的密码。
参数
[in] | icdev | 设备标识符。
[in] | newkey | 密码，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_changekey_ulc_hex()

short USER_API dc_changekey_ulc_hex | ( | HANDLE | icdev,
 |  | unsigned char * | newkey
 | ) |  |

修改Mifare Ultralight C卡密码。

说明：
dc_changekey_ulc 的HEX形式接口，参数 newkey 为HEX格式。

§ dc_getcpupara()

short USER_API dc_getcpupara | ( | HANDLE | icdev,
 |  | unsigned char | cputype,
 |  | unsigned char * | cpupro,
 |  | unsigned char * | cpuetu
 | ) |  |

获取接触式CPU卡参数。

说明：
此接口可获取接触式CPU卡操作行为的参数。
参数
[in] | icdev | 设备标识符。
[in] | cputype | 卡座编号，同 dc_setcpu 的 _Byte 。
[out] | cpupro | 卡协议编号，0x00表示T0，0x01表示T1，默认为0x00。
[out] | cpuetu | 卡复位波特率编号，0x5C表示9600，0x14表示38400.
返回
<0表示失败，==0表示成功。

§ dc_cpuapdusourceEXT()

short USER_API dc_cpuapdusourceEXT | ( | HANDLE | icdev,
 |  | short | slen,
 |  | unsigned char * | sendbuffer,
 |  | short * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
对当前卡座CPU卡进行指令交互操作，注意此接口不封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_cpuapdusourceEXT_hex()

short USER_API dc_cpuapdusourceEXT_hex | ( | HANDLE | icdev,
 |  | short | slen,
 |  | char * | sendbuffer,
 |  | short * | rlen,
 |  | char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
dc_cpuapdusourceEXT 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_cpuapduEXT()

short USER_API dc_cpuapduEXT | ( | HANDLE | icdev,
 |  | short | slen,
 |  | unsigned char * | sendbuffer,
 |  | short * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
对当前卡座CPU卡进行指令交互操作，注意此接口已封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_cpuapduEXT_hex()

short USER_API dc_cpuapduEXT_hex | ( | HANDLE | icdev,
 |  | short | slen,
 |  | char * | sendbuffer,
 |  | short * | rlen,
 |  | char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
dc_cpuapduEXT 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_cpuapduInt()

short USER_API dc_cpuapduInt | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
对当前卡座CPU卡进行指令交互操作，注意此接口已封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_cpuapduInt_hex()

short USER_API dc_cpuapduInt_hex | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
dc_cpuapduInt 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_pro_commandlinkEXT()

short USER_API dc_pro_commandlinkEXT | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout,
 |  | unsigned char | FG
 | ) |  |

非接触式CPU卡指令交互。

说明：
对感应区CPU卡进行指令交互操作，注意此接口已封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
[in] | timeout | 超时值，此值只在部分设备的底层使用，单位为250毫秒，一般调用建议值为7。
[in] | FG | 分割值，此值只在部分设备的底层使用，单位为字节，一般调用建议值为64。
返回
<0表示失败，==0表示成功。

§ dc_pro_commandlinkEXT_hex()

short USER_API dc_pro_commandlinkEXT_hex | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout,
 |  | unsigned char | FG
 | ) |  |

非接触式CPU卡指令交互。

说明：
dc_pro_commandlinkEXT 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_pro_commandlinkInt()

short USER_API dc_pro_commandlinkInt | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
对感应区CPU卡进行指令交互操作，注意此接口已封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
[in] | timeout | 超时值，此值只在部分设备的底层使用，单位为250毫秒，一般调用建议值为7。
返回
<0表示失败，==0表示成功。

§ dc_pro_commandlinkInt_hex()

short USER_API dc_pro_commandlinkInt_hex | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
dc_pro_commandlinkInt 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_cpuhotreset()

short USER_API dc_cpuhotreset | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

接触式CPU卡复位。

说明：
对当前卡座CPU卡进行复位操作，此复位为热复位。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回复位信息的长度。
[out] | databuffer | 返回的复位信息，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_cpuhotreset_hex()

short USER_API dc_cpuhotreset_hex | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | char * | databuffer
 | ) |  |

接触式CPU卡复位。

说明：
dc_cpuhotreset 的HEX形式接口，参数 databuffer 为HEX格式。

§ dc_card_exist()

short USER_API dc_card_exist | ( | HANDLE | icdev,
 |  | unsigned char * | flag
 | ) |  |

检测多卡状态。

说明：
检测设备中存在什么类型的卡片，支持磁卡、非接、接触、身份证。
参数
[in] icdev 设备标识符。
[out] flag 状态标记，固定为2个字节，可以解析为一个无符号整数（Big-Endian），值为下面列出的一种或多种之和。
0x0001 - 表示已刷磁卡。
0x0002 - 表示卡座存在接触式CPU卡。
0x0004 - 表示卡座存在接触式未知卡。
0x0008 - 表示感应区存在身份证。
0x0010 - 表示感应区存在激活前的Type A CPU卡或Type B CPU卡。
0x0020 - 表示感应区存在激活后的Type A CPU卡或Type B CPU卡。
0x0040 - 表示感应区存在激活前的M1卡。
0x0100 - 表示感应区存在激活前的多张Type A CPU卡。
0x0200 - 表示感应区存在激活前的多张M1卡。
0x0400 - 表示感应区同时存在激活前的Type A CPU卡和M1卡。
0x0800 - 表示刷磁卡失败。
0x1000 - 表示启动刷磁卡模式处于关闭状态。
0x2000 - 表示启动刷磁卡模式处于开启状态。
0x4000 - 表示感应区身份证激活前后状态一致。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_card_status()

short USER_API dc_card_status ( HANDLE icdev )

检测接触式卡存在。

说明：
检测接触式卡片是否存在于当前卡座中。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示存在，==1表示不存在。

§ dc_typeab_card_status()

short USER_API dc_typeab_card_status ( HANDLE icdev )

身份证、Type A CPU卡、Type B CPU卡检测。

说明：
检测感应区是否存在身份证、Type A CPU卡、Type B CPU卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示无卡，==1表示存在身份证，==2表示存在Type A CPU卡，==3表示存在Type B CPU卡。

§ dc_card_n()

short USER_API dc_card_n | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned int * | SnrLen,
 |  | unsigned char * | _Snr
 | ) |  |

寻卡请求、防卡冲突、选卡操作。

说明：
内部包含了 dc_request dc_anticoll dc_select dc_anticoll2 dc_select2 的功能。
参数
[in] | icdev | 设备标识符。
[in] | _Mode | 模式，同 dc_request 的 _Mode 。
[out] | SnrLen | 返回卡序列号的长度。
[out] | _Snr | 返回的卡序列号，请至少分配8个字节。
返回
<0表示失败，==0表示成功，==1表示无卡或无法寻到卡片。

§ dc_card_n_hex()

short USER_API dc_card_n_hex | ( | HANDLE | icdev,
 |  | unsigned char | _Mode,
 |  | unsigned int * | SnrLen,
 |  | unsigned char * | _Snr
 | ) |  |

寻卡请求、防卡冲突、选卡操作。

说明：
dc_card_n 的HEX形式接口，参数 _Snr 为HEX格式。

§ dc_pass_key_value()

short USER_API dc_pass_key_value | ( | HANDLE | icdev,
 |  | unsigned char | timeout,
 |  | char * | value
 | ) |  |

获取单个按键值。

说明：
获取设备键盘的按键值，每次调用仅能获取单个按键值。
参数
[in] | icdev | 设备标识符。
[in] | timeout | 设备超时值，单位为秒。
[out] | value | 返回的按键值，请至少分配8个字节。
返回
<0表示失败，==0表示成功。

§ dc_play_voice()

short USER_API dc_play_voice | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

播放语音。

说明：
播放设备内置语音。
参数
[in] | icdev | 设备标识符。
[in] | mode | 语音段号（1~12）。
返回
<0表示失败，==0表示成功。

§ dc_playvoice()

short USER_API dc_playvoice | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

播放语音。

说明：
播放设备内置语音。
参数
[in] | icdev | 设备标识符。
[in] | mode | 语音段号（1~12）。
返回
<0表示失败，==0表示成功。

§ dc_load_voice()

short USER_API dc_load_voice | ( | HANDLE | icdev,
 |  | int | flag,
 |  | int | slen,
 |  | const unsigned char * | sdata
 | ) |  |

装载语音。

说明：
装载语音数据到设备内。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0表示第一包，1表示第二包，以此类推，0xFFFF表示结束包。
[in] | slen | 传入数据的长度，必须小于或等于1024，当标记为结束包的时候为0。
[in] | sdata | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_setmag()

short USER_API dc_setmag | ( | HANDLE | icdev,
 |  | unsigned char | mode,
 |  | unsigned char | track1,
 |  | unsigned char | track2,
 |  | unsigned char | track3
 | ) |  |

磁条卡参数配置。

说明：
配置操作磁条卡的参数，参数仅针对自动输出的模式有效。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0x00表示不用输出，0x01表示自动输出。
[in] track1 1轨道参数。
bit0 - 轨道数据输出设置，0表示不输出，1表示输出。
bit1 - 轨道数据头设置，0表示无数据头，1表示有数据头。
bit2 - 轨道数据尾设置，0表示无数据尾，1表示有数据尾。
bit3 - 轨道数据换行符设置，0表示无换行符，1表示有换行符。
bit4 - 轨道数据等号与其后数据设置，0表示不输出，1表示输出。
bit5~bit7 - 保留。
[in] track2 2轨道参数。
bit0 - 轨道数据输出设置，0表示不输出，1表示输出。
bit1 - 轨道数据头设置，0表示无数据头，1表示有数据头。
bit2 - 轨道数据尾设置，0表示无数据尾，1表示有数据尾。
bit3 - 轨道数据换行符设置，0表示无换行符，1表示有换行符。
bit4 - 轨道数据等号与其后数据设置，0表示不输出，1表示输出。
bit5~bit7 - 保留。
[in] track3 3轨道参数。
bit0 - 轨道数据输出设置，0表示不输出，1表示输出。
bit1 - 轨道数据头设置，0表示无数据头，1表示有数据头。
bit2 - 轨道数据尾设置，0表示无数据尾，1表示有数据尾。
bit3 - 轨道数据换行符设置，0表示无换行符，1表示有换行符。
bit4 - 轨道数据等号与其后数据设置，0表示不输出，1表示输出。
bit5~bit7 - 保留。
返回
<0表示失败，==0表示成功。

§ dc_setprint()

short USER_API dc_setprint | ( | HANDLE | icdev,
 |  | unsigned char | FontSize,
 |  | unsigned char | Alignment,
 |  | unsigned char | LeftMargin,
 |  | unsigned char | RightMargin,
 |  | unsigned char | RowPitch,
 |  | unsigned char | PrintOutRate
 | ) |  |

设置打印机参数。

说明：
设置操作打印机的参数。
参数
[in] | icdev | 设备标识符。
[in] | FontSize | 字体设置，0x00表示字符大小为8*16，0x01表示字符大小为12*24，0x02表示字符大小为16*32。
[in] | Alignment | 对齐设置，0x00表示左对齐，0x01表示居中，0x02表示右对齐。
[in] | LeftMargin | 左边距设置，字符大小为8*16时<48，字符大小为12*24时<32，字符大小为16*32时<24。
[in] | RightMargin | 右边距设置，字符大小为8*16时<48，字符大小为12*24时<32，字符大小为16*32时<24。
[in] | RowPitch | 行间隔设置，单位为点。
[in] | PrintOutRate | 打印速度设置（0x00~0x03），0x00最快，0x03最慢。
返回
<0表示失败，==0表示成功。

§ dc_checkprint()

short USER_API dc_checkprint | ( | HANDLE | icdev,
 |  | unsigned char * | FontSize,
 |  | unsigned char * | Alignment,
 |  | unsigned char * | LeftMargin,
 |  | unsigned char * | RightMargin,
 |  | unsigned char * | RowPitch,
 |  | unsigned char * | PrintOutRate
 | ) |  |

查询打印机参数。

说明：
查询操作打印机的参数。
参数
[in] | icdev | 设备标识符。
[out] | FontSize | 字体设置，0x00表示字符大小为8*16，0x01表示字符大小为12*24，0x02表示字符大小为16*32。
[out] | Alignment | 对齐设置，0x00表示左对齐，0x01表示居中，0x02表示右对齐。
[out] | LeftMargin | 左边距设置，字符大小为8*16时<48，字符大小为12*24时<32，字符大小为16*32时<24。
[out] | RightMargin | 右边距设置，字符大小为8*16时<48，字符大小为12*24时<32，字符大小为16*32时<24。
[out] | RowPitch | 行间隔设置，单位为点。
[out] | PrintOutRate | 打印速度设置（0x00~0x03），0x00最快，0x03最慢。
返回
<0表示失败，==0表示成功。

§ dc_printcharacter()

short USER_API dc_printcharacter | ( | HANDLE | icdev,
 |  | unsigned short | length,
 |  | unsigned char * | character
 | ) |  |

打印字符。

说明：
打印文本字符信息。
参数
[in] | icdev | 设备标识符。
[in] | length | 字符数据的长度，必须小于或等于480。
[in] | character | 字符数据。
返回
<0表示失败，==0表示成功。

§ dc_printOnedimensional()

short USER_API dc_printOnedimensional | ( | HANDLE | icdev,
 |  | unsigned char | hight,
 |  | unsigned char | displayflag,
 |  | unsigned char | FontSize,
 |  | unsigned short | length,
 |  | unsigned char * | Onedimensional
 | ) |  |

打印一维码。

说明：
打印一维码信息。
参数
[in] | icdev | 设备标识符。
[in] | hight | 一维码的高度。
[in] | displayflag | 显示类型，0x00表示图形在下文本在上，0x01表示图形在上文本在下，0x02表示只显示图形不显示文本。
[in] | FontSize | 字体设置，0x00表示字符大小为8*16，0x01表示字符大小为12*24，0x02表示字符大小为16*32。
[in] | length | 文本数据的长度，必须小于或等于15。
[in] | Onedimensional | 文本数据。
返回
<0表示失败，==0表示成功。

§ dc_printPicture()

short USER_API dc_printPicture | ( | HANDLE | icdev,
 |  | unsigned char | length,
 |  | unsigned char | height,
 |  | unsigned char | Alignment,
 |  | unsigned char | LeftMargin,
 |  | unsigned char | RightMargin,
 |  | unsigned short | size,
 |  | unsigned char * | Picture
 | ) |  |

打印图片。

说明：
打印图片信息。
参数
[in] | icdev | 设备标识符。
[in] | length | 长度，单位为字节，必须小于或等于48，不能为0。
[in] | height | 高度，单位为点，必须小于100，不能为0。
[in] | Alignment | 对齐设置，0x00表示左对齐，0x01表示居中，0x02表示右对齐。
[in] | LeftMargin | 左边距设置，必须小于或等于48。
[in] | RightMargin | 右边距设置，必须小于或等于48。
[in] | size | 图片数据的大小。
[in] | Picture | 图片数据。
返回
<0表示失败，==0表示成功。

§ dc_printenter()

short USER_API dc_printenter | ( | HANDLE | icdev,
 |  | unsigned char | RowPitch
 | ) |  |

进纸。

说明：
进纸到设备内用于打印。
参数
[in] | icdev | 设备标识符。
[in] | RowPitch | 进纸行数，单位为点。
返回
<0表示失败，==0表示成功。

§ dc_printstatus()

short USER_API dc_printstatus | ( | HANDLE | icdev,
 |  | unsigned char * | paperstatus,
 |  | unsigned char * | tempturestatus,
 |  | unsigned char * | zkstatus
 | ) |  |

获取打印机状态。

说明：
获取打印机的状态。
参数
[in] | icdev | 设备标识符。
[out] | paperstatus | 纸状态，0x00表示不缺纸，0x01表示缺纸。
[out] | tempturestatus | 温度状态，0x00表示温度正常，0x01表示温度过高。
[out] zkstatus 字库状态。
0x00 - 三种字库都存在。
0x01 - 三种字库都不存在。
0x02 - 存在8*16字库。
0x03 - 存在12*24字库。
0x04 - 存在16*32字库。
0x05 - 存在8*16字库和12*24字库。
0x06 - 存在8*16字库和16*32字库。
0x07 - 存在12*24字库和16*32字库。
返回
<0表示失败，==0表示成功。

§ dc_set2dot4Gbaund()

short USER_API dc_set2dot4Gbaund | ( | HANDLE | icdev,
 |  | unsigned char | baund
 | ) |  |

设置2.4G模块波特率。

说明：
设置与2.4G模块之间通讯的波特率。
参数
[in] icdev 设备标识符。
[in] baund 波特率。
0x00 - 2400。
0x01 - 4800。
0x02 - 9600。
0x03 - 14400。
0x04 - 38400。
0x05 - 57600。
0x06 - 115200。
0x07 - 256000。
返回
<0表示失败，==0表示成功。

§ dc_check2dot4Gbaund()

short USER_API dc_check2dot4Gbaund | ( | HANDLE | icdev,
 |  | unsigned char * | baund
 | ) |  |

查询2.4G模块波特率。

说明：
查询与2.4G模块之间通讯的波特率。
参数
[in] icdev 设备标识符。
[out] baund 波特率。
0x00 - 2400。
0x01 - 4800。
0x02 - 9600。
0x03 - 14400。
0x04 - 38400。
0x05 - 57600。
0x06 - 115200。
0x07 - 256000。
返回
<0表示失败，==0表示成功。

§ dc_2dot4_reset()

short USER_API dc_2dot4_reset | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

2.4G复位。

说明：
用2.4G进行复位操作，
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回复位信息的长度。
[out] | databuffer | 返回的复位信息，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_2dot4_resethex()

short USER_API dc_2dot4_resethex | ( | HANDLE | icdev,
 |  | unsigned char * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

2.4G复位。

说明：
dc_2dot4_reset 的HEX形式接口，参数 databuffer 为HEX格式。

§ dc_2dot4_command()

short USER_API dc_2dot4_command | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | senddata,
 |  | unsigned int * | rlen,
 |  | unsigned char * | recvbuffer,
 |  | unsigned char | timeout
 | ) |  |

2.4G指令交互。

说明：
用2.4G进行指令交互操作。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | senddata | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | recvbuffer | 返回的数据。
[in] | timeout | 设备超时值，单位为秒。
返回
<0表示失败，==0表示成功。

§ dc_2dot4_command_hex()

short USER_API dc_2dot4_command_hex | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | senddata,
 |  | unsigned int * | rlen,
 |  | unsigned char * | recvbuffer,
 |  | unsigned char | timeout
 | ) |  |

2.4G指令交互。

说明：
dc_2dot4_command 的HEX形式接口，参数 senddata recvbuffer 为HEX格式。

§ dc_check_102()

short USER_API dc_check_102 ( HANDLE icdev )

检测102卡。

说明：
检测是否存在102卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_down_102()

short USER_API dc_down_102 ( HANDLE icdev )

102卡下电。

说明：
对102卡进行下电操作。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_read_102()

short USER_API dc_read_102 | ( | HANDLE | icdev,
 |  | unsigned char | offset,
 |  | unsigned char | length,
 |  | unsigned char * | readdata
 | ) |  |

读102卡。

说明：
读取102卡的数据。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | readdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_read_102_hex()

short USER_API dc_read_102_hex | ( | HANDLE | icdev,
 |  | unsigned char | offset,
 |  | unsigned char | length,
 |  | unsigned char * | readdata
 | ) |  |

读102卡。

说明：
dc_read_102 的HEX形式接口，参数 readdata 为HEX格式。

§ dc_write_102()

short USER_API dc_write_102 | ( | HANDLE | icdev,
 |  | unsigned char | offset,
 |  | unsigned char | length,
 |  | unsigned char * | writedata
 | ) |  |

写102卡。

说明：
写入数据到102卡中。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | writedata | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_write_102_hex()

short USER_API dc_write_102_hex | ( | HANDLE | icdev,
 |  | unsigned char | offset,
 |  | unsigned char | length,
 |  | unsigned char * | writedata
 | ) |  |

写102卡。

说明：
dc_write_102 的HEX形式接口，参数 writedata 为HEX格式。

§ dc_checkpass_102()

short USER_API dc_checkpass_102 | ( | HANDLE | icdev,
 |  | short | zone,
 |  | unsigned char * | password
 | ) |  |

验证102卡密码。

说明：
使用传入的密码来验证102卡密码。
参数
[in] | icdev | 设备标识符。
[in] zone 密码区。
0 - 表示总密码，密码长度为2个字节。
11 - 表示一区擦除密码，密码长度为6个字节。
12 - 表示二区擦除密码，密码长度为4个字节。
[in] | password | 密码。
返回
<0表示失败，==0表示成功。

§ dc_checkpass_102_hex()

short USER_API dc_checkpass_102_hex | ( | HANDLE | icdev,
 |  | short | zone,
 |  | unsigned char * | password
 | ) |  |

验证102卡密码。

说明：
dc_checkpass_102 的HEX形式接口，参数 password 为HEX格式。

§ dc_changepass_102()

short USER_API dc_changepass_102 | ( | HANDLE | icdev,
 |  | short | zone,
 |  | unsigned char * | password
 | ) |  |

修改102卡密码。

说明：
修改102卡的密码。
参数
[in] | icdev | 设备标识符。
[in] zone 密码区。
0 - 表示总密码，密码长度为2个字节。
11 - 表示一区擦除密码，密码长度为6个字节。
12 - 表示二区擦除密码，密码长度为4个字节。
[in] | password | 密码。
返回
<0表示失败，==0表示成功。

§ dc_changepass_102_hex()

short USER_API dc_changepass_102_hex | ( | HANDLE | icdev,
 |  | short | zone,
 |  | unsigned char * | password
 | ) |  |

修改102卡密码。

说明：
dc_changepass_102 的HEX形式接口，参数 password 为HEX格式。

§ dc_readcount_102()

short USER_API dc_readcount_102 | ( | HANDLE | icdev,
 |  | short | zone
 | ) |  |

读102卡密码计数。

说明：
读取102卡的密码计数，此计数值表示可以尝试验证密码的次数。
参数
[in] icdev 设备标识符。
[in] zone 密码区。
0 - 表示总密码。
返回
<0表示失败，否则为密码计数值。

§ dc_fuse_102()

short USER_API dc_fuse_102 ( HANDLE icdev )

102卡熔丝。

说明：
对102卡进行熔丝操作。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_check_1604()

short USER_API dc_check_1604 ( HANDLE icdev )

检测1604卡。

说明：
检测是否存在1604卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_down_1604()

short USER_API dc_down_1604 ( HANDLE icdev )

1604卡下电。

说明：
对1604卡进行下电操作。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_read_1604()

short USER_API dc_read_1604 | ( | HANDLE | icdev,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | readdata
 | ) |  |

读1604卡。

说明：
读取1604卡的数据。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | readdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_read_1604_hex()

short USER_API dc_read_1604_hex | ( | HANDLE | icdev,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | readdata
 | ) |  |

读1604卡。

说明：
dc_read_1604 的HEX形式接口，参数 readdata 为HEX格式。

§ dc_write_1604()

short USER_API dc_write_1604 | ( | HANDLE | icdev,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | writedata
 | ) |  |

写1604卡。

说明：
写入数据到1604卡中。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | writedata | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_write_1604_hex()

short USER_API dc_write_1604_hex | ( | HANDLE | icdev,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | writedata
 | ) |  |

写1604卡。

说明：
dc_write_1604 的HEX形式接口，参数 writedata 为HEX格式。

§ dc_checkpass_1604()

short USER_API dc_checkpass_1604 | ( | HANDLE | icdev,
 |  | short | zone,
 |  | unsigned char * | password
 | ) |  |

验证1604卡密码。

说明：
使用传入的密码来验证1604卡密码。
参数
[in] | icdev | 设备标识符。
[in] zone 密码区。
0 - 表示总密码。
1 - 表示一区密码。
2 - 表示二区密码。
3 - 表示三区密码。
4 - 表示四区密码。
11 - 表示一区擦除密码。
12 - 表示二区擦除密码。
13 - 表示三区擦除密码。
14 - 表示四区擦除密码。
[in] | password | 密码，固定为2个字节。
返回
<0表示失败，==0表示成功。

§ dc_checkpass_1604_hex()

short USER_API dc_checkpass_1604_hex | ( | HANDLE | icdev,
 |  | short | zone,
 |  | unsigned char * | password
 | ) |  |

验证1604卡密码。

说明：
dc_checkpass_1604 的HEX形式接口，参数 password 为HEX格式。

§ dc_changepass_1604()

short USER_API dc_changepass_1604 | ( | HANDLE | icdev,
 |  | short | zone,
 |  | unsigned char * | password
 | ) |  |

修改1604卡密码。

说明：
修改1604卡的密码。
参数
[in] | icdev | 设备标识符。
[in] zone 密码区。
0 - 表示总密码。
1 - 表示一区密码。
2 - 表示二区密码。
3 - 表示三区密码。
4 - 表示四区密码。
11 - 表示一区擦除密码。
12 - 表示二区擦除密码。
13 - 表示三区擦除密码。
14 - 表示四区擦除密码。
[in] | password | 密码，固定为2个字节。
返回
<0表示失败，==0表示成功。

§ dc_changepass_1604_hex()

short USER_API dc_changepass_1604_hex | ( | HANDLE | icdev,
 |  | short | zone,
 |  | unsigned char * | password
 | ) |  |

修改1604卡密码。

说明：
dc_changepass_1604 的HEX形式接口，参数 password 为HEX格式。

§ dc_readcount_1604()

short USER_API dc_readcount_1604 | ( | HANDLE | icdev,
 |  | short | zone
 | ) |  |

读1604卡密码计数。

说明：
读取1604卡的密码计数，此计数值表示可以尝试验证密码的次数。
参数
[in] icdev 设备标识符。
[in] zone 密码区。
0 - 表示总密码。
1 - 表示一区密码。
2 - 表示二区密码。
3 - 表示三区密码。
4 - 表示四区密码。
11 - 表示一区擦除密码。
12 - 表示二区擦除密码。
13 - 表示三区擦除密码。
14 - 表示四区擦除密码。
返回
<0表示失败，否则为密码计数值。

§ dc_fuse_1604()

short USER_API dc_fuse_1604 ( HANDLE icdev )

1604卡熔丝。

说明：
对1604卡进行熔丝操作。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_down_4428()

short USER_API dc_down_4428 ( HANDLE icdev )

4428卡下电。

说明：
对4428卡进行下电操作。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_down_4442()

short USER_API dc_down_4442 ( HANDLE icdev )

4442卡下电。

说明：
对4442卡进行下电操作。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_startreadmag()

short USER_API dc_startreadmag ( HANDLE icdev )

启动读磁条卡。

说明：
使设备进入监测刷磁条的状态，接口本身会直接返回，而不会等待刷完磁条卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_stopreadmag()

short USER_API dc_stopreadmag ( HANDLE icdev )

停止读磁条卡。

说明：
在设备进入监测刷磁条的状态后，只有刷完磁条卡或调用此接口才能使得设备退出这种状态。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_readmag()

short USER_API dc_readmag | ( | HANDLE | icdev,
 |  | unsigned char * | pTrack1Data,
 |  | unsigned int * | pTrack1Len,
 |  | unsigned char * | pTrack2Data,
 |  | unsigned int * | pTrack2Len,
 |  | unsigned char * | pTrack3Data,
 |  | unsigned int * | pTrack3Len
 | ) |  |

获取磁条卡数据。

说明：
获取设备已经读取到的磁条卡数据。
参数
[in] | icdev | 设备标识符。
[out] | pTrack1Data | 返回的1轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack1Len | 返回1轨道数据的长度，不含'\0'。
[out] | pTrack2Data | 返回的2轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack2Len | 返回2轨道数据的长度，不含'\0'。
[out] | pTrack3Data | 返回的3轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack3Len | 返回3轨道数据的长度，不含'\0'。
返回
<0表示失败，==0表示成功，==1表示等待刷卡，==2表示处于停止刷卡状态。

§ dc_readmagcardallA()

short USER_API dc_readmagcardallA | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char * | pTrack1Data,
 |  | unsigned int * | pTrack1Len,
 |  | unsigned char * | pTrack2Data,
 |  | unsigned int * | pTrack2Len,
 |  | unsigned char * | pTrack3Data,
 |  | unsigned int * | pTrack3Len
 | ) |  |

自动获取磁条卡数据。

说明：
内部包含了 dc_startreadmag dc_readmag dc_stopreadmag 的功能。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 接口超时值，单位为秒。
[out] | pTrack1Data | 返回的1轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack1Len | 返回1轨道数据的长度，不含'\0'。
[out] | pTrack2Data | 返回的2轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack2Len | 返回2轨道数据的长度，不含'\0'。
[out] | pTrack3Data | 返回的3轨道数据，数据格式为'\0'结尾的字符串。
[out] | pTrack3Len | 返回3轨道数据的长度，不含'\0'。
返回
<0表示失败，==0表示成功，==1表示等待刷卡，==2表示处于停止刷卡状态。

§ dc_InstallKbKey()

short USER_API dc_InstallKbKey | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | unsigned char | keylen,
 |  | unsigned char * | keydata,
 |  | unsigned char | mode
 | ) |  |

设置密码键盘密钥。

说明：
对密码键盘内的密钥进行设置操作。
参数
[in] | icdev | 设备标识符。
[in] flag 标记。
0x00 - 表示装载主密钥，明文装载。
0x01 - 表示装载PIN密钥，密文装载（用主密钥加密）。
0x02 - 表示装载MAC密钥，密文装载（用主密钥加密）。
0x03 - 表示装载TDK密钥，密文装载（用主密钥加密）。
0xF0 - 表示清空主密钥、PIN密钥、MAC密钥、TDK密钥。
0xF1 - 表示清空PIN密钥。
0xF2 - 表示清空MAC密钥。
0xF3 - 表示清空TDK密钥。
[in] | keylen | 密钥数据的长度。
[in] | keydata | 密钥数据。
[in] | mode | 模式，0x00表示单DES密钥，0x01表示三DES密钥，0x02表示SM4密钥，0x03表示24字节三DES密钥。
返回
<0表示失败，==0表示成功。

§ dc_SetKbKeyID()

short USER_API dc_SetKbKeyID | ( | HANDLE | icdev,
 |  | unsigned char | keyID
 | ) |  |

设置当前密钥组。

说明：
设置密码键盘当前使用的密钥组。
参数
[in] | icdev | 设备标识符。
[in] | keyID | 密钥组号，从0x00开始编号。
返回
<0表示失败，==0表示成功。

§ dc_GetEnPass()

short USER_API dc_GetEnPass | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char | panlen,
 |  | unsigned char * | pandata,
 |  | unsigned char * | rlen,
 |  | unsigned char * | cpass
 | ) |  |

获取加密按键数据。

说明：
从密码键盘获取ANSI X9.8 PIN BLOCK加密的按键数据。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[in] | panlen | 卡号的长度。
[in] | pandata | 卡号。
[out] | rlen | 返回加密数据的长度。
[out] | cpass | 返回的加密数据。
返回
<0表示失败，==0表示成功，==0xA1表示取消输入，==0xA2表示输入超时。

§ dc_CreatDesData()

short USER_API dc_CreatDesData | ( | HANDLE | icdev,
 |  | unsigned char | keytype,
 |  | unsigned char | enmode,
 |  | unsigned char * | sourcedata,
 |  | unsigned char * | retdata
 | ) |  |

用工作密钥加解密。

说明：
使用密码键盘的工作密钥进行数据加解密操作，仅支持单DES、三DES和24字节三DES算法，算法由设置密钥时确定，请参考 dc_InstallKbKey 。
参数
[in] | icdev | 设备标识符。
[in] | keytype | 密钥类型，0x01表示PIN密钥，0x02表示MAC密钥，0x03表示TDK密钥。
[in] | enmode | 运算模式，0x00表示加密，0x01表示解密。
[in] | sourcedata | 传入数据，固定为8个字节。
[out] | retdata | 返回的数据，固定为8个字节。
返回
<0表示失败，==0表示成功。

§ dc_CreatSm4Data()

short USER_API dc_CreatSm4Data | ( | HANDLE | icdev,
 |  | unsigned char | keytype,
 |  | unsigned char | enmode,
 |  | unsigned char * | sourcedata,
 |  | unsigned char * | retdata
 | ) |  |

用工作密钥加解密。

说明：
使用密码键盘的工作密钥进行数据加解密操作，仅支持SM4算法，算法由设置密钥时确定，请参考 dc_InstallKbKey 。
参数
[in] | icdev | 设备标识符。
[in] | keytype | 密钥类型，0x01表示PIN密钥，0x02表示MAC密钥，0x03表示TDK密钥。
[in] | enmode | 运算模式，0x00表示加密，0x01表示解密。
[in] | sourcedata | 传入数据，固定为16个字节。
[out] | retdata | 返回的数据，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ dc_CreatDesDataECB()

short USER_API dc_CreatDesDataECB | ( | HANDLE | icdev,
 |  | unsigned char | keytype,
 |  | unsigned char | enmode,
 |  | int | slen,
 |  | unsigned char * | sourcedata,
 |  | int * | rlen,
 |  | unsigned char * | retdata
 | ) |  |

用工作密钥加解密。

说明：
使用密码键盘的工作密钥进行数据加解密操作，仅支持单DES ECB和三DES ECB算法，内部会调用 dc_CreatDesData 。
参数
[in] | icdev | 设备标识符。
[in] | keytype | 密钥类型，0x01表示PIN密钥，0x02表示MAC密钥，0x03表示TDK密钥。
[in] | enmode | 运算模式，0x00表示加密，0x01表示解密。
[in] | slen | 传入数据的长度。
[in] | sourcedata | 传入数据。
[out] | rlen | 返回数据的长度。
[out] | retdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_CreatSm4DataECB()

short USER_API dc_CreatSm4DataECB | ( | HANDLE | icdev,
 |  | unsigned char | keytype,
 |  | unsigned char | enmode,
 |  | int | slen,
 |  | unsigned char * | sourcedata,
 |  | int * | rlen,
 |  | unsigned char * | retdata
 | ) |  |

用工作密钥加解密。

说明：
使用密码键盘的工作密钥进行数据加解密操作，仅支持SM4 ECB算法，内部会调用 dc_CreatSm4Data 。
参数
[in] | icdev | 设备标识符。
[in] | keytype | 密钥类型，0x01表示PIN密钥，0x02表示MAC密钥，0x03表示TDK密钥。
[in] | enmode | 运算模式，0x00表示加密，0x01表示解密。
[in] | slen | 传入数据的长度。
[in] | sourcedata | 传入数据。
[out] | rlen | 返回数据的长度。
[out] | retdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_CreatMacDataECB()

short USER_API dc_CreatMacDataECB | ( | HANDLE | icdev,
 |  | unsigned char | keytype,
 |  | unsigned char | enmode,
 |  | int | slen,
 |  | unsigned char * | sourcedata,
 |  | int * | rlen,
 |  | unsigned char * | retdata
 | ) |  |

用工作密钥算MAC。

说明：
使用密码键盘的工作密钥进行数据算MAC操作，内部会调用 dc_CreatDesData dc_CreatSm4Data 。
参数
[in] | icdev | 设备标识符。
[in] | keytype | 密钥类型，0x01表示PIN密钥，0x02表示MAC密钥，0x03表示TDK密钥。
[in] | enmode | 运算模式，0x00或0x01表示用DES POS ECB算MAC，0x02表示用SM4算MAC，0x03表示用DES X9.9算MAC，0x04表示用三DES X9.19算MAC，0x05表示用三DES POS ECB算MAC，0x06表示用24字节三DES X9.19算MAC，0x07表示用24字节三DES POS ECB算MAC。
[in] | slen | 传入数据的长度。
[in] | sourcedata | 传入数据。
[out] | rlen | 返回数据的长度。
[out] | retdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_writeSD()

short USER_API dc_writeSD | ( | HANDLE | icdev,
 |  | int | offset,
 |  | int | length,
 |  | unsigned char * | writebuffer
 | ) |  |

写SD存储。

说明：
写入数据到SD存储中，可以用作数据保存等。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移地址。
[in] | length | 写入长度。
[in] | writebuffer | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_readSD()

short USER_API dc_readSD | ( | HANDLE | icdev,
 |  | int | offset,
 |  | int | length,
 |  | unsigned char * | readbuffer
 | ) |  |

读SD存储。

说明：
读取SD存储中的数据，可以用作数据保存等。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移地址。
[in] | length | 读取长度。
[out] | readbuffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_SetUsbMode()

short USER_API dc_SetUsbMode | ( | HANDLE | icdev,
 |  | unsigned char | ucmode
 | ) |  |

设置USB模式。

说明：
设置USB通讯模式，必须重新对设备进行上电才能生效。
参数
[in] icdev 设备标识符。
[in] ucmode 模式。
0x00 - 表示中断发送和中断接收，此时VID=257B，PID=3010。
0x01 - 表示控制发送和控制接收，此时VID=257B，PID=3011。
0x02 - 表示控制发送和中断接收，此时VID=0471，PID=7002。
0x03 - 表示控制发送和中断接收，此时VID=0471，PID=7003。
0x04 - 表示控制发送和中断接收，此时VID=0471，PID=7003，支持磁条卡自动上传功能。
返回
<0表示失败，==0表示成功。

§ SD_InstallKey()

short USER_API SD_InstallKey | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char | senlen,
 |  | unsigned char * | source,
 |  | unsigned char * | reclen,
 |  | unsigned char * | rdata
 | ) |  |

外接密码键盘通讯。

说明：
与外置密码键盘进行通讯交互。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[in] | senlen | 发送数据的长度。
[in] | source | 发送数据。
[out] | reclen | 返回数据的长度。
[out] | rdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ SD_IFD_GetVersion()

short USER_API SD_IFD_GetVersion | ( | HANDLE | icdev,
 |  | char * | version
 | ) |  |

获取外接密码键盘的版本。

说明：
获取外接密码键盘的版本。
参数
[in] | icdev | 设备标识符。
[out] | version | 返回的版本字符串，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ SD_IFD_PlayVoice()

short USER_API SD_IFD_PlayVoice | ( | HANDLE | icdev,
 |  | unsigned char | _playmode
 | ) |  |

外接密码键盘播放语音。

说明：
播放外接密码键盘内置语音。
参数
[in] icdev 设备标识符。
[in] _playmode 语音段号（0x01~0x08）。
0x01 - "请输入密码"。
0x02 - "请输入原密码"。
0x03 - "请再输入一次"。
0x04 - "请输入新密码"。
0x05 - "请确认新密码"。
0x06 - "密码修改成功"。
0x07 - "请插卡"。
0x08 - "请刷卡"。
返回
<0表示失败，==0表示成功。

§ SD_IFD_Init()

short USER_API SD_IFD_Init ( HANDLE icdev )

外接密码键盘初始化。

说明：
对外接密码键盘进行初始化操作，使其复位为出厂状态，出厂状态下所有的主密钥内存空间都为字节0x88。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ SD_IFD_SetMainKey()

short USER_API SD_IFD_SetMainKey | ( | HANDLE | icdev,
 |  | unsigned char | keyset,
 |  | unsigned char * | oldkey,
 |  | unsigned char * | newkey
 | ) |  |

设置外接密码键盘主密钥。

说明：
对外接密码键盘内的主密钥进行设置操作。
参数
[in] | icdev | 设备标识符。
[in] | keyset | 密钥组号，从0x00开始编号。
[in] | oldkey | 旧主密钥数据，明文，固定为16个字节。
[in] | newkey | 新主密钥数据，明文，固定为16个字节。
返回
<0表示失败，==0表示成功。

§ SD_IFD_SetWorkKey()

short USER_API SD_IFD_SetWorkKey | ( | HANDLE | icdev,
 |  | unsigned char | keysetmain,
 |  | unsigned char | keysetwork,
 |  | unsigned char * | enkeywork
 | ) |  |

设置外接密码键盘工作密钥。

说明：
对外接密码键盘内的工作密钥进行设置操作。
参数
[in] | icdev | 设备标识符。
[in] | keysetmain | 主密钥组号，从0x00开始编号。
[in] | keysetwork | 工作密钥组号，从0x00开始编号。
[in] | enkeywork | 工作密钥数据，密文（用主密钥加密），固定为16个字节。
返回
<0表示失败，==0表示成功。

§ SD_IFD_ActWorkKey()

short USER_API SD_IFD_ActWorkKey | ( | HANDLE | icdev,
 |  | unsigned char | keysetmain,
 |  | unsigned char | keysetwork
 | ) |  |

激活外接密码键盘工作密钥。

说明：
激活外接密码键盘当前使用的工作密钥。
参数
[in] | icdev | 设备标识符。
[in] | keysetmain | 主密钥组号，从0x00开始编号。
[in] | keysetwork | 工作密钥组号，从0x00开始编号。
返回
<0表示失败，==0表示成功。

§ SD_IFD_SetKeyLength()

short USER_API SD_IFD_SetKeyLength | ( | HANDLE | icdev,
 |  | unsigned char | keylength
 | ) |  |

设置外接密码键盘最大输入长度。

说明：
设置外接密码键盘允许用户输入密码的最大长度。
参数
[in] | icdev | 设备标识符。
[in] | keylength | 密码最大长度（1~16）。
返回
<0表示失败，==0表示成功。

§ SD_IFD_GetPIN()

short USER_API SD_IFD_GetPIN | ( | HANDLE | icdev,
 |  | char * | szPasswd
 | ) |  |

获取外接密码键盘明文数据。

说明：
从外接密码键盘获取明文按键数据。
参数
[in] | icdev | 设备标识符。
[out] | szPasswd | 返回的按键数据，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功，==0xA1表示取消输入，==0xA2表示输入超时。

§ SD_IFD_GetEnPIN()

short USER_API SD_IFD_GetEnPIN | ( | HANDLE | icdev,
 |  | char * | szPasswd
 | ) |  |

获取外接密码键盘密文数据。

说明：
从外接密码键盘获取密文按键数据。
参数
[in] | icdev | 设备标识符。
[out] | szPasswd | 返回的按键数据，数据为密文的HEX格式字符串。
返回
<0表示失败，==0表示成功，==0xA1表示取消输入，==0xA2表示输入超时。

§ SD_IFD_GetPINPro()

short USER_API SD_IFD_GetPINPro | ( | HANDLE | icdev,
 |  | char * | szPasswd,
 |  | unsigned char | yyflag,
 |  | unsigned char | timeout
 | ) |  |

获取外接密码键盘明文数据。

说明：
从外接密码键盘获取明文按键数据。
参数
[in] | icdev | 设备标识符。
[out] | szPasswd | 返回的按键数据，数据格式为'\0'结尾的字符串。
[in] yyflag 标记。
0x80 - 绿灯亮，液晶显示"欢迎使用"，无语音提示。
0x81 - 绿灯亮，液晶显示"请再输入一次"，有语音提示。
0x82 - 绿灯亮，液晶显示"请输入密码"，有语音提示。
0x83 - 绿灯亮，液晶不操作，无语音提示。
0x84 - 绿灯亮，液晶显示"请输入原密码"，有语音提示。
0x85 - 绿灯亮，液晶显示"请输入新密码"，有语音提示。
0x86 - 绿灯亮，液晶显示"请输入新密码"，无语音提示。
[in] | timeout | 设备超时值，单位为秒。
返回
<0表示失败，==0表示成功，==0xA1表示取消输入，==0xA2表示输入超时。

§ SD_IFD_GetEnPINPro()

short USER_API SD_IFD_GetEnPINPro | ( | HANDLE | icdev,
 |  | char * | szPasswd,
 |  | unsigned char | yyflag,
 |  | unsigned char | modeflag,
 |  | unsigned char | timeout
 | ) |  |

获取外接密码键盘密文数据。

说明：
从外接密码键盘获取密文按键数据。
参数
[in] | icdev | 设备标识符。
[out] | szPasswd | 返回的按键数据，数据格式为'\0'结尾的字符串。
[in] yyflag 标记。
0x30 - 密码键盘提示"请输入密码"，语音提示，输入密码显示'*'。
0x31 - 密码键盘提示"请再输入一次"，语音提示，输入密码显示'*'。
0x32 - 密码键盘提示"请输入密码"，无语音提示，输入密码显示'*'。
0x33 - 密码键盘提示"请再输入一次"，无语音提示，输入密码显示'*'。
0x34 - 密码键盘提示"请输入密码"，语音提示，输入密码明文显示。
0x35 - 密码键盘提示"请再输入一次"，语音提示，输入密码明文显示。
0x36 - 密码键盘提示"请输入密码"，无语音提示，输入密码明文显示。
0x37 - 密码键盘提示"请再输入一次"，无语音提示，输入密码明文显示。
[in] modeflag 模式。
0x30 - 按"确认"键或到达指定的PIN长度。
0x31 - 按"确认"键。
0x32 - 到达指定的PIN长度。
0x33 - 到达指定的PIN长度并按"确认"键。
[in] | timeout | 设备超时值，单位为秒。
返回
<0表示失败，==0表示成功，==0xA1表示取消输入，==0xA2表示输入超时。

§ SD_IFD_GetEnPINBlock()

short USER_API SD_IFD_GetEnPINBlock | ( | HANDLE | icdev,
 |  | char * | szPasswd,
 |  | unsigned char | yyflag,
 |  | unsigned char | modeflag,
 |  | unsigned char * | cardno,
 |  | unsigned char | timeout
 | ) |  |

获取外接密码键盘密文数据。

说明：
从外接密码键盘获取ANSI X9.8 PIN BLOCK加密的按键数据。
参数
[in] | icdev | 设备标识符。
[out] | szPasswd | 返回的按键数据，数据格式为'\0'结尾的字符串。
[in] yyflag 标记。
0x30 - 密码键盘提示"请输入密码"，语音提示，输入密码显示'*'。
0x31 - 密码键盘提示"请再输入一次"，语音提示，输入密码显示'*'。
0x32 - 密码键盘提示"请输入密码"，无语音提示，输入密码显示'*'。
0x33 - 密码键盘提示"请再输入一次"，无语音提示，输入密码显示'*'。
0x34 - 密码键盘提示"请输入密码"，语音提示，输入密码明文显示。
0x35 - 密码键盘提示"请再输入一次"，语音提示，输入密码明文显示。
0x36 - 密码键盘提示"请输入密码"，无语音提示，输入密码明文显示。
0x37 - 密码键盘提示"请再输入一次"，无语音提示，输入密码明文显示。
[in] modeflag 模式。
0x30 - 按"确认"键或到达指定的PIN长度。
0x31 - 按"确认"键。
0x32 - 到达指定的PIN长度。
0x33 - 到达指定的PIN长度并按"确认"键。
[in] | cardno | 截取后的卡号，固定为12个字节。
[in] | timeout | 设备超时值，单位为秒。
返回
<0表示失败，==0表示成功，==0xA1表示取消输入，==0xA2表示输入超时。

§ SD_IFD_SelecetDes()

short USER_API SD_IFD_SelecetDes | ( | HANDLE | icdev,
 |  | unsigned char | desmode
 | ) |  |

设置外接密码键盘算法。

说明：
设置外接密码键盘使用的算法。
参数
[in] | icdev | 设备标识符。
[in] | desmode | 模式，0x01表示单DES，0x02表示三DES。
返回
<0表示失败，==0表示成功。

§ SD_IFD_LEDDisplay()

short USER_API SD_IFD_LEDDisplay | ( | HANDLE | icdev,
 |  | unsigned char | line,
 |  | unsigned char | row,
 |  | unsigned char * | leddata,
 |  | unsigned char | timeout
 | ) |  |

外接密码键盘液晶显示。

说明：
显示指定字符串到外接密码键盘的液晶屏幕上。
参数
[in] | icdev | 设备标识符。
[in] | line | 行号。
[in] | row | 偏移。
[in] | leddata | 要显示的字符串。
[in] | timeout | 设备超时值，单位为秒。
返回
<0表示失败，==0表示成功。

§ SD_IFD_DES()

short USER_API SD_IFD_DES | ( | HANDLE | icdev,
 |  | unsigned char | mode,
 |  | unsigned char * | srcdata,
 |  | unsigned char * | desdata
 | ) |  |

用外接密码键盘工作密钥加解密。

说明：
使用外接密码键盘的工作密钥进行数据加解密操作。
参数
[in] | icdev | 设备标识符。
[in] | mode | 运算模式，0x00表示加密，0x01表示解密。
[in] | srcdata | 传入数据，HEX格式字符串。
[out] | desdata | 返回的数据，HEX格式字符串。
返回
<0表示失败，==0表示成功。

§ SD_IFD_DesCaculate()

short USER_API SD_IFD_DesCaculate | ( | HANDLE | icdev,
 |  | unsigned char | srclen,
 |  | unsigned char * | srcdata,
 |  | unsigned char * | desdata,
 |  | unsigned char | flag
 | ) |  |

用外接密码键盘工作密钥加解密。

说明：
使用外接密码键盘的工作密钥进行数据加解密操作。
参数
[in] | icdev | 设备标识符。
[in] | srclen | 传入数据的长度。
[in] | srcdata | 传入数据。
[out] | desdata | 返回的数据，HEX格式字符串。
[in] | flag | 运算模式，0x00表示加密，0x01表示解密。
返回
<0表示失败，==0表示成功。

§ SD_IFD_CreateMac()

short USER_API SD_IFD_CreateMac | ( | HANDLE | icdev,
 |  | unsigned char | srclen,
 |  | unsigned char * | srcdata,
 |  | unsigned char * | macdata
 | ) |  |

用外接密码键盘工作密钥算MAC。

说明：
使用外接密码键盘的工作密钥进行数据算MAC操作。
参数
[in] | icdev | 设备标识符。
[in] | srclen | 传入数据的长度。
[in] | srcdata | 传入数据。
[out] | macdata | 返回的MAC字符串，请至少分配64个字节。
返回
<0表示失败，==0表示成功。

§ SD_IFD_Scan2DBarcodeStart()

short USER_API SD_IFD_Scan2DBarcodeStart | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

外接密码键盘开始扫描二维码。

说明：
外接密码键盘开始扫描二维码。
参数
[in] | icdev | 设备标识符。
[in] | mode | 保留，固定为0x00。
返回
<0表示失败，==0表示成功。

§ SD_IFD_Scan2DBarcodeGetData()

short USER_API SD_IFD_Scan2DBarcodeGetData | ( | HANDLE | icdev,
 |  | int * | rlen,
 |  | unsigned char * | rdata
 | ) |  |

外接密码键盘获取二维码数据。

说明：
外接密码键盘获取二维码数据。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回数据的长度。
[out] | rdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ SD_IFD_Scan2DBarcodeExit()

short USER_API SD_IFD_Scan2DBarcodeExit ( HANDLE icdev )

外接密码键盘退出扫描二维码。

说明：
外接密码键盘退出扫描二维码。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_find_i_d()

short USER_API dc_find_i_d ( HANDLE icdev )

查找身份证。

说明：
以读取数据方式查找是否有身份证存在于感应区。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_find_i_d_2()

short USER_API dc_find_i_d_2 ( HANDLE icdev )

查找身份证。

说明：
以读取状态方式查找是否有身份证存在于感应区。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_find_i_d_speed()

short USER_API dc_find_i_d_speed ( HANDLE icdev )

查找身份证。

说明：
以寻卡方式查找是否有身份证存在于感应区。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_get_i_d_raw_buffer()

short USER_API dc_get_i_d_raw_buffer | ( | HANDLE | icdev,
 |  | unsigned char * | rdata
 | ) |  |

读身份证原始数据。

说明：
读取身份证模块返回的原始数据，包含基础文字和相片内容。
参数
[in] | icdev | 设备标识符。
[out] | rdata | 返回的数据，请至少分配4096个字节。
返回
<0表示失败，==0表示成功。

§ dc_start_i_d()

HANDLE USER_API dc_start_i_d ( HANDLE icdev )

读身份证。

说明：
读取身份证模块返回的原始数据，包含基础文字和相片内容，内部会做解析并且分配资源来保存，释放资源请使用 dc_end_i_d 。
参数
[in] icdev 设备标识符。
返回
<0表示失败，否则为身份证标识符。

§ dc_start_i_d_2()

HANDLE USER_API dc_start_i_d_2 ( HANDLE icdev )

读身份证。

说明：
读取身份证模块返回的原始数据，包含基础文字、相片、指纹内容，内部会做解析并且分配资源来保存，释放资源请使用 dc_end_i_d 。
参数
[in] icdev 设备标识符。
返回
<0表示失败，否则为身份证标识符。

§ dc_i_d_query_name()

char* USER_API dc_i_d_query_name ( HANDLE idhandle )

获取姓名。

说明：
获取内部保存的姓名。
参数
[in] idhandle 身份证标识符。
返回
返回的姓名字符串。

§ dc_i_d_query_name_2()

short USER_API dc_i_d_query_name_2 | ( | HANDLE | idhandle,
 |  | char * | name
 | ) |  |

获取姓名。

说明：
获取内部保存的姓名。
参数
[in] | idhandle | 身份证标识符。
[out] | name | 姓名，请至少分配32个字节。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_sex()

char* USER_API dc_i_d_query_sex ( HANDLE idhandle )

获取性别。

说明：
获取内部保存的性别。
参数
[in] idhandle 身份证标识符。
返回
返回的性别字符串。

§ dc_i_d_query_sex_2()

short USER_API dc_i_d_query_sex_2 | ( | HANDLE | idhandle,
 |  | char * | sex
 | ) |  |

获取性别。

说明：
获取内部保存的性别。
参数
[in] | idhandle | 身份证标识符。
[out] | sex | 性别，请至少分配8个字节。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_nation()

char* USER_API dc_i_d_query_nation ( HANDLE idhandle )

获取民族。

说明：
获取内部保存的民族。
参数
[in] idhandle 身份证标识符。
返回
返回的民族字符串。

§ dc_i_d_query_nation_2()

short USER_API dc_i_d_query_nation_2 | ( | HANDLE | idhandle,
 |  | char * | nation
 | ) |  |

获取民族。

说明：
获取内部保存的民族。
参数
[in] | idhandle | 身份证标识符。
[out] | nation | 民族，请至少分配32个字节。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_birth()

char* USER_API dc_i_d_query_birth ( HANDLE idhandle )

获取生日。

说明：
获取内部保存的生日。
参数
[in] idhandle 身份证标识符。
返回
返回的生日字符串。

§ dc_i_d_query_birth_2()

short USER_API dc_i_d_query_birth_2 | ( | HANDLE | idhandle,
 |  | char * | birth
 | ) |  |

获取生日。

说明：
获取内部保存的生日。
参数
[in] | idhandle | 身份证标识符。
[out] | birth | 生日，请至少分配16个字节。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_address()

char* USER_API dc_i_d_query_address ( HANDLE idhandle )

获取住址。

说明：
获取内部保存的住址。
参数
[in] idhandle 身份证标识符。
返回
返回的住址字符串。

§ dc_i_d_query_address_2()

short USER_API dc_i_d_query_address_2 | ( | HANDLE | idhandle,
 |  | char * | address
 | ) |  |

获取住址。

说明：
获取内部保存的住址。
参数
[in] | idhandle | 身份证标识符。
[out] | address | 住址，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_id_number()

char* USER_API dc_i_d_query_id_number ( HANDLE idhandle )

获取公民身份号码。

说明：
获取内部保存的公民身份号码。
参数
[in] idhandle 身份证标识符。
返回
返回的公民身份号码字符串。

§ dc_i_d_query_id_number_2()

short USER_API dc_i_d_query_id_number_2 | ( | HANDLE | idhandle,
 |  | char * | id_number
 | ) |  |

获取公民身份号码。

说明：
获取内部保存的公民身份号码。
参数
[in] | idhandle | 身份证标识符。
[out] | id_number | 公民身份号码，请至少分配32个字节。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_department()

char* USER_API dc_i_d_query_department ( HANDLE idhandle )

获取签发机关。

说明：
获取内部保存的签发机关。
参数
[in] idhandle 身份证标识符。
返回
返回的签发机关字符串。

§ dc_i_d_query_department_2()

short USER_API dc_i_d_query_department_2 | ( | HANDLE | idhandle,
 |  | char * | department
 | ) |  |

获取签发机关。

说明：
获取内部保存的签发机关。
参数
[in] | idhandle | 身份证标识符。
[out] | department | 签发机关，请至少分配32个字节。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_expire_day()

char* USER_API dc_i_d_query_expire_day ( HANDLE idhandle )

获取有效期限。

说明：
获取内部保存的有效期限。
参数
[in] idhandle 身份证标识符。
返回
返回的有效期限字符串。

§ dc_i_d_query_expire_day_2()

short USER_API dc_i_d_query_expire_day_2 | ( | HANDLE | idhandle,
 |  | char * | expire_day
 | ) |  |

获取有效期限。

说明：
获取内部保存的有效期限。
参数
[in] | idhandle | 身份证标识符。
[out] | expire_day | 有效期限，请至少分配32个字节。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_photo()

unsigned char* USER_API dc_i_d_query_photo ( HANDLE idhandle )

获取相片原始数据。

说明：
获取内部保存的相片原始数据，此数据需要通过公安部相片解码库解码才能生成相片图像。
参数
[in] idhandle 身份证标识符。
返回
返回的相片原始数据，数据实际长度通过调用 dc_i_d_query_photo_len 来获取。

§ dc_i_d_query_photo_2()

short USER_API dc_i_d_query_photo_2 | ( | HANDLE | idhandle,
 |  | unsigned char * | photo
 | ) |  |

获取相片原始数据。

说明：
获取内部保存的相片原始数据，此数据需要通过公安部相片解码库解码才能生成相片图像。
参数
[in] | idhandle | 身份证标识符。
[out] | photo | 相片原始数据，请至少分配4096个字节，数据实际长度通过调用 dc_i_d_query_photo_len 来获取。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_photo_len()

unsigned int USER_API dc_i_d_query_photo_len ( HANDLE idhandle )

获取相片原始数据长度。

说明：
获取内部保存的相片原始数据的长度。
参数
[in] idhandle 身份证标识符。
返回
返回的相片原始数据长度。

§ dc_i_d_query_photo_file()

short USER_API dc_i_d_query_photo_file | ( | HANDLE | idhandle,
 |  | const char * | FileName
 | ) |  |

生成相片图像文件。

说明：
使用内部保存的相片原始数据，通过调用公安部相片解码库解码生成相片图像文件。
参数
[in] | idhandle | 身份证标识符。
[in] | FileName | 文件名，请确保有写入的权限。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_photo_bmp_buffer()

short USER_API dc_i_d_query_photo_bmp_buffer | ( | HANDLE | idhandle,
 |  | unsigned char * | BmpBuffer,
 |  | unsigned int * | BmpLength
 | ) |  |

生成相片图像数据。

说明：
使用内部保存的相片原始数据，通过调用公安部相片解码库解码生成相片图像数据。
参数
[in] | idhandle | 身份证标识符。
[out] | BmpBuffer | 返回的相片图像数据，请至少分配65536个字节。
[in,out] | BmpLength | 传入 BmpBuffer 分配的字节数，返回相片图像数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_finger()

unsigned char* USER_API dc_i_d_query_finger ( HANDLE idhandle )

获取指纹原始数据。

说明：
获取内部保存的指纹原始数据。
参数
[in] idhandle 身份证标识符。
返回
返回的指纹原始数据，数据实际长度通过调用 dc_i_d_query_finger_len 来获取。

§ dc_i_d_query_finger_2()

short USER_API dc_i_d_query_finger_2 | ( | HANDLE | idhandle,
 |  | unsigned char * | finger
 | ) |  |

获取指纹原始数据。

说明：
获取内部保存的指纹原始数据。
参数
[in] | idhandle | 身份证标识符。
[out] | finger | 指纹原始数据，请至少分配4096个字节，数据实际长度通过调用 dc_i_d_query_finger_len 来获取。
返回
<0表示失败，==0表示成功。

§ dc_i_d_query_finger_len()

unsigned int USER_API dc_i_d_query_finger_len ( HANDLE idhandle )

获取指纹原始数据长度。

说明：
获取内部保存的指纹原始数据的长度。
参数
[in] idhandle 身份证标识符。
返回
返回的指纹原始数据长度。

§ dc_end_i_d()

void USER_API dc_end_i_d ( HANDLE idhandle )

释放读身份证资源。

说明：
释放 dc_start_i_d dc_start_i_d_2 分配的资源。
参数
[in] idhandle 身份证标识符。

§ dc_getuid_i_d()

short USER_API dc_getuid_i_d | ( | HANDLE | icdev,
 |  | unsigned char * | uid
 | ) |  |

获取身份证UID。

说明：
获取身份证的唯一标识，长度为8个字节。
参数
[in] | icdev | 设备标识符。
[out] | uid | 返回的UID，固定为8个字节。
返回
<0表示失败，==0表示成功。

§ dc_display_2dbarcode()

short USER_API dc_display_2dbarcode | ( | HANDLE | icdev,
 |  | int | point_x,
 |  | int | point_y,
 |  | const char * | info
 | ) |  |

LCD显示二维码。

说明：
在设备LCD显示屏上显示二维码。
参数
[in] | icdev | 设备标识符。
[in] | point_x | X轴偏移点数（0~60）。
[in] | point_y | Y轴偏移点数（0~5）。
[in] | info | 文本字符串。
返回
<0表示失败，==0表示成功。

§ dc_getfingerdata()

short USER_API dc_getfingerdata | ( | HANDLE | icdev,
 |  | int * | length,
 |  | unsigned char * | data
 | ) |  |

读身份证指纹。

说明：
读取身份证中的指纹数据。
参数
[in] | icdev | 设备标识符。
[out] | length | 返回指纹数据的长度，不含'\0'。
[out] | data | 返回的指纹数据，HEX格式字符串。
返回
<0表示失败，==0表示成功。

§ dc_card_status2()

short USER_API dc_card_status2 | ( | HANDLE | icdev,
 |  | unsigned char * | pos
 | ) |  |

检测卡片位置。

说明：
检测卡片在设备中的位置。
参数
[in] icdev 设备标识符。
[out] pos 位置。
0x01 - 卡到开始位。
0x02 - 卡到末位。
0x03 - 卡已锁住。
返回
<0表示失败，==0表示成功，==1表示无卡。

§ dc_card_make_and_lock()

short USER_API dc_card_make_and_lock | ( | HANDLE | icdev,
 |  | unsigned char | flag
 | ) |  |

开卡与锁卡。

说明：
开卡与锁卡。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0x00表示锁卡，0x01表示开卡。
返回
<0表示失败，==0表示成功，==1表示无卡。

§ dc_send_sms()

short USER_API dc_send_sms | ( | HANDLE | icdev,
 |  | const char * | phone_no,
 |  | const char * | sms_content
 | ) |  |

发送短信。

说明：
发送短信给指定号码。
参数
[in] | icdev | 设备标识符。
[in] | phone_no | 号码。
[in] | sms_content | 短信内容。
返回
<0表示失败，==0表示成功。

§ dc_fingerprint_io_control()

short USER_API dc_fingerprint_io_control | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | const unsigned char * | request,
 |  | int | request_len,
 |  | unsigned char * | response,
 |  | int * | response_len
 | ) |  |

指纹模块通讯。

说明：
与指纹模块进行通讯交互。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[in] | request | 发送数据。
[in] | request_len | 发送数据的长度。
[out] | response | 返回的数据。
[out] | response_len | 返回数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_RfGetCardType()

short USER_API dc_RfGetCardType ( HANDLE icdev )

获取非接触卡类型。

说明：
获取感应区中存在的非接触卡类型。
参数
[in] icdev 设备标识符。
返回
<0表示失败。
0x00 - 无卡。
0x11 - Type A CPU Card。
0x13 - Type A Mifare S50。
0x14 - Type A Mifare S70。
0x15 - Type A Mifare Ultralight。
0x21 - Type B CPU Card。
0x22 - Type B 存储卡。

§ dc_get_idsnr()

short USER_API dc_get_idsnr | ( | HANDLE | icdev,
 |  | unsigned char * | _Data
 | ) |  |

获取身份证UID。

说明：
获取身份证的唯一标识，长度为8个字节。
参数
[in] | icdev | 设备标识符。
[out] | _Data | 返回的UID，固定为8个字节。
返回
<0表示失败，==0表示成功。

§ dc_get_idsnr_hex()

short USER_API dc_get_idsnr_hex | ( | HANDLE | icdev,
 |  | char * | _Data
 | ) |  |

获取身份证UID。

说明：
dc_get_idsnr 的HEX形式接口，参数 _Data 为HEX格式。

§ dc_PinpadCommunication()

short USER_API dc_PinpadCommunication | ( | HANDLE | icdev,
 |  | int | time_100ms,
 |  | int | slen,
 |  | const unsigned char * | sdata,
 |  | int * | rlen,
 |  | unsigned char * | rdata
 | ) |  |

密码键盘模块通讯。

说明：
与密码键盘模块进行通讯交互。
参数
[in] | icdev | 设备标识符。
[in] | time_100ms | 设备超时值，单位为100毫秒。
[in] | slen | 发送数据的长度。
[in] | sdata | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | rdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_ReadFlash()

short USER_API dc_ReadFlash | ( | HANDLE | icdev,
 |  | int | offset,
 |  | int | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读Flash。

说明：
读取设备内部Flash中的数据，可以用作数据保存等。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移地址。
[in] | length | 读取长度。
[out] | data_buffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_WriteFlash()

short USER_API dc_WriteFlash | ( | HANDLE | icdev,
 |  | int | offset,
 |  | int | length,
 |  | const unsigned char * | data_buffer
 | ) |  |

写Flash。

说明：
写入数据到设备内部Flash中，可以用作数据保存等。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移地址。
[in] | length | 写入长度。
[in] | data_buffer | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceCardStatus()

short USER_API dc_SelfServiceDeviceCardStatus | ( | HANDLE | icdev,
 |  | unsigned char * | pos
 | ) |  |

检测卡位置状态。

说明：
检测卡片当前的位置状态。
参数
[in] icdev 设备标识符。
[out] pos 位置状态，可为多个以下值按位或在一起。
0x00 - 无卡。
0x01 - 无卡，卡在前门口，处夹卡位置。
0x02 - 无卡，卡在前门口，处不夹卡位置。
0x10 - 有卡，不可操作任何卡。
0x11 - 有卡，可操作磁条。
0x12 - 有卡，可操作接触。
0x14 - 有卡，可操作非接触。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceCardInject()

short USER_API dc_SelfServiceDeviceCardInject | ( | HANDLE | icdev,
 |  | unsigned char | time_s,
 |  | unsigned char | mode
 | ) |  |

进入卡片。

说明：
进入卡片，操作前设备内有卡则错误。
参数
[in] | icdev | 设备标识符。
[in] | time_s | 设备超时值，单位为秒。
[in] mode 模式。
0x00 - 前端进卡，不带磁条。
0x01 - 前端进卡，带磁条。
0x02 - 后端进卡，不带磁条。
0x03 - 后端进卡，带磁条。
返回
<0表示失败。
0 - 操作成功。
1 - 设备内已有卡。
2 - 接收超时。
3 - 读磁卡错误。
4 - 参数设置出错。
5 - 异常卡正常弹出。
6 - 异常卡卡在设备内。

§ dc_SelfServiceDeviceCardEject()

short USER_API dc_SelfServiceDeviceCardEject | ( | HANDLE | icdev,
 |  | unsigned char | time_s,
 |  | unsigned char | mode
 | ) |  |

弹出卡片。

说明：
弹出卡片，操作前设备内无卡则错误。
参数
[in] | icdev | 设备标识符。
[in] | time_s | 设备超时值，单位为秒。
[in] mode 模式。
0x00 - 弹到前端并夹卡。
0x01 - 弹道后端。
0x02 - 弹到前端不夹卡。
返回
<0表示失败。
0 - 操作成功。
1 - 设备内没有卡。
2 - 接收超时。
3 - 参数设置出错。
4 - 卡片已到前门夹卡位置，可操作卡片。
5 - 卡片已到前门不夹卡位置，不可操作卡片。

§ dc_SelfServiceDeviceCardMove()

short USER_API dc_SelfServiceDeviceCardMove | ( | HANDLE | icdev,
 |  | unsigned char | time_s,
 |  | unsigned char | mode
 | ) |  |

移动卡片。

说明：
移动卡片，操作前设备内无卡则错误。
参数
[in] | icdev | 设备标识符。
[in] | time_s | 设备超时值，单位为秒。
[in] mode 模式。
0x00 - 移动到磁条卡操作位置。
0x01 - 移动到接触卡操作位置。
0x02 - 移动到非接触卡操作位置。
返回
<0表示失败。
0 - 操作成功。
1 - 设备内没有卡。
2 - 接收超时。
3 - 参数设置出错。
4 - 卡片已到前门不夹卡位置，不可操作卡片。

§ dc_SelfServiceDeviceSensorStatus()

short USER_API dc_SelfServiceDeviceSensorStatus | ( | HANDLE | icdev,
 |  | unsigned char * | value
 | ) |  |

获取传感器状态。

说明：
获取设备传感器的状态。
参数
[in] icdev 设备标识符。
[out] value 状态值。
bit0 - 电闸门开关传感器，0表示打开，1表示关闭。
bit1 - 压卡传感器，0表示卡已被下压，1表示无卡。
bit2~bit7 - 分别表示从前端到后端的传感器，每个传感器值0表示有卡，值1表示无卡。
返回
<0表示失败，==0表示成功，==1表示掉电无法使用。

§ dc_SelfServiceDeviceConfig()

short USER_API dc_SelfServiceDeviceConfig | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

设置弹卡模式。

说明：
设置弹卡模式。
参数
[in] icdev 设备标识符。
[in] mode 模式。
0x00 - 弹到前端并夹卡。
0x01 - 弹道后端。
0x02 - 弹到前端不夹卡。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceConfigFront()

short USER_API dc_SelfServiceDeviceConfigFront | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

设置前端进卡模式。

说明：
设置前端进卡模式。
参数
[in] icdev 设备标识符。
[in] mode 模式。
0x00 - 前端禁止进卡。
0x01 - 前端磁卡方式进卡。
0x02 - 前端开关方式进卡。
0x03 - 前端磁信号方式进卡。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceConfigBack()

short USER_API dc_SelfServiceDeviceConfigBack | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

设置后端进卡模式。

说明：
设置后端进卡模式。
参数
[in] icdev 设备标识符。
[in] mode 模式。
0x00 - 后端禁止进卡。
0x01 - 后端磁卡方式进卡。
0x02 - 后端非磁卡方式进卡。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceConfigPlace()

short USER_API dc_SelfServiceDeviceConfigPlace | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

设置停卡位置。

说明：
设置停卡位置。
参数
[in] icdev 设备标识符。
[in] mode 模式。
0x00 - 前端不夹卡。
0x01 - 前端夹卡。
0x02 - 接触式IC卡位置。
0x03 - 射频卡位置。
0x04 - 磁卡位置。
0x05 - 弹卡到后端。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceCheckCardType()

short USER_API dc_SelfServiceDeviceCheckCardType ( HANDLE icdev )

检测卡类型。

说明：
设备将自动移动卡片并且检测卡片类型。
参数
[in] icdev 设备标识符。
返回
<0表示失败。
0x00 - 表示无法检测到相应卡片。
0x01 - 表示设备内无卡。
0x11 - 表示Type A CPU Card。
0x13 - 表示Type A Mifare S50。
0x14 - 表示Type A Mifare S70。
0x15 - 表示Type A Mifare Ultralight。
0x21 - 表示Type B CPU Card。
0x22 - 表示Type B 存储卡。
0x31 - 表示接触T=0 CPU Card。
0x32 - 表示接触T=1 CPU Card。
0x41 - 表示4442 Card。
0x42 - 表示4428 Card。

§ dc_SelfServiceDeviceReset()

short USER_API dc_SelfServiceDeviceReset ( HANDLE icdev )

复位自助设备。

说明：
使自助设备进入上电初始状态，并且设置参数为缺省参数。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_MulticardStatus()

short USER_API dc_MulticardStatus | ( | HANDLE | icdev,
 |  | unsigned char * | type
 | ) |  |

检测多卡状态。

说明：
判断是否为多张卡，是否为Type A或Type B卡。
参数
[in] | icdev | 设备标识符。
[out] | type | 卡类型，0x0A表示Type A卡，0x0B表示Type B卡。
返回
<0表示失败，==0表示成功，==1表示无卡，==2表示存在多张卡。

§ dc_pass_key_value2()

short USER_API dc_pass_key_value2 | ( | HANDLE | icdev,
 |  | unsigned char | ctime,
 |  | unsigned char * | rlen,
 |  | unsigned char * | cpass
 | ) |  |

获取多个按键值。

说明：
获取设备键盘的按键值，每次调用可以获取多个按键值。
参数
[in] | icdev | 设备标识符。
[in] | ctime | 设备超时值，单位为秒。
[out] | rlen | 返回按键数据的长度，不含'\0'。
[out] | cpass | 返回的按键数据，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功，==0xA1表示取消输入，==0xA2表示输入超时。

§ dc_ReadOutEeprom()

short USER_API dc_ReadOutEeprom | ( | HANDLE | icdev,
 |  | int | offset,
 |  | int | length,
 |  | unsigned char * | data_buffer
 | ) |  |

读外部EEPROM。

说明：
读取设备外部EEPROM中的数据，可以用作数据保存等。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移地址。
[in] | length | 读取长度。
[out] | data_buffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_WriteOutEeprom()

short USER_API dc_WriteOutEeprom | ( | HANDLE | icdev,
 |  | int | offset,
 |  | int | length,
 |  | const unsigned char * | data_buffer
 | ) |  |

写外部EEPROM。

说明：
写入数据到设备外部EEPROM中，可以用作数据保存等。
参数
[in] | icdev | 设备标识符。
[in] | offset | 偏移地址。
[in] | length | 写入长度。
[in] | data_buffer | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_ReadIdCardInfo()

short USER_API dc_ReadIdCardInfo | ( | HANDLE | icdev,
 |  | int | time_ms,
 |  | int * | rlen,
 |  | unsigned char * | rdata
 | ) |  |

读ID卡。

说明：
读取ID卡数据。
参数
[in] | icdev | 设备标识符。
[in] | time_ms | 设备超时值，单位为毫秒。
[out] | rlen | 返回数据的长度。
[out] | rdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_procommandInt()

short USER_API dc_procommandInt | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | unsigned char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
对感应区CPU卡进行指令交互操作，注意此接口已封装卡协议部分。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
[in] | timeout | 超时值，此值只在部分设备的底层使用，单位为250毫秒，一般调用建议值为7。
返回
<0表示失败，==0表示成功。

§ dc_procommandInt_hex()

short USER_API dc_procommandInt_hex | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | char * | databuffer,
 |  | unsigned char | timeout
 | ) |  |

非接触式CPU卡指令交互。

说明：
dc_procommandInt 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_NfcInit()

short USER_API dc_NfcInit ( HANDLE icdev )

初始化NFC。

说明：
切换射频到NFC点对点模式，操作NFC点对点模式之前必须使用此接口进行初始化。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_NfcActivate()

short USER_API dc_NfcActivate | ( | HANDLE | icdev,
 |  | unsigned char * | atr,
 |  | int * | atr_len
 | ) |  |

激活NFC。

说明：
寻NFC（即激活NFC后自动链接）并返回ATR数据。
参数
[in] | icdev | 设备标识符。
[out] | atr | 返回的数据。
[out] | atr_len | 返回数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_NfcDeactivate()

short USER_API dc_NfcDeactivate ( HANDLE icdev )

断开NFC。

说明：
断开链接并关闭天线，调用此接口必须先激活NFC。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_NfcPush()

short USER_API dc_NfcPush | ( | HANDLE | icdev,
 |  | const unsigned char * | request,
 |  | int | request_len
 | ) |  |

NFC点对点数据透传（推送服务端）。

说明：
推送数据到NFC手机，调用此接口必须先激活NFC。
参数
[in] | icdev | 设备标识符。
[in] | request | 发送数据。
[in] | request_len | 发送数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_NfcService()

short USER_API dc_NfcService | ( | HANDLE | icdev,
 |  | int | flag
 | ) |  |

NFC点对点数据透传（从服务端接收）。

说明：
设置接收模式，开启后将进入准备接收NFC手机数据的模式，调用此接口无须激活NFC。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0表示关闭，1表示开启。
返回
<0表示失败，==0表示成功。

§ dc_NfcFetch()

short USER_API dc_NfcFetch | ( | HANDLE | icdev,
 |  | unsigned char * | response,
 |  | int * | response_len,
 |  | int | time_ms
 | ) |  |

接收NFC手机数据。

说明：
设备进入接收模式后，可以使用此接口来接收NFC手机的数据。
参数
[in] | icdev | 设备标识符。
[out] | response | 返回的数据。
[out] | response_len | 返回数据的长度。
[in] | time_ms | 接口超时值，单位为秒。
返回
<0表示失败，==0表示成功，==1表示手机不在感应区，==2表示数据需要重新传递。

§ dc_NfcDataReceiver()

short USER_API dc_NfcDataReceiver | ( | HANDLE | icdev,
 |  | int | time_ms,
 |  | unsigned char * | flag,
 |  | unsigned char * | response,
 |  | int * | response_len
 | ) |  |

接收NFC手机数据。

说明：
设备进入接收模式后，可以使用此接口来接收NFC手机的数据（CCID类设备使用）。
参数
[in] | icdev | 设备标识符。
[in] | time_ms | 接口超时值，单位为秒。
[out] | flag | 标记，固定为1个字节，0x00表示中间帧，0x01表示起始帧，0x02表示结束帧，0x03表示起始结束帧。
[out] | response | 返回的数据。
[out] | response_len | 返回数据的长度。
返回
<0表示失败，==0表示成功，==1表示手机不在感应区，==2表示数据需要重新传递。

§ dc_NfcSimulateCardConfig()

short USER_API dc_NfcSimulateCardConfig | ( | HANDLE | icdev,
 |  | int | mode
 | ) |  |

NFC点对点数据透传（从服务端接收）。

说明：
设置接收模式，开启后将进入准备接收NFC手机数据的模式，调用此接口无须激活NFC。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0表示关闭，1表示开启。
返回
<0表示失败，==0表示成功。

§ dc_MagFormatConfig()

short USER_API dc_MagFormatConfig | ( | HANDLE | icdev,
 |  | int | mode
 | ) |  |

磁条卡数据自动上传数据模式设置。

说明：
磁条卡数据自动上传数据模式设置。
参数
[in] icdev 设备标识符。
[in] mode 模式。
0 - 输出数据中如果带字母，字母转化为大写字母。
1 - 输出数据是原始数据（默认）。
返回
<0表示失败，==0表示成功。

§ dc_ReadModuleMacAddress()

short USER_API dc_ReadModuleMacAddress | ( | HANDLE | icdev,
 |  | int | type,
 |  | char * | value
 | ) |  |

获取通讯模块MAC地址。

说明：
获取通讯模块MAC地址。
参数
[in] | icdev | 设备标识符。
[in] | type | 模块类型，1表示蓝牙模块，2表示WIFI模块，3表示GPRS/CDMA/全网通等模块。
[out] | value | 返回的MAC地址，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功。

§ dc_WriteModuleMacAddress()

short USER_API dc_WriteModuleMacAddress | ( | HANDLE | icdev,
 |  | int | type,
 |  | const char * | value
 | ) |  |

设置通讯模块MAC地址。

说明：
设置通讯模块MAC地址。
参数
[in] | icdev | 设备标识符。
[in] | type | 模块类型，1表示蓝牙模块，2表示WIFI模块，3表示GPRS/CDMA/全网通等模块。
[in] | value | 传入MAC地址，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功。

§ dc_ReadRfTypeABATS()

short USER_API dc_ReadRfTypeABATS | ( | HANDLE | icdev,
 |  | int * | ats_len,
 |  | unsigned char * | ats
 | ) |  |

读取ATS数据。

说明：
读取Type A、Type B卡的ATS，此接口必须在卡片激活后才可使用。
参数
[in] | icdev | 设备标识符。
[out] | ats_len | 返回ATS数据的长度。
[out] | ats | 返回的ATS数据。
返回
<0表示失败，==0表示成功。

§ dc_ReadRfTypeABATS_hex()

short USER_API dc_ReadRfTypeABATS_hex | ( | HANDLE | icdev,
 |  | int * | ats_len,
 |  | char * | ats
 | ) |  |

读取ATS数据。

说明：
dc_ReadRfTypeABATS 的HEX形式接口，参数 ats 为HEX格式。

§ dc_FlashErase()

short USER_API dc_FlashErase | ( | HANDLE | icdev,
 |  | int | sector
 | ) |  |

Flash扇区擦除。

说明：
擦除Flash扇区中的数据。
参数
[in] | icdev | 设备标识符。
[in] | sector | 扇区地址，0xFFFF表示擦除全部。
返回
<0表示失败，==0表示成功。

§ dc_BuzzerBeep()

short USER_API dc_BuzzerBeep | ( | HANDLE | icdev,
 |  | unsigned short | beep_time_ms,
 |  | unsigned short | interval_time_ms,
 |  | unsigned short | count
 | ) |  |

设备蜂鸣。

说明：
设备蜂鸣器按照指定参数进行蜂鸣，接口本身会直接返回，而不会等待蜂鸣器工作完成。
参数
[in] | icdev | 设备标识符。
[in] | beep_time_ms | 单次蜂鸣时间，单位为毫秒。
[in] | interval_time_ms | 间隔时间，单位为毫秒。
[in] | count | 蜂鸣次数，其中0x0000表示停止，0xFFFF表示无限次。
返回
<0表示失败，==0表示成功。

§ dc_BtModeControl()

short USER_API dc_BtModeControl | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

蓝牙模式设置。

说明：
设置蓝牙模块的通讯模式。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0x00表示串口模式（AT指令集或EEPROM读写），0x01表示蓝牙模式。
返回
<0表示失败，==0表示成功。

§ dc_BtBaudrateControl()

short USER_API dc_BtBaudrateControl | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | unsigned char * | value
 | ) |  |

蓝牙波特率查询/设置。

说明：
查询/设置蓝牙模块的通讯波特率，修改的是蓝牙模块端。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0x00表示查询，0x01表示设置。
[in,out] value 波特率。
0x00 - 9600。
0x01 - 19200。
0x02 - 38400。
0x03 - 57600。
0x04 - 115200。
返回
<0表示失败，==0表示成功。

§ dc_BtPasswordControl()

short USER_API dc_BtPasswordControl | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | char * | value
 | ) |  |

蓝牙连接密码查询/设置。

说明：
查询/设置蓝牙模块的连接密码。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0x00表示查询，0x01表示设置。
[in,out] | value | 密码字符串，查询时请至少分配64个字节。
返回
<0表示失败，==0表示成功。

§ dc_BtAddressControl()

short USER_API dc_BtAddressControl | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | unsigned char * | length,
 |  | unsigned char * | value
 | ) |  |

蓝牙模块地址查询/设置。

说明：
查询/设置蓝牙模块的地址。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0x00表示查询，0x01表示设置。
[in,out] | length | 地址的长度。
[in,out] | value | 地址，查询时请至少分配64个字节。
返回
<0表示失败，==0表示成功。

§ dc_BtNameControl()

short USER_API dc_BtNameControl | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | char * | value
 | ) |  |

蓝牙模块名称查询/设置。

说明：
查询/设置蓝牙模块的名称。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0x00表示查询，0x01表示设置。
[in,out] | value | 名称字符串，查询时请至少分配64个字节。
返回
<0表示失败，==0表示成功。

§ dc_BtUserControl()

short USER_API dc_BtUserControl | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | int | offset,
 |  | int | length,
 |  | unsigned char * | value
 | ) |  |

蓝牙用户自定义的配置命令。

说明：
采用读写EEPROM方式进行蓝牙模块的自定义配置。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0x00表示读EEPROM，0x01表示写EEPROM或AT指令集模式。
[in] | offset | 偏移地址。
[in] | length | 数据的长度。
[in,out] | value | 数据。
返回
<0表示失败，==0表示成功。

§ dc_BtReset()

short USER_API dc_BtReset ( HANDLE icdev )

蓝牙软件复位。

说明：
对蓝牙模块进行软件复位。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_BtCommunicationTest()

short USER_API dc_BtCommunicationTest | ( | HANDLE | icdev,
 |  | int | length,
 |  | const unsigned char * | value
 | ) |  |

蓝牙模块通讯测试。

说明：
蓝牙模块在蓝牙通讯模式下，用此接口可以测试蓝牙通讯是否通畅，数据发送成功后，监测相关串口是否有接收到该数据来判断通讯是否成功。
参数
[in] | icdev | 设备标识符。
[in] | length | 发送数据的长度。
[in] | value | 发送数据。
返回
<0表示失败，==0表示成功。

§ dc_BtWithReaderBaudrateControl()

short USER_API dc_BtWithReaderBaudrateControl | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | unsigned char * | value
 | ) |  |

蓝牙波特率查询/设置。

说明：
查询/设置与蓝牙模块之间的通讯波特率，修改的是设备端。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0x00表示查询，0x01表示设置。
[in,out] value 波特率。
0x00 - 2400。
0x01 - 4800。
0x02 - 9600。
0x03 - 14400。
0x04 - 38400。
0x05 - 57600。
0x06 - 115200。
0x07 - 256000。
返回
<0表示失败，==0表示成功。

§ dc_BtCommand()

short USER_API dc_BtCommand | ( | HANDLE | icdev,
 |  | int | slen,
 |  | const unsigned char * | sdata,
 |  | int * | rlen,
 |  | unsigned char * | rdata
 | ) |  |

蓝牙模块通讯。

说明：
与蓝牙模块进行通讯交互。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sdata | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | rdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_BtSignalStrength()

short USER_API dc_BtSignalStrength | ( | HANDLE | icdev,
 |  | unsigned char * | state,
 |  | short * | value
 | ) |  |

获取蓝牙信号强度。

说明：
获取蓝牙信号强度。
参数
[in] | icdev | 设备标识符。
[out] | state | 状态，0x00表示蓝牙未连接，0x01表示蓝牙已连接。
[out] | value | 信号值。
返回
<0表示失败，==0表示成功。

§ dc_BtDataResponse()

short USER_API dc_BtDataResponse | ( | HANDLE | icdev,
 |  | int * | length,
 |  | unsigned char * | value
 | ) |  |

获取蓝牙响应。

说明：
获取蓝牙模块当前执行命令的响应或数据。
参数
[in] | icdev | 设备标识符。
[out] | length | 返回数据的长度。
[out] | value | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_BtDataTransmit()

short USER_API dc_BtDataTransmit | ( | HANDLE | icdev,
 |  | int | slen,
 |  | const unsigned char * | sdata,
 |  | int * | rlen,
 |  | unsigned char * | rdata
 | ) |  |

蓝牙数据透传。

说明：
此接口用于将从蓝牙接收到的数据透传到外设中，并返回从外设接收的数据。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sdata | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | rdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_SamAControl()

short USER_API dc_SamAControl | ( | HANDLE | icdev,
 |  | int | code,
 |  | int | slen,
 |  | const unsigned char * | sdata,
 |  | int * | rlen,
 |  | unsigned char * | rdata
 | ) |  |

SAM_A模块指令交互。

说明：
此接口用于操作居民身份证验证安全控制模块。
参数
[in] | icdev | 设备标识符。
[in] code 指令代码。
0x10FF - 复位SAM_A，无发送数据，无返回数据。
0x11FF - SAM_A状态检测，无发送数据，无返回数据。
0x12FF - 读SAM_A管理信息，无发送数据，返回数据为16个字节的SAM_A编号。
0x2001 - 寻找居民身份证，无发送数据，返回数据为4个字节的0x00。
0x2002 - 选取居民身份证，无发送数据，返回数据为8个字节的0x00。
0x3001 - 读机读文字信息和相片信息，无发送数据，返回数据格式为：【2个字节文字信息长度（Big-Endian）】【2个字节相片信息长度（Big-Endian）】【文字信息（不大于256个字节）】【相片信息（不大于1024个字节）】。
0x3010 - 读机读文字信息、相片信息和指纹信息，无发送数据，返回数据格式为：【2个字节文字信息长度（Big-Endian）】【2个字节相片信息长度（Big-Endian）】【2个字节指纹信息长度（Big-Endian）】【文字信息（不大于256个字节）】【相片信息（不大于1024个字节）】【指纹信息（不大于1024个字节）】。
0x3003 - 读追加住址信息，无发送数据，返回数据为70个字节的追加住址信息。
0x6000 - 设置UART接口速率，速率为115200bps，无发送数据，无返回数据。
0x6001 - 设置UART接口速率，速率为57600bps，无发送数据，无返回数据。
0x6002 - 设置UART接口速率，速率为38400bps，无发送数据，无返回数据。
0x6003 - 设置UART接口速率，速率为19200bps，无发送数据，无返回数据。
0x6004 - 设置UART接口速率，速率为9600bps，无发送数据，无返回数据。
0x61FF - 设置SAM_A与射频模块一帧通信数据的最大字节数，发送数据为1个字节的最大字节数，取值返回为0x18~0xFF，默认值为0x58，无返回数据。
[in] | slen | 发送数据的长度。
[in] | sdata | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | rdata | 返回的数据，请至少分配4096个字节。
返回
<0表示失败，==0表示成功。

§ dc_SamAReadCardInfo()

short USER_API dc_SamAReadCardInfo | ( | HANDLE | icdev,
 |  | int | type,
 |  | int * | text_len,
 |  | unsigned char * | text,
 |  | int * | photo_len,
 |  | unsigned char * | photo,
 |  | int * | fingerprint_len,
 |  | unsigned char * | fingerprint,
 |  | int * | extra_len,
 |  | unsigned char * | extra
 | ) |  |

读身份证。

说明：
读取身份证的原始信息数据。
参数
[in] | icdev | 设备标识符。
[in] type 类型。
1 - 读取文字信息、相片信息和指纹信息。
2 - 读取追加住址信息。
3 - 读取文字信息、相片信息、指纹信息和追加住址信息。
[out] | text_len | 返回文字信息的长度。
[out] | text | 返回的文字信息，请至少分配256个字节。
[out] | photo_len | 返回相片信息的长度。
[out] | photo | 返回的相片信息，请至少分配1024个字节。
[out] | fingerprint_len | 返回指纹信息的长度。
[out] | fingerprint | 返回的指纹信息，请至少分配1024个字节。
[out] | extra_len | 返回追加住址信息的长度。
[out] | extra | 返回的追加住址信息，请至少分配70个字节。
返回
<0表示失败，==0表示成功。

§ dc_ParseTextInfo()

short USER_API dc_ParseTextInfo | ( | HANDLE | icdev,
 |  | int | charset,
 |  | int | info_len,
 |  | const unsigned char * | info,
 |  | unsigned char * | name,
 |  | unsigned char * | sex,
 |  | unsigned char * | nation,
 |  | unsigned char * | birth_day,
 |  | unsigned char * | address,
 |  | unsigned char * | id_number,
 |  | unsigned char * | department,
 |  | unsigned char * | expire_start_day,
 |  | unsigned char * | expire_end_day,
 |  | unsigned char * | reserved
 | ) |  |

解析文字信息。

说明：
解析中国人居民身份证文字信息，获取相应的条目。
参数
[in] | icdev | 设备标识符。
[in] | charset | 获取条目将采用的字符集，0表示GBK，1表示UCS-2。
[in] | info_len | 文字信息的长度。
[in] | info | 文字信息。
[out] | name | 姓名，请至少分配64个字节。
[out] | sex | 性别，请至少分配8个字节。
[out] | nation | 民族，请至少分配12个字节。
[out] | birth_day | 出生日期，请至少分配36个字节。
[out] | address | 住址，请至少分配144个字节。
[out] | id_number | 公民身份号码，请至少分配76个字节。
[out] | department | 签发机关，请至少分配64个字节。
[out] | expire_start_day | 证件签发日期，请至少分配36个字节。
[out] | expire_end_day | 证件终止日期，请至少分配36个字节。
[out] | reserved | 预留项，请至少分配76个字节。
返回
<0表示失败，==0表示成功。

§ dc_ParseTextInfoForForeigner()

short USER_API dc_ParseTextInfoForForeigner | ( | HANDLE | icdev,
 |  | int | charset,
 |  | int | info_len,
 |  | const unsigned char * | info,
 |  | unsigned char * | english_name,
 |  | unsigned char * | sex,
 |  | unsigned char * | id_number,
 |  | unsigned char * | citizenship,
 |  | unsigned char * | chinese_name,
 |  | unsigned char * | expire_start_day,
 |  | unsigned char * | expire_end_day,
 |  | unsigned char * | birth_day,
 |  | unsigned char * | version_number,
 |  | unsigned char * | department_code,
 |  | unsigned char * | type_sign,
 |  | unsigned char * | reserved
 | ) |  |

解析文字信息。

说明：
解析外国人永久居留证文字信息，获取相应的条目。
参数
[in] | icdev | 设备标识符。
[in] | charset | 获取条目将采用的字符集，0表示GBK，1表示UCS-2。
[in] | info_len | 文字信息的长度。
[in] | info | 文字信息。
[out] | english_name | 英文姓名，请至少分配244个字节。
[out] | sex | 性别，请至少分配8个字节。
[out] | id_number | 永久居留证号码，请至少分配64个字节。
[out] | citizenship | 国籍或所在地区代码，请至少分配16个字节。
[out] | chinese_name | 中文姓名，请至少分配64个字节。
[out] | expire_start_day | 证件签发日期，请至少分配36个字节。
[out] | expire_end_day | 证件终止日期，请至少分配36个字节。
[out] | birth_day | 出生日期，请至少分配36个字节。
[out] | version_number | 证件版本号，请至少分配12个字节。
[out] | department_code | 当次申请受理机关代码，请至少分配20个字节。
[out] | type_sign | 证件类型标识，请至少分配8个字节。
[out] | reserved | 预留项，请至少分配16个字节。
返回
<0表示失败，==0表示成功。

§ dc_ParseTextInfoForHkMoTw()

short USER_API dc_ParseTextInfoForHkMoTw | ( | HANDLE | icdev,
 |  | int | charset,
 |  | int | info_len,
 |  | const unsigned char * | info,
 |  | unsigned char * | name,
 |  | unsigned char * | sex,
 |  | unsigned char * | reserved,
 |  | unsigned char * | birth_day,
 |  | unsigned char * | address,
 |  | unsigned char * | id_number,
 |  | unsigned char * | department,
 |  | unsigned char * | expire_start_day,
 |  | unsigned char * | expire_end_day,
 |  | unsigned char * | pass_number,
 |  | unsigned char * | sign_count,
 |  | unsigned char * | reserved2,
 |  | unsigned char * | type_sign,
 |  | unsigned char * | reserved3
 | ) |  |

解析文字信息。

说明：
解析港澳台居民居住证文字信息，获取相应的条目。
参数
[in] | icdev | 设备标识符。
[in] | charset | 获取条目将采用的字符集，0表示GBK，1表示UCS-2。
[in] | info_len | 文字信息的长度。
[in] | info | 文字信息。
[out] | name | 姓名，请至少分配64个字节。
[out] | sex | 性别，请至少分配8个字节。
[out] | reserved | 预留项，请至少分配12个字节。
[out] | birth_day | 出生日期，请至少分配36个字节。
[out] | address | 住址，请至少分配144个字节。
[out] | id_number | 公民身份号码，请至少分配76个字节。
[out] | department | 签发机关，请至少分配64个字节。
[out] | expire_start_day | 证件签发日期，请至少分配36个字节。
[out] | expire_end_day | 证件终止日期，请至少分配36个字节。
[out] | pass_number | 通行证号码，请至少分配40个字节。
[out] | sign_count | 签发次数，请至少分配12个字节。
[out] | reserved2 | 预留项，请至少分配16个字节。
[out] | type_sign | 证件类型标识，请至少分配8个字节。
[out] | reserved3 | 预留项，请至少分配16个字节。
返回
<0表示失败，==0表示成功。

§ dc_ParsePhotoInfo()

short USER_API dc_ParsePhotoInfo | ( | HANDLE | icdev,
 |  | int | type,
 |  | int | info_len,
 |  | const unsigned char * | info,
 |  | int * | photo_len,
 |  | unsigned char * | photo
 | ) |  |

解析相片信息。

说明：
解析相片信息，通过公安部相片解码库还原相片图像数据。
参数
[in] | icdev | 设备标识符。
[in] | type | 相片图像数据的格式，0表示BMP文件，1表示BMP缓存，2表示BMP Base64字符串。
[in] | info_len | 相片信息的长度。
[in] | info | 相片信息。
[in,out] photo_len 数据的长度。
BMP文件 - 无效。
BMP缓存 - 传入 photo 分配的字节数，返回相片图像数据的长度。
BMP Base64字符串 - 传入 photo 分配的字节数，返回相片图像数据Base64字符串的长度，不含'\0'。
[in,out] photo 数据。
BMP文件 - 传入文件名，请确保有写入的权限。
BMP缓存 - 返回的相片图像数据，请至少分配65536个字节。
BMP Base64字符串 - 返回的相片图像数据Base64字符串，请至少分配65536个字节。
返回
<0表示失败，==0表示成功。

§ dc_ParseOtherInfo()

short USER_API dc_ParseOtherInfo | ( | HANDLE | icdev,
 |  | int | flag,
 |  | const unsigned char * | in_info,
 |  | unsigned char * | out_info
 | ) |  |

解析其它信息。

说明：
解析其它信息。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标志，0表示性别，1表示民族，2表示国籍。
[in] | in_info | 传入信息。
[out] | out_info | 返回的信息。
返回
<0表示失败，==0表示成功。

§ dc_CpuCardStatus()

short USER_API dc_CpuCardStatus ( HANDLE icdev )

检测接触式CPU卡。

说明：
检测当前卡座中CPU卡的状态。
参数
[in] icdev 设备标识符。
返回
<0表示失败。
0 - 状态未知。
1 - 无卡。
2 - 有卡，但卡类型未知。
3 - 有卡，卡未上电。
4 - 有卡，卡已上电。

§ dc_WakeDevice()

short USER_API dc_WakeDevice ( HANDLE icdev )

唤醒设备。

说明：
唤醒设备，此接口用于向设备发出唤醒请求，成功则表示设备已经唤醒。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_RestDevice()

short USER_API dc_RestDevice ( HANDLE icdev )

休眠设备。

说明：
休眠设备，此接口用于向设备发出休眠请求，执行成功仅仅表示成功发出休眠请求，并不表示设备已经进入休眠状态。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_GetBatteryValue()

short USER_API dc_GetBatteryValue | ( | HANDLE | icdev,
 |  | unsigned char * | value
 | ) |  |

获取电池电量。

说明：
获取电池电量。
参数
[in] | icdev | 设备标识符。
[out] | value | 电池百分比（0x00~0x64），0x00表示0，0x64表示100。
返回
<0表示失败，==0表示成功。

§ dc_anticoll_mode()

short USER_API dc_anticoll_mode | ( | HANDLE | icdev,
 |  | unsigned char | mode,
 |  | unsigned char | _Bcnt,
 |  | unsigned int * | _Snr
 | ) |  |

防卡冲突。

说明：
支持ISO 14443 Type A类型卡片的防卡冲突。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0x93表示一级，0x95表示二级，0x97表示三级。
[in] | _Bcnt | 保留，固定为0x00。
[out] | _Snr | 返回的卡序列号。
返回
<0表示失败，==0表示成功。

§ dc_select_mode()

short USER_API dc_select_mode | ( | HANDLE | icdev,
 |  | unsigned char | mode,
 |  | unsigned int | _Snr,
 |  | unsigned char * | _Size
 | ) |  |

选卡操作。

说明：
通过指定序列号，选取相应的卡片。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0x93表示一级，0x95表示二级，0x97表示三级。
[in] | _Snr | 卡片序列号。
[out] | _Size | 返回的SAK值。
返回
<0表示失败，==0表示成功。

§ dc_attribInt()

short USER_API dc_attribInt | ( | HANDLE | icdev,
 |  | unsigned char * | PUPI,
 |  | unsigned char | CID
 | ) |  |

激活卡片。

说明：
支持ISO 14443 Type B类型卡片的激活。
参数
[in] | icdev | 设备标识符。
[in] | PUPI | 伪唯一PICC标识符。
[in] | CID | 信道号。
返回
<0表示失败，==0表示成功。

§ dc_rf_poweron()

short USER_API dc_rf_poweron | ( | HANDLE | icdev,
 |  | unsigned char | icc_slot_no,
 |  | unsigned char * | response
 | ) |  |

卡上电。

说明：
对指定卡座的卡片进行上电操作。
参数
[in] | icdev | 设备标识符。
[in] | icc_slot_no | 卡座编号，用户卡为0x0n，SAM卡为0x1n，其中“n”的取值范围为1~F。
[out] | response | 返回的复位信息，请至少分配128个字节。
返回
<0表示失败，否则为返回复位信息的长度。
-1 - 卡片类型不对。
-2 - 无卡。
-3 - 有卡未上电。
-4 - 卡片无应答。

§ dc_rf_poweroff()

short USER_API dc_rf_poweroff | ( | HANDLE | icdev,
 |  | unsigned char | icc_slot_no
 | ) |  |

卡下电。

说明：
对指定卡座的卡片进行下电操作。
参数
[in] | icdev | 设备标识符。
[in] | icc_slot_no | 卡座编号，用户卡为0x0n，SAM卡为0x1n，其中“n”的取值范围为1~F。
返回
<0表示失败，==0表示成功。
-1 - 卡片类型不对。
-2 - 无卡。
-3 - 有卡未上电。
-4 - 卡片无应答。

§ dc_rf_getstatus()

short USER_API dc_rf_getstatus | ( | HANDLE | icdev,
 |  | unsigned char | icc_slot_no
 | ) |  |

获取卡状态。

说明：
获取指定卡座的卡片状态。
参数
[in] | icdev | 设备标识符。
[in] | icc_slot_no | 卡座编号，用户卡为0x0n，SAM卡为0x1n，其中“n”的取值范围为1~F。
返回
<0表示失败，==0表示有卡且已上电。
-1 - 卡片类型不对。
-2 - 无卡。
-3 - 有卡未上电。
-4 - 卡片无应答。

§ dc_rf_application()

short USER_API dc_rf_application | ( | HANDLE | icdev,
 |  | unsigned char | icc_slot_no,
 |  | int | length_of_command_apdu,
 |  | unsigned char * | command_apdu,
 |  | unsigned char * | response_apdu
 | ) |  |

卡指令交互。

说明：
对指定卡座的卡片进行指令交互操作。
参数
[in] | icdev | 设备标识符。
[in] | icc_slot_no | 卡座编号，用户卡为0x0n，SAM卡为0x1n，其中“n”的取值范围为1~F。
[in] | length_of_command_apdu | 发送数据的长度。
[in] | command_apdu | 发送数据的长度。
[in] | length_of_command_apdu | 发送数据。
[out] | response_apdu | 返回的数据。
返回
<0表示失败，否则为返回数据的长度。
-1 - 卡片类型不对。
-2 - 无卡。
-3 - 有卡未上电。
-4 - 卡片无应答。

§ dc_RequestMultiCard()

short USER_API dc_RequestMultiCard | ( | HANDLE | icdev,
 |  | unsigned char * | uid_data
 | ) |  |

获取多张Type A卡UID。

说明：
获取多张Type A卡UID。
参数
[in] | icdev | 设备标识符。
[out] | uid_data | 返回的数据，请至少分配256个字节。格式为：【1字节UID条目数量】【1字节UID长度】【UID】【1字节UID2长度】【UID2】...。
返回
<0表示失败，==0表示成功。

§ dc_ActivateCard()

short USER_API dc_ActivateCard | ( | HANDLE | icdev,
 |  | unsigned char | uid_len,
 |  | const unsigned char * | uid
 | ) |  |

选择一张Type A卡并激活。

说明：
选择一张Type A卡并激活。
参数
[in] | icdev | 设备标识符。
[in] | uid_len | 传入UID的长度。
[in] | uid | 传入UID。
返回
<0表示失败，==0表示成功。

§ dc_GetLastResponseCode()

short USER_API dc_GetLastResponseCode | ( | HANDLE | icdev,
 |  | unsigned int * | code
 | ) |  |

获取最后响应码。

说明：
获取最后一次和设备交互时设备返回的响应状态代码，此接口获取的响应码依赖设备内部固件代码的实现，不同的设备可能有不一致的响应码。
参数
[in] | icdev | 设备标识符。
[out] | code | 返回的响应码。
返回
<0表示失败，==0表示成功。

§ dc_MultiFlashErase()

short USER_API dc_MultiFlashErase | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | unsigned int | sector
 | ) |  |

多个Flash扇区擦除。

说明：
擦除指定Flash扇区中的数据。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0x00表示核心板上的Flash，0x01表示主Spi的Flash，0x02表示备份Spi的Flash，0x03表示语音存储的Flash，0x04表示字库存储的Flash。
[in] | sector | 扇区地址，0xFFFFFFFF表示擦除全部。
返回
<0表示失败，==0表示成功。

§ dc_MultiFlashRead()

short USER_API dc_MultiFlashRead | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | unsigned int | offset_h,
 |  | unsigned int | offset_l,
 |  | unsigned int | length_h,
 |  | unsigned int | length_l,
 |  | unsigned char * | data_buffer
 | ) |  |

多个Flash读数据。

说明：
读取指定Flash中的数据。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0x00表示核心板上的Flash，0x01表示主Spi的Flash，0x02表示备份Spi的Flash，0x03表示语音存储的Flash，0x04表示字库存储的Flash。
[in] | offset_h | 偏移地址（高位）。
[in] | offset_l | 偏移地址（低位）。
[in] | length_h | 读取长度（高位）。
[in] | length_l | 读取长度（低位）。
[out] | data_buffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_MultiFlashWrite()

short USER_API dc_MultiFlashWrite | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | unsigned int | offset_h,
 |  | unsigned int | offset_l,
 |  | unsigned int | length_h,
 |  | unsigned int | length_l,
 |  | const unsigned char * | data_buffer
 | ) |  |

多个Flash写数据。

说明：
写入数据到指定Flash中。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0x00表示核心板上的Flash，0x01表示主Spi的Flash，0x02表示备份Spi的Flash，0x03表示语音存储的Flash，0x04表示字库存储的Flash。
[in] | offset_h | 偏移地址（高位）。
[in] | offset_l | 偏移地址（低位）。
[in] | length_h | 读取长度（高位）。
[in] | length_l | 读取长度（低位）。
[in] | data_buffer | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_MultiFlashGetSize()

short USER_API dc_MultiFlashGetSize | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | unsigned int * | length_h,
 |  | unsigned int * | length_l
 | ) |  |

多个FLASH容量大小获取。

说明：
获取指定Flash的容量大小。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0x00表示核心板上的Flash，0x01表示主Spi的Flash，0x02表示备份Spi的Flash，0x03表示语音存储的Flash，0x04表示字库存储的Flash。
[out] | length_h | 返回的长度（高位）。
[out] | length_l | 返回的长度（低位）。
返回
<0表示失败，==0表示成功。

§ dc_RfMultiRequest()

short USER_API dc_RfMultiRequest ( HANDLE icdev )

多重寻卡。

说明：
有卡寻卡、无卡寻卡、多卡防冲突。
参数
[in] icdev 设备标识符。
返回
<0表示失败。
0 - 操作成功。
1 - 未检测到射频卡。
2 - 检测到身份证。
3 - 多卡报错。
4 - 其它射频卡。
5 - 检测到Type A / Type B CPU卡。
6 - 检测到有卡后的卡片还在感应区。

§ dc_TtsVoicePlay()

short USER_API dc_TtsVoicePlay | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | const unsigned char * | content,
 |  | int | content_len
 | ) |  |

TTS语音播放。

说明：
TTS语音播放。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0x00表示停止播放，0x01表示播放内容为UCS2编码，0x02表示播放内容为GBK编码。
[in] | content | 播放内容。
[in] | content_len | 播放内容的长度。
返回
<0表示失败，==0表示成功。

§ dc_TtsVoiceConfig()

short USER_API dc_TtsVoiceConfig | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | unsigned char | value
 | ) |  |

TTS语音设置。

说明：
TTS语音设置。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0x01表示设置语速，0x02表示设置音量，0x03表示设置音色。
[in] | value | 增益值（0x00~0xFF），正常为0x80。
返回
<0表示失败，==0表示成功。

§ dc_Config2DBarcode()

short USER_API dc_Config2DBarcode | ( | HANDLE | icdev,
 |  | const unsigned char * | content,
 |  | int | content_len
 | ) |  |

配置二维码工作模式。

说明：
配置二维码工作模式。
参数
[in] | icdev | 设备标识符。
[in] | content | 配置内容。
[in] | content_len | 配置内容的长度。
返回
<0表示失败，==0表示成功。

§ dc_Scan2DBarcode()

short USER_API dc_Scan2DBarcode | ( | HANDLE | icdev,
 |  | unsigned short | time_ms,
 |  | char * | message_data
 | ) |  |

扫描二维码。

说明：
扫描二维码。
参数
[in] | icdev | 设备标识符。
[in] | time_ms | 设备超时值，单位为毫秒。
[out] | message_data | 二维码，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功。

§ dc_KeypadOpen()

short USER_API dc_KeypadOpen | ( | HANDLE | icdev,
 |  | int | number,
 |  | char * | version
 | ) |  |

打开密码键盘。

说明：
打开密码键盘并且分配相关资源。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
[out] | version | 返回的版本字符串，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_KeypadClose()

short USER_API dc_KeypadClose | ( | HANDLE | icdev,
 |  | int | number
 | ) |  |

关闭密码键盘。

说明：
关闭密码键盘并且释放相关资源。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
返回
<0表示失败，==0表示成功。

§ dc_KeypadLoadKey()

short USER_API dc_KeypadLoadKey | ( | HANDLE | icdev,
 |  | int | number,
 |  | int | set_index,
 |  | int | sub_index,
 |  | int | type,
 |  | int | mode,
 |  | const unsigned char * | key_data,
 |  | int | key_len,
 |  | int | flag,
 |  | unsigned char * | ex_data,
 |  | int * | ex_len
 | ) |  |

装载密钥。

说明：
装载密钥到密码键盘中永久保存。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
[in] | set_index | 密钥套索引（0~15）。
[in] | sub_index | 密钥索引（0~15），其中0表示主密钥。
[in] | type | 密钥类型，0表示单DES，1表示三DES，2表示24字节三DES，16表示SM4。
[in] | mode | 装载模式，0表示明文装载，1表示密文装载。
[in] | key_data | 密钥数据。
[in] | key_len | 密钥数据的长度。
[in] | flag | 标志，0表示不验证，1表示验证类别1，2表示验证类别2。
[in,out] ex_data 附加数据，含义由 flag 的值来决定。
flag为1 - ex_data为out形式的参数，返回加密全0x00后的数据。
flag为2 - ex_data为In形式的参数，传入加密全0x00后的数据。
[in,out] ex_len 附加数据的长度，含义由 flag 的值来决定。
flag为1 - ex_len为Out形式的参数，返回 ex_data 的长度。
flag为2 - ex_len为In形式的参数，传入 ex_data 的长度。
返回
<0表示失败，==0表示成功。

§ dc_KeypadClearKey()

short USER_API dc_KeypadClearKey | ( | HANDLE | icdev,
 |  | int | number,
 |  | int | set_index,
 |  | int | sub_index
 | ) |  |

清除密钥。

说明：
清除密码键盘中指定的密钥。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
[in] | set_index | 密钥套索引（0~15），-1表示全部密钥套。
[in] | sub_index | 密钥索引（0~15），其中0表示主密钥，-1表示全部密钥。
返回
<0表示失败，==0表示成功。

§ dc_KeypadGetKeyType()

short USER_API dc_KeypadGetKeyType | ( | HANDLE | icdev,
 |  | int | number,
 |  | int | set_index,
 |  | int | sub_index,
 |  | int * | type
 | ) |  |

获取密钥类型。

说明：
获取密码键盘中指定密钥的类型。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
[in] | set_index | 密钥套索引（0~15）。
[in] | sub_index | 密钥索引（0~15），其中0表示主密钥。
[out] | type | 密钥类型，0表示单DES，1表示三DES，2表示24字节三DES，16表示SM4。
返回
<0表示失败，==0表示成功。

§ dc_KeypadAlgorithm()

short USER_API dc_KeypadAlgorithm | ( | HANDLE | icdev,
 |  | int | number,
 |  | int | set_index,
 |  | int | sub_index,
 |  | int | flag,
 |  | int | mode,
 |  | const unsigned char * | in_data,
 |  | int | in_len,
 |  | unsigned char * | out_data,
 |  | int * | out_len
 | ) |  |

数据加解密。

说明：
使用密码键盘中装载的密钥进行数据加解密操作。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
[in] | set_index | 密钥套索引（0~15）。
[in] | sub_index | 密钥索引（0~15），其中0表示主密钥。
[in] | flag | 标志，0表示使用密钥默认算法，1表示使用密钥0~7字节算单DES，2表示使用密钥8~15字节算单DES，3表示使用密钥16~23字节算单DES。
[in] | mode | 模式，0表示加密，1表示解密。
[in] | in_data | 输入数据。
[in] | in_len | 输入数据的长度。
[out] | out_data | 输出数据。
[out] | out_len | 输出数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_KeypadStartInput()

short USER_API dc_KeypadStartInput | ( | HANDLE | icdev,
 |  | int | number,
 |  | int | mode,
 |  | int | set_index,
 |  | int | sub_index,
 |  | const unsigned char * | in_data,
 |  | int | in_len,
 |  | int | min_len,
 |  | int | max_len,
 |  | int | auto_end,
 |  | int | enable_beep,
 |  | int | time_s,
 |  | unsigned char * | out_data,
 |  | int * | out_len
 | ) |  |

启动按键输入。

说明：
启动密码键盘的按键输入，这时设备将开始接收用户的按键输入操作。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
[in] | mode | 模式，0表示获取明文，1表示获取ANSI X9.8 PIN BLOCK加密的按键数据，2表示获取IBM3624加密的按键数据，3表示获取ANSII加密的按键数据。
[in] | set_index | 密钥套索引（0~15），明文模式内部将忽略它的传入。
[in] | sub_index | 密钥索引（0~15），其中0表示主密钥，明文模式内部将忽略它的传入。
[in] | in_data | 输入数据，依赖于模式，明文模式内部将忽略它的传入，密文模式为卡号，固定为12个字节。
[in] | in_len | 输入数据的长度。
[in] | min_len | 最小长度。
[in] | max_len | 最大长度。
[in] | auto_end | 按键时结束控制（此处的结束表示的仅仅是设备是否会自动加入【确认】键值），0表示不自动结束，1表示自动结束。
[in] | enable_beep | 按键时蜂鸣声控制，0表示不使用蜂鸣，1表示使用蜂鸣。
[in] | time_s | 从开始按键后，两次按键之间的时间间隔超时值，单位为秒，其中-1表示不使用时间间隔超时值，0表示缺省值（由设备实现决定）。
[out] | out_data | 输出数据。
[out] | out_len | 输出数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_KeypadGetKeyValue()

short USER_API dc_KeypadGetKeyValue | ( | HANDLE | icdev,
 |  | int | number,
 |  | unsigned char * | value
 | ) |  |

获取键值。

说明：
获取一个按下的按键值，每次只能获取一个。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
[out] | value | 明文输入模式下数值键为键值的ASCII值，如键盘1为0x31；密文输入模式下数值键为0x2A；任何输入模式下控制键的键值一致，【退格】为0x08，【确认】为0x0D，【取消】为0x1B，【清除】为0x7F；另外没有按键按下为0xFF，输入超时为0x80。
返回
<0表示失败，==0表示成功。

§ dc_KeypadExitAndGetInput()

short USER_API dc_KeypadExitAndGetInput | ( | HANDLE | icdev,
 |  | int | number,
 |  | int | mode,
 |  | unsigned char * | out_data,
 |  | int * | out_len
 | ) |  |

退出并且获取密码数据。

说明：
退出并且获取密码键盘的密码数据，这时设备将停止接收用户的按键输入操作。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
[in] | mode | 模式，0表示仅退出，1表示退出并且获取数据。
[out] | out_data | 输出数据。
[out] | out_len | 输出数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_KeypadSetKeyValue()

short USER_API dc_KeypadSetKeyValue | ( | HANDLE | icdev,
 |  | int | number,
 |  | unsigned char | value
 | ) |  |

设置键值。

说明：
设置一个按下的按键值，每次只能设置一个。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，0表示内置密码键盘，1表示外置密码键盘。
[in] | value | 数值键为键值的ASCII值，如键盘1为0x31；控制键【退格】为0x08，【确认】为0x0D，【取消】为0x1B，【清除】为0x7F。
返回
<0表示失败，==0表示成功。

§ dc_GetDeviceUid()

short USER_API dc_GetDeviceUid | ( | HANDLE | icdev,
 |  | char * | uid
 | ) |  |

获取设备唯一识别码。

说明：
获取设备内部写入的唯一识别码。
参数
[in] | icdev | 设备标识符。
[out] | uid | 返回的唯一识别码字符串，请至少分配33个字节。
返回
<0表示失败，==0表示成功。

§ dc_GetDeviceTradeNumber()

short USER_API dc_GetDeviceTradeNumber | ( | HANDLE | icdev,
 |  | char * | number
 | ) |  |

获取设备商户号。

说明：
获取设备内部写入的商户号。
参数
[in] | icdev | 设备标识符。
[out] | number | 返回的商户号字符串，请至少分配33个字节。
返回
<0表示失败，==0表示成功。

§ dc_GetDeviceTerminalNumber()

short USER_API dc_GetDeviceTerminalNumber | ( | HANDLE | icdev,
 |  | char * | number
 | ) |  |

获取设备终端号。

说明：
获取设备内部写入的终端号。
参数
[in] | icdev | 设备标识符。
[out] | number | 返回的终端号字符串，请至少分配33个字节。
返回
<0表示失败，==0表示成功。

§ dc_ReadDeviceCustomInfo()

short USER_API dc_ReadDeviceCustomInfo | ( | HANDLE | icdev,
 |  | unsigned char * | info
 | ) |  |

读取设备自定义信息。

说明：
读取设备自定义信息。
参数
[in] | icdev | 设备标识符。
[out] | info | 返回的信息，固定为8个字节。
返回
<0表示失败，==0表示成功。

§ dc_WriteDeviceCustomInfo()

short USER_API dc_WriteDeviceCustomInfo | ( | HANDLE | icdev,
 |  | const unsigned char * | info
 | ) |  |

写入设备自定义信息。

说明：
写入设备自定义信息。
参数
[in] | icdev | 设备标识符。
[in] | info | 传入信息，固定为8个字节。
返回
<0表示失败，==0表示成功。

§ dc_ReadDeviceTypeName()

short USER_API dc_ReadDeviceTypeName | ( | HANDLE | icdev,
 |  | char * | name
 | ) |  |

读取设备型号名称。

说明：
读取设备型号名称。
参数
[in] | icdev | 设备标识符。
[out] | name | 返回的型号名称字符串，请至少分配33个字节。
返回
<0表示失败，==0表示成功。

§ dc_WriteDeviceTypeName()

short USER_API dc_WriteDeviceTypeName | ( | HANDLE | icdev,
 |  | const char * | name
 | ) |  |

写入设备型号名称。

说明：
写入设备型号名称。
参数
[in] | icdev | 设备标识符。
[in] | name | 传入型号名称，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功。

§ dc_WirelessPowerControl()

short USER_API dc_WirelessPowerControl | ( | HANDLE | icdev,
 |  | unsigned char | value
 | ) |  |

无线模块电源控制。

说明：
无线模块电源控制。
参数
[in] | icdev | 设备标识符。
[in] | value | 开关，0x00表示关闭，0x01表示开启。
返回
<0表示失败，==0表示成功。

§ dc_WirelessTcpOpen()

short USER_API dc_WirelessTcpOpen | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | const char * | network_address,
 |  | const char * | network_port
 | ) |  |

打开TCP链接。

说明：
打开TCP链接。
参数
[in] | icdev | 设备标识符。
[in] | type | 无线模块类型，0x00表示CDMA，0x01表示GPRS，0x02表示WIFI。
[in] | network_address | IP地址或域名，数据格式为'\0'结尾的字符串。
[in] | network_port | IP端口号，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功。

§ dc_WirelessTcpClose()

short USER_API dc_WirelessTcpClose ( HANDLE icdev )

关闭TCP链接。

说明：
关闭TCP链接。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_WirelessGetStatus()

short USER_API dc_WirelessGetStatus | ( | HANDLE | icdev,
 |  | unsigned char * | value
 | ) |  |

查询网络状态。

说明：
查询网络状态。
参数
[in] icdev 设备标识符。
[out] value 状态值，固定为1个字节。
0x00 - 表示TCP初始状态。
0x01 - 表示无线模块无法通讯。
0x02 - 表示无线模块电源关闭。
0x03 - 表示无线模块电源开启。
0x04 - 表示SIM卡异常或者无卡。
0x05 - 表示网络信号异常。
0x06 - 表示无线模块自检成功。
0x07 - 表示TCP空闲状态。
0x08 - 表示TCP已经连接成功。
0x09 - 表示TCP已经断开连接。
返回
<0表示失败，==0表示成功。

§ dc_WirelessSend()

short USER_API dc_WirelessSend | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | const unsigned char * | data_buffer,
 |  | int | data_len
 | ) |  |

发送数据到网络端。

说明：
发送数据到网络端。
参数
[in] | icdev | 设备标识符。
[in] | type | 无线模块类型，0x00表示CDMA，0x01表示GPRS，0x02表示WIFI。
[in] | data_buffer | 发送数据。
[in] | data_len | 发送数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_WirelessRecv()

short USER_API dc_WirelessRecv | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | unsigned char | mode,
 |  | unsigned char | time_100ms,
 |  | unsigned char * | data_buffer,
 |  | int * | data_len
 | ) |  |

从网络端接收数据。

说明：
从网络端接收数据。
参数
[in] | icdev | 设备标识符。
[in] | type | 无线模块类型，0x00表示CDMA，0x01表示GPRS，0x02表示WIFI。
[in] | mode | 模式，0x00表示接收的数据格式不带格式头符号，0x01表示接收的数据格式带格式头符号，WIFI模块此参数无效。
[in] | time_100ms | 设备超时值，单位为100毫秒。
[out] | data_buffer | 返回的数据。
[out] | data_len | 返回数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_WirelessWifiConfig()

short USER_API dc_WirelessWifiConfig | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | const char * | ssid,
 |  | const char * | password
 | ) |  |

配置WIFI参数。

说明：
配置WIFI参数。
参数
[in] | icdev | 设备标识符。
[in] | type | 无线模块类型，0x00表示CDMA，0x01表示GPRS，0x02表示WIFI。
[in] | ssid | WIFI SSID，数据格式为'\0'结尾的字符串。
[in] | password | WIFI密码，数据格式为'\0'结尾的字符串。
返回
<0表示失败，==0表示成功。

§ dc_GpsGetInfo()

short USER_API dc_GpsGetInfo | ( | HANDLE | icdev,
 |  | int | time_ms,
 |  | unsigned char * | data_buffer,
 |  | int * | data_len
 | ) |  |

获取GPS信息。

说明：
获取GPS信息。
参数
[in] | icdev | 设备标识符。
[in] | time_ms | 设备超时值，单位为毫秒。
[out] | data_buffer | 返回的数据。
[out] | data_len | 返回数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_SetCpuCard616C()

short USER_API dc_SetCpuCard616C | ( | HANDLE | icdev,
 |  | unsigned char | value
 | ) |  |

设置接触式CPU卡616C配置。

说明：
设置接触式CPU卡616C配置。
参数
[in] | icdev | 设备标识符。
[in] | value | 配置值，0x00表示设备不处理616C，0x01表示设备处理616C。
返回
<0表示失败，==0表示成功。

§ dc_GetCpuCard616C()

short USER_API dc_GetCpuCard616C | ( | HANDLE | icdev,
 |  | unsigned char * | value
 | ) |  |

获取接触式CPU卡616C配置。

说明：
获取接触式CPU卡616C配置。
参数
[in] | icdev | 设备标识符。
[out] | value | 配置值，0x00表示设备不处理616C，0x01表示设备处理616C。
返回
<0表示失败，==0表示成功。

§ dc_GetChipIdNumber()

short USER_API dc_GetChipIdNumber | ( | HANDLE | icdev,
 |  | char * | number
 | ) |  |

获取芯片唯一ID号。

说明：
获取芯片唯一ID号。
参数
[in] | icdev | 设备标识符。
[out] | number | 返回的ID号字符串，请至少分配128个字节。
返回
<0表示失败，==0表示成功。

§ dc_LedDisplay()

short USER_API dc_LedDisplay | ( | HANDLE | icdev,
 |  | unsigned char | number,
 |  | unsigned char | mode,
 |  | unsigned char | value
 | ) |  |

数码管显示。

说明：
数码管显示。
参数
[in] | icdev | 设备标识符。
[in] | number | 数码管编号（1~12）。
[in] | mode | 模式，0x00表示数据正常显示，0x01表示数据闪烁显示，0x02表示数据不闪烁显示，0x03表示数据带小数点显示。
[in] | value | 显示数据值。
返回
<0表示失败，==0表示成功。

§ dc_LedControl()

short USER_API dc_LedControl | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

数码管显示设置。

说明：
数码管显示设置。
参数
[in] icdev 设备标识符。
[in] mode 模式。
0x00 - 左移。
0x01 - 右移。
0x02 - 左循环。
0x03 - 右循环。
0x04 - 显示清除。
0x05 - 显示置位。
0x06 - 显示亮度增加。
0x07 - 显示亮度降低。
0x08 - 开显示。
0x09 - 关显示。
返回
<0表示失败，==0表示成功。

§ dc_RfCrcModeConfig()

short USER_API dc_RfCrcModeConfig | ( | HANDLE | icdev,
 |  | unsigned char | tx_crc,
 |  | unsigned char | rx_crc
 | ) |  |

透传CRC模式配置。

说明：
透传CRC模式配置。
参数
[in] | icdev | 设备标识符。
[in] | tx_crc | TXCRC模式，0x00表示内部不处理TXCRC，0x01表示内部处理TXCRC（只支持ISO14443标准卡）。
[in] | rx_crc | RXCRC模式，0x00表示内部不处理RXCRC，0x01表示内部处理RXCRC（只支持ISO14443标准卡）。
返回
<0表示失败，==0表示成功。

§ dc_TcpGetInfo()

short USER_API dc_TcpGetInfo | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | unsigned char * | data_buffer,
 |  | int * | data_len
 | ) |  |

获取TCP信息。

说明：
获取TCP信息。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0x01表示请求获得模块型号，0x02表示请求获得当前信号强度。
[out] | data_buffer | 返回的数据。
[out] | data_len | 返回数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_RfMarch()

short USER_API dc_RfMarch ( HANDLE icdev )

射频天线打开。

说明：
射频天线打开。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_SelectAntenna()

short USER_API dc_SelectAntenna | ( | HANDLE | icdev,
 |  | unsigned char | number
 | ) |  |

选择天线。

说明：
选择天线。
参数
[in] | icdev | 设备标识符。
[in] | number | 天线编号，从1开始编号。
返回
<0表示失败，==0表示成功。

§ dc_ReadNicMacAddress()

short USER_API dc_ReadNicMacAddress | ( | HANDLE | icdev,
 |  | unsigned char * | data_buffer,
 |  | int * | data_len
 | ) |  |

读网卡MAC地址。

说明：
读网卡MAC地址。
参数
[in] | icdev | 设备标识符。
[out] | data_buffer | 返回的网卡地址。
[out] | data_len | 返回网卡地址的长度。
返回
<0表示失败，==0表示成功。

§ dc_WriteNicMacAddress()

short USER_API dc_WriteNicMacAddress | ( | HANDLE | icdev,
 |  | const unsigned char * | data_buffer,
 |  | int | data_len
 | ) |  |

写网卡MAC地址。

说明：
写网卡MAC地址。
参数
[in] | icdev | 设备标识符。
[in] | data_buffer | 传入网卡地址。
[in] | data_len | 传入网卡地址的长度。
返回
<0表示失败，==0表示成功。

§ dc_TestNic()

short USER_API dc_TestNic | ( | HANDLE | icdev,
 |  | const unsigned char * | data_buffer,
 |  | int | data_len
 | ) |  |

测试网卡。

说明：
测试网卡。
参数
[in] | icdev | 设备标识符。
[in] | data_buffer | 传入IP地址。
[in] | data_len | 传入IP地址的长度。
返回
<0表示失败，==0表示成功。

§ dc_TestUsb()

short USER_API dc_TestUsb | ( | HANDLE | icdev,
 |  | const unsigned char * | data_buffer,
 |  | int | data_len
 | ) |  |

测试USB。

说明：
测试USB。
参数
[in] | icdev | 设备标识符。
[in] | data_buffer | 保留。
[in] | data_len | 保留，固定为0。
返回
<0表示失败，==0表示成功。

§ dc_TestCom()

short USER_API dc_TestCom | ( | HANDLE | icdev,
 |  | unsigned char | number,
 |  | const char * | name,
 |  | unsigned char * | data_buffer,
 |  | int * | data_len
 | ) |  |

测试串口。

说明：
测试串口。
参数
[in] | icdev | 设备标识符。
[in] | number | 串口编号（1~3）。
[in] | name | 主机串口名称，如："COM1:115200"。
[in,out] | data_buffer | 通讯数据。
[in,out] | data_len | 通讯数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_ConfigTempIpAddress()

short USER_API dc_ConfigTempIpAddress | ( | HANDLE | icdev,
 |  | const unsigned char * | data_buffer,
 |  | int | data_len
 | ) |  |

设定临时IP地址。

说明：
设定临时IP地址。
参数
[in] | icdev | 设备标识符。
[in] | data_buffer | 传入IP地址。
[in] | data_len | 传入IP地址的长度。
返回
<0表示失败，==0表示成功。

§ dc_GetMagFormat()

short USER_API dc_GetMagFormat | ( | HANDLE | icdev,
 |  | int * | mode
 | ) |  |

磁条卡数据自动上传数据模式获取。

说明：
获取磁条卡数据自动上传数据模式。
参数
[in] icdev 设备标识符。
[out] mode 模式。
0 - 输出数据中如果带字母，字母转化为大写字母。
1 - 输出数据是原始数据（默认）。
返回
<0表示失败，==0表示成功。

§ dc_GetMag()

short USER_API dc_GetMag | ( | HANDLE | icdev,
 |  | unsigned char * | mode,
 |  | unsigned char * | track1,
 |  | unsigned char * | track2,
 |  | unsigned char * | track3
 | ) |  |

磁条卡参数获取。

说明：
获取操作磁条卡的参数，参数仅针对自动输出的模式有效。
参数
[in] | icdev | 设备标识符。
[out] | mode | 模式，0x00表示不用输出，0x01表示自动输出。
[out] track1 1轨道参数。
bit0 - 轨道数据输出设置，0表示不输出，1表示输出。
bit1 - 轨道数据头设置，0表示无数据头，1表示有数据头。
bit2 - 轨道数据尾设置，0表示无数据尾，1表示有数据尾。
bit3 - 轨道数据换行符设置，0表示无换行符，1表示有换行符。
bit4 - 轨道数据等号与其后数据设置，0表示不输出，1表示输出。
bit5~bit7 - 保留。
[out] track2 2轨道参数。
bit0 - 轨道数据输出设置，0表示不输出，1表示输出。
bit1 - 轨道数据头设置，0表示无数据头，1表示有数据头。
bit2 - 轨道数据尾设置，0表示无数据尾，1表示有数据尾。
bit3 - 轨道数据换行符设置，0表示无换行符，1表示有换行符。
bit4 - 轨道数据等号与其后数据设置，0表示不输出，1表示输出。
bit5~bit7 - 保留。
[out] track3 3轨道参数。
bit0 - 轨道数据输出设置，0表示不输出，1表示输出。
bit1 - 轨道数据头设置，0表示无数据头，1表示有数据头。
bit2 - 轨道数据尾设置，0表示无数据尾，1表示有数据尾。
bit3 - 轨道数据换行符设置，0表示无换行符，1表示有换行符。
bit4 - 轨道数据等号与其后数据设置，0表示不输出，1表示输出。
bit5~bit7 - 保留。
返回
<0表示失败，==0表示成功。

§ dc_GetDeviceBaud()

short USER_API dc_GetDeviceBaud | ( | HANDLE | icdev,
 |  | unsigned char * | baud
 | ) |  |

获取串口设备通讯波特率。

说明：
获取串口设备通讯波特率。
参数
[in] icdev 设备标识符。
[out] baud 波特率。
0x00 - 115200。
0x01 - 57600。
0x02 - 38400。
0x03 - 19200。
0x04 - 9600。
0x05 - 4800。
0x06 - 2400。
0x07 - 1200。
返回
<0表示失败，==0表示成功。

§ dc_GetUsbMode()

short USER_API dc_GetUsbMode | ( | HANDLE | icdev,
 |  | unsigned char * | ucmode
 | ) |  |

获取USB模式。

说明：
获取USB通讯模式。
参数
[in] icdev 设备标识符。
[out] ucmode 模式。
0x00 - 表示中断发送和中断接收，此时VID=257B，PID=3010。
0x01 - 表示控制发送和控制接收，此时VID=257B，PID=3011。
0x02 - 表示控制发送和中断接收，此时VID=0471，PID=7002。
0x03 - 表示控制发送和中断接收，此时VID=0471，PID=7003。
0x04 - 表示控制发送和中断接收，此时VID=0471，PID=7003，支持磁条卡自动上传功能。
返回
<0表示失败，==0表示成功。

§ dc_cpuapduresponInt()

short USER_API dc_cpuapduresponInt | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
对当前卡座CPU卡进行指令交互操作，注意此接口已封装卡协议部分，内部处理了SW1为0x61和0x6C的情况。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_cpuapduresponInt_hex()

short USER_API dc_cpuapduresponInt_hex | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | char * | databuffer
 | ) |  |

接触式CPU卡指令交互。

说明：
dc_cpuapduresponInt 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_Scan2DBarcodeStart()

short USER_API dc_Scan2DBarcodeStart | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

开始扫描二维码。

说明：
开始扫描二维码。
参数
[in] | icdev | 设备标识符。
[in] | mode | 保留，固定为0x00。
返回
<0表示失败，==0表示成功。

§ dc_Scan2DBarcodeGetData()

short USER_API dc_Scan2DBarcodeGetData | ( | HANDLE | icdev,
 |  | int * | rlen,
 |  | unsigned char * | rdata
 | ) |  |

获取二维码数据。

说明：
获取二维码数据。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回数据的长度。
[out] | rdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_Scan2DBarcodeExit()

short USER_API dc_Scan2DBarcodeExit ( HANDLE icdev )

退出扫描二维码。

说明：
退出扫描二维码。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceWriteMagConfig()

short USER_API dc_SelfServiceDeviceWriteMagConfig | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

写磁条卡参数设置。

说明：
写磁条卡参数设置。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0表示写三轨共移动三次，1表示写三轨共移动一次。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceShakeConfig()

short USER_API dc_SelfServiceDeviceShakeConfig | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

抖动模式设置。

说明：
抖动模式设置。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0表示抖动模式，1表示非抖动模式。
返回
<0表示失败，==0表示成功。

§ dc_VoicePlayAndDisplay()

short USER_API dc_VoicePlayAndDisplay | ( | HANDLE | icdev,
 |  | unsigned char | mode,
 |  | unsigned char | type
 | ) |  |

语音播放及显示。

说明：
播放设备内置语音以及是否需要显示。
参数
[in] | icdev | 设备标识符。
[in] mode 语音段号（0~8）。
0 - 请输入密码。
1 - 请输入原密码。
2 - 请再输入一次。
3 - 请输入新密码。
4 - 请确认新密码。
5 - 密码修改成功。
6 - 请插卡。
7 - 请刷卡。
8 - 密码错误。
[in] | type | 显示类型，0表示显示语音播放内容，1表示不显示语音播放内容。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceSetFrontSwitch()

short USER_API dc_SelfServiceDeviceSetFrontSwitch | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

前门电闸门设置。

说明：
前门电闸门设置。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0表示存在前门电闸门，1表示不存在前门电闸门。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceGetFrontSwitch()

short USER_API dc_SelfServiceDeviceGetFrontSwitch | ( | HANDLE | icdev,
 |  | unsigned char * | mode
 | ) |  |

前门电闸门获取。

说明：
前门电闸门获取。
参数
[in] | icdev | 设备标识符。
[out] | mode | 模式，0表示存在前门电闸门，1表示不存在前门电闸门。
返回
<0表示失败，==0表示成功。

§ dc_ClearDeviceConfig()

short USER_API dc_ClearDeviceConfig ( HANDLE icdev )

清除设备配置。

说明：
清除设备配置。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_SetCpuCardPps()

short USER_API dc_SetCpuCardPps | ( | HANDLE | icdev,
 |  | unsigned char | mode
 | ) |  |

接触式CPU卡PPS配置设置。

说明：
接触式CPU卡PPS配置设置。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，0表示底层不支持PPS，1表示底层支持PPS。
返回
<0表示失败，==0表示成功。

§ dc_GetCpuCardPps()

short USER_API dc_GetCpuCardPps | ( | HANDLE | icdev,
 |  | unsigned char * | mode
 | ) |  |

接触式CPU卡PPS配置获取。

说明：
接触式CPU卡PPS配置获取。
参数
[in] | icdev | 设备标识符。
[out] | mode | 模式，0表示底层不支持PPS，1表示底层支持PPS。
返回
<0表示失败，==0表示成功。

§ dc_RefreshAndDisplayMainUI()

short USER_API dc_RefreshAndDisplayMainUI ( HANDLE icdev )

刷新返回主界面。

说明：
刷新返回主界面。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_SamAReadSerialNumber()

short USER_API dc_SamAReadSerialNumber | ( | HANDLE | icdev,
 |  | char * | number
 | ) |  |

读取SAM_A模块序列号。

说明：
读取SAM_A模块序列号。
参数
[in] | icdev | 设备标识符。
[out] | number | 返回的序列号字符串，请至少分配64个字节。
返回
<0表示失败，==0表示成功。

§ dc_2dot4Apdu()

short USER_API dc_2dot4Apdu | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | unsigned char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | unsigned char * | databuffer
 | ) |  |

2.4G APDU指令交互。

说明：
2.4G APDU指令交互。
参数
[in] | icdev | 设备标识符。
[in] | slen | 发送数据的长度。
[in] | sendbuffer | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | databuffer | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_2dot4Apdu_hex()

short USER_API dc_2dot4Apdu_hex | ( | HANDLE | icdev,
 |  | unsigned int | slen,
 |  | char * | sendbuffer,
 |  | unsigned int * | rlen,
 |  | char * | databuffer
 | ) |  |

2.4G APDU指令交互。

说明：
dc_2dot4Apdu 的HEX形式接口，参数 sendbuffer databuffer 为HEX格式。

§ dc_ScreenDisplayImage()

short USER_API dc_ScreenDisplayImage | ( | HANDLE | icdev,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | int | time_s,
 |  | const unsigned char * | image_data
 | ) |  |

显示图像。

说明：
在屏幕上显示图像，这里的图像指的是前景图像。
参数
[in] | icdev | 设备标识符。
[in] | x | 图像显示的起始X坐标。
[in] | y | 图像显示的起始Y坐标。
[in] | w | 图像显示的宽度。
[in] | h | 图像显示的高度。
[in] | time_s | 显示时间，单位为秒，0表示一直显示。
[in] | image_data | 图像数据。格式为：【4个字节图像信息长度（Big-Endian）】【图像信息】。
返回
<0表示失败，==0表示成功。

§ dc_ScreenClearDisplay()

short USER_API dc_ScreenClearDisplay | ( | HANDLE | icdev,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | int | time_s
 | ) |  |

清除显示。

说明：
清除屏幕上的显示，这里清除的显示为前景。
参数
[in] | icdev | 设备标识符。
[in] | x | 清除显示的起始X坐标。
[in] | y | 清除显示的起始Y坐标。
[in] | w | 清除显示的宽度。
[in] | h | 清除显示的高度。
[in] | time_s | 延时清除时间，单位为秒，0表示立即清除。
返回
<0表示失败，==0表示成功。

§ dc_ScreenLoadBgImage()

short USER_API dc_ScreenLoadBgImage | ( | HANDLE | icdev,
 |  | int | number,
 |  | const unsigned char * | image_data
 | ) |  |

装载背景图像。

说明：
装载背景图像到设备内部。
参数
[in] | icdev | 设备标识符。
[in] | number | 图像序号，从1开始编号。
[in] | image_data | 图像数据。格式为：【4个字节图像信息长度（Big-Endian）】【图像信息】。
返回
<0表示失败，==0表示成功。

§ dc_ScreenDisplayBgImage()

short USER_API dc_ScreenDisplayBgImage | ( | HANDLE | icdev,
 |  | int | number,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h
 | ) |  |

显示背景图像。

说明：
显示设备内部装载的背景图像。
参数
[in] | icdev | 设备标识符。
[in] | number | 图像序号，从1开始编号。
[in] | x | 图像显示的起始X坐标。
[in] | y | 图像显示的起始Y坐标。
[in] | w | 图像显示的宽度。
[in] | h | 图像显示的高度。
返回
<0表示失败，==0表示成功。

§ dc_ScreenDisplayGetConfig()

short USER_API dc_ScreenDisplayGetConfig | ( | HANDLE | icdev,
 |  | unsigned char | tag,
 |  | unsigned char * | config_data
 | ) |  |

获取显示配置。

说明：
获取显示配置。
参数
[in] | icdev | 设备标识符。
[in] tag 标签。
0x01 - 熄屏时间，配置信息长度固定为4个字节，单位为秒（Big-Endian）。如：config_data = {0x04,0x00,0x00,0x00,0x10}表示熄屏时间为16秒。
0x02 - 显示分辨率，配置信息长度固定为4个字节，前2个字节为水平分辨率（Big-Endian），后2个字节为垂直分辨率（Big-Endian）。如：config_data = {0x04,0x02,0x80,0x01,0xE0}表示分辨率为640x480。
[out] | config_data | 配置数据。格式为：【1字节配置信息长度】【配置信息】。
返回
<0表示失败，==0表示成功。

§ dc_ScreenDisplaySetConfig()

short USER_API dc_ScreenDisplaySetConfig | ( | HANDLE | icdev,
 |  | unsigned char | tag,
 |  | const unsigned char * | config_data
 | ) |  |

设置显示配置。

说明：
设置显示配置。
参数
[in] | icdev | 设备标识符。
[in] tag 标签。
0x01 - 熄屏时间，配置信息长度固定为4个字节，单位为秒（Big-Endian）。如：config_data = {0x04,0x00,0x00,0x00,0x10}表示熄屏时间为16秒。
0x02 - 显示分辨率，配置信息长度固定为4个字节，前2个字节为水平分辨率（Big-Endian），后2个字节为垂直分辨率（Big-Endian）。如：config_data = {0x04,0x02,0x80,0x01,0xE0}表示分辨率为640x480。
[in] | config_data | 配置数据。格式为：【1字节配置信息长度】【配置信息】。
返回
<0表示失败，==0表示成功。

§ dc_ScreenDisplayText()

short USER_API dc_ScreenDisplayText | ( | HANDLE | icdev,
 |  | unsigned char | font_size,
 |  | const unsigned char * | fg_rgb,
 |  | const unsigned char * | bg_rgb,
 |  | int | x,
 |  | int | y,
 |  | int | time_s,
 |  | unsigned char | line_flag,
 |  | unsigned char | voice_flag,
 |  | const char * | text
 | ) |  |

显示文字。

说明：
在屏幕上显示文字，注意文字也属于前景。
参数
[in] | icdev | 设备标识符。
[in] | font_size | 字体大小。
[in] | fg_rgb | 文字前景色，3个字节RGB值，第一个字节为R，第二个字节为G，第三个字节为B。
[in] | bg_rgb | 文字背景色，3个字节RGB值，第一个字节为R，第二个字节为G，第三个字节为B。
[in] | x | 文字显示的起始X坐标。
[in] | y | 文字显示的起始Y坐标。
[in] | time_s | 显示时间，单位为秒，0表示一直显示。
[in] | line_flag | 换行标志，0表示不自动换行，1表示自动换行。
[in] | voice_flag | 语音标志，0表示不播放语音，1表示播放语音。
[in] | text | 文本字符串。
返回
<0表示失败，==0表示成功。

§ dc_ScreenDisplayBgImageByColor()

short USER_API dc_ScreenDisplayBgImageByColor | ( | HANDLE | icdev,
 |  | const unsigned char * | rgb,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h
 | ) |  |

填充背景。

说明：
使用指定颜色填充背景。
参数
[in] | icdev | 设备标识符。
[in] | rgb | 颜色，3个字节RGB值，第一个字节为R，第二个字节为G，第三个字节为B。
[in] | x | 起始X坐标。
[in] | y | 起始Y坐标。
[in] | w | 宽度。
[in] | h | 高度。
返回
<0表示失败，==0表示成功。

§ dc_NtagCommand()

short USER_API dc_NtagCommand | ( | HANDLE | icdev,
 |  | unsigned char | type,
 |  | unsigned char | mode,
 |  | unsigned int | slen,
 |  | const unsigned char * | sdata,
 |  | unsigned int * | rlen,
 |  | unsigned char * | rdata
 | ) |  |

NTAG标签交互。

说明：
NTAG标签交互。
参数
[in] | icdev | 设备标识符。
[in] | type | 保留，固定为0x00。
[in] | mode | 模式。
[in] | slen | 发送数据的长度。
[in] | sdata | 发送数据。
[out] | rlen | 返回数据的长度。
[out] | rdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_SetCpuVoltage()

short USER_API dc_SetCpuVoltage | ( | HANDLE | icdev,
 |  | unsigned char | voltage
 | ) |  |

设置接触式CPU卡电压。

说明：
设置接触式CPU卡电压。
参数
[in] | icdev | 设备标识符。
[in] | voltage | 电压值，0x00表示5V，0x01表示3.3V，0x02表示1.8V。
返回
<0表示失败，==0表示成功。

§ dc_LcdDisplayText()

short USER_API dc_LcdDisplayText | ( | HANDLE | icdev,
 |  | unsigned char | line,
 |  | unsigned char | offset,
 |  | unsigned char | mode,
 |  | unsigned char | charset,
 |  | const unsigned char * | text
 | ) |  |

LCD显示文字。

说明：
在设备LCD显示屏上显示文字。
参数
[in] | icdev | 设备标识符。
[in] | line | 行号。
[in] | offset | 偏移。
[in] | mode | 模式，0表示正色，1表示反色。
[in] charset 字符集。
0 - ASCII。
1 - GB2312。
2 - GBK。
3 - GB18030。
4 - ANSI。
5 - UNICODE（Little-Endian）。
6 - UNICODE（Big-Endian）。
[in] | text | 文本字符串。
返回
<0表示失败，==0表示成功。

§ dc_LcdDisplayTextFromData()

short USER_API dc_LcdDisplayTextFromData | ( | HANDLE | icdev,
 |  | unsigned char | line,
 |  | unsigned char | offset,
 |  | unsigned char | mode,
 |  | unsigned char | charset,
 |  | const unsigned char * | text,
 |  | const unsigned char * | data,
 |  | int | data_len
 | ) |  |

LCD显示文字。

说明：
通过指定字模点阵数据，在设备LCD显示屏上显示文字。
参数
[in] | icdev | 设备标识符。
[in] | line | 行号。
[in] | offset | 偏移。
[in] | mode | 模式，0表示正色，1表示反色。
[in] charset 字符集。
0 - ASCII。
1 - GB2312。
2 - GBK。
3 - GB18030。
4 - ANSI。
5 - UNICODE（Little-Endian）。
6 - UNICODE（Big-Endian）。
[in] | text | 文本字符串。
[in] | data | 字模点阵数据。
[in] | data_len | 字模点阵数据的长度。
返回
<0表示失败，==0表示成功。

§ dc_DownloadFileData()

short USER_API dc_DownloadFileData | ( | HANDLE | icdev,
 |  | unsigned int | file_type,
 |  | unsigned int | file_size,
 |  | unsigned int | flag,
 |  | const unsigned char * | data,
 |  | unsigned int * | data_size
 | ) |  |

装载文件数据。

说明：
装载文件数据到设备中。
参数
[in] | icdev | 设备标识符。
[in] | file_type | 文件类型。
[in] | file_size | 文件大小。
[in] flag 传输标志。
0 - 准备传输。
1~0xFFFFFFFE - 非结尾传输。
0xFFFFFFFF - 结尾传输。
[in] | data | 数据，当 flag 不为0时有效。
[in,out] data_size 数据大小。
flag为0 - data_size为Out形式的参数，返回设备支持的最大分包长度。
flag不为0 - data_size为In形式的参数，传入 data 的长度。
返回
<0表示失败，==0表示成功。

§ dc_check_1608()

short USER_API dc_check_1608 ( HANDLE icdev )

检测1608卡。

说明：
检测是否存在1608卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_down_1608()

short USER_API dc_down_1608 ( HANDLE icdev )

1608卡下电。

说明：
对1608卡进行下电操作。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_read_1608()

short USER_API dc_read_1608 | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | readdata
 | ) |  |

读1608卡。

说明：
读取1608卡的数据。
参数
[in] | icdev | 设备标识符。
[in] zone 数据区。
0~7 - 表示用户区。
8 - 表示配置区。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | readdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_read_1608_hex()

short USER_API dc_read_1608_hex | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | readdata
 | ) |  |

读1608卡。

说明：
dc_read_1608 的HEX形式接口，参数 readdata 为HEX格式。

§ dc_write_1608()

short USER_API dc_write_1608 | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | writedata
 | ) |  |

写1608卡。

说明：
写入数据到1608卡中。
参数
[in] | icdev | 设备标识符。
[in] zone 数据区。
0~7 - 表示用户区。
8 - 表示配置区。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | writedata | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_write_1608_hex()

short USER_API dc_write_1608_hex | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | writedata
 | ) |  |

写1608卡。

说明：
dc_write_1608 的HEX形式接口，参数 writedata 为HEX格式。

§ dc_checkpass_1608()

short USER_API dc_checkpass_1608 | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned char | type,
 |  | unsigned char * | password
 | ) |  |

验证1608卡密码。

说明：
使用传入的密码来验证1608卡密码。
参数
[in] | icdev | 设备标识符。
[in] zone 数据区。
0~7 - 表示用户区。
8 - 表示配置区。
[in] | type | 类型，0表示验证写密钥，1表示验证读密钥。
[in] | password | 密码，固定为3个字节。
返回
<0表示失败，==0表示成功。

§ dc_checkpass_1608_hex()

short USER_API dc_checkpass_1608_hex | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned char | type,
 |  | unsigned char * | password
 | ) |  |

验证1608卡密码。

说明：
dc_checkpass_1608 的HEX形式接口，参数 password 为HEX格式。

§ dc_init_auth_1608()

short USER_API dc_init_auth_1608 | ( | HANDLE | icdev,
 |  | unsigned char * | databuffer
 | ) |  |

初始化1608卡认证。

说明：
使用传入的数据来初始化1608卡认证。
参数
[in] | icdev | 设备标识符。
[in] | databuffer | 数据，固定为8个字节。
返回
<0表示失败，==0表示成功。

§ dc_init_auth_1608_hex()

short USER_API dc_init_auth_1608_hex | ( | HANDLE | icdev,
 |  | unsigned char * | databuffer
 | ) |  |

初始化1608卡认证。

说明：
dc_init_auth_1608 的HEX形式接口，参数 databuffer 为HEX格式。

§ dc_check_auth_1608()

short USER_API dc_check_auth_1608 | ( | HANDLE | icdev,
 |  | unsigned char * | databuffer
 | ) |  |

核对1608卡认证。

说明：
使用传入的数据来核对1608卡认证。
参数
[in] | icdev | 设备标识符。
[in] | databuffer | 数据，固定为8个字节。
返回
<0表示失败，==0表示成功。

§ dc_check_auth_1608_hex()

short USER_API dc_check_auth_1608_hex | ( | HANDLE | icdev,
 |  | unsigned char * | databuffer
 | ) |  |

核对1608卡认证。

说明：
dc_check_auth_1608 的HEX形式接口，参数 databuffer 为HEX格式。

§ dc_write_fuse_1608()

short USER_API dc_write_fuse_1608 | ( | HANDLE | icdev,
 |  | unsigned char | value
 | ) |  |

写1608卡熔丝。

说明：
写1608卡熔丝。
参数
[in] | icdev | 设备标识符。
[in] | value | 保留，固定为0x00。
返回
<0表示失败，==0表示成功。

§ dc_read_fuse_1608()

short USER_API dc_read_fuse_1608 | ( | HANDLE | icdev,
 |  | unsigned char * | value
 | ) |  |

读1608卡熔丝。

说明：
读1608卡熔丝。
参数
[in] icdev 设备标识符。
[out] value 状态值。
bit0 - FAB，Atmel公司发行熔丝，0表示已熔丝，1表示未熔丝。
bit1 - CMA，卡发行商发行熔丝，0表示已熔丝，1表示未熔丝。
bit2 - PER，个人化发行熔丝，0表示已熔丝，1表示未熔丝。
bit3~bit7 - 保留。
返回
<0表示失败，==0表示成功。

§ dc_check_153()

short USER_API dc_check_153 ( HANDLE icdev )

检测153卡。

说明：
检测是否存在153卡。
参数
[in] icdev 设备标识符。
返回
<0表示失败或不存在，==0表示存在。

§ dc_down_153()

short USER_API dc_down_153 ( HANDLE icdev )

153卡下电。

说明：
对153卡进行下电操作。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_read_153()

short USER_API dc_read_153 | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | readdata
 | ) |  |

读153卡。

说明：
读取153卡的数据。
参数
[in] | icdev | 设备标识符。
[in] zone 数据区。
0~2 - 表示用户区。
3 - 表示配置区。
[in] | offset | 偏移。
[in] | length | 读取长度。
[out] | readdata | 返回的数据。
返回
<0表示失败，==0表示成功。

§ dc_read_153_hex()

short USER_API dc_read_153_hex | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | readdata
 | ) |  |

读153卡。

说明：
dc_read_153 的HEX形式接口，参数 readdata 为HEX格式。

§ dc_write_153()

short USER_API dc_write_153 | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | writedata
 | ) |  |

写153卡。

说明：
写入数据到153卡中。
参数
[in] | icdev | 设备标识符。
[in] zone 数据区。
0~2 - 表示用户区。
3 - 表示配置区。
[in] | offset | 偏移。
[in] | length | 写入长度。
[in] | writedata | 传入数据。
返回
<0表示失败，==0表示成功。

§ dc_write_153_hex()

short USER_API dc_write_153_hex | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned int | offset,
 |  | unsigned int | length,
 |  | unsigned char * | writedata
 | ) |  |

写153卡。

说明：
dc_write_153 的HEX形式接口，参数 writedata 为HEX格式。

§ dc_checkpass_153()

short USER_API dc_checkpass_153 | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned char | type,
 |  | unsigned char * | password
 | ) |  |

验证153卡密码。

说明：
使用传入的密码来验证153卡密码。
参数
[in] | icdev | 设备标识符。
[in] zone 数据区。
0~2 - 表示用户区。
3 - 表示配置区。
[in] | type | 类型，0表示验证写密钥，1表示验证读密钥。
[in] | password | 密码，固定为3个字节。
返回
<0表示失败，==0表示成功。

§ dc_checkpass_153_hex()

short USER_API dc_checkpass_153_hex | ( | HANDLE | icdev,
 |  | unsigned char | zone,
 |  | unsigned char | type,
 |  | unsigned char * | password
 | ) |  |

验证153卡密码。

说明：
dc_checkpass_153 的HEX形式接口，参数 password 为HEX格式。

§ dc_init_auth_153()

short USER_API dc_init_auth_153 | ( | HANDLE | icdev,
 |  | unsigned char * | databuffer
 | ) |  |

初始化153卡认证。

说明：
使用传入的数据来初始化153卡认证。
参数
[in] | icdev | 设备标识符。
[in] | databuffer | 数据，固定为8个字节。
返回
<0表示失败，==0表示成功。

§ dc_init_auth_153_hex()

short USER_API dc_init_auth_153_hex | ( | HANDLE | icdev,
 |  | unsigned char * | databuffer
 | ) |  |

初始化153卡认证。

说明：
dc_init_auth_153 的HEX形式接口，参数 databuffer 为HEX格式。

§ dc_check_auth_153()

short USER_API dc_check_auth_153 | ( | HANDLE | icdev,
 |  | unsigned char * | databuffer
 | ) |  |

核对153卡认证。

说明：
使用传入的数据来核对153卡认证。
参数
[in] | icdev | 设备标识符。
[in] | databuffer | 数据，固定为8个字节。
返回
<0表示失败，==0表示成功。

§ dc_check_auth_153_hex()

short USER_API dc_check_auth_153_hex | ( | HANDLE | icdev,
 |  | unsigned char * | databuffer
 | ) |  |

核对153卡认证。

说明：
dc_check_auth_153 的HEX形式接口，参数 databuffer 为HEX格式。

§ dc_write_fuse_153()

short USER_API dc_write_fuse_153 | ( | HANDLE | icdev,
 |  | unsigned char | value
 | ) |  |

写153卡熔丝。

说明：
写153卡熔丝。
参数
[in] | icdev | 设备标识符。
[in] | value | 保留，固定为0x00。
返回
<0表示失败，==0表示成功。

§ dc_read_fuse_153()

short USER_API dc_read_fuse_153 | ( | HANDLE | icdev,
 |  | unsigned char * | value
 | ) |  |

读153卡熔丝。

说明：
读153卡熔丝。
参数
[in] icdev 设备标识符。
[out] value 状态值。
bit0 - FAB，Atmel公司发行熔丝，0表示已熔丝，1表示未熔丝。
bit1 - CMA，卡发行商发行熔丝，0表示已熔丝，1表示未熔丝。
bit2 - PER，个人化发行熔丝，0表示已熔丝，1表示未熔丝。
bit3~bit7 - 保留。
返回
<0表示失败，==0表示成功。

§ dc_MultiAntennaStartOrStop()

short USER_API dc_MultiAntennaStartOrStop | ( | HANDLE | icdev,
 |  | unsigned char | flag,
 |  | unsigned int * | mask
 | ) |  |

多天线启动或停止。

说明：
多天线启动或停止。
参数
[in] | icdev | 设备标识符。
[in] | flag | 标记，0表示停止，1表示启动。
[in,out] | mask | 掩码值，32bit分别表示32路天线，相应bit位为1表示天线有效，传入为期待值，返回为实际值。
返回
<0表示失败，==0表示成功。

§ dc_MultiAntennaGetCardStatus()

short USER_API dc_MultiAntennaGetCardStatus | ( | HANDLE | icdev,
 |  | int * | rlen,
 |  | unsigned char * | rdata
 | ) |  |

多天线获取卡状态。

说明：
多天线获取卡状态。
参数
[in] | icdev | 设备标识符。
[out] | rlen | 返回数据的长度。
[out] rdata 返回的数据。
0x00 - 无卡。
0x8A - 有卡，Type A CPU卡。
0x8B - 有卡，Type B CPU卡。
0x80 - 有卡，未知卡型。
0x81 - 有卡，M1卡。
返回
<0表示失败，==0表示成功。

§ dc_SetPinpadWithReaderBaudrate()

short USER_API dc_SetPinpadWithReaderBaudrate | ( | HANDLE | icdev,
 |  | unsigned char | value
 | ) |  |

设置reader与密码键盘串口波特率。

说明：
设置reader与密码键盘串口波特率。
参数
[in] icdev 设备标识符。
[in] value 波特率。
0x00 - 2400。
0x01 - 4800。
0x02 - 9600。
0x03 - 14400。
0x04 - 38400。
0x05 - 57600。
0x06 - 115200。
0x07 - 256000。
返回
<0表示失败，==0表示成功。

§ dc_CheckPinpadWithReaderBaudrate()

short USER_API dc_CheckPinpadWithReaderBaudrate | ( | HANDLE | icdev,
 |  | unsigned char * | value
 | ) |  |

查询reader与密码键盘串口波特率。

说明：
查询reader与密码键盘串口波特率。
参数
[in] icdev 设备标识符。
[out] value 波特率。
0x00 - 2400。
0x01 - 4800。
0x02 - 9600。
0x03 - 14400。
0x04 - 38400。
0x05 - 57600。
0x06 - 115200。
0x07 - 256000。
返回
<0表示失败，==0表示成功。

§ dc_IdCardReadCardInfo()

short USER_API dc_IdCardReadCardInfo | ( | HANDLE | icdev,
 |  | unsigned char | mode,
 |  | unsigned char | type,
 |  | int * | text_len,
 |  | unsigned char * | text,
 |  | int * | photo_len,
 |  | unsigned char * | photo,
 |  | int * | fingerprint_len,
 |  | unsigned char * | fingerprint,
 |  | int * | extra_len,
 |  | unsigned char * | extra
 | ) |  |

读身份证。

说明：
读取身份证的原始信息数据，此接口使用硬件加速，需固件支持。
参数
[in] | icdev | 设备标识符。
[in] | mode | 模式，为0x00表示定制卡（内部使用），为0x01表示身份证卡。
[in] type 类型，为0x00表示内部使用，否则值为下面列出的一种或多种之和。
0x01 - 读取文字信息。
0x02 - 读取相片信息。
0x04 - 读取指纹信息。
0x08 - 读取追加住址信息。
[out] | text_len | 返回文字信息的长度。
[out] | text | 返回的文字信息，请至少分配256个字节。
[out] | photo_len | 返回相片信息的长度。
[out] | photo | 返回的相片信息，请至少分配1024个字节。
[out] | fingerprint_len | 返回指纹信息的长度。
[out] | fingerprint | 返回的指纹信息，请至少分配1024个字节。
[out] | extra_len | 返回追加住址信息的长度。
[out] | extra | 返回的追加住址信息，请至少分配70个字节。
返回
<0表示失败，==0表示成功。

§ dc_LcdDisplay()

short USER_API dc_LcdDisplay | ( | HANDLE | icdev,
 |  | unsigned char | line,
 |  | unsigned char | offset,
 |  | unsigned char | mode,
 |  | const char * | data
 | ) |  |

液晶显示。

说明：
显示指定字符串到液晶屏幕上。
参数
[in] | icdev | 设备标识符。
[in] | line | 行号。
[in] | offset | 偏移。
[in] | mode | 模式，为0x00表示正显，为0x01表示反显。
[in] | data | 要显示的字符串。
返回
<0表示失败，==0表示成功。

§ dc_ReadDeviceCustomSerialNumber()

short USER_API dc_ReadDeviceCustomSerialNumber | ( | HANDLE | icdev,
 |  | unsigned char | number,
 |  | char * | data
 | ) |  |

读设备定制序列号。

说明：
读设备定制序列号。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，从0开始编号。
[out] | data | 序列号字符串。
返回
<0表示失败，==0表示成功。

§ dc_WriteDeviceCustomSerialNumber()

short USER_API dc_WriteDeviceCustomSerialNumber | ( | HANDLE | icdev,
 |  | unsigned char | number,
 |  | const char * | data
 | ) |  |

写设备定制序列号。

说明：
写设备定制序列号。
参数
[in] | icdev | 设备标识符。
[in] | number | 编号，从0开始编号。
[in] | data | 序列号字符串。
返回
<0表示失败，==0表示成功。

§ dc_SelfServiceDeviceRecoverError()

short USER_API dc_SelfServiceDeviceRecoverError | ( | HANDLE | icdev,
 |  | unsigned char | type
 | ) |  |

错误恢复。

说明：
错误恢复。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，从0开始编号。
返回
<0表示失败，==0表示成功。

§ dc_GetBankAccountNumber()

short USER_API dc_GetBankAccountNumber | ( | HANDLE | icdev,
 |  | int | type,
 |  | char * | number
 | ) |  |

获取银行卡帐户号码。

说明：
获取银行卡帐户号码。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0表示非接触式，1表示接触式。
[out] | number | 返回的银行卡帐户号码字符串，请至少分配64个字节。
返回
<0表示失败，==0表示成功。

§ dc_GetBankMagInfo()

short USER_API dc_GetBankMagInfo | ( | HANDLE | icdev,
 |  | int | type,
 |  | char * | track1,
 |  | char * | track2,
 |  | char * | track3
 | ) |  |

获取银行卡磁条信息。

说明：
获取银行卡磁条信息。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0表示非接触式，1表示接触式。
[out] | track1 | 返回的银行卡磁条轨道1信息字符串，请至少分配512个字节。
[out] | track2 | 返回的银行卡磁条轨道2信息字符串，请至少分配512个字节。
[out] | track3 | 返回的银行卡磁条轨道3信息字符串，请至少分配512个字节。
返回
<0表示失败，==0表示成功。

§ dc_IdCardImageBuild()

short USER_API dc_IdCardImageBuild | ( | HANDLE | icdev,
 |  | int | type,
 |  | int | text_len,
 |  | const unsigned char * | text,
 |  | int | photo_len,
 |  | const unsigned char * | photo,
 |  | const char * | front_file,
 |  | const char * | back_file
 | ) |  |

生成身份证正面和背面图像。

说明：
生成身份证正面和背面图像。
参数
[in] | icdev | 设备标识符。
[in] | type | 类型，0表示中国人居民身份证，1表示外国人永久居留证。
[in] | text_len | 文字信息的长度。
[in] | text | 文字信息。
[in] | photo_len | 相片信息的长度。
[in] | photo | 相片信息。
[in] | front_file | 传入正面图像文件名，请确保有写入的权限。
[in] | back_file | 传入背面图像文件名，请确保有写入的权限。
返回
<0表示失败，==0表示成功。

§ dc_CvLibLoad()

short USER_API dc_CvLibLoad ( HANDLE icdev )

摄像视觉库加载。

说明：
摄像视觉库加载。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_CvLibUnload()

short USER_API dc_CvLibUnload ( HANDLE icdev )

摄像视觉库卸载。

说明：
摄像视觉库卸载。
参数
[in] icdev 设备标识符。
返回
<0表示失败，==0表示成功。

§ dc_CvOpen()

short USER_API dc_CvOpen | ( | HANDLE | icdev,
 |  | int | number
 | ) |  |

开启摄像头。

说明：
开启指定的摄像头。
参数
[in] | icdev | 设备标识符。
[in] | number | 摄像头编号。
返回
<0表示失败，==0表示成功。

§ dc_CvClose()

short USER_API dc_CvClose | ( | HANDLE | icdev,
 |  | int | number
 | ) |  |

关闭摄像头。

说明：
关闭指定的摄像头。
参数
[in] | icdev | 设备标识符。
[in] | number | 摄像头编号。
返回
<0表示失败，==0表示成功。

§ dc_CvCapture()

short USER_API dc_CvCapture | ( | HANDLE | icdev,
 |  | int | number,
 |  | int | mode,
 |  | const char * | file_name
 | ) |  |

拍照。

说明：
使用指定的摄像头进行拍照。
参数
[in] | icdev | 设备标识符。
[in] | number | 摄像头编号。
[in] | mode | 模式。
[in] | file_name | 文件名，请确保有写入的权限。
返回
<0表示失败，==0表示成功。


DCRF32: 文件成员

这里列出了所有文档化的文件成员,并附带其详细说明:

- a -

  • a_hex() : dcrf32.h


这里列出了所有文档化的文件成员,并附带其详细说明:

- d -

  • dc_2dot4_command() : dcrf32.h
  • dc_2dot4_command_hex() : dcrf32.h
  • dc_2dot4_reset() : dcrf32.h
  • dc_2dot4_resethex() : dcrf32.h
  • dc_2dot4Apdu() : dcrf32.h
  • dc_2dot4Apdu_hex() : dcrf32.h
  • dc_ActivateCard() : dcrf32.h
  • dc_anticoll() : dcrf32.h
  • dc_anticoll2() : dcrf32.h
  • dc_anticoll_mode() : dcrf32.h
  • dc_attrib() : dcrf32.h
  • dc_attribInt() : dcrf32.h
  • dc_auth_shc1102() : dcrf32.h
  • dc_auth_ulc() : dcrf32.h
  • dc_auth_ulc_hex() : dcrf32.h
  • dc_authentication() : dcrf32.h
  • dc_authentication_2() : dcrf32.h
  • dc_authentication_key() : dcrf32.h
  • dc_authentication_pass() : dcrf32.h
  • dc_authentication_pass_hex() : dcrf32.h
  • dc_authentication_passaddr() : dcrf32.h
  • dc_authentication_passaddr_hex() : dcrf32.h
  • dc_beep() : dcrf32.h
  • dc_BtAddressControl() : dcrf32.h
  • dc_BtBaudrateControl() : dcrf32.h
  • dc_BtCommand() : dcrf32.h
  • dc_BtCommunicationTest() : dcrf32.h
  • dc_BtDataResponse() : dcrf32.h
  • dc_BtDataTransmit() : dcrf32.h
  • dc_BtModeControl() : dcrf32.h
  • dc_BtNameControl() : dcrf32.h
  • dc_BtPasswordControl() : dcrf32.h
  • dc_BtReset() : dcrf32.h
  • dc_BtSignalStrength() : dcrf32.h
  • dc_BtUserControl() : dcrf32.h
  • dc_BtWithReaderBaudrateControl() : dcrf32.h
  • dc_BuzzerBeep() : dcrf32.h
  • dc_CalculateDes() : dcrf32.h
  • dc_CalculateMACCheck() : dcrf32.h
  • dc_CalculateSm4() : dcrf32.h
  • dc_card() : dcrf32.h
  • dc_card_b() : dcrf32.h
  • dc_card_b_hex() : dcrf32.h
  • dc_card_double() : dcrf32.h
  • dc_card_double_hex() : dcrf32.h
  • dc_card_exist() : dcrf32.h
  • dc_card_fm11rf005() : dcrf32.h
  • dc_card_hex() : dcrf32.h
  • dc_card_make_and_lock() : dcrf32.h
  • dc_card_n() : dcrf32.h
  • dc_card_n_hex() : dcrf32.h
  • dc_card_n_number() : dcrf32.h
  • dc_card_status() : dcrf32.h
  • dc_card_status2() : dcrf32.h
  • dc_cardAB() : dcrf32.h
  • dc_CardIssuingScript() : dcrf32.h
  • dc_cardstr() : dcrf32.h
  • dc_change_addr() : dcrf32.h
  • dc_changeb3() : dcrf32.h
  • dc_changeb3_hex() : dcrf32.h
  • dc_changebaud_485() : dcrf32.h
  • dc_changekey_ulc() : dcrf32.h
  • dc_changekey_ulc_hex() : dcrf32.h
  • dc_changepass_102() : dcrf32.h
  • dc_changepass_102_hex() : dcrf32.h
  • dc_changepass_1604() : dcrf32.h
  • dc_changepass_1604_hex() : dcrf32.h
  • dc_changepin_4428() : dcrf32.h
  • dc_changepin_4428_hex() : dcrf32.h
  • dc_changepin_4442() : dcrf32.h
  • dc_changepin_4442_hex() : dcrf32.h
  • dc_check2dot4Gbaund() : dcrf32.h
  • dc_check_102() : dcrf32.h
  • dc_check_153() : dcrf32.h
  • dc_check_1604() : dcrf32.h
  • dc_check_1608() : dcrf32.h
  • dc_Check_24C01() : dcrf32.h
  • dc_Check_24C02() : dcrf32.h
  • dc_Check_24C04() : dcrf32.h
  • dc_Check_24C08() : dcrf32.h
  • dc_Check_24C16() : dcrf32.h
  • dc_Check_24C64() : dcrf32.h
  • dc_Check_4428() : dcrf32.h
  • dc_Check_4442() : dcrf32.h
  • dc_check_auth_153() : dcrf32.h
  • dc_check_auth_153_hex() : dcrf32.h
  • dc_check_auth_1608() : dcrf32.h
  • dc_check_auth_1608_hex() : dcrf32.h
  • dc_Check_CPU() : dcrf32.h
  • dc_check_write() : dcrf32.h
  • dc_check_write_hex() : dcrf32.h
  • dc_check_writehex() : dcrf32.h
  • dc_CheckCard() : dcrf32.h
  • dc_checkcopy_m1() : dcrf32.h
  • dc_checkpass_102() : dcrf32.h
  • dc_checkpass_102_hex() : dcrf32.h
  • dc_checkpass_153() : dcrf32.h
  • dc_checkpass_153_hex() : dcrf32.h
  • dc_checkpass_1604() : dcrf32.h
  • dc_checkpass_1604_hex() : dcrf32.h
  • dc_checkpass_1608() : dcrf32.h
  • dc_checkpass_1608_hex() : dcrf32.h
  • dc_CheckPinpadWithReaderBaudrate() : dcrf32.h
  • dc_checkprint() : dcrf32.h
  • dc_ClearDeviceConfig() : dcrf32.h
  • dc_clearlcd_T8() : dcrf32.h
  • dc_clr_control_bit() : dcrf32.h
  • dc_command() : dcrf32.h
  • dc_command_hex() : dcrf32.h
  • dc_config() : dcrf32.h
  • dc_Config2DBarcode() : dcrf32.h
  • dc_config_card() : dcrf32.h
  • dc_config_port_name() : dcrf32.h
  • dc_ConfigTempIpAddress() : dcrf32.h
  • dc_consume_wallet() : dcrf32.h
  • dc_cpuapdu() : dcrf32.h
  • dc_cpuapdu_hex() : dcrf32.h
  • dc_cpuapduEXT() : dcrf32.h
  • dc_cpuapduEXT_hex() : dcrf32.h
  • dc_cpuapduInt() : dcrf32.h
  • dc_cpuapduInt_hex() : dcrf32.h
  • dc_cpuapdurespon() : dcrf32.h
  • dc_cpuapdurespon_hex() : dcrf32.h
  • dc_cpuapduresponInt() : dcrf32.h
  • dc_cpuapduresponInt_hex() : dcrf32.h
  • dc_cpuapdusource() : dcrf32.h
  • dc_cpuapdusource_hex() : dcrf32.h
  • dc_cpuapdusourceEXT() : dcrf32.h
  • dc_cpuapdusourceEXT_hex() : dcrf32.h
  • dc_CpuCardStatus() : dcrf32.h
  • dc_cpudown() : dcrf32.h
  • dc_cpuhotreset() : dcrf32.h
  • dc_cpuhotreset_hex() : dcrf32.h
  • dc_cpureset() : dcrf32.h
  • dc_cpureset_hex() : dcrf32.h
  • dc_cpy_cpuapdu() : dcrf32.h
  • dc_cpy_cpuapdu_hex() : dcrf32.h
  • dc_cpy_cpuapduInt() : dcrf32.h
  • dc_cpy_cpuapduInt_hex() : dcrf32.h
  • dc_cpy_getkey() : dcrf32.h
  • dc_cpy_procommand() : dcrf32.h
  • dc_cpy_procommand_hex() : dcrf32.h
  • dc_cpy_procommandInt() : dcrf32.h
  • dc_cpy_procommandInt_hex() : dcrf32.h
  • dc_cpy_setkey() : dcrf32.h
  • dc_creat_mac() : dcrf32.h
  • dc_creat_mac2() : dcrf32.h
  • dc_creat_mac2_hex() : dcrf32.h
  • dc_creat_mac_hex() : dcrf32.h
  • dc_CreatDesData() : dcrf32.h
  • dc_CreatDesDataECB() : dcrf32.h
  • dc_CreatMacDataECB() : dcrf32.h
  • dc_CreatSm4Data() : dcrf32.h
  • dc_CreatSm4DataECB() : dcrf32.h
  • dc_ctl_mode() : dcrf32.h
  • dc_ctlbacklight() : dcrf32.h
  • dc_ctlled() : dcrf32.h
  • dc_CvCapture() : dcrf32.h
  • dc_CvClose() : dcrf32.h
  • dc_CvLibLoad() : dcrf32.h
  • dc_CvLibUnload() : dcrf32.h
  • dc_CvOpen() : dcrf32.h
  • dc_decrement() : dcrf32.h
  • dc_decrement_ml() : dcrf32.h
  • dc_decrypt() : dcrf32.h
  • dc_decrypt_hex() : dcrf32.h
  • dc_des() : dcrf32.h
  • dc_des_hex() : dcrf32.h
  • dc_disp_mode() : dcrf32.h
  • dc_disp_neg() : dcrf32.h
  • dc_disp_str() : dcrf32.h
  • dc_dispinfo() : dcrf32.h
  • dc_dispinfo_pro_T8() : dcrf32.h
  • dc_dispinfo_T8() : dcrf32.h
  • dc_display_2dbarcode() : dcrf32.h
  • dc_displcd() : dcrf32.h
  • dc_displcd_ext() : dcrf32.h
  • dc_displow_T8() : dcrf32.h
  • dc_dispmaininfo() : dcrf32.h
  • dc_dispmainmenu() : dcrf32.h
  • dc_dispmap_T8() : dcrf32.h
  • dc_down_102() : dcrf32.h
  • dc_down_153() : dcrf32.h
  • dc_down_1604() : dcrf32.h
  • dc_down_1608() : dcrf32.h
  • dc_down_4428() : dcrf32.h
  • dc_down_4442() : dcrf32.h
  • dc_DownloadFileData() : dcrf32.h
  • dc_encrypt() : dcrf32.h
  • dc_encrypt_hex() : dcrf32.h
  • dc_end_i_d() : dcrf32.h
  • dc_erase_random() : dcrf32.h
  • dc_exchangeblock() : dcrf32.h
  • dc_exchangeblock_hex() : dcrf32.h
  • dc_exit() : dcrf32.h
  • dc_find_i_d() : dcrf32.h
  • dc_find_i_d_2() : dcrf32.h
  • dc_find_i_d_speed() : dcrf32.h
  • dc_fingerprint_io_control() : dcrf32.h
  • dc_flash_card() : dcrf32.h
  • dc_FlashErase() : dcrf32.h
  • dc_fuse_102() : dcrf32.h
  • dc_fuse_1604() : dcrf32.h
  • dc_get55data() : dcrf32.h
  • dc_get_hardwareserialnumber() : dcrf32.h
  • dc_get_i_d_raw_buffer() : dcrf32.h
  • dc_get_idsnr() : dcrf32.h
  • dc_get_idsnr_hex() : dcrf32.h
  • dc_get_record() : dcrf32.h
  • dc_get_securityinfo() : dcrf32.h
  • dc_get_securityinfo_hex() : dcrf32.h
  • dc_get_signmessageparameters() : dcrf32.h
  • dc_get_systeminfo() : dcrf32.h
  • dc_get_systeminfo_hex() : dcrf32.h
  • dc_get_terminalnumber() : dcrf32.h
  • dc_get_trademerchantcode() : dcrf32.h
  • dc_get_tradesecretkey() : dcrf32.h
  • dc_get_transactiontype() : dcrf32.h
  • dc_GetBankAccountNumber() : dcrf32.h
  • dc_GetBankMagInfo() : dcrf32.h
  • dc_GetBatteryValue() : dcrf32.h
  • dc_GetChipIdNumber() : dcrf32.h
  • dc_GetCpuCard616C() : dcrf32.h
  • dc_GetCpuCardPps() : dcrf32.h
  • dc_getcpupara() : dcrf32.h
  • dc_GetDeviceBaud() : dcrf32.h
  • dc_GetDeviceTerminalNumber() : dcrf32.h
  • dc_getdevicetime() : dcrf32.h
  • dc_GetDeviceTradeNumber() : dcrf32.h
  • dc_GetDeviceUid() : dcrf32.h
  • dc_GetEnPass() : dcrf32.h
  • dc_getfingerdata() : dcrf32.h
  • dc_getinputkey() : dcrf32.h
  • dc_getinputpass() : dcrf32.h
  • dc_GetInputPass() : dcrf32.h
  • dc_GetLastResponseCode() : dcrf32.h
  • dc_getlongver() : dcrf32.h
  • dc_GetMag() : dcrf32.h
  • dc_GetMagFormat() : dcrf32.h
  • dc_getname() : dcrf32.h
  • dc_getrcinfo() : dcrf32.h
  • dc_getrcinfo_hex() : dcrf32.h
  • dc_getsnr_fm11rf005() : dcrf32.h
  • dc_getsnr_fm11rf005_hex() : dcrf32.h
  • dc_gettime() : dcrf32.h
  • dc_gettime_hex() : dcrf32.h
  • dc_gettimehex() : dcrf32.h
  • dc_getuid_i_d() : dcrf32.h
  • dc_GetUsbMode() : dcrf32.h
  • dc_getver() : dcrf32.h
  • dc_GlyProCommand() : dcrf32.h
  • dc_GlyProCommand_hex() : dcrf32.h
  • dc_GpsGetInfo() : dcrf32.h
  • dc_halt() : dcrf32.h
  • dc_halt_shc1102() : dcrf32.h
  • dc_high_disp() : dcrf32.h
  • dc_HL_authentication() : dcrf32.h
  • dc_HL_read() : dcrf32.h
  • dc_HL_read_hex() : dcrf32.h
  • dc_HL_readhex() : dcrf32.h
  • dc_HL_write() : dcrf32.h
  • dc_HL_write_hex() : dcrf32.h
  • dc_HL_writehex() : dcrf32.h
  • dc_hltb() : dcrf32.h
  • dc_i_d_query_address() : dcrf32.h
  • dc_i_d_query_address_2() : dcrf32.h
  • dc_i_d_query_birth() : dcrf32.h
  • dc_i_d_query_birth_2() : dcrf32.h
  • dc_i_d_query_department() : dcrf32.h
  • dc_i_d_query_department_2() : dcrf32.h
  • dc_i_d_query_expire_day() : dcrf32.h
  • dc_i_d_query_expire_day_2() : dcrf32.h
  • dc_i_d_query_finger() : dcrf32.h
  • dc_i_d_query_finger_2() : dcrf32.h
  • dc_i_d_query_finger_bmp_buffer() : dcrf32.h
  • dc_i_d_query_finger_file() : dcrf32.h
  • dc_i_d_query_finger_len() : dcrf32.h
  • dc_i_d_query_id_number() : dcrf32.h
  • dc_i_d_query_id_number_2() : dcrf32.h
  • dc_i_d_query_name() : dcrf32.h
  • dc_i_d_query_name_2() : dcrf32.h
  • dc_i_d_query_nation() : dcrf32.h
  • dc_i_d_query_nation_2() : dcrf32.h
  • dc_i_d_query_photo() : dcrf32.h
  • dc_i_d_query_photo_2() : dcrf32.h
  • dc_i_d_query_photo_bmp_buffer() : dcrf32.h
  • dc_i_d_query_photo_file() : dcrf32.h
  • dc_i_d_query_photo_len() : dcrf32.h
  • dc_i_d_query_sex() : dcrf32.h
  • dc_i_d_query_sex_2() : dcrf32.h
  • dc_IdCardImageBuild() : dcrf32.h
  • dc_IdCardReadCardInfo() : dcrf32.h
  • dc_increment() : dcrf32.h
  • dc_init() : dcrf32.h
  • dc_init_485() : dcrf32.h
  • dc_init_auth_153() : dcrf32.h
  • dc_init_auth_153_hex() : dcrf32.h
  • dc_init_auth_1608() : dcrf32.h
  • dc_init_auth_1608_hex() : dcrf32.h
  • dc_init_name() : dcrf32.h
  • dc_initval() : dcrf32.h
  • dc_initval_ml() : dcrf32.h
  • dc_InstallKbKey() : dcrf32.h
  • dc_inventory() : dcrf32.h
  • dc_inventory_hex() : dcrf32.h
  • dc_keypad_DeleteKey() : dcrf32.h
  • dc_keypad_End() : dcrf32.h
  • dc_keypad_GetDecryptDataOfCBC() : dcrf32.h
  • dc_keypad_GetDecryptDataOfECB() : dcrf32.h
  • dc_keypad_GetEncryptDataOfCBC() : dcrf32.h
  • dc_keypad_GetEncryptDataOfECB() : dcrf32.h
  • dc_keypad_GetMACDataOfCBC() : dcrf32.h
  • dc_keypad_GetPinBlock() : dcrf32.h
  • dc_keypad_GetPressed() : dcrf32.h
  • dc_keypad_GetRandomValue() : dcrf32.h
  • dc_keypad_ImportKey() : dcrf32.h
  • dc_keypad_io_control() : dcrf32.h
  • dc_keypad_SetButtonMark() : dcrf32.h
  • dc_keypad_Start() : dcrf32.h
  • dc_KeypadAlgorithm() : dcrf32.h
  • dc_KeypadClearKey() : dcrf32.h
  • dc_KeypadClose() : dcrf32.h
  • dc_KeypadExitAndGetInput() : dcrf32.h
  • dc_KeypadGetKeyType() : dcrf32.h
  • dc_KeypadGetKeyValue() : dcrf32.h
  • dc_KeypadLoadKey() : dcrf32.h
  • dc_KeypadOpen() : dcrf32.h
  • dc_KeypadSetKeyValue() : dcrf32.h
  • dc_KeypadStartInput() : dcrf32.h
  • dc_lcdclrscrn() : dcrf32.h
  • dc_LcdDisplay() : dcrf32.h
  • dc_LcdDisplayText() : dcrf32.h
  • dc_LcdDisplayTextFromData() : dcrf32.h
  • dc_led_T8() : dcrf32.h
  • dc_LedControl() : dcrf32.h
  • dc_LedDisplay() : dcrf32.h
  • dc_light() : dcrf32.h
  • dc_load_key() : dcrf32.h
  • dc_load_key_hex() : dcrf32.h
  • dc_load_voice() : dcrf32.h
  • dc_lock_afi() : dcrf32.h
  • dc_lock_afi_hex() : dcrf32.h
  • dc_lock_block() : dcrf32.h
  • dc_lock_block_hex() : dcrf32.h
  • dc_lock_dsfid() : dcrf32.h
  • dc_lock_dsfid_hex() : dcrf32.h
  • dc_MagFormatConfig() : dcrf32.h
  • dc_mfdes_auth() : dcrf32.h
  • dc_mfdes_auth_hex() : dcrf32.h
  • dc_mfdes_baud() : dcrf32.h
  • dc_MFPL0_commitperso() : dcrf32.h
  • dc_MFPL0_writeperso() : dcrf32.h
  • dc_MFPL0_writeperso_hex() : dcrf32.h
  • dc_MFPL1_authl1key() : dcrf32.h
  • dc_MFPL1_authl1key_hex() : dcrf32.h
  • dc_MFPL1_switchtol2() : dcrf32.h
  • dc_MFPL1_switchtol3() : dcrf32.h
  • dc_MFPL2_switchtol3() : dcrf32.h
  • dc_MFPL3_authl3key() : dcrf32.h
  • dc_MFPL3_authl3key_hex() : dcrf32.h
  • dc_MFPL3_authl3sectorkey() : dcrf32.h
  • dc_MFPL3_authl3sectorkey_hex() : dcrf32.h
  • dc_MFPL3_readencrypted() : dcrf32.h
  • dc_MFPL3_readencrypted_hex() : dcrf32.h
  • dc_MFPL3_readinplain() : dcrf32.h
  • dc_MFPL3_readinplain_hex() : dcrf32.h
  • dc_MFPL3_writeencrypted() : dcrf32.h
  • dc_MFPL3_writeencrypted_hex() : dcrf32.h
  • dc_MFPL3_writeinplain() : dcrf32.h
  • dc_MFPL3_writeinplain_hex() : dcrf32.h
  • dc_mulrequest_b() : dcrf32.h
  • dc_MultiAntennaGetCardStatus() : dcrf32.h
  • dc_MultiAntennaStartOrStop() : dcrf32.h
  • dc_MulticardStatus() : dcrf32.h
  • dc_MultiFlashErase() : dcrf32.h
  • dc_MultiFlashGetSize() : dcrf32.h
  • dc_MultiFlashRead() : dcrf32.h
  • dc_MultiFlashWrite() : dcrf32.h
  • dc_NfcActivate() : dcrf32.h
  • dc_NfcDataReceiver() : dcrf32.h
  • dc_NfcDeactivate() : dcrf32.h
  • dc_NfcFetch() : dcrf32.h
  • dc_NfcInit() : dcrf32.h
  • dc_NfcPush() : dcrf32.h
  • dc_NfcService() : dcrf32.h
  • dc_NfcSimulateCardConfig() : dcrf32.h
  • dc_NtagCommand() : dcrf32.h
  • dc_open_door() : dcrf32.h
  • dc_open_timedoor() : dcrf32.h
  • dc_ParseOtherInfo() : dcrf32.h
  • dc_ParsePhotoInfo() : dcrf32.h
  • dc_ParseTextInfo() : dcrf32.h
  • dc_ParseTextInfoForForeigner() : dcrf32.h
  • dc_ParseTextInfoForHkMoTw() : dcrf32.h
  • dc_pass_key_value() : dcrf32.h
  • dc_pass_key_value2() : dcrf32.h
  • dc_passcancel() : dcrf32.h
  • dc_PassCancel() : dcrf32.h
  • dc_PassGet() : dcrf32.h
  • dc_passget() : dcrf32.h
  • dc_passin() : dcrf32.h
  • dc_PassIn() : dcrf32.h
  • dc_passin2() : dcrf32.h
  • dc_PassIn2() : dcrf32.h
  • dc_PinpadCommunication() : dcrf32.h
  • dc_play_voice() : dcrf32.h
  • dc_playvoice() : dcrf32.h
  • dc_posbeep() : dcrf32.h
  • dc_printcharacter() : dcrf32.h
  • dc_printenter() : dcrf32.h
  • dc_printOnedimensional() : dcrf32.h
  • dc_printPicture() : dcrf32.h
  • dc_printstatus() : dcrf32.h
  • dc_pro_command() : dcrf32.h
  • dc_pro_command_hex() : dcrf32.h
  • dc_pro_commandhex() : dcrf32.h
  • dc_pro_commandlink() : dcrf32.h
  • dc_pro_commandlink_hex() : dcrf32.h
  • dc_pro_commandlinkEXT() : dcrf32.h
  • dc_pro_commandlinkEXT_hex() : dcrf32.h
  • dc_pro_commandlinkInt() : dcrf32.h
  • dc_pro_commandlinkInt_hex() : dcrf32.h
  • dc_pro_commandsource() : dcrf32.h
  • dc_pro_commandsource_hex() : dcrf32.h
  • dc_pro_commandsource_int() : dcrf32.h
  • dc_pro_commandsourceCRC() : dcrf32.h
  • dc_pro_commandsourceCRChex() : dcrf32.h
  • dc_pro_commandsourcehex() : dcrf32.h
  • dc_pro_halt() : dcrf32.h
  • dc_pro_receivecommandsource() : dcrf32.h
  • dc_pro_reset() : dcrf32.h
  • dc_pro_reset_hex() : dcrf32.h
  • dc_pro_resethex() : dcrf32.h
  • dc_pro_resetInt() : dcrf32.h
  • dc_pro_resetInt_hex() : dcrf32.h
  • dc_pro_sendcommandsource() : dcrf32.h
  • dc_procommandInt() : dcrf32.h
  • dc_procommandInt_hex() : dcrf32.h
  • dc_read() : dcrf32.h
  • dc_read1024() : dcrf32.h
  • dc_read1024_hex() : dcrf32.h
  • dc_read_102() : dcrf32.h
  • dc_read_102_hex() : dcrf32.h
  • dc_read_153() : dcrf32.h
  • dc_read_153_hex() : dcrf32.h
  • dc_read_1604() : dcrf32.h
  • dc_read_1604_hex() : dcrf32.h
  • dc_read_1608() : dcrf32.h
  • dc_read_1608_hex() : dcrf32.h
  • dc_read_24c() : dcrf32.h
  • dc_read_24c64() : dcrf32.h
  • dc_read_24c64_hex() : dcrf32.h
  • dc_read_24c_hex() : dcrf32.h
  • dc_read_4428() : dcrf32.h
  • dc_read_4428_hex() : dcrf32.h
  • dc_read_4442() : dcrf32.h
  • dc_read_4442_hex() : dcrf32.h
  • dc_read_fm11rf005() : dcrf32.h
  • dc_read_fm11rf005_hex() : dcrf32.h
  • dc_read_fuse_153() : dcrf32.h
  • dc_read_fuse_1608() : dcrf32.h
  • dc_read_hex() : dcrf32.h
  • dc_read_idcard() : dcrf32.h
  • dc_read_idcard_hex() : dcrf32.h
  • dc_read_random() : dcrf32.h
  • dc_read_random_hex() : dcrf32.h
  • dc_read_shc1102() : dcrf32.h
  • dc_read_walletbalance() : dcrf32.h
  • dc_readblock() : dcrf32.h
  • dc_readblock_hex() : dcrf32.h
  • dc_readcount_102() : dcrf32.h
  • dc_readcount_1604() : dcrf32.h
  • dc_ReadDeviceCustomInfo() : dcrf32.h
  • dc_ReadDeviceCustomSerialNumber() : dcrf32.h
  • dc_ReadDeviceTypeName() : dcrf32.h
  • dc_readdevsnr() : dcrf32.h
  • dc_ReadFlash() : dcrf32.h
  • dc_ReadIdCardInfo() : dcrf32.h
  • dc_readmag() : dcrf32.h
  • dc_readmagcard() : dcrf32.h
  • dc_readmagcardall() : dcrf32.h
  • dc_readmagcardallA() : dcrf32.h
  • dc_ReadModuleMacAddress() : dcrf32.h
  • dc_ReadNicMacAddress() : dcrf32.h
  • dc_ReadOutEeprom() : dcrf32.h
  • dc_readpin_4428() : dcrf32.h
  • dc_readpin_4428_hex() : dcrf32.h
  • dc_readpin_4442() : dcrf32.h
  • dc_readpin_4442_hex() : dcrf32.h
  • dc_readpincount_4428() : dcrf32.h
  • dc_readpincount_4442() : dcrf32.h
  • dc_readprotect_4428() : dcrf32.h
  • dc_readprotect_4428_hex() : dcrf32.h
  • dc_readprotect_4442() : dcrf32.h
  • dc_readprotect_4442_hex() : dcrf32.h
  • dc_readreadersnr() : dcrf32.h
  • dc_ReadRfCfgReg() : dcrf32.h
  • dc_ReadRfTypeABATS() : dcrf32.h
  • dc_ReadRfTypeABATS_hex() : dcrf32.h
  • dc_readSD() : dcrf32.h
  • dc_readval() : dcrf32.h
  • dc_readval_ml() : dcrf32.h
  • dc_readwrotect_4442() : dcrf32.h
  • dc_readwrotect_4442_hex() : dcrf32.h
  • dc_RefreshAndDisplayMainUI() : dcrf32.h
  • dc_request() : dcrf32.h
  • dc_request_b() : dcrf32.h
  • dc_request_shc1102() : dcrf32.h
  • dc_RequestMultiCard() : dcrf32.h
  • dc_reset() : dcrf32.h
  • dc_reset_factory() : dcrf32.h
  • dc_reset_to_ready() : dcrf32.h
  • dc_reset_to_ready_hex() : dcrf32.h
  • dc_resetdevice() : dcrf32.h
  • dc_RestDevice() : dcrf32.h
  • dc_restore() : dcrf32.h
  • dc_rf_application() : dcrf32.h
  • dc_rf_getstatus() : dcrf32.h
  • dc_rf_poweroff() : dcrf32.h
  • dc_rf_poweron() : dcrf32.h
  • dc_RfCrcModeConfig() : dcrf32.h
  • dc_RfFormatConfig() : dcrf32.h
  • dc_RfGetCardType() : dcrf32.h
  • dc_RfMarch() : dcrf32.h
  • dc_RfMultiRequest() : dcrf32.h
  • dc_RfReadChipRegister() : dcrf32.h
  • dc_RfSetChipRegister() : dcrf32.h
  • dc_RfWaveControl() : dcrf32.h
  • dc_rw_rfreg() : dcrf32.h
  • dc_rw_rfreg_hex() : dcrf32.h
  • dc_SamAControl() : dcrf32.h
  • dc_SamAReadCardInfo() : dcrf32.h
  • dc_SamAReadSerialNumber() : dcrf32.h
  • dc_Scan2DBarcode() : dcrf32.h
  • dc_Scan2DBarcodeExit() : dcrf32.h
  • dc_Scan2DBarcodeGetData() : dcrf32.h
  • dc_Scan2DBarcodeStart() : dcrf32.h
  • dc_ScreenClearDisplay() : dcrf32.h
  • dc_ScreenDisplayBgImage() : dcrf32.h
  • dc_ScreenDisplayBgImageByColor() : dcrf32.h
  • dc_ScreenDisplayGetConfig() : dcrf32.h
  • dc_ScreenDisplayImage() : dcrf32.h
  • dc_ScreenDisplaySetConfig() : dcrf32.h
  • dc_ScreenDisplayText() : dcrf32.h
  • dc_ScreenLoadBgImage() : dcrf32.h
  • dc_select() : dcrf32.h
  • dc_select2() : dcrf32.h
  • dc_select_mode() : dcrf32.h
  • dc_select_uid() : dcrf32.h
  • dc_select_uid_hex() : dcrf32.h
  • dc_SelectAntenna() : dcrf32.h
  • dc_SelfServiceDeviceCardEject() : dcrf32.h
  • dc_SelfServiceDeviceCardInject() : dcrf32.h
  • dc_SelfServiceDeviceCardMove() : dcrf32.h
  • dc_SelfServiceDeviceCardStatus() : dcrf32.h
  • dc_SelfServiceDeviceCheckCardType() : dcrf32.h
  • dc_SelfServiceDeviceConfig() : dcrf32.h
  • dc_SelfServiceDeviceConfigBack() : dcrf32.h
  • dc_SelfServiceDeviceConfigFront() : dcrf32.h
  • dc_SelfServiceDeviceConfigPlace() : dcrf32.h
  • dc_SelfServiceDeviceGetFrontSwitch() : dcrf32.h
  • dc_SelfServiceDeviceRecoverError() : dcrf32.h
  • dc_SelfServiceDeviceReset() : dcrf32.h
  • dc_SelfServiceDeviceSensorStatus() : dcrf32.h
  • dc_SelfServiceDeviceSetFrontSwitch() : dcrf32.h
  • dc_SelfServiceDeviceShakeConfig() : dcrf32.h
  • dc_SelfServiceDeviceWriteMagConfig() : dcrf32.h
  • dc_send_sms() : dcrf32.h
  • dc_set2dot4Gbaund() : dcrf32.h
  • dc_set_addr() : dcrf32.h
  • dc_set_control_bit() : dcrf32.h
  • dc_set_hardwareserialnumber() : dcrf32.h
  • dc_set_poweroff() : dcrf32.h
  • dc_set_terminalnumber() : dcrf32.h
  • dc_set_trademerchantcode() : dcrf32.h
  • dc_set_tradesecretkey() : dcrf32.h
  • dc_set_transactiontype() : dcrf32.h
  • dc_setbright() : dcrf32.h
  • dc_setcpu() : dcrf32.h
  • dc_SetCpuCard616C() : dcrf32.h
  • dc_SetCpuCardPps() : dcrf32.h
  • dc_setcpupara() : dcrf32.h
  • dc_SetCpuVoltage() : dcrf32.h
  • dc_setdevicebaud() : dcrf32.h
  • dc_setdevicetime() : dcrf32.h
  • dc_SetEMVPara() : dcrf32.h
  • dc_SetKbKeyID() : dcrf32.h
  • dc_setmag() : dcrf32.h
  • dc_SetPinpadWithReaderBaudrate() : dcrf32.h
  • dc_setprint() : dcrf32.h
  • dc_settime() : dcrf32.h
  • dc_settime_hex() : dcrf32.h
  • dc_settimehex() : dcrf32.h
  • dc_SetUsbMode() : dcrf32.h
  • dc_setusbtimeout() : dcrf32.h
  • dc_slotmarker() : dcrf32.h
  • dc_srd_eeprom() : dcrf32.h
  • dc_srd_eeprom_hex() : dcrf32.h
  • dc_srd_eepromhex() : dcrf32.h
  • dc_start_i_d() : dcrf32.h
  • dc_start_i_d_2() : dcrf32.h
  • dc_startreadmag() : dcrf32.h
  • dc_stay_quiet() : dcrf32.h
  • dc_stay_quiet_hex() : dcrf32.h
  • dc_stopreadmag() : dcrf32.h
  • dc_switch_linux() : dcrf32.h
  • dc_switch_unix() : dcrf32.h
  • dc_swr_eeprom() : dcrf32.h
  • dc_swr_eeprom_hex() : dcrf32.h
  • dc_swr_eepromhex() : dcrf32.h
  • dc_TcpGetInfo() : dcrf32.h
  • dc_TestCom() : dcrf32.h
  • dc_testdevicecomm() : dcrf32.h
  • dc_TestNic() : dcrf32.h
  • dc_TestUsb() : dcrf32.h
  • dc_transfer() : dcrf32.h
  • dc_transfer_wallet() : dcrf32.h
  • dc_tripledes() : dcrf32.h
  • dc_tripledes_hex() : dcrf32.h
  • dc_TtsVoiceConfig() : dcrf32.h
  • dc_TtsVoicePlay() : dcrf32.h
  • dc_typeab_card_status() : dcrf32.h
  • dc_update() : dcrf32.h
  • dc_verifypin_4428() : dcrf32.h
  • dc_verifypin_4428_hex() : dcrf32.h
  • dc_verifypin_4442() : dcrf32.h
  • dc_verifypin_4442_hex() : dcrf32.h
  • dc_VoicePlayAndDisplay() : dcrf32.h
  • dc_WakeDevice() : dcrf32.h
  • dc_WirelessGetStatus() : dcrf32.h
  • dc_WirelessPowerControl() : dcrf32.h
  • dc_WirelessRecv() : dcrf32.h
  • dc_WirelessSend() : dcrf32.h
  • dc_WirelessTcpClose() : dcrf32.h
  • dc_WirelessTcpOpen() : dcrf32.h
  • dc_WirelessWifiConfig() : dcrf32.h
  • dc_write() : dcrf32.h
  • dc_write1024() : dcrf32.h
  • dc_write1024_hex() : dcrf32.h
  • dc_write_102() : dcrf32.h
  • dc_write_102_hex() : dcrf32.h
  • dc_write_153() : dcrf32.h
  • dc_write_153_hex() : dcrf32.h
  • dc_write_1604() : dcrf32.h
  • dc_write_1604_hex() : dcrf32.h
  • dc_write_1608() : dcrf32.h
  • dc_write_1608_hex() : dcrf32.h
  • dc_write_24c() : dcrf32.h
  • dc_write_24c64() : dcrf32.h
  • dc_write_24c64_hex() : dcrf32.h
  • dc_write_24c_hex() : dcrf32.h
  • dc_write_4428() : dcrf32.h
  • dc_write_4428_hex() : dcrf32.h
  • dc_write_4442() : dcrf32.h
  • dc_write_4442_hex() : dcrf32.h
  • dc_write_afi() : dcrf32.h
  • dc_write_afi_hex() : dcrf32.h
  • dc_write_dsfid() : dcrf32.h
  • dc_write_dsfid_hex() : dcrf32.h
  • dc_write_fm11rf005() : dcrf32.h
  • dc_write_fm11rf005_hex() : dcrf32.h
  • dc_write_fuse_153() : dcrf32.h
  • dc_write_fuse_1608() : dcrf32.h
  • dc_write_hex() : dcrf32.h
  • dc_write_random() : dcrf32.h
  • dc_write_random_hex() : dcrf32.h
  • dc_write_shc1102() : dcrf32.h
  • dc_write_TS() : dcrf32.h
  • dc_writeblock() : dcrf32.h
  • dc_writeblock_hex() : dcrf32.h
  • dc_WriteDeviceCustomInfo() : dcrf32.h
  • dc_WriteDeviceCustomSerialNumber() : dcrf32.h
  • dc_WriteDeviceTypeName() : dcrf32.h
  • dc_WriteFlash() : dcrf32.h
  • dc_writemagcard() : dcrf32.h
  • dc_WriteModuleMacAddress() : dcrf32.h
  • dc_WriteNicMacAddress() : dcrf32.h
  • dc_WriteOutEeprom() : dcrf32.h
  • dc_writeprotect_4428() : dcrf32.h
  • dc_writeprotect_4428_hex() : dcrf32.h
  • dc_writeprotect_4442() : dcrf32.h
  • dc_writeprotect_4442_hex() : dcrf32.h
  • dc_WriteRfCfgReg() : dcrf32.h
  • dc_writeSD() : dcrf32.h
  • dcdes() : dcrf32.h
  • dcdeshex() : dcrf32.h
  • DCDEV_CommandMcu() : dcrf32.h
  • DCDEV_CommandMcu_Hex() : dcrf32.h


这里列出了所有文档化的文件成员,并附带其详细说明:

- h -

  • hex_a() : dcrf32.h


这里列出了所有文档化的文件成员,并附带其详细说明:

- l -

  • LibMain() : dcrf32.h


这里列出了所有文档化的文件成员,并附带其详细说明:

- s -

  • SD_IFD_ActWorkKey() : dcrf32.h
  • SD_IFD_CreateMac() : dcrf32.h
  • SD_IFD_DES() : dcrf32.h
  • SD_IFD_DesCaculate() : dcrf32.h
  • SD_IFD_GetEnPIN() : dcrf32.h
  • SD_IFD_GetEnPINBlock() : dcrf32.h
  • SD_IFD_GetEnPINPro() : dcrf32.h
  • SD_IFD_GetPIN() : dcrf32.h
  • SD_IFD_GetPINPro() : dcrf32.h
  • SD_IFD_GetVersion() : dcrf32.h
  • SD_IFD_Init() : dcrf32.h
  • SD_IFD_LEDDisplay() : dcrf32.h
  • SD_IFD_PlayVoice() : dcrf32.h
  • SD_IFD_Scan2DBarcodeExit() : dcrf32.h
  • SD_IFD_Scan2DBarcodeGetData() : dcrf32.h
  • SD_IFD_Scan2DBarcodeStart() : dcrf32.h
  • SD_IFD_SelecetDes() : dcrf32.h
  • SD_IFD_SetKeyLength() : dcrf32.h
  • SD_IFD_SetMainKey() : dcrf32.h
  • SD_IFD_SetWorkKey() : dcrf32.h
  • SD_InstallKey() : dcrf32.h
  • srd_alleeprom() : dcrf32.h
  • swr_alleeprom() : dcrf32.h


- a -

  • a_hex() : dcrf32.h


- d -

  • dc_2dot4_command() : dcrf32.h
  • dc_2dot4_command_hex() : dcrf32.h
  • dc_2dot4_reset() : dcrf32.h
  • dc_2dot4_resethex() : dcrf32.h
  • dc_2dot4Apdu() : dcrf32.h
  • dc_2dot4Apdu_hex() : dcrf32.h
  • dc_ActivateCard() : dcrf32.h
  • dc_anticoll() : dcrf32.h
  • dc_anticoll2() : dcrf32.h
  • dc_anticoll_mode() : dcrf32.h
  • dc_attrib() : dcrf32.h
  • dc_attribInt() : dcrf32.h
  • dc_auth_shc1102() : dcrf32.h
  • dc_auth_ulc() : dcrf32.h
  • dc_auth_ulc_hex() : dcrf32.h
  • dc_authentication() : dcrf32.h
  • dc_authentication_2() : dcrf32.h
  • dc_authentication_key() : dcrf32.h
  • dc_authentication_pass() : dcrf32.h
  • dc_authentication_pass_hex() : dcrf32.h
  • dc_authentication_passaddr() : dcrf32.h
  • dc_authentication_passaddr_hex() : dcrf32.h
  • dc_beep() : dcrf32.h
  • dc_BtAddressControl() : dcrf32.h
  • dc_BtBaudrateControl() : dcrf32.h
  • dc_BtCommand() : dcrf32.h
  • dc_BtCommunicationTest() : dcrf32.h
  • dc_BtDataResponse() : dcrf32.h
  • dc_BtDataTransmit() : dcrf32.h
  • dc_BtModeControl() : dcrf32.h
  • dc_BtNameControl() : dcrf32.h
  • dc_BtPasswordControl() : dcrf32.h
  • dc_BtReset() : dcrf32.h
  • dc_BtSignalStrength() : dcrf32.h
  • dc_BtUserControl() : dcrf32.h
  • dc_BtWithReaderBaudrateControl() : dcrf32.h
  • dc_BuzzerBeep() : dcrf32.h
  • dc_CalculateDes() : dcrf32.h
  • dc_CalculateMACCheck() : dcrf32.h
  • dc_CalculateSm4() : dcrf32.h
  • dc_card() : dcrf32.h
  • dc_card_b() : dcrf32.h
  • dc_card_b_hex() : dcrf32.h
  • dc_card_double() : dcrf32.h
  • dc_card_double_hex() : dcrf32.h
  • dc_card_exist() : dcrf32.h
  • dc_card_fm11rf005() : dcrf32.h
  • dc_card_hex() : dcrf32.h
  • dc_card_make_and_lock() : dcrf32.h
  • dc_card_n() : dcrf32.h
  • dc_card_n_hex() : dcrf32.h
  • dc_card_n_number() : dcrf32.h
  • dc_card_status() : dcrf32.h
  • dc_card_status2() : dcrf32.h
  • dc_cardAB() : dcrf32.h
  • dc_CardIssuingScript() : dcrf32.h
  • dc_cardstr() : dcrf32.h
  • dc_change_addr() : dcrf32.h
  • dc_changeb3() : dcrf32.h
  • dc_changeb3_hex() : dcrf32.h
  • dc_changebaud_485() : dcrf32.h
  • dc_changekey_ulc() : dcrf32.h
  • dc_changekey_ulc_hex() : dcrf32.h
  • dc_changepass_102() : dcrf32.h
  • dc_changepass_102_hex() : dcrf32.h
  • dc_changepass_1604() : dcrf32.h
  • dc_changepass_1604_hex() : dcrf32.h
  • dc_changepin_4428() : dcrf32.h
  • dc_changepin_4428_hex() : dcrf32.h
  • dc_changepin_4442() : dcrf32.h
  • dc_changepin_4442_hex() : dcrf32.h
  • dc_check2dot4Gbaund() : dcrf32.h
  • dc_check_102() : dcrf32.h
  • dc_check_153() : dcrf32.h
  • dc_check_1604() : dcrf32.h
  • dc_check_1608() : dcrf32.h
  • dc_Check_24C01() : dcrf32.h
  • dc_Check_24C02() : dcrf32.h
  • dc_Check_24C04() : dcrf32.h
  • dc_Check_24C08() : dcrf32.h
  • dc_Check_24C16() : dcrf32.h
  • dc_Check_24C64() : dcrf32.h
  • dc_Check_4428() : dcrf32.h
  • dc_Check_4442() : dcrf32.h
  • dc_check_auth_153() : dcrf32.h
  • dc_check_auth_153_hex() : dcrf32.h
  • dc_check_auth_1608() : dcrf32.h
  • dc_check_auth_1608_hex() : dcrf32.h
  • dc_Check_CPU() : dcrf32.h
  • dc_check_write() : dcrf32.h
  • dc_check_write_hex() : dcrf32.h
  • dc_check_writehex() : dcrf32.h
  • dc_CheckCard() : dcrf32.h
  • dc_checkcopy_m1() : dcrf32.h
  • dc_checkpass_102() : dcrf32.h
  • dc_checkpass_102_hex() : dcrf32.h
  • dc_checkpass_153() : dcrf32.h
  • dc_checkpass_153_hex() : dcrf32.h
  • dc_checkpass_1604() : dcrf32.h
  • dc_checkpass_1604_hex() : dcrf32.h
  • dc_checkpass_1608() : dcrf32.h
  • dc_checkpass_1608_hex() : dcrf32.h
  • dc_CheckPinpadWithReaderBaudrate() : dcrf32.h
  • dc_checkprint() : dcrf32.h
  • dc_ClearDeviceConfig() : dcrf32.h
  • dc_clearlcd_T8() : dcrf32.h
  • dc_clr_control_bit() : dcrf32.h
  • dc_command() : dcrf32.h
  • dc_command_hex() : dcrf32.h
  • dc_config() : dcrf32.h
  • dc_Config2DBarcode() : dcrf32.h
  • dc_config_card() : dcrf32.h
  • dc_config_port_name() : dcrf32.h
  • dc_ConfigTempIpAddress() : dcrf32.h
  • dc_consume_wallet() : dcrf32.h
  • dc_cpuapdu() : dcrf32.h
  • dc_cpuapdu_hex() : dcrf32.h
  • dc_cpuapduEXT() : dcrf32.h
  • dc_cpuapduEXT_hex() : dcrf32.h
  • dc_cpuapduInt() : dcrf32.h
  • dc_cpuapduInt_hex() : dcrf32.h
  • dc_cpuapdurespon() : dcrf32.h
  • dc_cpuapdurespon_hex() : dcrf32.h
  • dc_cpuapduresponInt() : dcrf32.h
  • dc_cpuapduresponInt_hex() : dcrf32.h
  • dc_cpuapdusource() : dcrf32.h
  • dc_cpuapdusource_hex() : dcrf32.h
  • dc_cpuapdusourceEXT() : dcrf32.h
  • dc_cpuapdusourceEXT_hex() : dcrf32.h
  • dc_CpuCardStatus() : dcrf32.h
  • dc_cpudown() : dcrf32.h
  • dc_cpuhotreset() : dcrf32.h
  • dc_cpuhotreset_hex() : dcrf32.h
  • dc_cpureset() : dcrf32.h
  • dc_cpureset_hex() : dcrf32.h
  • dc_cpy_cpuapdu() : dcrf32.h
  • dc_cpy_cpuapdu_hex() : dcrf32.h
  • dc_cpy_cpuapduInt() : dcrf32.h
  • dc_cpy_cpuapduInt_hex() : dcrf32.h
  • dc_cpy_getkey() : dcrf32.h
  • dc_cpy_procommand() : dcrf32.h
  • dc_cpy_procommand_hex() : dcrf32.h
  • dc_cpy_procommandInt() : dcrf32.h
  • dc_cpy_procommandInt_hex() : dcrf32.h
  • dc_cpy_setkey() : dcrf32.h
  • dc_creat_mac() : dcrf32.h
  • dc_creat_mac2() : dcrf32.h
  • dc_creat_mac2_hex() : dcrf32.h
  • dc_creat_mac_hex() : dcrf32.h
  • dc_CreatDesData() : dcrf32.h
  • dc_CreatDesDataECB() : dcrf32.h
  • dc_CreatMacDataECB() : dcrf32.h
  • dc_CreatSm4Data() : dcrf32.h
  • dc_CreatSm4DataECB() : dcrf32.h
  • dc_ctl_mode() : dcrf32.h
  • dc_ctlbacklight() : dcrf32.h
  • dc_ctlled() : dcrf32.h
  • dc_CvCapture() : dcrf32.h
  • dc_CvClose() : dcrf32.h
  • dc_CvLibLoad() : dcrf32.h
  • dc_CvLibUnload() : dcrf32.h
  • dc_CvOpen() : dcrf32.h
  • dc_decrement() : dcrf32.h
  • dc_decrement_ml() : dcrf32.h
  • dc_decrypt() : dcrf32.h
  • dc_decrypt_hex() : dcrf32.h
  • dc_des() : dcrf32.h
  • dc_des_hex() : dcrf32.h
  • dc_disp_mode() : dcrf32.h
  • dc_disp_neg() : dcrf32.h
  • dc_disp_str() : dcrf32.h
  • dc_dispinfo() : dcrf32.h
  • dc_dispinfo_pro_T8() : dcrf32.h
  • dc_dispinfo_T8() : dcrf32.h
  • dc_display_2dbarcode() : dcrf32.h
  • dc_displcd() : dcrf32.h
  • dc_displcd_ext() : dcrf32.h
  • dc_displow_T8() : dcrf32.h
  • dc_dispmaininfo() : dcrf32.h
  • dc_dispmainmenu() : dcrf32.h
  • dc_dispmap_T8() : dcrf32.h
  • dc_down_102() : dcrf32.h
  • dc_down_153() : dcrf32.h
  • dc_down_1604() : dcrf32.h
  • dc_down_1608() : dcrf32.h
  • dc_down_4428() : dcrf32.h
  • dc_down_4442() : dcrf32.h
  • dc_DownloadFileData() : dcrf32.h
  • dc_encrypt() : dcrf32.h
  • dc_encrypt_hex() : dcrf32.h
  • dc_end_i_d() : dcrf32.h
  • dc_erase_random() : dcrf32.h
  • dc_exchangeblock() : dcrf32.h
  • dc_exchangeblock_hex() : dcrf32.h
  • dc_exit() : dcrf32.h
  • dc_find_i_d() : dcrf32.h
  • dc_find_i_d_2() : dcrf32.h
  • dc_find_i_d_speed() : dcrf32.h
  • dc_fingerprint_io_control() : dcrf32.h
  • dc_flash_card() : dcrf32.h
  • dc_FlashErase() : dcrf32.h
  • dc_fuse_102() : dcrf32.h
  • dc_fuse_1604() : dcrf32.h
  • dc_get55data() : dcrf32.h
  • dc_get_hardwareserialnumber() : dcrf32.h
  • dc_get_i_d_raw_buffer() : dcrf32.h
  • dc_get_idsnr() : dcrf32.h
  • dc_get_idsnr_hex() : dcrf32.h
  • dc_get_record() : dcrf32.h
  • dc_get_securityinfo() : dcrf32.h
  • dc_get_securityinfo_hex() : dcrf32.h
  • dc_get_signmessageparameters() : dcrf32.h
  • dc_get_systeminfo() : dcrf32.h
  • dc_get_systeminfo_hex() : dcrf32.h
  • dc_get_terminalnumber() : dcrf32.h
  • dc_get_trademerchantcode() : dcrf32.h
  • dc_get_tradesecretkey() : dcrf32.h
  • dc_get_transactiontype() : dcrf32.h
  • dc_GetBankAccountNumber() : dcrf32.h
  • dc_GetBankMagInfo() : dcrf32.h
  • dc_GetBatteryValue() : dcrf32.h
  • dc_GetChipIdNumber() : dcrf32.h
  • dc_GetCpuCard616C() : dcrf32.h
  • dc_GetCpuCardPps() : dcrf32.h
  • dc_getcpupara() : dcrf32.h
  • dc_GetDeviceBaud() : dcrf32.h
  • dc_GetDeviceTerminalNumber() : dcrf32.h
  • dc_getdevicetime() : dcrf32.h
  • dc_GetDeviceTradeNumber() : dcrf32.h
  • dc_GetDeviceUid() : dcrf32.h
  • dc_GetEnPass() : dcrf32.h
  • dc_getfingerdata() : dcrf32.h
  • dc_getinputkey() : dcrf32.h
  • dc_getinputpass() : dcrf32.h
  • dc_GetInputPass() : dcrf32.h
  • dc_GetLastResponseCode() : dcrf32.h
  • dc_getlongver() : dcrf32.h
  • dc_GetMag() : dcrf32.h
  • dc_GetMagFormat() : dcrf32.h
  • dc_getname() : dcrf32.h
  • dc_getrcinfo() : dcrf32.h
  • dc_getrcinfo_hex() : dcrf32.h
  • dc_getsnr_fm11rf005() : dcrf32.h
  • dc_getsnr_fm11rf005_hex() : dcrf32.h
  • dc_gettime() : dcrf32.h
  • dc_gettime_hex() : dcrf32.h
  • dc_gettimehex() : dcrf32.h
  • dc_getuid_i_d() : dcrf32.h
  • dc_GetUsbMode() : dcrf32.h
  • dc_getver() : dcrf32.h
  • dc_GlyProCommand() : dcrf32.h
  • dc_GlyProCommand_hex() : dcrf32.h
  • dc_GpsGetInfo() : dcrf32.h
  • dc_halt() : dcrf32.h
  • dc_halt_shc1102() : dcrf32.h
  • dc_high_disp() : dcrf32.h
  • dc_HL_authentication() : dcrf32.h
  • dc_HL_read() : dcrf32.h
  • dc_HL_read_hex() : dcrf32.h
  • dc_HL_readhex() : dcrf32.h
  • dc_HL_write() : dcrf32.h
  • dc_HL_write_hex() : dcrf32.h
  • dc_HL_writehex() : dcrf32.h
  • dc_hltb() : dcrf32.h
  • dc_i_d_query_address() : dcrf32.h
  • dc_i_d_query_address_2() : dcrf32.h
  • dc_i_d_query_birth() : dcrf32.h
  • dc_i_d_query_birth_2() : dcrf32.h
  • dc_i_d_query_department() : dcrf32.h
  • dc_i_d_query_department_2() : dcrf32.h
  • dc_i_d_query_expire_day() : dcrf32.h
  • dc_i_d_query_expire_day_2() : dcrf32.h
  • dc_i_d_query_finger() : dcrf32.h
  • dc_i_d_query_finger_2() : dcrf32.h
  • dc_i_d_query_finger_bmp_buffer() : dcrf32.h
  • dc_i_d_query_finger_file() : dcrf32.h
  • dc_i_d_query_finger_len() : dcrf32.h
  • dc_i_d_query_id_number() : dcrf32.h
  • dc_i_d_query_id_number_2() : dcrf32.h
  • dc_i_d_query_name() : dcrf32.h
  • dc_i_d_query_name_2() : dcrf32.h
  • dc_i_d_query_nation() : dcrf32.h
  • dc_i_d_query_nation_2() : dcrf32.h
  • dc_i_d_query_photo() : dcrf32.h
  • dc_i_d_query_photo_2() : dcrf32.h
  • dc_i_d_query_photo_bmp_buffer() : dcrf32.h
  • dc_i_d_query_photo_file() : dcrf32.h
  • dc_i_d_query_photo_len() : dcrf32.h
  • dc_i_d_query_sex() : dcrf32.h
  • dc_i_d_query_sex_2() : dcrf32.h
  • dc_IdCardImageBuild() : dcrf32.h
  • dc_IdCardReadCardInfo() : dcrf32.h
  • dc_increment() : dcrf32.h
  • dc_init() : dcrf32.h
  • dc_init_485() : dcrf32.h
  • dc_init_auth_153() : dcrf32.h
  • dc_init_auth_153_hex() : dcrf32.h
  • dc_init_auth_1608() : dcrf32.h
  • dc_init_auth_1608_hex() : dcrf32.h
  • dc_init_name() : dcrf32.h
  • dc_initval() : dcrf32.h
  • dc_initval_ml() : dcrf32.h
  • dc_InstallKbKey() : dcrf32.h
  • dc_inventory() : dcrf32.h
  • dc_inventory_hex() : dcrf32.h
  • dc_keypad_DeleteKey() : dcrf32.h
  • dc_keypad_End() : dcrf32.h
  • dc_keypad_GetDecryptDataOfCBC() : dcrf32.h
  • dc_keypad_GetDecryptDataOfECB() : dcrf32.h
  • dc_keypad_GetEncryptDataOfCBC() : dcrf32.h
  • dc_keypad_GetEncryptDataOfECB() : dcrf32.h
  • dc_keypad_GetMACDataOfCBC() : dcrf32.h
  • dc_keypad_GetPinBlock() : dcrf32.h
  • dc_keypad_GetPressed() : dcrf32.h
  • dc_keypad_GetRandomValue() : dcrf32.h
  • dc_keypad_ImportKey() : dcrf32.h
  • dc_keypad_io_control() : dcrf32.h
  • dc_keypad_SetButtonMark() : dcrf32.h
  • dc_keypad_Start() : dcrf32.h
  • dc_KeypadAlgorithm() : dcrf32.h
  • dc_KeypadClearKey() : dcrf32.h
  • dc_KeypadClose() : dcrf32.h
  • dc_KeypadExitAndGetInput() : dcrf32.h
  • dc_KeypadGetKeyType() : dcrf32.h
  • dc_KeypadGetKeyValue() : dcrf32.h
  • dc_KeypadLoadKey() : dcrf32.h
  • dc_KeypadOpen() : dcrf32.h
  • dc_KeypadSetKeyValue() : dcrf32.h
  • dc_KeypadStartInput() : dcrf32.h
  • dc_lcdclrscrn() : dcrf32.h
  • dc_LcdDisplay() : dcrf32.h
  • dc_LcdDisplayText() : dcrf32.h
  • dc_LcdDisplayTextFromData() : dcrf32.h
  • dc_led_T8() : dcrf32.h
  • dc_LedControl() : dcrf32.h
  • dc_LedDisplay() : dcrf32.h
  • dc_light() : dcrf32.h
  • dc_load_key() : dcrf32.h
  • dc_load_key_hex() : dcrf32.h
  • dc_load_voice() : dcrf32.h
  • dc_lock_afi() : dcrf32.h
  • dc_lock_afi_hex() : dcrf32.h
  • dc_lock_block() : dcrf32.h
  • dc_lock_block_hex() : dcrf32.h
  • dc_lock_dsfid() : dcrf32.h
  • dc_lock_dsfid_hex() : dcrf32.h
  • dc_MagFormatConfig() : dcrf32.h
  • dc_mfdes_auth() : dcrf32.h
  • dc_mfdes_auth_hex() : dcrf32.h
  • dc_mfdes_baud() : dcrf32.h
  • dc_MFPL0_commitperso() : dcrf32.h
  • dc_MFPL0_writeperso() : dcrf32.h
  • dc_MFPL0_writeperso_hex() : dcrf32.h
  • dc_MFPL1_authl1key() : dcrf32.h
  • dc_MFPL1_authl1key_hex() : dcrf32.h
  • dc_MFPL1_switchtol2() : dcrf32.h
  • dc_MFPL1_switchtol3() : dcrf32.h
  • dc_MFPL2_switchtol3() : dcrf32.h
  • dc_MFPL3_authl3key() : dcrf32.h
  • dc_MFPL3_authl3key_hex() : dcrf32.h
  • dc_MFPL3_authl3sectorkey() : dcrf32.h
  • dc_MFPL3_authl3sectorkey_hex() : dcrf32.h
  • dc_MFPL3_readencrypted() : dcrf32.h
  • dc_MFPL3_readencrypted_hex() : dcrf32.h
  • dc_MFPL3_readinplain() : dcrf32.h
  • dc_MFPL3_readinplain_hex() : dcrf32.h
  • dc_MFPL3_writeencrypted() : dcrf32.h
  • dc_MFPL3_writeencrypted_hex() : dcrf32.h
  • dc_MFPL3_writeinplain() : dcrf32.h
  • dc_MFPL3_writeinplain_hex() : dcrf32.h
  • dc_mulrequest_b() : dcrf32.h
  • dc_MultiAntennaGetCardStatus() : dcrf32.h
  • dc_MultiAntennaStartOrStop() : dcrf32.h
  • dc_MulticardStatus() : dcrf32.h
  • dc_MultiFlashErase() : dcrf32.h
  • dc_MultiFlashGetSize() : dcrf32.h
  • dc_MultiFlashRead() : dcrf32.h
  • dc_MultiFlashWrite() : dcrf32.h
  • dc_NfcActivate() : dcrf32.h
  • dc_NfcDataReceiver() : dcrf32.h
  • dc_NfcDeactivate() : dcrf32.h
  • dc_NfcFetch() : dcrf32.h
  • dc_NfcInit() : dcrf32.h
  • dc_NfcPush() : dcrf32.h
  • dc_NfcService() : dcrf32.h
  • dc_NfcSimulateCardConfig() : dcrf32.h
  • dc_NtagCommand() : dcrf32.h
  • dc_open_door() : dcrf32.h
  • dc_open_timedoor() : dcrf32.h
  • dc_ParseOtherInfo() : dcrf32.h
  • dc_ParsePhotoInfo() : dcrf32.h
  • dc_ParseTextInfo() : dcrf32.h
  • dc_ParseTextInfoForForeigner() : dcrf32.h
  • dc_ParseTextInfoForHkMoTw() : dcrf32.h
  • dc_pass_key_value() : dcrf32.h
  • dc_pass_key_value2() : dcrf32.h
  • dc_passcancel() : dcrf32.h
  • dc_PassCancel() : dcrf32.h
  • dc_PassGet() : dcrf32.h
  • dc_passget() : dcrf32.h
  • dc_passin() : dcrf32.h
  • dc_PassIn() : dcrf32.h
  • dc_passin2() : dcrf32.h
  • dc_PassIn2() : dcrf32.h
  • dc_PinpadCommunication() : dcrf32.h
  • dc_play_voice() : dcrf32.h
  • dc_playvoice() : dcrf32.h
  • dc_posbeep() : dcrf32.h
  • dc_printcharacter() : dcrf32.h
  • dc_printenter() : dcrf32.h
  • dc_printOnedimensional() : dcrf32.h
  • dc_printPicture() : dcrf32.h
  • dc_printstatus() : dcrf32.h
  • dc_pro_command() : dcrf32.h
  • dc_pro_command_hex() : dcrf32.h
  • dc_pro_commandhex() : dcrf32.h
  • dc_pro_commandlink() : dcrf32.h
  • dc_pro_commandlink_hex() : dcrf32.h
  • dc_pro_commandlinkEXT() : dcrf32.h
  • dc_pro_commandlinkEXT_hex() : dcrf32.h
  • dc_pro_commandlinkInt() : dcrf32.h
  • dc_pro_commandlinkInt_hex() : dcrf32.h
  • dc_pro_commandsource() : dcrf32.h
  • dc_pro_commandsource_hex() : dcrf32.h
  • dc_pro_commandsource_int() : dcrf32.h
  • dc_pro_commandsourceCRC() : dcrf32.h
  • dc_pro_commandsourceCRChex() : dcrf32.h
  • dc_pro_commandsourcehex() : dcrf32.h
  • dc_pro_halt() : dcrf32.h
  • dc_pro_receivecommandsource() : dcrf32.h
  • dc_pro_reset() : dcrf32.h
  • dc_pro_reset_hex() : dcrf32.h
  • dc_pro_resethex() : dcrf32.h
  • dc_pro_resetInt() : dcrf32.h
  • dc_pro_resetInt_hex() : dcrf32.h
  • dc_pro_sendcommandsource() : dcrf32.h
  • dc_procommandInt() : dcrf32.h
  • dc_procommandInt_hex() : dcrf32.h
  • dc_read() : dcrf32.h
  • dc_read1024() : dcrf32.h
  • dc_read1024_hex() : dcrf32.h
  • dc_read_102() : dcrf32.h
  • dc_read_102_hex() : dcrf32.h
  • dc_read_153() : dcrf32.h
  • dc_read_153_hex() : dcrf32.h
  • dc_read_1604() : dcrf32.h
  • dc_read_1604_hex() : dcrf32.h
  • dc_read_1608() : dcrf32.h
  • dc_read_1608_hex() : dcrf32.h
  • dc_read_24c() : dcrf32.h
  • dc_read_24c64() : dcrf32.h
  • dc_read_24c64_hex() : dcrf32.h
  • dc_read_24c_hex() : dcrf32.h
  • dc_read_4428() : dcrf32.h
  • dc_read_4428_hex() : dcrf32.h
  • dc_read_4442() : dcrf32.h
  • dc_read_4442_hex() : dcrf32.h
  • dc_read_fm11rf005() : dcrf32.h
  • dc_read_fm11rf005_hex() : dcrf32.h
  • dc_read_fuse_153() : dcrf32.h
  • dc_read_fuse_1608() : dcrf32.h
  • dc_read_hex() : dcrf32.h
  • dc_read_idcard() : dcrf32.h
  • dc_read_idcard_hex() : dcrf32.h
  • dc_read_random() : dcrf32.h
  • dc_read_random_hex() : dcrf32.h
  • dc_read_shc1102() : dcrf32.h
  • dc_read_walletbalance() : dcrf32.h
  • dc_readblock() : dcrf32.h
  • dc_readblock_hex() : dcrf32.h
  • dc_readcount_102() : dcrf32.h
  • dc_readcount_1604() : dcrf32.h
  • dc_ReadDeviceCustomInfo() : dcrf32.h
  • dc_ReadDeviceCustomSerialNumber() : dcrf32.h
  • dc_ReadDeviceTypeName() : dcrf32.h
  • dc_readdevsnr() : dcrf32.h
  • dc_ReadFlash() : dcrf32.h
  • dc_ReadIdCardInfo() : dcrf32.h
  • dc_readmag() : dcrf32.h
  • dc_readmagcard() : dcrf32.h
  • dc_readmagcardall() : dcrf32.h
  • dc_readmagcardallA() : dcrf32.h
  • dc_ReadModuleMacAddress() : dcrf32.h
  • dc_ReadNicMacAddress() : dcrf32.h
  • dc_ReadOutEeprom() : dcrf32.h
  • dc_readpin_4428() : dcrf32.h
  • dc_readpin_4428_hex() : dcrf32.h
  • dc_readpin_4442() : dcrf32.h
  • dc_readpin_4442_hex() : dcrf32.h
  • dc_readpincount_4428() : dcrf32.h
  • dc_readpincount_4442() : dcrf32.h
  • dc_readprotect_4428() : dcrf32.h
  • dc_readprotect_4428_hex() : dcrf32.h
  • dc_readprotect_4442() : dcrf32.h
  • dc_readprotect_4442_hex() : dcrf32.h
  • dc_readreadersnr() : dcrf32.h
  • dc_ReadRfCfgReg() : dcrf32.h
  • dc_ReadRfTypeABATS() : dcrf32.h
  • dc_ReadRfTypeABATS_hex() : dcrf32.h
  • dc_readSD() : dcrf32.h
  • dc_readval() : dcrf32.h
  • dc_readval_ml() : dcrf32.h
  • dc_readwrotect_4442() : dcrf32.h
  • dc_readwrotect_4442_hex() : dcrf32.h
  • dc_RefreshAndDisplayMainUI() : dcrf32.h
  • dc_request() : dcrf32.h
  • dc_request_b() : dcrf32.h
  • dc_request_shc1102() : dcrf32.h
  • dc_RequestMultiCard() : dcrf32.h
  • dc_reset() : dcrf32.h
  • dc_reset_factory() : dcrf32.h
  • dc_reset_to_ready() : dcrf32.h
  • dc_reset_to_ready_hex() : dcrf32.h
  • dc_resetdevice() : dcrf32.h
  • dc_RestDevice() : dcrf32.h
  • dc_restore() : dcrf32.h
  • dc_rf_application() : dcrf32.h
  • dc_rf_getstatus() : dcrf32.h
  • dc_rf_poweroff() : dcrf32.h
  • dc_rf_poweron() : dcrf32.h
  • dc_RfCrcModeConfig() : dcrf32.h
  • dc_RfFormatConfig() : dcrf32.h
  • dc_RfGetCardType() : dcrf32.h
  • dc_RfMarch() : dcrf32.h
  • dc_RfMultiRequest() : dcrf32.h
  • dc_RfReadChipRegister() : dcrf32.h
  • dc_RfSetChipRegister() : dcrf32.h
  • dc_RfWaveControl() : dcrf32.h
  • dc_rw_rfreg() : dcrf32.h
  • dc_rw_rfreg_hex() : dcrf32.h
  • dc_SamAControl() : dcrf32.h
  • dc_SamAReadCardInfo() : dcrf32.h
  • dc_SamAReadSerialNumber() : dcrf32.h
  • dc_Scan2DBarcode() : dcrf32.h
  • dc_Scan2DBarcodeExit() : dcrf32.h
  • dc_Scan2DBarcodeGetData() : dcrf32.h
  • dc_Scan2DBarcodeStart() : dcrf32.h
  • dc_ScreenClearDisplay() : dcrf32.h
  • dc_ScreenDisplayBgImage() : dcrf32.h
  • dc_ScreenDisplayBgImageByColor() : dcrf32.h
  • dc_ScreenDisplayGetConfig() : dcrf32.h
  • dc_ScreenDisplayImage() : dcrf32.h
  • dc_ScreenDisplaySetConfig() : dcrf32.h
  • dc_ScreenDisplayText() : dcrf32.h
  • dc_ScreenLoadBgImage() : dcrf32.h
  • dc_select() : dcrf32.h
  • dc_select2() : dcrf32.h
  • dc_select_mode() : dcrf32.h
  • dc_select_uid() : dcrf32.h
  • dc_select_uid_hex() : dcrf32.h
  • dc_SelectAntenna() : dcrf32.h
  • dc_SelfServiceDeviceCardEject() : dcrf32.h
  • dc_SelfServiceDeviceCardInject() : dcrf32.h
  • dc_SelfServiceDeviceCardMove() : dcrf32.h
  • dc_SelfServiceDeviceCardStatus() : dcrf32.h
  • dc_SelfServiceDeviceCheckCardType() : dcrf32.h
  • dc_SelfServiceDeviceConfig() : dcrf32.h
  • dc_SelfServiceDeviceConfigBack() : dcrf32.h
  • dc_SelfServiceDeviceConfigFront() : dcrf32.h
  • dc_SelfServiceDeviceConfigPlace() : dcrf32.h
  • dc_SelfServiceDeviceGetFrontSwitch() : dcrf32.h
  • dc_SelfServiceDeviceRecoverError() : dcrf32.h
  • dc_SelfServiceDeviceReset() : dcrf32.h
  • dc_SelfServiceDeviceSensorStatus() : dcrf32.h
  • dc_SelfServiceDeviceSetFrontSwitch() : dcrf32.h
  • dc_SelfServiceDeviceShakeConfig() : dcrf32.h
  • dc_SelfServiceDeviceWriteMagConfig() : dcrf32.h
  • dc_send_sms() : dcrf32.h
  • dc_set2dot4Gbaund() : dcrf32.h
  • dc_set_addr() : dcrf32.h
  • dc_set_control_bit() : dcrf32.h
  • dc_set_hardwareserialnumber() : dcrf32.h
  • dc_set_poweroff() : dcrf32.h
  • dc_set_terminalnumber() : dcrf32.h
  • dc_set_trademerchantcode() : dcrf32.h
  • dc_set_tradesecretkey() : dcrf32.h
  • dc_set_transactiontype() : dcrf32.h
  • dc_setbright() : dcrf32.h
  • dc_setcpu() : dcrf32.h
  • dc_SetCpuCard616C() : dcrf32.h
  • dc_SetCpuCardPps() : dcrf32.h
  • dc_setcpupara() : dcrf32.h
  • dc_SetCpuVoltage() : dcrf32.h
  • dc_setdevicebaud() : dcrf32.h
  • dc_setdevicetime() : dcrf32.h
  • dc_SetEMVPara() : dcrf32.h
  • dc_SetKbKeyID() : dcrf32.h
  • dc_setmag() : dcrf32.h
  • dc_SetPinpadWithReaderBaudrate() : dcrf32.h
  • dc_setprint() : dcrf32.h
  • dc_settime() : dcrf32.h
  • dc_settime_hex() : dcrf32.h
  • dc_settimehex() : dcrf32.h
  • dc_SetUsbMode() : dcrf32.h
  • dc_setusbtimeout() : dcrf32.h
  • dc_slotmarker() : dcrf32.h
  • dc_srd_eeprom() : dcrf32.h
  • dc_srd_eeprom_hex() : dcrf32.h
  • dc_srd_eepromhex() : dcrf32.h
  • dc_start_i_d() : dcrf32.h
  • dc_start_i_d_2() : dcrf32.h
  • dc_startreadmag() : dcrf32.h
  • dc_stay_quiet() : dcrf32.h
  • dc_stay_quiet_hex() : dcrf32.h
  • dc_stopreadmag() : dcrf32.h
  • dc_switch_linux() : dcrf32.h
  • dc_switch_unix() : dcrf32.h
  • dc_swr_eeprom() : dcrf32.h
  • dc_swr_eeprom_hex() : dcrf32.h
  • dc_swr_eepromhex() : dcrf32.h
  • dc_TcpGetInfo() : dcrf32.h
  • dc_TestCom() : dcrf32.h
  • dc_testdevicecomm() : dcrf32.h
  • dc_TestNic() : dcrf32.h
  • dc_TestUsb() : dcrf32.h
  • dc_transfer() : dcrf32.h
  • dc_transfer_wallet() : dcrf32.h
  • dc_tripledes() : dcrf32.h
  • dc_tripledes_hex() : dcrf32.h
  • dc_TtsVoiceConfig() : dcrf32.h
  • dc_TtsVoicePlay() : dcrf32.h
  • dc_typeab_card_status() : dcrf32.h
  • dc_update() : dcrf32.h
  • dc_verifypin_4428() : dcrf32.h
  • dc_verifypin_4428_hex() : dcrf32.h
  • dc_verifypin_4442() : dcrf32.h
  • dc_verifypin_4442_hex() : dcrf32.h
  • dc_VoicePlayAndDisplay() : dcrf32.h
  • dc_WakeDevice() : dcrf32.h
  • dc_WirelessGetStatus() : dcrf32.h
  • dc_WirelessPowerControl() : dcrf32.h
  • dc_WirelessRecv() : dcrf32.h
  • dc_WirelessSend() : dcrf32.h
  • dc_WirelessTcpClose() : dcrf32.h
  • dc_WirelessTcpOpen() : dcrf32.h
  • dc_WirelessWifiConfig() : dcrf32.h
  • dc_write() : dcrf32.h
  • dc_write1024() : dcrf32.h
  • dc_write1024_hex() : dcrf32.h
  • dc_write_102() : dcrf32.h
  • dc_write_102_hex() : dcrf32.h
  • dc_write_153() : dcrf32.h
  • dc_write_153_hex() : dcrf32.h
  • dc_write_1604() : dcrf32.h
  • dc_write_1604_hex() : dcrf32.h
  • dc_write_1608() : dcrf32.h
  • dc_write_1608_hex() : dcrf32.h
  • dc_write_24c() : dcrf32.h
  • dc_write_24c64() : dcrf32.h
  • dc_write_24c64_hex() : dcrf32.h
  • dc_write_24c_hex() : dcrf32.h
  • dc_write_4428() : dcrf32.h
  • dc_write_4428_hex() : dcrf32.h
  • dc_write_4442() : dcrf32.h
  • dc_write_4442_hex() : dcrf32.h
  • dc_write_afi() : dcrf32.h
  • dc_write_afi_hex() : dcrf32.h
  • dc_write_dsfid() : dcrf32.h
  • dc_write_dsfid_hex() : dcrf32.h
  • dc_write_fm11rf005() : dcrf32.h
  • dc_write_fm11rf005_hex() : dcrf32.h
  • dc_write_fuse_153() : dcrf32.h
  • dc_write_fuse_1608() : dcrf32.h
  • dc_write_hex() : dcrf32.h
  • dc_write_random() : dcrf32.h
  • dc_write_random_hex() : dcrf32.h
  • dc_write_shc1102() : dcrf32.h
  • dc_write_TS() : dcrf32.h
  • dc_writeblock() : dcrf32.h
  • dc_writeblock_hex() : dcrf32.h
  • dc_WriteDeviceCustomInfo() : dcrf32.h
  • dc_WriteDeviceCustomSerialNumber() : dcrf32.h
  • dc_WriteDeviceTypeName() : dcrf32.h
  • dc_WriteFlash() : dcrf32.h
  • dc_writemagcard() : dcrf32.h
  • dc_WriteModuleMacAddress() : dcrf32.h
  • dc_WriteNicMacAddress() : dcrf32.h
  • dc_WriteOutEeprom() : dcrf32.h
  • dc_writeprotect_4428() : dcrf32.h
  • dc_writeprotect_4428_hex() : dcrf32.h
  • dc_writeprotect_4442() : dcrf32.h
  • dc_writeprotect_4442_hex() : dcrf32.h
  • dc_WriteRfCfgReg() : dcrf32.h
  • dc_writeSD() : dcrf32.h
  • dcdes() : dcrf32.h
  • dcdeshex() : dcrf32.h
  • DCDEV_CommandMcu() : dcrf32.h
  • DCDEV_CommandMcu_Hex() : dcrf32.h


- h -

  • hex_a() : dcrf32.h


- l -

  • LibMain() : dcrf32.h


- s -

  • SD_IFD_ActWorkKey() : dcrf32.h
  • SD_IFD_CreateMac() : dcrf32.h
  • SD_IFD_DES() : dcrf32.h
  • SD_IFD_DesCaculate() : dcrf32.h
  • SD_IFD_GetEnPIN() : dcrf32.h
  • SD_IFD_GetEnPINBlock() : dcrf32.h
  • SD_IFD_GetEnPINPro() : dcrf32.h
  • SD_IFD_GetPIN() : dcrf32.h
  • SD_IFD_GetPINPro() : dcrf32.h
  • SD_IFD_GetVersion() : dcrf32.h
  • SD_IFD_Init() : dcrf32.h
  • SD_IFD_LEDDisplay() : dcrf32.h
  • SD_IFD_PlayVoice() : dcrf32.h
  • SD_IFD_Scan2DBarcodeExit() : dcrf32.h
  • SD_IFD_Scan2DBarcodeGetData() : dcrf32.h
  • SD_IFD_Scan2DBarcodeStart() : dcrf32.h
  • SD_IFD_SelecetDes() : dcrf32.h
  • SD_IFD_SetKeyLength() : dcrf32.h
  • SD_IFD_SetMainKey() : dcrf32.h
  • SD_IFD_SetWorkKey() : dcrf32.h
  • SD_InstallKey() : dcrf32.h
  • srd_alleeprom() : dcrf32.h
  • swr_alleeprom() : dcrf32.h


DCRF32: dcrf32.h 源文件

dcrf32.h
浏览该文件的文档.
1 // -*- mode:c++ -*-
2
10 #ifndef DCRF32_H_
11 #define DCRF32_H_
12
13 #ifdef WIN32
14 #include <winsock2.h>
15 #pragma comment(lib, "ws2_32.lib")
16 #define USER_API __stdcall
17 #else
18 typedef int HANDLE;
19 #define USER_API
20 #endif
21
22 #ifdef __cplusplus
23 extern "C" {
24 #endif
25
38 void USER_API LibMain(int flag, void *context);
39
47 void USER_API dc_config_port_name(short port, const char *name);
48
61 HANDLE USER_API dc_init(short port, int baud);
62
76 HANDLE USER_API dc_init_name(short port, int baud, const char *name);
77
85 short USER_API dc_exit(HANDLE icdev);
86
95 short USER_API dc_getname(HANDLE icdev, char *name);
96
100 short USER_API dc_config(HANDLE icdev, unsigned char _Mode, unsigned char _Baud);
101
111 short USER_API dc_request(HANDLE icdev, unsigned char _Mode, unsigned short *TagType);
112
122 short USER_API dc_anticoll(HANDLE icdev, unsigned char _Bcnt, unsigned int *_Snr);
123
133 short USER_API dc_select(HANDLE icdev, unsigned int _Snr, unsigned char *_Size);
134
150 short USER_API dc_authentication(HANDLE icdev, unsigned char _Mode, unsigned char _SecNr);
151
159 short USER_API dc_halt(HANDLE icdev);
160
172 short USER_API dc_read(HANDLE icdev, unsigned char _Adr, unsigned char *_Data);
173
179 short USER_API dc_read_hex(HANDLE icdev, unsigned char _Adr, char *_Data);
180
192 short USER_API dc_write(HANDLE icdev, unsigned char _Adr, unsigned char *_Data);
193
199 short USER_API dc_write_hex(HANDLE icdev, unsigned char _Adr, char *_Data);
200
204 short USER_API dc_write_TS(HANDLE icdev);
205
216 short USER_API dc_load_key(HANDLE icdev, unsigned char _Mode, unsigned char _SecNr, unsigned char *_NKey);
217
223 short USER_API dc_load_key_hex(HANDLE icdev, unsigned char _Mode, unsigned char _SecNr, char *_NKey);
224
234 short USER_API dc_card(HANDLE icdev, unsigned char _Mode, unsigned int *_Snr);
235
241 short USER_API dc_card_hex(HANDLE icdev, unsigned char _Mode, unsigned char *snrstr);
242
258 short USER_API dc_changeb3(HANDLE icdev, unsigned char _SecNr, unsigned char *_KeyA, unsigned char _B0, unsigned char _B1, unsigned char _B2, unsigned char _B3, unsigned char _Bk, unsigned char *_KeyB);
259
265 short USER_API dc_changeb3_hex(HANDLE icdev, unsigned char _SecNr, const char *_KeyA, unsigned char _B0, unsigned char _B1, unsigned char _B2, unsigned char _B3, unsigned char _Bk, const char *_KeyB);
266
275 short USER_API dc_restore(HANDLE icdev, unsigned char _Adr);
276
285 short USER_API dc_transfer(HANDLE icdev, unsigned char _Adr);
286
296 short USER_API dc_increment(HANDLE icdev, unsigned char _Adr, unsigned int _Value);
297
307 short USER_API dc_decrement(HANDLE icdev, unsigned char _Adr, unsigned int _Value);
308
318 short USER_API dc_initval(HANDLE icdev, unsigned char _Adr, unsigned int _Value);
319
329 short USER_API dc_readval(HANDLE icdev, unsigned char _Adr, unsigned int *_Value);
330
339 short USER_API dc_initval_ml(HANDLE icdev, unsigned short _Value);
340
349 short USER_API dc_readval_ml(HANDLE icdev, unsigned short *_Value);
350
359 short USER_API dc_decrement_ml(HANDLE icdev, unsigned short _Value);
360
371 short USER_API dc_authentication_2(HANDLE icdev, unsigned char _Mode, unsigned char KeyNr, unsigned char Adr);
372
382 short USER_API dc_anticoll2(HANDLE icdev, unsigned char _Bcnt, unsigned int *_Snr);
383
393 short USER_API dc_select2(HANDLE icdev, unsigned int _Snr, unsigned char *_Size);
394
398 short USER_API dc_HL_write(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int *_Snr, unsigned char *_Data);
399
403 short USER_API dc_HL_writehex(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int *_Snr, unsigned char *_Data);
404
408 short USER_API dc_HL_read(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int _Snr, unsigned char *_Data, unsigned int *_NSnr);
409
413 short USER_API dc_HL_readhex(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int _Snr, unsigned char *_Data, unsigned int *_NSnr);
414
426 short USER_API dc_HL_authentication(HANDLE icdev, unsigned char reqmode, unsigned int snr, unsigned char authmode, unsigned char secnr);
427
439 short USER_API dc_check_write(HANDLE icdev, unsigned int Snr, unsigned char authmode, unsigned char Adr, unsigned char *_data);
440
446 short USER_API dc_check_writehex(HANDLE icdev, unsigned int Snr, unsigned char authmode, unsigned char Adr, unsigned char *_data);
447
456 short USER_API dc_getver(HANDLE icdev, unsigned char *sver);
457
461 short USER_API dc_update(HANDLE icdev);
462
466 short USER_API dc_clr_control_bit(HANDLE icdev, unsigned char _b);
467
471 short USER_API dc_set_control_bit(HANDLE icdev, unsigned char _b);
472
481 short USER_API dc_reset(HANDLE icdev, unsigned short _Msec);
482
491 short USER_API dc_beep(HANDLE icdev, unsigned short _Msec);
492
501 short USER_API dc_disp_str(HANDLE icdev, char *dispstr);
502
513 short USER_API dc_srd_eeprom(HANDLE icdev, short offset, short length, unsigned char *rec_buffer);
514
525 short USER_API dc_swr_eeprom(HANDLE icdev, short offset, short length, unsigned char *send_buffer);
526
532 short USER_API swr_alleeprom(HANDLE icdev, short offset, short length, unsigned char *snd_buffer);
533
539 short USER_API srd_alleeprom(HANDLE icdev, short offset, short length, unsigned char *receive_buffer);
540
546 short USER_API dc_srd_eepromhex(HANDLE icdev, short offset, short length, unsigned char *rec_buffer);
547
553 short USER_API dc_swr_eepromhex(HANDLE icdev, short offset, short length, unsigned char *send_buffer);
554
563 short USER_API dc_gettime(HANDLE icdev, unsigned char *time);
564
570 short USER_API dc_gettimehex(HANDLE icdev, char *time);
571
580 short USER_API dc_settime(HANDLE icdev, unsigned char *time);
581
587 short USER_API dc_settimehex(HANDLE icdev, char *time);
588
592 short USER_API dc_setbright(HANDLE icdev, unsigned char bright);
593
597 short USER_API dc_ctl_mode(HANDLE icdev, unsigned char mode);
598
602 short USER_API dc_disp_mode(HANDLE icdev, unsigned char mode);
603
609 short USER_API dcdeshex(unsigned char *key, unsigned char *sour, unsigned char *dest, short m);
610
621 short USER_API dcdes(unsigned char *key, unsigned char *sour, unsigned char *dest, short m);
622
631 short USER_API dc_light(HANDLE icdev, unsigned short _OnOff);
632
643 short USER_API dc_high_disp(HANDLE icdev, unsigned char offset, unsigned char displen, unsigned char *dispstr);
644
663 short USER_API dc_setcpu(HANDLE icdev, unsigned char _Byte);
664
674 short USER_API dc_cpureset(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer);
675
687 short USER_API dc_cpuapdusource(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer);
688
700 short USER_API dc_cpuapdu(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer);
701
707 short USER_API dc_cpureset_hex(HANDLE icdev, unsigned char *rlen, char *databuffer);
708
714 short USER_API dc_cpuapdusource_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer);
715
721 short USER_API dc_cpuapdu_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer);
722
734 short USER_API dc_cpuapdurespon(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer);
735
741 short USER_API dc_cpuapdurespon_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer);
742
750 short USER_API dc_cpudown(HANDLE icdev);
751
755 short USER_API dc_set_addr(unsigned char saddr);
756
760 HANDLE USER_API dc_init_485(short port, int baud);
761
765 short USER_API dc_changebaud_485(HANDLE icdev, int baud);
766
770 short USER_API dc_change_addr(HANDLE icdev, unsigned char saddr);
771
781 short USER_API dc_pro_reset(HANDLE icdev, unsigned char *rlen, unsigned char *receive_data);
782
795 short USER_API dc_pro_command(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout);
796
802 short USER_API dc_pro_resethex(HANDLE icdev, unsigned char *rlen, char *receive_data);
803
813 short USER_API dc_pro_resetInt(HANDLE icdev, unsigned char *rlen, unsigned char *receive_data);
814
820 short USER_API dc_pro_resetInt_hex(HANDLE icdev, unsigned char *rlen, char *receive_data);
821
827 short USER_API dc_pro_commandhex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout);
828
841 short USER_API dc_pro_commandsource(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout);
842
848 short USER_API dc_pro_commandsourcehex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout);
849
862 short USER_API dc_pro_commandsource_int(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout);
863
871 short USER_API dc_pro_halt(HANDLE icdev);
872
882 short USER_API dc_request_shc1102(HANDLE icdev, unsigned char _Mode, unsigned short *TagType);
883
892 short USER_API dc_auth_shc1102(HANDLE icdev, unsigned char *_Data);
893
903 short USER_API dc_read_shc1102(HANDLE icdev, unsigned char _Adr, unsigned char *_Data);
904
914 short USER_API dc_write_shc1102(HANDLE icdev, unsigned char _Adr, unsigned char *_Data);
915
923 short USER_API dc_halt_shc1102(HANDLE icdev);
924
934 short USER_API hex_a(unsigned char *hex, unsigned char *a, short length);
935
945 short USER_API a_hex(unsigned char *a, unsigned char *hex, short len);
946
955 short USER_API dc_config_card(HANDLE icdev, unsigned char cardtype);
956
968 short USER_API dc_request_b(HANDLE icdev, unsigned char _Mode, unsigned char AFI, unsigned char N, unsigned char *ATQB);
969
979 short USER_API dc_slotmarker(HANDLE icdev, unsigned char N, unsigned char *ATQB);
980
990 short USER_API dc_attrib(HANDLE icdev, unsigned char *PUPI, unsigned char CID);
991
995 short USER_API dc_open_door(HANDLE icdev, unsigned char cflag);
996
1000 short USER_API dc_open_timedoor(HANDLE icdev, unsigned short utime);
1001
1005 short USER_API dc_read_random(HANDLE icdev, unsigned char *data);
1006
1010 short USER_API dc_write_random(HANDLE icdev, short length, unsigned char *data);
1011
1015 short USER_API dc_read_random_hex(HANDLE icdev, unsigned char *data);
1016
1020 short USER_API dc_write_random_hex(HANDLE icdev, short length, unsigned char *data);
1021
1025 short USER_API dc_erase_random(HANDLE icdev, short length);
1026
1039 short USER_API dc_mfdes_auth(HANDLE icdev, unsigned char keyno, unsigned char keylen, unsigned char *authkey, unsigned char *randAdata, unsigned char *randBdata);
1040
1051 short USER_API dc_authentication_pass(HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff);
1052
1061 short USER_API dc_disp_neg(HANDLE icdev, char *dispstr);
1062
1076 short USER_API dc_pro_commandlink(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG);
1077
1083 short USER_API dc_pro_commandlink_hex(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG);
1084
1094 short USER_API dc_card_double(HANDLE icdev, unsigned char _Mode, unsigned char *_Snr);
1095
1101 short USER_API dc_card_double_hex(HANDLE icdev, unsigned char _Mode, unsigned char *_Snr);
1102
1112 short USER_API dc_read_idcard(HANDLE icdev, unsigned char times, unsigned char *_Data);
1113
1119 short USER_API dc_read_idcard_hex(HANDLE icdev, unsigned char times, unsigned char *_Data);
1120
1126 short USER_API dc_authentication_pass_hex(HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff);
1127
1138 short USER_API dc_setcpupara(HANDLE icdev, unsigned char cputype, unsigned char cpupro, unsigned char cpuetu);
1139
1143 short USER_API dc_command(HANDLE icdev, unsigned char cmd, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer);
1144
1148 short USER_API dc_command_hex(HANDLE icdev, unsigned char cmd, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer);
1149
1153 short USER_API dc_creat_mac(unsigned char KeyLen, unsigned char *Key, unsigned short DataLen, unsigned char *Data, unsigned char *InitData, unsigned char AutoFixFlag, unsigned char FixChar, unsigned char *MacData);
1154
1158 short USER_API dc_creat_mac_hex(unsigned char KeyLen, unsigned char *Key, unsigned short DataLen, unsigned char *Data, unsigned char *InitData, unsigned char AutoFixFlag, unsigned char FixChar, unsigned char *MacData);
1159
1163 short USER_API dc_creat_mac2(HANDLE icdev, unsigned short DataLen, unsigned char *Data, unsigned char *MacData, unsigned char flag);
1164
1168 short USER_API dc_creat_mac2_hex(HANDLE icdev, unsigned short DataLen, unsigned char *Data, unsigned char *MacData, unsigned char flag);
1169
1173 short USER_API dc_encrypt(char *key, char *ptrSource, unsigned short msgLen, char *ptrDest);
1174
1178 short USER_API dc_decrypt(char *key, char *ptrSource, unsigned short msgLen, char *ptrDest);
1179
1183 short USER_API dc_encrypt_hex(char *key, char *ptrSource, unsigned short msgLen, char *ptrDest);
1184
1188 short USER_API dc_decrypt_hex(char *key, char *ptrSource, unsigned short msgLen, char *ptrDest);
1189
1193 short USER_API dc_HL_write_hex(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int *_Snr, unsigned char *_Data);
1194
1198 short USER_API dc_HL_read_hex(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int _Snr, unsigned char *_Data, unsigned int *_NSnr);
1199
1205 short USER_API dc_check_write_hex(HANDLE icdev, unsigned int Snr, unsigned char authmode, unsigned char Adr, unsigned char *_data);
1206
1212 short USER_API dc_srd_eeprom_hex(HANDLE icdev, short offset, short length, unsigned char *rec_buffer);
1213
1219 short USER_API dc_swr_eeprom_hex(HANDLE icdev, short offset, short length, unsigned char *send_buffer);
1220
1226 short USER_API dc_gettime_hex(HANDLE icdev, char *time);
1227
1233 short USER_API dc_settime_hex(HANDLE icdev, char *time);
1234
1240 short USER_API dc_des_hex(unsigned char *key, unsigned char *sour, unsigned char *dest, short m);
1241
1252 short USER_API dc_des(unsigned char *key, unsigned char *sour, unsigned char *dest, short m);
1253
1259 short USER_API dc_pro_reset_hex(HANDLE icdev, unsigned char *rlen, char *receive_data);
1260
1266 short USER_API dc_pro_command_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout);
1267
1273 short USER_API dc_pro_commandsource_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout);
1274
1278 short USER_API dc_switch_unix(HANDLE icdev, int baud);
1279
1290 short USER_API dc_authentication_passaddr(HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff);
1291
1297 short USER_API dc_authentication_passaddr_hex(HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff);
1298
1308 short USER_API dc_card_fm11rf005(HANDLE icdev, unsigned char _Mode, unsigned int *_Snr);
1309
1313 short USER_API dc_setusbtimeout(unsigned char ntimes);
1314
1318 short USER_API dc_mfdes_baud(HANDLE icdev, unsigned char _Mode, unsigned char para);
1319
1330 short USER_API dc_tripledes(unsigned char *key, unsigned char *src, unsigned char *dest, short m);
1331
1337 short USER_API dc_tripledes_hex(unsigned char *key, unsigned char *src, unsigned char *dest, short m);
1338
1344 short USER_API dc_mfdes_auth_hex(HANDLE icdev, unsigned char keyno, unsigned char keylen, unsigned char *authkey, unsigned char *randAdata, unsigned char *randBdata);
1345
1349 short USER_API dc_pro_sendcommandsource(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char timeout);
1350
1354 short USER_API dc_pro_receivecommandsource(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer);
1355
1359 short USER_API dc_inventory(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char masklen, unsigned char *rlen, unsigned char *rbuffer);
1360
1364 short USER_API dc_inventory_hex(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char masklen, unsigned char *rlen, unsigned char *rbuffer);
1365
1369 short USER_API dc_stay_quiet(HANDLE icdev, unsigned char flags, unsigned char *UID);
1370
1374 short USER_API dc_stay_quiet_hex(HANDLE icdev, unsigned char flags, unsigned char *UID);
1375
1379 short USER_API dc_select_uid(HANDLE icdev, unsigned char flags, unsigned char *UID);
1380
1384 short USER_API dc_select_uid_hex(HANDLE icdev, unsigned char flags, unsigned char *UID);
1385
1389 short USER_API dc_reset_to_ready(HANDLE icdev, unsigned char flags, unsigned char *UID);
1390
1394 short USER_API dc_reset_to_ready_hex(HANDLE icdev, unsigned char flags, unsigned char *UID);
1395
1399 short USER_API dc_readblock(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer);
1400
1404 short USER_API dc_readblock_hex(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer);
1405
1409 short USER_API dc_writeblock(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char wlen, unsigned char *wbuffer);
1410
1414 short USER_API dc_writeblock_hex(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char wlen, unsigned char *wbuffer);
1415
1419 short USER_API dc_lock_block(HANDLE icdev, unsigned char flags, unsigned char block, unsigned char *UID);
1420
1424 short USER_API dc_lock_block_hex(HANDLE icdev, unsigned char flags, unsigned char block, unsigned char *UID);
1425
1429 short USER_API dc_write_afi(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID);
1430
1434 short USER_API dc_write_afi_hex(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID);
1435
1439 short USER_API dc_lock_afi(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID);
1440
1444 short USER_API dc_lock_afi_hex(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID);
1445
1449 short USER_API dc_write_dsfid(HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID);
1450
1454 short USER_API dc_write_dsfid_hex(HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID);
1455
1459 short USER_API dc_lock_dsfid(HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID);
1460
1464 short USER_API dc_lock_dsfid_hex(HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID);
1465
1469 short USER_API dc_get_systeminfo(HANDLE icdev, unsigned char flags, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer);
1470
1474 short USER_API dc_get_systeminfo_hex(HANDLE icdev, unsigned char flags, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer);
1475
1479 short USER_API dc_get_securityinfo(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer);
1480
1484 short USER_API dc_get_securityinfo_hex(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer);
1485
1494 short USER_API dc_getsnr_fm11rf005(HANDLE icdev, unsigned int *_Snr);
1495
1501 short USER_API dc_getsnr_fm11rf005_hex(HANDLE icdev, unsigned char *snrstr);
1502
1512 short USER_API dc_write_fm11rf005(HANDLE icdev, unsigned char _Adr, unsigned char *_Data);
1513
1523 short USER_API dc_read_fm11rf005(HANDLE icdev, unsigned char _Adr, unsigned char *_Data);
1524
1530 short USER_API dc_read_fm11rf005_hex(HANDLE icdev, unsigned char _Adr, char *_Data);
1531
1537 short USER_API dc_write_fm11rf005_hex(HANDLE icdev, unsigned char _Adr, char *_Data);
1538
1542 short USER_API DCDEV_CommandMcu(HANDLE icdev, unsigned char ctimeout, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer);
1543
1547 short USER_API DCDEV_CommandMcu_Hex(HANDLE icdev, unsigned char ctimeout, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer);
1548
1552 short USER_API dc_displcd(HANDLE icdev, unsigned char flag);
1553
1564 short USER_API dc_getinputpass(HANDLE icdev, unsigned char ctime, unsigned char *rlen, unsigned char *cpass);
1565
1576 short USER_API dc_GetInputPass(HANDLE icdev, unsigned char ctime, unsigned char *rlen, unsigned char *cpass);
1577
1590 short USER_API dc_readmagcard(HANDLE icdev, unsigned char ctime, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len);
1591
1606 short USER_API dc_writemagcard(HANDLE icdev, unsigned char ctime, unsigned char *pTrack1Data, unsigned char pTrack1Len, unsigned char *pTrack2Data, unsigned char pTrack2Len, unsigned char *pTrack3Data, unsigned char pTrack3Len);
1607
1615 short USER_API dc_testdevicecomm(HANDLE icdev);
1616
1624 short USER_API dc_dispmainmenu(HANDLE icdev);
1625
1639 short USER_API dc_setdevicetime(HANDLE icdev, unsigned char year, unsigned char month, unsigned char date, unsigned char hour, unsigned char minute, unsigned char second);
1640
1654 short USER_API dc_getdevicetime(HANDLE icdev, unsigned char *year, unsigned char *month, unsigned char *date, unsigned char *hour, unsigned char *minute, unsigned char *second);
1655
1666 short USER_API dc_dispinfo(HANDLE icdev, unsigned char line, unsigned char offset, char *data);
1667
1677 short USER_API dc_dispmaininfo(HANDLE icdev, unsigned char offset, char *data);
1678
1687 short USER_API dc_posbeep(HANDLE icdev, unsigned char beeptime);
1688
1697 short USER_API dc_ctlbacklight(HANDLE icdev, unsigned char cOpenFlag);
1698
1708 short USER_API dc_ctlled(HANDLE icdev, unsigned char cLed, unsigned char cOpenFlag);
1709
1718 short USER_API dc_lcdclrscrn(HANDLE icdev, unsigned char cLine);
1719
1728 short USER_API dc_passin(HANDLE icdev, unsigned char ctime);
1729
1738 short USER_API dc_PassIn(HANDLE icdev, unsigned char ctime);
1739
1750 short USER_API dc_passin2(HANDLE icdev, unsigned char ctime, unsigned char ucmode, unsigned char *cardno);
1751
1762 short USER_API dc_PassIn2(HANDLE icdev, unsigned char ctime, unsigned char ucmode, unsigned char *cardno);
1763
1773 short USER_API dc_passget(HANDLE icdev, unsigned char *rlen, unsigned char *cpass);
1774
1784 short USER_API dc_PassGet(HANDLE icdev, unsigned char *rlen, unsigned char *cpass);
1785
1793 short USER_API dc_passcancel(HANDLE icdev);
1794
1802 short USER_API dc_PassCancel(HANDLE icdev);
1803
1816 short USER_API dc_getinputkey(HANDLE icdev, unsigned char disptype, unsigned char line, unsigned char ctime, unsigned char *rlen, unsigned char *ckeydata);
1817
1821 short USER_API dc_displcd_ext(HANDLE icdev, unsigned char flag, unsigned char row, unsigned char offset);
1822
1837 short USER_API dc_readmagcardall(HANDLE icdev, unsigned char ctime, unsigned char *pTrack1Data, unsigned int *pTrack1Len, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len);
1838
1847 short USER_API dc_readdevsnr(HANDLE icdev, unsigned char *snr);
1848
1857 short USER_API dc_readreadersnr(HANDLE icdev, unsigned char *snr);
1858
1866 short USER_API dc_resetdevice(HANDLE icdev);
1867
1884 short USER_API dc_setdevicebaud(HANDLE icdev, unsigned char baud);
1885
1896 short USER_API dc_read_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
1897
1903 short USER_API dc_read_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
1904
1915 short USER_API dc_write_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
1916
1922 short USER_API dc_write_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
1923
1932 short USER_API dc_verifypin_4442(HANDLE icdev, unsigned char *passwd);
1933
1939 short USER_API dc_verifypin_4442_hex(HANDLE icdev, unsigned char *passwd);
1940
1949 short USER_API dc_readpin_4442(HANDLE icdev, unsigned char *passwd);
1950
1956 short USER_API dc_readpin_4442_hex(HANDLE icdev, unsigned char *passwd);
1957
1965 short USER_API dc_readpincount_4442(HANDLE icdev);
1966
1975 short USER_API dc_changepin_4442(HANDLE icdev, unsigned char *passwd);
1976
1982 short USER_API dc_changepin_4442_hex(HANDLE icdev, unsigned char *passwd);
1983
1994 short USER_API dc_readwrotect_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
1995
2001 short USER_API dc_readwrotect_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2002
2013 short USER_API dc_readprotect_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2014
2020 short USER_API dc_readprotect_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2021
2032 short USER_API dc_writeprotect_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2033
2039 short USER_API dc_writeprotect_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2040
2051 short USER_API dc_write_24c(HANDLE icdev, short offset, short length, unsigned char *snd_buffer);
2052
2058 short USER_API dc_write_24c_hex(HANDLE icdev, short offset, short length, unsigned char *snd_buffer);
2059
2070 short USER_API dc_write_24c64(HANDLE icdev, short offset, short length, unsigned char *snd_buffer);
2071
2077 short USER_API dc_write_24c64_hex(HANDLE icdev, short offset, short length, unsigned char *snd_buffer);
2078
2089 short USER_API dc_read_24c(HANDLE icdev, short offset, short length, unsigned char *receive_buffer);
2090
2096 short USER_API dc_read_24c_hex(HANDLE icdev, short offset, short length, unsigned char *receive_buffer);
2097
2108 short USER_API dc_read_24c64(HANDLE icdev, short offset, short length, unsigned char *receive_buffer);
2109
2115 short USER_API dc_read_24c64_hex(HANDLE icdev, short offset, short length, unsigned char *receive_buffer);
2116
2127 short USER_API dc_read_4428(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2128
2134 short USER_API dc_read_4428_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2135
2146 short USER_API dc_write_4428(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2147
2153 short USER_API dc_write_4428_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2154
2163 short USER_API dc_verifypin_4428(HANDLE icdev, unsigned char *passwd);
2164
2170 short USER_API dc_verifypin_4428_hex(HANDLE icdev, unsigned char *passwd);
2171
2180 short USER_API dc_readpin_4428(HANDLE icdev, unsigned char *passwd);
2181
2187 short USER_API dc_readpin_4428_hex(HANDLE icdev, unsigned char *passwd);
2188
2196 short USER_API dc_readpincount_4428(HANDLE icdev);
2197
2206 short USER_API dc_changepin_4428(HANDLE icdev, unsigned char *passwd);
2207
2213 short USER_API dc_changepin_4428_hex(HANDLE icdev, unsigned char *passwd);
2214
2225 short USER_API dc_readprotect_4428(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2226
2232 short USER_API dc_readprotect_4428_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2233
2244 short USER_API dc_writeprotect_4428(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2245
2251 short USER_API dc_writeprotect_4428_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer);
2252
2260 short USER_API dc_Check_4442(HANDLE icdev);
2261
2269 short USER_API dc_Check_4428(HANDLE icdev);
2270
2278 short USER_API dc_Check_24C01(HANDLE icdev);
2279
2287 short USER_API dc_Check_24C02(HANDLE icdev);
2288
2296 short USER_API dc_Check_24C04(HANDLE icdev);
2297
2305 short USER_API dc_Check_24C08(HANDLE icdev);
2306
2314 short USER_API dc_Check_24C16(HANDLE icdev);
2315
2323 short USER_API dc_Check_24C64(HANDLE icdev);
2324
2332 short USER_API dc_Check_CPU(HANDLE icdev);
2333
2351 short USER_API dc_CheckCard(HANDLE icdev);
2352
2356 short USER_API dc_getrcinfo(HANDLE icdev, unsigned char *info);
2357
2361 short USER_API dc_getrcinfo_hex(HANDLE icdev, unsigned char *info);
2362
2371 short USER_API dc_getlongver(HANDLE icdev, unsigned char *sver);
2372
2382 short USER_API dc_cardstr(HANDLE icdev, unsigned char _Mode, char *Strsnr);
2383
2394 short USER_API dc_cardAB(HANDLE icdev, unsigned char *rlen, unsigned char *rbuf, unsigned char *type);
2395
2404 short USER_API dc_card_b(HANDLE icdev, unsigned char *rbuf);
2405
2411 short USER_API dc_card_b_hex(HANDLE icdev, char *rbuf);
2412
2423 short USER_API dc_dispinfo_T8(HANDLE icdev, unsigned char line, unsigned char offset, char *data);
2424
2434 short USER_API dc_dispinfo_pro_T8(HANDLE icdev, unsigned char offset, char *data);
2435
2444 short USER_API dc_clearlcd_T8(HANDLE icdev, unsigned char line);
2445
2455 short USER_API dc_led_T8(HANDLE icdev, unsigned char cled, unsigned char cflag);
2456
2460 short USER_API dc_dispmap_T8(HANDLE icdev, unsigned char *mapdata);
2461
2465 short USER_API dc_displow_T8(HANDLE icdev, unsigned char rs, unsigned char cdata);
2466
2477 short USER_API dc_rw_rfreg(HANDLE icdev, unsigned char flag, unsigned char _Adr, unsigned char *_Data);
2478
2484 short USER_API dc_rw_rfreg_hex(HANDLE icdev, unsigned char flag, unsigned char _Adr, unsigned char *_Data);
2485
2489 short USER_API dc_mulrequest_b(HANDLE icdev, unsigned char _Mode, unsigned char AFI, unsigned char *cardnum, unsigned char *mulATQB);
2490
2494 short USER_API dc_hltb(HANDLE icdev, unsigned char *PUPI);
2495
2499 short USER_API dc_set_poweroff(HANDLE icdev, unsigned int MsTimes, unsigned char TimerClock, unsigned char TimerReload);
2500
2514 short USER_API dc_pro_commandsourceCRC(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char CRCSTU);
2515
2521 short USER_API dc_pro_commandsourceCRChex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout, unsigned char CRCSTU);
2522
2532 short USER_API dc_MFPL0_writeperso(HANDLE icdev, unsigned int BNr, unsigned char *dataperso);
2533
2539 short USER_API dc_MFPL0_writeperso_hex(HANDLE icdev, unsigned int BNr, unsigned char *dataperso);
2540
2548 short USER_API dc_MFPL0_commitperso(HANDLE icdev);
2549
2558 short USER_API dc_MFPL1_authl1key(HANDLE icdev, unsigned char *authkey);
2559
2565 short USER_API dc_MFPL1_authl1key_hex(HANDLE icdev, unsigned char *authkey);
2566
2575 short USER_API dc_MFPL1_switchtol2(HANDLE icdev, unsigned char *authkey);
2576
2585 short USER_API dc_MFPL1_switchtol3(HANDLE icdev, unsigned char *authkey);
2586
2595 short USER_API dc_MFPL2_switchtol3(HANDLE icdev, unsigned char *authkey);
2596
2606 short USER_API dc_MFPL3_authl3key(HANDLE icdev, unsigned int keyBNr, unsigned char *authkey);
2607
2613 short USER_API dc_MFPL3_authl3key_hex(HANDLE icdev, unsigned int keyBNr, unsigned char *authkey);
2614
2625 short USER_API dc_MFPL3_authl3sectorkey(HANDLE icdev, unsigned char mode, unsigned int sectorBNr, unsigned char *authkey);
2626
2632 short USER_API dc_MFPL3_authl3sectorkey_hex(HANDLE icdev, unsigned char mode, unsigned int sectorBNr, unsigned char *authkey);
2633
2644 short USER_API dc_MFPL3_readinplain(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata);
2645
2651 short USER_API dc_MFPL3_readinplain_hex(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata);
2652
2664 short USER_API dc_MFPL3_readencrypted(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata, unsigned char flag);
2665
2671 short USER_API dc_MFPL3_readencrypted_hex(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata, unsigned char flag);
2672
2683 short USER_API dc_MFPL3_writeinplain(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata);
2684
2690 short USER_API dc_MFPL3_writeinplain_hex(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata);
2691
2703 short USER_API dc_MFPL3_writeencrypted(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata, unsigned char flag);
2704
2710 short USER_API dc_MFPL3_writeencrypted_hex(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata, unsigned char flag);
2711
2720 short USER_API dc_auth_ulc(HANDLE icdev, unsigned char *key);
2721
2727 short USER_API dc_auth_ulc_hex(HANDLE icdev, unsigned char *key);
2728
2737 short USER_API dc_changekey_ulc(HANDLE icdev, unsigned char *newkey);
2738
2744 short USER_API dc_changekey_ulc_hex(HANDLE icdev, unsigned char *newkey);
2745
2756 short USER_API dc_getcpupara(HANDLE icdev, unsigned char cputype, unsigned char *cpupro, unsigned char *cpuetu);
2757
2769 short USER_API dc_cpuapdusourceEXT(HANDLE icdev, short slen, unsigned char *sendbuffer, short *rlen, unsigned char *databuffer);
2770
2776 short USER_API dc_cpuapdusourceEXT_hex(HANDLE icdev, short slen, char *sendbuffer, short *rlen, char *databuffer);
2777
2789 short USER_API dc_cpuapduEXT(HANDLE icdev, short slen, unsigned char *sendbuffer, short *rlen, unsigned char *databuffer);
2790
2796 short USER_API dc_cpuapduEXT_hex(HANDLE icdev, short slen, char *sendbuffer, short *rlen, char *databuffer);
2797
2809 short USER_API dc_cpuapduInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer);
2810
2816 short USER_API dc_cpuapduInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer);
2817
2831 short USER_API dc_pro_commandlinkEXT(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG);
2832
2838 short USER_API dc_pro_commandlinkEXT_hex(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG);
2839
2852 short USER_API dc_pro_commandlinkInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout);
2853
2859 short USER_API dc_pro_commandlinkInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout);
2860
2864 short USER_API dc_exchangeblock(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout);
2865
2869 short USER_API dc_exchangeblock_hex(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout);
2870
2874 short USER_API dc_write1024(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writebuffer);
2875
2879 short USER_API dc_write1024_hex(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writebuffer);
2880
2884 short USER_API dc_read1024(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *databuffer);
2885
2889 short USER_API dc_read1024_hex(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *databuffer);
2890
2894 short USER_API dc_switch_linux(HANDLE icdev);
2895
2905 short USER_API dc_cpuhotreset(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer);
2906
2912 short USER_API dc_cpuhotreset_hex(HANDLE icdev, unsigned char *rlen, char *databuffer);
2913
2936 short USER_API dc_card_exist(HANDLE icdev, unsigned char *flag);
2937
2945 short USER_API dc_card_status(HANDLE icdev);
2946
2954 short USER_API dc_typeab_card_status(HANDLE icdev);
2955
2966 short USER_API dc_card_n(HANDLE icdev, unsigned char _Mode, unsigned int *SnrLen, unsigned char *_Snr);
2967
2973 short USER_API dc_card_n_hex(HANDLE icdev, unsigned char _Mode, unsigned int *SnrLen, unsigned char *_Snr);
2974
2978 short USER_API dc_card_n_number(HANDLE icdev, unsigned char _Mode, char *_Snr);
2979
2989 short USER_API dc_pass_key_value(HANDLE icdev, unsigned char timeout, char *value);
2990
2999 short USER_API dc_play_voice(HANDLE icdev, unsigned char mode);
3000
3009 short USER_API dc_playvoice(HANDLE icdev, unsigned char mode);
3010
3021 short USER_API dc_load_voice(HANDLE icdev, int flag, int slen, const unsigned char *sdata);
3022
3052 short USER_API dc_setmag(HANDLE icdev, unsigned char mode, unsigned char track1, unsigned char track2, unsigned char track3);
3053
3067 short USER_API dc_setprint(HANDLE icdev, unsigned char FontSize, unsigned char Alignment, unsigned char LeftMargin, unsigned char RightMargin, unsigned char RowPitch, unsigned char PrintOutRate);
3068
3082 short USER_API dc_checkprint(HANDLE icdev, unsigned char *FontSize, unsigned char *Alignment, unsigned char *LeftMargin, unsigned char *RightMargin, unsigned char *RowPitch, unsigned char *PrintOutRate);
3083
3093 short USER_API dc_printcharacter(HANDLE icdev, unsigned short length, unsigned char *character);
3094
3107 short USER_API dc_printOnedimensional(HANDLE icdev, unsigned char hight, unsigned char displayflag, unsigned char FontSize, unsigned short length, unsigned char *Onedimensional);
3108
3123 short USER_API dc_printPicture(HANDLE icdev, unsigned char length, unsigned char height, unsigned char Alignment, unsigned char LeftMargin, unsigned char RightMargin, unsigned short size, unsigned char *Picture);
3124
3133 short USER_API dc_printenter(HANDLE icdev, unsigned char RowPitch);
3134
3153 short USER_API dc_printstatus(HANDLE icdev, unsigned char *paperstatus, unsigned char *tempturestatus, unsigned char *zkstatus);
3154
3171 short USER_API dc_set2dot4Gbaund(HANDLE icdev, unsigned char baund);
3172
3189 short USER_API dc_check2dot4Gbaund(HANDLE icdev, unsigned char *baund);
3190
3200 short USER_API dc_2dot4_reset(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer);
3201
3207 short USER_API dc_2dot4_resethex(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer);
3208
3221 short USER_API dc_2dot4_command(HANDLE icdev, unsigned int slen, unsigned char *senddata, unsigned int *rlen, unsigned char *recvbuffer, unsigned char timeout);
3222
3228 short USER_API dc_2dot4_command_hex(HANDLE icdev, unsigned int slen, unsigned char *senddata, unsigned int *rlen, unsigned char *recvbuffer, unsigned char timeout);
3229
3237 short USER_API dc_check_102(HANDLE icdev);
3238
3246 short USER_API dc_down_102(HANDLE icdev);
3247
3258 short USER_API dc_read_102(HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *readdata);
3259
3265 short USER_API dc_read_102_hex(HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *readdata);
3266
3277 short USER_API dc_write_102(HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *writedata);
3278
3284 short USER_API dc_write_102_hex(HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *writedata);
3285
3298 short USER_API dc_checkpass_102(HANDLE icdev, short zone, unsigned char *password);
3299
3305 short USER_API dc_checkpass_102_hex(HANDLE icdev, short zone, unsigned char *password);
3306
3319 short USER_API dc_changepass_102(HANDLE icdev, short zone, unsigned char *password);
3320
3326 short USER_API dc_changepass_102_hex(HANDLE icdev, short zone, unsigned char *password);
3327
3337 short USER_API dc_readcount_102(HANDLE icdev, short zone);
3338
3346 short USER_API dc_fuse_102(HANDLE icdev);
3347
3355 short USER_API dc_check_1604(HANDLE icdev);
3356
3364 short USER_API dc_down_1604(HANDLE icdev);
3365
3376 short USER_API dc_read_1604(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *readdata);
3377
3383 short USER_API dc_read_1604_hex(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *readdata);
3384
3395 short USER_API dc_write_1604(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writedata);
3396
3402 short USER_API dc_write_1604_hex(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writedata);
3403
3422 short USER_API dc_checkpass_1604(HANDLE icdev, short zone, unsigned char *password);
3423
3429 short USER_API dc_checkpass_1604_hex(HANDLE icdev, short zone, unsigned char *password);
3430
3449 short USER_API dc_changepass_1604(HANDLE icdev, short zone, unsigned char *password);
3450
3456 short USER_API dc_changepass_1604_hex(HANDLE icdev, short zone, unsigned char *password);
3457
3475 short USER_API dc_readcount_1604(HANDLE icdev, short zone);
3476
3484 short USER_API dc_fuse_1604(HANDLE icdev);
3485
3493 short USER_API dc_down_4428(HANDLE icdev);
3494
3502 short USER_API dc_down_4442(HANDLE icdev);
3503
3507 short USER_API dc_flash_card(HANDLE icdev);
3508
3512 short USER_API dc_read_walletbalance(HANDLE icdev, unsigned char *walletvalue);
3513
3517 short USER_API dc_consume_wallet(HANDLE icdev, unsigned char *walletvalue, unsigned char *secret);
3518
3522 short USER_API dc_transfer_wallet(HANDLE icdev, unsigned char *walletvalue);
3523
3527 short USER_API dc_authentication_key(HANDLE icdev, unsigned char *data, unsigned char *desdata);
3528
3532 short USER_API dc_set_terminalnumber(HANDLE icdev, unsigned char length, unsigned char *serieldata);
3533
3537 short USER_API dc_get_terminalnumber(HANDLE icdev, unsigned char length, unsigned char *serieldata);
3538
3542 short USER_API dc_set_trademerchantcode(HANDLE icdev, unsigned char length, unsigned char *merchantcode);
3543
3547 short USER_API dc_get_trademerchantcode(HANDLE icdev, unsigned char length, unsigned char *merchantcode);
3548
3552 short USER_API dc_set_transactiontype(HANDLE icdev, unsigned char typecode);
3553
3557 short USER_API dc_get_transactiontype(HANDLE icdev, unsigned char *typecode);
3558
3562 short USER_API dc_set_tradesecretkey(HANDLE icdev, unsigned char *secretkey);
3563
3567 short USER_API dc_get_tradesecretkey(HANDLE icdev, unsigned char *secretkey);
3568
3572 short USER_API dc_set_hardwareserialnumber(HANDLE icdev, unsigned char length, unsigned char *hardwareserial);
3573
3577 short USER_API dc_get_hardwareserialnumber(HANDLE icdev, unsigned char length, unsigned char *hardwareserial);
3578
3582 short USER_API dc_reset_factory(HANDLE icdev);
3583
3587 short USER_API dc_get_signmessageparameters(HANDLE icdev, unsigned char length, unsigned char *parameters);
3588
3592 short USER_API dc_get_record(HANDLE icdev, unsigned char tablenumber, unsigned char recordnumber, unsigned char *recordquantity, unsigned char *recorddata);
3593
3601 short USER_API dc_startreadmag(HANDLE icdev);
3602
3610 short USER_API dc_stopreadmag(HANDLE icdev);
3611
3625 short USER_API dc_readmag(HANDLE icdev, unsigned char *pTrack1Data, unsigned int *pTrack1Len, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len);
3626
3641 short USER_API dc_readmagcardallA(HANDLE icdev, unsigned char ctime, unsigned char *pTrack1Data, unsigned int *pTrack1Len, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len);
3642
3662 short USER_API dc_InstallKbKey(HANDLE icdev, unsigned char flag, unsigned char keylen, unsigned char *keydata, unsigned char mode);
3663
3672 short USER_API dc_SetKbKeyID(HANDLE icdev, unsigned char keyID);
3673
3686 short USER_API dc_GetEnPass(HANDLE icdev, unsigned char ctime, unsigned char panlen, unsigned char *pandata, unsigned char *rlen, unsigned char *cpass);
3687
3691 short USER_API dc_get55data(HANDLE icdev, unsigned int slen, unsigned char *sdata, unsigned char *PacketType, unsigned int *rlen, unsigned char *rdata);
3692
3696 short USER_API dc_CardIssuingScript(HANDLE icdev, unsigned int slen, unsigned char *sdata, unsigned char *TransactionIsInterrupted, unsigned char *TradingResult);
3697
3701 short USER_API dc_SetEMVPara(HANDLE icdev, unsigned int slen, unsigned char *sdata);
3702
3706 short USER_API dc_CalculateMACCheck(HANDLE icdev, unsigned char keyindex, unsigned char macmode, unsigned int datalen, unsigned char *srcdata, unsigned char *macdata);
3707
3711 short USER_API dc_CalculateDes(HANDLE icdev, unsigned char keyindex, unsigned char enmode, unsigned short datalen, unsigned char *srcdata, unsigned char *desdata);
3712
3716 short USER_API dc_CalculateSm4(HANDLE icdev, unsigned char keyindex, unsigned char enmode, unsigned short datalen, unsigned char *srcdata, unsigned char *sm4data);
3717
3729 short USER_API dc_CreatDesData(HANDLE icdev, unsigned char keytype, unsigned char enmode, unsigned char *sourcedata, unsigned char *retdata);
3730
3742 short USER_API dc_CreatSm4Data(HANDLE icdev, unsigned char keytype, unsigned char enmode, unsigned char *sourcedata, unsigned char *retdata);
3743
3757 short USER_API dc_CreatDesDataECB(HANDLE icdev, unsigned char keytype, unsigned char enmode, int slen, unsigned char *sourcedata, int *rlen, unsigned char *retdata);
3758
3772 short USER_API dc_CreatSm4DataECB(HANDLE icdev, unsigned char keytype, unsigned char enmode, int slen, unsigned char *sourcedata, int *rlen, unsigned char *retdata);
3773
3787 short USER_API dc_CreatMacDataECB(HANDLE icdev, unsigned char keytype, unsigned char enmode, int slen, unsigned char *sourcedata, int *rlen, unsigned char *retdata);
3788
3799 short USER_API dc_writeSD(HANDLE icdev, int offset, int length, unsigned char *writebuffer);
3800
3811 short USER_API dc_readSD(HANDLE icdev, int offset, int length, unsigned char *readbuffer);
3812
3826 short USER_API dc_SetUsbMode(HANDLE icdev, unsigned char ucmode);
3827
3840 short USER_API SD_InstallKey(HANDLE icdev, unsigned char ctime, unsigned char senlen, unsigned char *source, unsigned char *reclen, unsigned char *rdata);
3841
3850 short USER_API SD_IFD_GetVersion(HANDLE icdev, char *version);
3851
3868 short USER_API SD_IFD_PlayVoice(HANDLE icdev, unsigned char _playmode);
3869
3877 short USER_API SD_IFD_Init(HANDLE icdev);
3878
3889 short USER_API SD_IFD_SetMainKey(HANDLE icdev, unsigned char keyset, unsigned char *oldkey, unsigned char *newkey);
3890
3901 short USER_API SD_IFD_SetWorkKey(HANDLE icdev, unsigned char keysetmain, unsigned char keysetwork, unsigned char *enkeywork);
3902
3912 short USER_API SD_IFD_ActWorkKey(HANDLE icdev, unsigned char keysetmain, unsigned char keysetwork);
3913
3922 short USER_API SD_IFD_SetKeyLength(HANDLE icdev, unsigned char keylength);
3923
3932 short USER_API SD_IFD_GetPIN(HANDLE icdev, char *szPasswd);
3933
3942 short USER_API SD_IFD_GetEnPIN(HANDLE icdev, char *szPasswd);
3943
3961 short USER_API SD_IFD_GetPINPro(HANDLE icdev, char *szPasswd, unsigned char yyflag, unsigned char timeout);
3962
3986 short USER_API SD_IFD_GetEnPINPro(HANDLE icdev, char *szPasswd, unsigned char yyflag, unsigned char modeflag, unsigned char timeout);
3987
4012 short USER_API SD_IFD_GetEnPINBlock(HANDLE icdev, char *szPasswd, unsigned char yyflag, unsigned char modeflag, unsigned char *cardno, unsigned char timeout);
4013
4022 short USER_API SD_IFD_SelecetDes(HANDLE icdev, unsigned char desmode);
4023
4035 short USER_API SD_IFD_LEDDisplay(HANDLE icdev, unsigned char line, unsigned char row, unsigned char *leddata, unsigned char timeout);
4036
4047 short USER_API SD_IFD_DES(HANDLE icdev, unsigned char mode, unsigned char *srcdata, unsigned char *desdata);
4048
4060 short USER_API SD_IFD_DesCaculate(HANDLE icdev, unsigned char srclen, unsigned char *srcdata, unsigned char *desdata, unsigned char flag);
4061
4072 short USER_API SD_IFD_CreateMac(HANDLE icdev, unsigned char srclen, unsigned char *srcdata, unsigned char *macdata);
4073
4082 short USER_API SD_IFD_Scan2DBarcodeStart(HANDLE icdev, unsigned char mode);
4083
4093 short USER_API SD_IFD_Scan2DBarcodeGetData(HANDLE icdev, int *rlen, unsigned char *rdata);
4094
4102 short USER_API SD_IFD_Scan2DBarcodeExit(HANDLE icdev);
4103
4111 short USER_API dc_find_i_d(HANDLE icdev);
4112
4120 short USER_API dc_find_i_d_2(HANDLE icdev);
4121
4129 short USER_API dc_find_i_d_speed(HANDLE icdev);
4130
4139 short USER_API dc_get_i_d_raw_buffer(HANDLE icdev, unsigned char *rdata);
4140
4148 HANDLE USER_API dc_start_i_d(HANDLE icdev);
4149
4157 HANDLE USER_API dc_start_i_d_2(HANDLE icdev);
4158
4166 char *USER_API dc_i_d_query_name(HANDLE idhandle);
4167
4176 short USER_API dc_i_d_query_name_2(HANDLE idhandle, char *name);
4177
4185 char *USER_API dc_i_d_query_sex(HANDLE idhandle);
4186
4195 short USER_API dc_i_d_query_sex_2(HANDLE idhandle, char *sex);
4196
4204 char *USER_API dc_i_d_query_nation(HANDLE idhandle);
4205
4214 short USER_API dc_i_d_query_nation_2(HANDLE idhandle, char *nation);
4215
4223 char *USER_API dc_i_d_query_birth(HANDLE idhandle);
4224
4233 short USER_API dc_i_d_query_birth_2(HANDLE idhandle, char *birth);
4234
4242 char *USER_API dc_i_d_query_address(HANDLE idhandle);
4243
4252 short USER_API dc_i_d_query_address_2(HANDLE idhandle, char *address);
4253
4261 char *USER_API dc_i_d_query_id_number(HANDLE idhandle);
4262
4271 short USER_API dc_i_d_query_id_number_2(HANDLE idhandle, char *id_number);
4272
4280 char *USER_API dc_i_d_query_department(HANDLE idhandle);
4281
4290 short USER_API dc_i_d_query_department_2(HANDLE idhandle, char *department);
4291
4299 char *USER_API dc_i_d_query_expire_day(HANDLE idhandle);
4300
4309 short USER_API dc_i_d_query_expire_day_2(HANDLE idhandle, char *expire_day);
4310
4318 unsigned char *USER_API dc_i_d_query_photo(HANDLE idhandle);
4319
4328 short USER_API dc_i_d_query_photo_2(HANDLE idhandle, unsigned char *photo);
4329
4337 unsigned int USER_API dc_i_d_query_photo_len(HANDLE idhandle);
4338
4347 short USER_API dc_i_d_query_photo_file(HANDLE idhandle, const char *FileName);
4348
4358 short USER_API dc_i_d_query_photo_bmp_buffer(HANDLE idhandle, unsigned char *BmpBuffer, unsigned int *BmpLength);
4359
4367 unsigned char *USER_API dc_i_d_query_finger(HANDLE idhandle);
4368
4377 short USER_API dc_i_d_query_finger_2(HANDLE idhandle, unsigned char *finger);
4378
4386 unsigned int USER_API dc_i_d_query_finger_len(HANDLE idhandle);
4387
4391 short USER_API dc_i_d_query_finger_file(HANDLE idhandle, const char *FileName);
4392
4396 short USER_API dc_i_d_query_finger_bmp_buffer(HANDLE idhandle, unsigned char *BmpBuffer, unsigned int *BmpLength);
4397
4404 void USER_API dc_end_i_d(HANDLE idhandle);
4405
4414 short USER_API dc_getuid_i_d(HANDLE icdev, unsigned char *uid);
4415
4426 short USER_API dc_display_2dbarcode(HANDLE icdev, int point_x, int point_y, const char *info);
4427
4437 short USER_API dc_getfingerdata(HANDLE icdev, int *length, unsigned char *data);
4438
4450 short USER_API dc_card_status2(HANDLE icdev, unsigned char *pos);
4451
4460 short USER_API dc_card_make_and_lock(HANDLE icdev, unsigned char flag);
4461
4471 short USER_API dc_send_sms(HANDLE icdev, const char *phone_no, const char *sms_content);
4472
4485 short USER_API dc_fingerprint_io_control(HANDLE icdev, unsigned char ctime, const unsigned char *request, int request_len, unsigned char *response, int *response_len);
4486
4490 short USER_API dc_keypad_io_control(HANDLE icdev, unsigned char ctime, const unsigned char *request, int request_len, unsigned char *response, int *response_len);
4491
4495 short USER_API dc_keypad_ImportKey(HANDLE icdev, unsigned char *check_value, unsigned char check_mode, int key_index, int use_key_index, unsigned char enable, const unsigned char *key, int key_len);
4496
4500 short USER_API dc_keypad_DeleteKey(HANDLE icdev, int key_index);
4501
4505 short USER_API dc_keypad_SetButtonMark(HANDLE icdev, unsigned int mark_value, unsigned char use);
4506
4510 short USER_API dc_keypad_Start(HANDLE icdev, unsigned char mode, int max_len, unsigned char auto_end, unsigned char enable_sound);
4511
4515 short USER_API dc_keypad_End(HANDLE icdev);
4516
4520 short USER_API dc_keypad_GetPressed(HANDLE icdev, int time_ms, unsigned char *value);
4521
4525 short USER_API dc_keypad_GetPinBlock(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *customer_data, int customer_data_len, unsigned char *out_data, int *out_data_len);
4526
4530 short USER_API dc_keypad_GetRandomValue(HANDLE icdev, int length, unsigned char *value);
4531
4535 short USER_API dc_keypad_GetEncryptDataOfCBC(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len);
4536
4540 short USER_API dc_keypad_GetDecryptDataOfCBC(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len);
4541
4545 short USER_API dc_keypad_GetEncryptDataOfECB(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len);
4546
4550 short USER_API dc_keypad_GetDecryptDataOfECB(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len);
4551
4555 short USER_API dc_keypad_GetMACDataOfCBC(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len);
4556
4571 short USER_API dc_RfGetCardType(HANDLE icdev);
4572
4576 short USER_API dc_RfWaveControl(HANDLE icdev, unsigned char mode);
4577
4581 short USER_API dc_RfReadChipRegister(HANDLE icdev, unsigned char *register_data);
4582
4586 short USER_API dc_RfSetChipRegister(HANDLE icdev, unsigned char register_type, unsigned char register_value);
4587
4596 short USER_API dc_get_idsnr(HANDLE icdev, unsigned char *_Data);
4597
4603 short USER_API dc_get_idsnr_hex(HANDLE icdev, char *_Data);
4604
4617 short USER_API dc_PinpadCommunication(HANDLE icdev, int time_100ms, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata);
4618
4629 short USER_API dc_ReadFlash(HANDLE icdev, int offset, int length, unsigned char *data_buffer);
4630
4641 short USER_API dc_WriteFlash(HANDLE icdev, int offset, int length, const unsigned char *data_buffer);
4642
4658 short USER_API dc_SelfServiceDeviceCardStatus(HANDLE icdev, unsigned char *pos);
4659
4680 short USER_API dc_SelfServiceDeviceCardInject(HANDLE icdev, unsigned char time_s, unsigned char mode);
4681
4700 short USER_API dc_SelfServiceDeviceCardEject(HANDLE icdev, unsigned char time_s, unsigned char mode);
4701
4719 short USER_API dc_SelfServiceDeviceCardMove(HANDLE icdev, unsigned char time_s, unsigned char mode);
4720
4732 short USER_API dc_SelfServiceDeviceSensorStatus(HANDLE icdev, unsigned char *value);
4733
4745 short USER_API dc_SelfServiceDeviceConfig(HANDLE icdev, unsigned char mode);
4746
4759 short USER_API dc_SelfServiceDeviceConfigFront(HANDLE icdev, unsigned char mode);
4760
4772 short USER_API dc_SelfServiceDeviceConfigBack(HANDLE icdev, unsigned char mode);
4773
4788 short USER_API dc_SelfServiceDeviceConfigPlace(HANDLE icdev, unsigned char mode);
4789
4809 short USER_API dc_SelfServiceDeviceCheckCardType(HANDLE icdev);
4810
4818 short USER_API dc_SelfServiceDeviceReset(HANDLE icdev);
4819
4828 short USER_API dc_MulticardStatus(HANDLE icdev, unsigned char *type);
4829
4840 short USER_API dc_pass_key_value2(HANDLE icdev, unsigned char ctime, unsigned char *rlen, unsigned char *cpass);
4841
4852 short USER_API dc_ReadOutEeprom(HANDLE icdev, int offset, int length, unsigned char *data_buffer);
4853
4864 short USER_API dc_WriteOutEeprom(HANDLE icdev, int offset, int length, const unsigned char *data_buffer);
4865
4876 short USER_API dc_ReadIdCardInfo(HANDLE icdev, int time_ms, int *rlen, unsigned char *rdata);
4877
4881 short USER_API dc_cpy_getkey(HANDLE icdev, unsigned char *respkey, int *resplen);
4882
4886 short USER_API dc_cpy_setkey(HANDLE icdev, unsigned char *genkey, int keylen);
4887
4891 short USER_API dc_cpy_cpuapdu(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer);
4892
4896 short USER_API dc_cpy_cpuapdu_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer);
4897
4901 short USER_API dc_cpy_cpuapduInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer);
4902
4906 short USER_API dc_cpy_cpuapduInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer);
4907
4911 short USER_API dc_cpy_procommand(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout);
4912
4916 short USER_API dc_cpy_procommand_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout);
4917
4921 short USER_API dc_cpy_procommandInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout);
4922
4926 short USER_API dc_cpy_procommandInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout);
4927
4940 short USER_API dc_procommandInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout);
4941
4947 short USER_API dc_procommandInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout);
4948
4952 short USER_API dc_ReadRfCfgReg(HANDLE icdev, int type, int number, int *value);
4953
4957 short USER_API dc_WriteRfCfgReg(HANDLE icdev, int type, int number, int value);
4958
4966 short USER_API dc_NfcInit(HANDLE icdev);
4967
4977 short USER_API dc_NfcActivate(HANDLE icdev, unsigned char *atr, int *atr_len);
4978
4986 short USER_API dc_NfcDeactivate(HANDLE icdev);
4987
4997 short USER_API dc_NfcPush(HANDLE icdev, const unsigned char *request, int request_len);
4998
5007 short USER_API dc_NfcService(HANDLE icdev, int flag);
5008
5019 short USER_API dc_NfcFetch(HANDLE icdev, unsigned char *response, int *response_len, int time_ms);
5020
5032 short USER_API dc_NfcDataReceiver(HANDLE icdev, int time_ms, unsigned char *flag, unsigned char *response, int *response_len);
5033
5042 short USER_API dc_NfcSimulateCardConfig(HANDLE icdev, int mode);
5043
5054 short USER_API dc_MagFormatConfig(HANDLE icdev, int mode);
5055
5065 short USER_API dc_ReadModuleMacAddress(HANDLE icdev, int type, char *value);
5066
5076 short USER_API dc_WriteModuleMacAddress(HANDLE icdev, int type, const char *value);
5077
5087 short USER_API dc_ReadRfTypeABATS(HANDLE icdev, int *ats_len, unsigned char *ats);
5088
5094 short USER_API dc_ReadRfTypeABATS_hex(HANDLE icdev, int *ats_len, char *ats);
5095
5099 short USER_API dc_RfFormatConfig(HANDLE icdev, int mode, int block_number, int offset, int length);
5100
5109 short USER_API dc_FlashErase(HANDLE icdev, int sector);
5110
5121 short USER_API dc_BuzzerBeep(HANDLE icdev, unsigned short beep_time_ms, unsigned short interval_time_ms, unsigned short count);
5122
5131 short USER_API dc_BtModeControl(HANDLE icdev, unsigned char mode);
5132
5147 short USER_API dc_BtBaudrateControl(HANDLE icdev, unsigned char flag, unsigned char *value);
5148
5158 short USER_API dc_BtPasswordControl(HANDLE icdev, unsigned char flag, char *value);
5159
5170 short USER_API dc_BtAddressControl(HANDLE icdev, unsigned char flag, unsigned char *length, unsigned char *value);
5171
5181 short USER_API dc_BtNameControl(HANDLE icdev, unsigned char flag, char *value);
5182
5194 short USER_API dc_BtUserControl(HANDLE icdev, unsigned char flag, int offset, int length, unsigned char *value);
5195
5203 short USER_API dc_BtReset(HANDLE icdev);
5204
5214 short USER_API dc_BtCommunicationTest(HANDLE icdev, int length, const unsigned char *value);
5215
5233 short USER_API dc_BtWithReaderBaudrateControl(HANDLE icdev, unsigned char flag, unsigned char *value);
5234
5246 short USER_API dc_BtCommand(HANDLE icdev, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata);
5247
5257 short USER_API dc_BtSignalStrength(HANDLE icdev, unsigned char *state, short *value);
5258
5268 short USER_API dc_BtDataResponse(HANDLE icdev, int *length, unsigned char *value);
5269
5281 short USER_API dc_BtDataTransmit(HANDLE icdev, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata);
5282
5309 short USER_API dc_SamAControl(HANDLE icdev, int code, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata);
5310
5330 short USER_API dc_SamAReadCardInfo(HANDLE icdev, int type, int *text_len, unsigned char *text, int *photo_len, unsigned char *photo, int *fingerprint_len, unsigned char *fingerprint, int *extra_len, unsigned char *extra);
5331
5352 short USER_API dc_ParseTextInfo(HANDLE icdev, int charset, int info_len, const unsigned char *info, unsigned char *name, unsigned char *sex, unsigned char *nation, unsigned char *birth_day, unsigned char *address, unsigned char *id_number, unsigned char *department, unsigned char *expire_start_day, unsigned char *expire_end_day, unsigned char *reserved);
5353
5376 short USER_API dc_ParseTextInfoForForeigner(HANDLE icdev, int charset, int info_len, const unsigned char *info, unsigned char *english_name, unsigned char *sex, unsigned char *id_number, unsigned char *citizenship, unsigned char *chinese_name, unsigned char *expire_start_day, unsigned char *expire_end_day, unsigned char *birth_day, unsigned char *version_number, unsigned char *department_code, unsigned char *type_sign, unsigned char *reserved);
5377
5402 short USER_API dc_ParseTextInfoForHkMoTw(HANDLE icdev, int charset, int info_len, const unsigned char *info, unsigned char *name, unsigned char *sex, unsigned char *reserved, unsigned char *birth_day, unsigned char *address, unsigned char *id_number, unsigned char *department, unsigned char *expire_start_day, unsigned char *expire_end_day, unsigned char *pass_number, unsigned char *sign_count, unsigned char *reserved2, unsigned char *type_sign, unsigned char *reserved3);
5403
5422 short USER_API dc_ParsePhotoInfo(HANDLE icdev, int type, int info_len, const unsigned char *info, int *photo_len, unsigned char *photo);
5423
5434 short USER_API dc_ParseOtherInfo(HANDLE icdev, int flag, const unsigned char *in_info, unsigned char *out_info);
5435
5448 short USER_API dc_CpuCardStatus(HANDLE icdev);
5449
5457 short USER_API dc_WakeDevice(HANDLE icdev);
5458
5466 short USER_API dc_RestDevice(HANDLE icdev);
5467
5476 short USER_API dc_GetBatteryValue(HANDLE icdev, unsigned char *value);
5477
5488 short USER_API dc_anticoll_mode(HANDLE icdev, unsigned char mode, unsigned char _Bcnt, unsigned int *_Snr);
5489
5500 short USER_API dc_select_mode(HANDLE icdev, unsigned char mode, unsigned int _Snr, unsigned char *_Size);
5501
5511 short USER_API dc_attribInt(HANDLE icdev, unsigned char *PUPI, unsigned char CID);
5512
5526 short USER_API dc_rf_poweron(HANDLE icdev, unsigned char icc_slot_no, unsigned char *response);
5527
5540 short USER_API dc_rf_poweroff(HANDLE icdev, unsigned char icc_slot_no);
5541
5554 short USER_API dc_rf_getstatus(HANDLE icdev, unsigned char icc_slot_no);
5555
5572 short USER_API dc_rf_application(HANDLE icdev, unsigned char icc_slot_no, int length_of_command_apdu, unsigned char *command_apdu, unsigned char *response_apdu);
5573
5582 short USER_API dc_RequestMultiCard(HANDLE icdev, unsigned char *uid_data);
5583
5593 short USER_API dc_ActivateCard(HANDLE icdev, unsigned char uid_len, const unsigned char *uid);
5594
5603 short USER_API dc_GetLastResponseCode(HANDLE icdev, unsigned int *code);
5604
5614 short USER_API dc_MultiFlashErase(HANDLE icdev, unsigned char type, unsigned int sector);
5615
5629 short USER_API dc_MultiFlashRead(HANDLE icdev, unsigned char type, unsigned int offset_h, unsigned int offset_l, unsigned int length_h, unsigned int length_l, unsigned char *data_buffer);
5630
5644 short USER_API dc_MultiFlashWrite(HANDLE icdev, unsigned char type, unsigned int offset_h, unsigned int offset_l, unsigned int length_h, unsigned int length_l, const unsigned char *data_buffer);
5645
5656 short USER_API dc_MultiFlashGetSize(HANDLE icdev, unsigned char type, unsigned int *length_h, unsigned int *length_l);
5657
5672 short USER_API dc_RfMultiRequest(HANDLE icdev);
5673
5684 short USER_API dc_TtsVoicePlay(HANDLE icdev, unsigned char type, const unsigned char *content, int content_len);
5685
5695 short USER_API dc_TtsVoiceConfig(HANDLE icdev, unsigned char type, unsigned char value);
5696
5706 short USER_API dc_Config2DBarcode(HANDLE icdev, const unsigned char *content, int content_len);
5707
5717 short USER_API dc_Scan2DBarcode(HANDLE icdev, unsigned short time_ms, char *message_data);
5718
5728 short USER_API dc_KeypadOpen(HANDLE icdev, int number, char *version);
5729
5738 short USER_API dc_KeypadClose(HANDLE icdev, int number);
5739
5761 short USER_API dc_KeypadLoadKey(HANDLE icdev, int number, int set_index, int sub_index, int type, int mode, const unsigned char *key_data, int key_len, int flag, unsigned char *ex_data, int *ex_len);
5762
5773 short USER_API dc_KeypadClearKey(HANDLE icdev, int number, int set_index, int sub_index);
5774
5786 short USER_API dc_KeypadGetKeyType(HANDLE icdev, int number, int set_index, int sub_index, int *type);
5787
5804 short USER_API dc_KeypadAlgorithm(HANDLE icdev, int number, int set_index, int sub_index, int flag, int mode, const unsigned char *in_data, int in_len, unsigned char *out_data, int *out_len);
5805
5826 short USER_API dc_KeypadStartInput(HANDLE icdev, int number, int mode, int set_index, int sub_index, const unsigned char *in_data, int in_len, int min_len, int max_len, int auto_end, int enable_beep, int time_s, unsigned char *out_data, int *out_len);
5827
5837 short USER_API dc_KeypadGetKeyValue(HANDLE icdev, int number, unsigned char *value);
5838
5850 short USER_API dc_KeypadExitAndGetInput(HANDLE icdev, int number, int mode, unsigned char *out_data, int *out_len);
5851
5861 short USER_API dc_KeypadSetKeyValue(HANDLE icdev, int number, unsigned char value);
5862
5871 short USER_API dc_GetDeviceUid(HANDLE icdev, char *uid);
5872
5881 short USER_API dc_GetDeviceTradeNumber(HANDLE icdev, char *number);
5882
5891 short USER_API dc_GetDeviceTerminalNumber(HANDLE icdev, char *number);
5892
5901 short USER_API dc_ReadDeviceCustomInfo(HANDLE icdev, unsigned char *info);
5902
5911 short USER_API dc_WriteDeviceCustomInfo(HANDLE icdev, const unsigned char *info);
5912
5921 short USER_API dc_ReadDeviceTypeName(HANDLE icdev, char *name);
5922
5931 short USER_API dc_WriteDeviceTypeName(HANDLE icdev, const char *name);
5932
5941 short USER_API dc_WirelessPowerControl(HANDLE icdev, unsigned char value);
5942
5953 short USER_API dc_WirelessTcpOpen(HANDLE icdev, unsigned char type, const char *network_address, const char *network_port);
5954
5962 short USER_API dc_WirelessTcpClose(HANDLE icdev);
5963
5982 short USER_API dc_WirelessGetStatus(HANDLE icdev, unsigned char *value);
5983
5994 short USER_API dc_WirelessSend(HANDLE icdev, unsigned char type, const unsigned char *data_buffer, int data_len);
5995
6008 short USER_API dc_WirelessRecv(HANDLE icdev, unsigned char type, unsigned char mode, unsigned char time_100ms, unsigned char *data_buffer, int *data_len);
6009
6020 short USER_API dc_WirelessWifiConfig(HANDLE icdev, unsigned char type, const char *ssid, const char *password);
6021
6032 short USER_API dc_GpsGetInfo(HANDLE icdev, int time_ms, unsigned char *data_buffer, int *data_len);
6033
6042 short USER_API dc_SetCpuCard616C(HANDLE icdev, unsigned char value);
6043
6052 short USER_API dc_GetCpuCard616C(HANDLE icdev, unsigned char *value);
6053
6062 short USER_API dc_GetChipIdNumber(HANDLE icdev, char *number);
6063
6074 short USER_API dc_LedDisplay(HANDLE icdev, unsigned char number, unsigned char mode, unsigned char value);
6075
6094 short USER_API dc_LedControl(HANDLE icdev, unsigned char mode);
6095
6105 short USER_API dc_RfCrcModeConfig(HANDLE icdev, unsigned char tx_crc, unsigned char rx_crc);
6106
6117 short USER_API dc_TcpGetInfo(HANDLE icdev, unsigned char type, unsigned char *data_buffer, int *data_len);
6118
6126 short USER_API dc_RfMarch(HANDLE icdev);
6127
6136 short USER_API dc_SelectAntenna(HANDLE icdev, unsigned char number);
6137
6147 short USER_API dc_ReadNicMacAddress(HANDLE icdev, unsigned char *data_buffer, int *data_len);
6148
6158 short USER_API dc_WriteNicMacAddress(HANDLE icdev, const unsigned char *data_buffer, int data_len);
6159
6169 short USER_API dc_TestNic(HANDLE icdev, const unsigned char *data_buffer, int data_len);
6170
6180 short USER_API dc_TestUsb(HANDLE icdev, const unsigned char *data_buffer, int data_len);
6181
6193 short USER_API dc_TestCom(HANDLE icdev, unsigned char number, const char *name, unsigned char *data_buffer, int *data_len);
6194
6204 short USER_API dc_ConfigTempIpAddress(HANDLE icdev, const unsigned char *data_buffer, int data_len);
6205
6216 short USER_API dc_GetMagFormat(HANDLE icdev, int *mode);
6217
6247 short USER_API dc_GetMag(HANDLE icdev, unsigned char *mode, unsigned char *track1, unsigned char *track2, unsigned char *track3);
6248
6265 short USER_API dc_GetDeviceBaud(HANDLE icdev, unsigned char *baud);
6266
6280 short USER_API dc_GetUsbMode(HANDLE icdev, unsigned char *ucmode);
6281
6293 short USER_API dc_cpuapduresponInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer);
6294
6300 short USER_API dc_cpuapduresponInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer);
6301
6310 short USER_API dc_Scan2DBarcodeStart(HANDLE icdev, unsigned char mode);
6311
6321 short USER_API dc_Scan2DBarcodeGetData(HANDLE icdev, int *rlen, unsigned char *rdata);
6322
6330 short USER_API dc_Scan2DBarcodeExit(HANDLE icdev);
6331
6340 short USER_API dc_SelfServiceDeviceWriteMagConfig(HANDLE icdev, unsigned char mode);
6341
6350 short USER_API dc_SelfServiceDeviceShakeConfig(HANDLE icdev, unsigned char mode);
6351
6370 short USER_API dc_VoicePlayAndDisplay(HANDLE icdev, unsigned char mode, unsigned char type);
6371
6380 short USER_API dc_SelfServiceDeviceSetFrontSwitch(HANDLE icdev, unsigned char mode);
6381
6390 short USER_API dc_SelfServiceDeviceGetFrontSwitch(HANDLE icdev, unsigned char *mode);
6391
6399 short USER_API dc_ClearDeviceConfig(HANDLE icdev);
6400
6409 short USER_API dc_SetCpuCardPps(HANDLE icdev, unsigned char mode);
6410
6419 short USER_API dc_GetCpuCardPps(HANDLE icdev, unsigned char *mode);
6420
6424 short USER_API dc_checkcopy_m1(HANDLE icdev, unsigned char mode);
6425
6433 short USER_API dc_RefreshAndDisplayMainUI(HANDLE icdev);
6434
6438 short USER_API dc_GlyProCommand(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout);
6439
6443 short USER_API dc_GlyProCommand_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout);
6444
6453 short USER_API dc_SamAReadSerialNumber(HANDLE icdev, char *number);
6454
6466 short USER_API dc_2dot4Apdu(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer);
6467
6473 short USER_API dc_2dot4Apdu_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer);
6474
6488 short USER_API dc_ScreenDisplayImage(HANDLE icdev, int x, int y, int w, int h, int time_s, const unsigned char *image_data);
6489
6502 short USER_API dc_ScreenClearDisplay(HANDLE icdev, int x, int y, int w, int h, int time_s);
6503
6513 short USER_API dc_ScreenLoadBgImage(HANDLE icdev, int number, const unsigned char *image_data);
6514
6527 short USER_API dc_ScreenDisplayBgImage(HANDLE icdev, int number, int x, int y, int w, int h);
6528
6540 short USER_API dc_ScreenDisplayGetConfig(HANDLE icdev, unsigned char tag, unsigned char *config_data);
6541
6553 short USER_API dc_ScreenDisplaySetConfig(HANDLE icdev, unsigned char tag, const unsigned char *config_data);
6554
6571 short USER_API dc_ScreenDisplayText(HANDLE icdev, unsigned char font_size, const unsigned char *fg_rgb, const unsigned char *bg_rgb, int x, int y, int time_s, unsigned char line_flag, unsigned char voice_flag, const char *text);
6572
6585 short USER_API dc_ScreenDisplayBgImageByColor(HANDLE icdev, const unsigned char *rgb, int x, int y, int w, int h);
6586
6600 short USER_API dc_NtagCommand(HANDLE icdev, unsigned char type, unsigned char mode, unsigned int slen, const unsigned char *sdata, unsigned int *rlen, unsigned char *rdata);
6601
6610 short USER_API dc_SetCpuVoltage(HANDLE icdev, unsigned char voltage);
6611
6631 short USER_API dc_LcdDisplayText(HANDLE icdev, unsigned char line, unsigned char offset, unsigned char mode, unsigned char charset, const unsigned char *text);
6632
6654 short USER_API dc_LcdDisplayTextFromData(HANDLE icdev, unsigned char line, unsigned char offset, unsigned char mode, unsigned char charset, const unsigned char *text, const unsigned char *data, int data_len);
6655
6673 short USER_API dc_DownloadFileData(HANDLE icdev, unsigned int file_type, unsigned int file_size, unsigned int flag, const unsigned char *data, unsigned int *data_size);
6674
6682 short USER_API dc_check_1608(HANDLE icdev);
6683
6691 short USER_API dc_down_1608(HANDLE icdev);
6692
6706 short USER_API dc_read_1608(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata);
6707
6713 short USER_API dc_read_1608_hex(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata);
6714
6728 short USER_API dc_write_1608(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata);
6729
6735 short USER_API dc_write_1608_hex(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata);
6736
6749 short USER_API dc_checkpass_1608(HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password);
6750
6756 short USER_API dc_checkpass_1608_hex(HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password);
6757
6766 short USER_API dc_init_auth_1608(HANDLE icdev, unsigned char *databuffer);
6767
6773 short USER_API dc_init_auth_1608_hex(HANDLE icdev, unsigned char *databuffer);
6774
6783 short USER_API dc_check_auth_1608(HANDLE icdev, unsigned char *databuffer);
6784
6790 short USER_API dc_check_auth_1608_hex(HANDLE icdev, unsigned char *databuffer);
6791
6800 short USER_API dc_write_fuse_1608(HANDLE icdev, unsigned char value);
6801
6814 short USER_API dc_read_fuse_1608(HANDLE icdev, unsigned char *value);
6815
6823 short USER_API dc_check_153(HANDLE icdev);
6824
6832 short USER_API dc_down_153(HANDLE icdev);
6833
6847 short USER_API dc_read_153(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata);
6848
6854 short USER_API dc_read_153_hex(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata);
6855
6869 short USER_API dc_write_153(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata);
6870
6876 short USER_API dc_write_153_hex(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata);
6877
6890 short USER_API dc_checkpass_153(HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password);
6891
6897 short USER_API dc_checkpass_153_hex(HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password);
6898
6907 short USER_API dc_init_auth_153(HANDLE icdev, unsigned char *databuffer);
6908
6914 short USER_API dc_init_auth_153_hex(HANDLE icdev, unsigned char *databuffer);
6915
6924 short USER_API dc_check_auth_153(HANDLE icdev, unsigned char *databuffer);
6925
6931 short USER_API dc_check_auth_153_hex(HANDLE icdev, unsigned char *databuffer);
6932
6941 short USER_API dc_write_fuse_153(HANDLE icdev, unsigned char value);
6942
6955 short USER_API dc_read_fuse_153(HANDLE icdev, unsigned char *value);
6956
6966 short USER_API dc_MultiAntennaStartOrStop(HANDLE icdev, unsigned char flag, unsigned int *mask);
6967
6982 short USER_API dc_MultiAntennaGetCardStatus(HANDLE icdev, int *rlen, unsigned char *rdata);
6983
7000 short USER_API dc_SetPinpadWithReaderBaudrate(HANDLE icdev, unsigned char value);
7001
7018 short USER_API dc_CheckPinpadWithReaderBaudrate(HANDLE icdev, unsigned char *value);
7019
7041 short USER_API dc_IdCardReadCardInfo(HANDLE icdev, unsigned char mode, unsigned char type, int *text_len, unsigned char *text, int *photo_len, unsigned char *photo, int *fingerprint_len, unsigned char *fingerprint, int *extra_len, unsigned char *extra);
7042
7054 short USER_API dc_LcdDisplay(HANDLE icdev, unsigned char line, unsigned char offset, unsigned char mode, const char *data);
7055
7065 short USER_API dc_ReadDeviceCustomSerialNumber(HANDLE icdev, unsigned char number, char *data);
7066
7076 short USER_API dc_WriteDeviceCustomSerialNumber(HANDLE icdev, unsigned char number, const char *data);
7077
7086 short USER_API dc_SelfServiceDeviceRecoverError(HANDLE icdev, unsigned char type);
7087
7097 short USER_API dc_GetBankAccountNumber(HANDLE icdev, int type, char *number);
7098
7110 short USER_API dc_GetBankMagInfo(HANDLE icdev, int type, char *track1, char *track2, char *track3);
7111
7126 short USER_API dc_IdCardImageBuild(HANDLE icdev, int type, int text_len, const unsigned char *text, int photo_len, const unsigned char *photo, const char *front_file, const char *back_file);
7127
7135 short USER_API dc_CvLibLoad(HANDLE icdev);
7136
7144 short USER_API dc_CvLibUnload(HANDLE icdev);
7145
7154 short USER_API dc_CvOpen(HANDLE icdev, int number);
7155
7164 short USER_API dc_CvClose(HANDLE icdev, int number);
7165
7176 short USER_API dc_CvCapture(HANDLE icdev, int number, int mode, const char *file_name);
7177
7178 #ifdef __cplusplus
7179 }
7180 #endif
7181
7182 #endif // DCRF32_H_
dc_MultiFlashRead
short USER_API dc_MultiFlashRead(HANDLE icdev, unsigned char type, unsigned int offset_h, unsigned int offset_l, unsigned int length_h, unsigned int length_l, unsigned char *data_buffer)
多个Flash读数据。
dc_procommandInt
short USER_API dc_procommandInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_KeypadExitAndGetInput
short USER_API dc_KeypadExitAndGetInput(HANDLE icdev, int number, int mode, unsigned char *out_data, int *out_len)
退出并且获取密码数据。
dcdeshex
short USER_API dcdeshex(unsigned char *key, unsigned char *sour, unsigned char *dest, short m)
单DES加解密。
dc_settimehex
short USER_API dc_settimehex(HANDLE icdev, char *time)
设置设备时间。
dc_getcpupara
short USER_API dc_getcpupara(HANDLE icdev, unsigned char cputype, unsigned char *cpupro, unsigned char *cpuetu)
获取接触式CPU卡参数。
dc_BtAddressControl
short USER_API dc_BtAddressControl(HANDLE icdev, unsigned char flag, unsigned char *length, unsigned char *value)
蓝牙模块地址查询/设置。
dc_GetBankAccountNumber
short USER_API dc_GetBankAccountNumber(HANDLE icdev, int type, char *number)
获取银行卡帐户号码。
dc_BtCommunicationTest
short USER_API dc_BtCommunicationTest(HANDLE icdev, int length, const unsigned char *value)
蓝牙模块通讯测试。
dc_write_fm11rf005_hex
short USER_API dc_write_fm11rf005_hex(HANDLE icdev, unsigned char _Adr, char *_Data)
写FM11RF005卡。
dc_SamAReadCardInfo
short USER_API dc_SamAReadCardInfo(HANDLE icdev, int type, int *text_len, unsigned char *text, int *photo_len, unsigned char *photo, int *fingerprint_len, unsigned char *fingerprint, int *extra_len, unsigned char *extra)
读身份证。
dc_SetEMVPara
short USER_API dc_SetEMVPara(HANDLE icdev, unsigned int slen, unsigned char *sdata)
保留。
dc_NfcService
short USER_API dc_NfcService(HANDLE icdev, int flag)
NFC点对点数据透传（从服务端接收）。
dc_init_name
HANDLE USER_API dc_init_name(short port, int baud, const char *name)
打开设备。
dc_2dot4_resethex
short USER_API dc_2dot4_resethex(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
2.4G复位。
dc_pro_resethex
short USER_API dc_pro_resethex(HANDLE icdev, unsigned char *rlen, char *receive_data)
非接触式CPU卡复位。
SD_IFD_GetEnPINBlock
short USER_API SD_IFD_GetEnPINBlock(HANDLE icdev, char *szPasswd, unsigned char yyflag, unsigned char modeflag, unsigned char *cardno, unsigned char timeout)
获取外接密码键盘密文数据。
dc_erase_random
short USER_API dc_erase_random(HANDLE icdev, short length)
保留。
dc_authentication_pass
short USER_API dc_authentication_pass(HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff)
验证M1卡密码。
dc_GetEnPass
short USER_API dc_GetEnPass(HANDLE icdev, unsigned char ctime, unsigned char panlen, unsigned char *pandata, unsigned char *rlen, unsigned char *cpass)
获取加密按键数据。
dc_Check_24C64
short USER_API dc_Check_24C64(HANDLE icdev)
检测24C64卡。
dc_SetUsbMode
short USER_API dc_SetUsbMode(HANDLE icdev, unsigned char ucmode)
设置USB模式。
dc_reset
short USER_API dc_reset(HANDLE icdev, unsigned short _Msec)
复位射频。
dc_SelfServiceDeviceWriteMagConfig
short USER_API dc_SelfServiceDeviceWriteMagConfig(HANDLE icdev, unsigned char mode)
写磁条卡参数设置。
dc_BuzzerBeep
short USER_API dc_BuzzerBeep(HANDLE icdev, unsigned short beep_time_ms, unsigned short interval_time_ms, unsigned short count)
设备蜂鸣。
dc_cpy_procommandInt_hex
short USER_API dc_cpy_procommandInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout)
保留。
dc_getuid_i_d
short USER_API dc_getuid_i_d(HANDLE icdev, unsigned char *uid)
获取身份证UID。
dc_i_d_query_photo_len
unsigned int USER_API dc_i_d_query_photo_len(HANDLE idhandle)
获取相片原始数据长度。
dc_LcdDisplayText
short USER_API dc_LcdDisplayText(HANDLE icdev, unsigned char line, unsigned char offset, unsigned char mode, unsigned char charset, const unsigned char *text)
LCD显示文字。
dc_keypad_GetEncryptDataOfECB
short USER_API dc_keypad_GetEncryptDataOfECB(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
dc_WriteModuleMacAddress
short USER_API dc_WriteModuleMacAddress(HANDLE icdev, int type, const char *value)
设置通讯模块MAC地址。
dc_SelfServiceDeviceRecoverError
short USER_API dc_SelfServiceDeviceRecoverError(HANDLE icdev, unsigned char type)
错误恢复。
dc_cpuapdu_hex
short USER_API dc_cpuapdu_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
接触式CPU卡指令交互。
dc_slotmarker
short USER_API dc_slotmarker(HANDLE icdev, unsigned char N, unsigned char *ATQB)
管道标记。
dc_KeypadClose
short USER_API dc_KeypadClose(HANDLE icdev, int number)
关闭密码键盘。
dc_SelfServiceDeviceCardStatus
short USER_API dc_SelfServiceDeviceCardStatus(HANDLE icdev, unsigned char *pos)
检测卡位置状态。
dc_keypad_GetEncryptDataOfCBC
short USER_API dc_keypad_GetEncryptDataOfCBC(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
dc_pro_commandsource_int
short USER_API dc_pro_commandsource_int(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_transfer_wallet
short USER_API dc_transfer_wallet(HANDLE icdev, unsigned char *walletvalue)
保留。
dc_authentication
short USER_API dc_authentication(HANDLE icdev, unsigned char _Mode, unsigned char _SecNr)
验证M1卡密码。
dc_creat_mac_hex
short USER_API dc_creat_mac_hex(unsigned char KeyLen, unsigned char *Key, unsigned short DataLen, unsigned char *Data, unsigned char *InitData, unsigned char AutoFixFlag, unsigned char FixChar, unsigned char *MacData)
保留。
dc_typeab_card_status
short USER_API dc_typeab_card_status(HANDLE icdev)
身份证、Type A CPU卡、Type B CPU卡检测。
dc_NfcDeactivate
short USER_API dc_NfcDeactivate(HANDLE icdev)
断开NFC。
dc_swr_eepromhex
short USER_API dc_swr_eepromhex(HANDLE icdev, short offset, short length, unsigned char *send_buffer)
写EEPROM。
dc_ScreenLoadBgImage
short USER_API dc_ScreenLoadBgImage(HANDLE icdev, int number, const unsigned char *image_data)
装载背景图像。
dc_WirelessSend
short USER_API dc_WirelessSend(HANDLE icdev, unsigned char type, const unsigned char *data_buffer, int data_len)
发送数据到网络端。
dc_select_mode
short USER_API dc_select_mode(HANDLE icdev, unsigned char mode, unsigned int _Snr, unsigned char *_Size)
选卡操作。
dc_swr_eeprom_hex
short USER_API dc_swr_eeprom_hex(HANDLE icdev, short offset, short length, unsigned char *send_buffer)
写EEPROM。
dc_SamAControl
short USER_API dc_SamAControl(HANDLE icdev, int code, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata)
SAM_A模块指令交互。
dc_exchangeblock
short USER_API dc_exchangeblock(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
dc_cpuapdusource_hex
short USER_API dc_cpuapdusource_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
接触式CPU卡指令交互。
dc_GetDeviceBaud
short USER_API dc_GetDeviceBaud(HANDLE icdev, unsigned char *baud)
获取串口设备通讯波特率。
dc_WriteRfCfgReg
short USER_API dc_WriteRfCfgReg(HANDLE icdev, int type, int number, int value)
保留。
dc_open_timedoor
short USER_API dc_open_timedoor(HANDLE icdev, unsigned short utime)
保留。
dc_RfSetChipRegister
short USER_API dc_RfSetChipRegister(HANDLE icdev, unsigned char register_type, unsigned char register_value)
保留。
dc_keypad_SetButtonMark
short USER_API dc_keypad_SetButtonMark(HANDLE icdev, unsigned int mark_value, unsigned char use)
保留。
dc_stopreadmag
short USER_API dc_stopreadmag(HANDLE icdev)
停止读磁条卡。
dc_setcpu
short USER_API dc_setcpu(HANDLE icdev, unsigned char _Byte)
设置当前接触式卡座。
SD_IFD_SetKeyLength
short USER_API SD_IFD_SetKeyLength(HANDLE icdev, unsigned char keylength)
设置外接密码键盘最大输入长度。
SD_IFD_DesCaculate
short USER_API SD_IFD_DesCaculate(HANDLE icdev, unsigned char srclen, unsigned char *srcdata, unsigned char *desdata, unsigned char flag)
用外接密码键盘工作密钥加解密。
dc_IdCardReadCardInfo
short USER_API dc_IdCardReadCardInfo(HANDLE icdev, unsigned char mode, unsigned char type, int *text_len, unsigned char *text, int *photo_len, unsigned char *photo, int *fingerprint_len, unsigned char *fingerprint, int *extra_len, unsigned char *extra)
读身份证。
dc_i_d_query_address
char *USER_API dc_i_d_query_address(HANDLE idhandle)
获取住址。
dc_down_1608
short USER_API dc_down_1608(HANDLE icdev)
1608卡下电。
dc_ctl_mode
short USER_API dc_ctl_mode(HANDLE icdev, unsigned char mode)
保留。
dc_checkpass_1608_hex
short USER_API dc_checkpass_1608_hex(HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password)
验证1608卡密码。
dc_TtsVoiceConfig
short USER_API dc_TtsVoiceConfig(HANDLE icdev, unsigned char type, unsigned char value)
TTS语音设置。
dc_start_i_d_2
HANDLE USER_API dc_start_i_d_2(HANDLE icdev)
读身份证。
dc_decrypt_hex
short USER_API dc_decrypt_hex(char *key, char *ptrSource, unsigned short msgLen, char *ptrDest)
保留。
dc_gettimehex
short USER_API dc_gettimehex(HANDLE icdev, char *time)
获取设备时间。
dc_config_card
short USER_API dc_config_card(HANDLE icdev, unsigned char cardtype)
配置非接触卡类型。
dc_CreatDesDataECB
short USER_API dc_CreatDesDataECB(HANDLE icdev, unsigned char keytype, unsigned char enmode, int slen, unsigned char *sourcedata, int *rlen, unsigned char *retdata)
用工作密钥加解密。
dc_SamAReadSerialNumber
short USER_API dc_SamAReadSerialNumber(HANDLE icdev, char *number)
读取SAM_A模块序列号。
dc_write_4428_hex
short USER_API dc_write_4428_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4428卡。
SD_IFD_DES
short USER_API SD_IFD_DES(HANDLE icdev, unsigned char mode, unsigned char *srcdata, unsigned char *desdata)
用外接密码键盘工作密钥加解密。
dc_getinputpass
short USER_API dc_getinputpass(HANDLE icdev, unsigned char ctime, unsigned char *rlen, unsigned char *cpass)
键盘密码输入。
dc_ScreenDisplayGetConfig
short USER_API dc_ScreenDisplayGetConfig(HANDLE icdev, unsigned char tag, unsigned char *config_data)
获取显示配置。
dc_HL_write
short USER_API dc_HL_write(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int *_Snr, unsigned char *_Data)
保留。
dc_write_fuse_153
short USER_API dc_write_fuse_153(HANDLE icdev, unsigned char value)
写153卡熔丝。
dc_attribInt
short USER_API dc_attribInt(HANDLE icdev, unsigned char *PUPI, unsigned char CID)
激活卡片。
dc_changepass_1604
short USER_API dc_changepass_1604(HANDLE icdev, short zone, unsigned char *password)
修改1604卡密码。
dc_keypad_Start
short USER_API dc_keypad_Start(HANDLE icdev, unsigned char mode, int max_len, unsigned char auto_end, unsigned char enable_sound)
保留。
dc_KeypadGetKeyType
short USER_API dc_KeypadGetKeyType(HANDLE icdev, int number, int set_index, int sub_index, int *type)
获取密钥类型。
dc_gettime_hex
short USER_API dc_gettime_hex(HANDLE icdev, char *time)
获取设备时间。
dc_cpureset_hex
short USER_API dc_cpureset_hex(HANDLE icdev, unsigned char *rlen, char *databuffer)
接触式CPU卡复位。
dc_readdevsnr
short USER_API dc_readdevsnr(HANDLE icdev, unsigned char *snr)
获取设备序列号。
dc_read_fuse_153
short USER_API dc_read_fuse_153(HANDLE icdev, unsigned char *value)
读153卡熔丝。
dc_cpuapduEXT_hex
short USER_API dc_cpuapduEXT_hex(HANDLE icdev, short slen, char *sendbuffer, short *rlen, char *databuffer)
接触式CPU卡指令交互。
dc_cpuapdurespon_hex
short USER_API dc_cpuapdurespon_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
接触式CPU卡指令交互。
dc_RfWaveControl
short USER_API dc_RfWaveControl(HANDLE icdev, unsigned char mode)
保留。
dc_readSD
short USER_API dc_readSD(HANDLE icdev, int offset, int length, unsigned char *readbuffer)
读SD存储。
dc_ReadModuleMacAddress
short USER_API dc_ReadModuleMacAddress(HANDLE icdev, int type, char *value)
获取通讯模块MAC地址。
dc_GetDeviceUid
short USER_API dc_GetDeviceUid(HANDLE icdev, char *uid)
获取设备唯一识别码。
dc_LcdDisplayTextFromData
short USER_API dc_LcdDisplayTextFromData(HANDLE icdev, unsigned char line, unsigned char offset, unsigned char mode, unsigned char charset, const unsigned char *text, const unsigned char *data, int data_len)
LCD显示文字。
dc_read_153
short USER_API dc_read_153(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata)
读153卡。
dc_cpy_cpuapdu
short USER_API dc_cpy_cpuapdu(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
保留。
dc_SelfServiceDeviceCheckCardType
short USER_API dc_SelfServiceDeviceCheckCardType(HANDLE icdev)
检测卡类型。
dc_card_n_hex
short USER_API dc_card_n_hex(HANDLE icdev, unsigned char _Mode, unsigned int *SnrLen, unsigned char *_Snr)
寻卡请求、防卡冲突、选卡操作。
dc_check_1604
short USER_API dc_check_1604(HANDLE icdev)
检测1604卡。
dc_SelfServiceDeviceCardInject
short USER_API dc_SelfServiceDeviceCardInject(HANDLE icdev, unsigned char time_s, unsigned char mode)
进入卡片。
dc_SelfServiceDeviceCardEject
short USER_API dc_SelfServiceDeviceCardEject(HANDLE icdev, unsigned char time_s, unsigned char mode)
弹出卡片。
dc_BtModeControl
short USER_API dc_BtModeControl(HANDLE icdev, unsigned char mode)
蓝牙模式设置。
dc_i_d_query_address_2
short USER_API dc_i_d_query_address_2(HANDLE idhandle, char *address)
获取住址。
dc_lcdclrscrn
short USER_API dc_lcdclrscrn(HANDLE icdev, unsigned char cLine)
LCD清屏。
dc_SelfServiceDeviceConfig
short USER_API dc_SelfServiceDeviceConfig(HANDLE icdev, unsigned char mode)
设置弹卡模式。
dc_card_fm11rf005
short USER_API dc_card_fm11rf005(HANDLE icdev, unsigned char _Mode, unsigned int *_Snr)
寻FM11RF005卡。
dc_consume_wallet
short USER_API dc_consume_wallet(HANDLE icdev, unsigned char *walletvalue, unsigned char *secret)
保留。
dc_cpuapdu
short USER_API dc_cpuapdu(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。
dc_verifypin_4442
short USER_API dc_verifypin_4442(HANDLE icdev, unsigned char *passwd)
验证4442卡密码。
dc_MagFormatConfig
short USER_API dc_MagFormatConfig(HANDLE icdev, int mode)
磁条卡数据自动上传数据模式设置。
dc_write_153_hex
short USER_API dc_write_153_hex(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata)
写153卡。
SD_InstallKey
short USER_API SD_InstallKey(HANDLE icdev, unsigned char ctime, unsigned char senlen, unsigned char *source, unsigned char *reclen, unsigned char *rdata)
外接密码键盘通讯。
dc_ReadFlash
short USER_API dc_ReadFlash(HANDLE icdev, int offset, int length, unsigned char *data_buffer)
读Flash。
dc_write_102
short USER_API dc_write_102(HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *writedata)
写102卡。
dc_beep
short USER_API dc_beep(HANDLE icdev, unsigned short _Msec)
设备蜂鸣。
dc_restore
short USER_API dc_restore(HANDLE icdev, unsigned char _Adr)
M1卡值块回传。
dc_RfFormatConfig
short USER_API dc_RfFormatConfig(HANDLE icdev, int mode, int block_number, int offset, int length)
保留。
dc_srd_eeprom
short USER_API dc_srd_eeprom(HANDLE icdev, short offset, short length, unsigned char *rec_buffer)
读EEPROM。
dc_writeblock_hex
short USER_API dc_writeblock_hex(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char wlen, unsigned char *wbuffer)
保留。
dc_write_102_hex
short USER_API dc_write_102_hex(HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *writedata)
写102卡。
dc_writemagcard
short USER_API dc_writemagcard(HANDLE icdev, unsigned char ctime, unsigned char *pTrack1Data, unsigned char pTrack1Len, unsigned char *pTrack2Data, unsigned char pTrack2Len, unsigned char *pTrack3Data, unsigned char pTrack3Len)
写磁条卡。
dc_init_auth_153_hex
short USER_API dc_init_auth_153_hex(HANDLE icdev, unsigned char *databuffer)
初始化153卡认证。
dc_readpincount_4428
short USER_API dc_readpincount_4428(HANDLE icdev)
读4428卡密码计数。
dc_cpy_cpuapdu_hex
short USER_API dc_cpy_cpuapdu_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
保留。
dc_check_auth_1608
short USER_API dc_check_auth_1608(HANDLE icdev, unsigned char *databuffer)
核对1608卡认证。
dc_cpudown
short USER_API dc_cpudown(HANDLE icdev)
接触式CPU卡下电。
dc_pro_commandsource
short USER_API dc_pro_commandsource(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_read_102
short USER_API dc_read_102(HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *readdata)
读102卡。
dc_PassIn
short USER_API dc_PassIn(HANDLE icdev, unsigned char ctime)
进入读键盘模式。
dc_printPicture
short USER_API dc_printPicture(HANDLE icdev, unsigned char length, unsigned char height, unsigned char Alignment, unsigned char LeftMargin, unsigned char RightMargin, unsigned short size, unsigned char *Picture)
打印图片。
dc_NfcPush
short USER_API dc_NfcPush(HANDLE icdev, const unsigned char *request, int request_len)
NFC点对点数据透传（推送服务端）。
dc_checkpass_102
short USER_API dc_checkpass_102(HANDLE icdev, short zone, unsigned char *password)
验证102卡密码。
dc_reset_factory
short USER_API dc_reset_factory(HANDLE icdev)
保留。
dc_set_control_bit
short USER_API dc_set_control_bit(HANDLE icdev, unsigned char _b)
保留。
dc_BtWithReaderBaudrateControl
short USER_API dc_BtWithReaderBaudrateControl(HANDLE icdev, unsigned char flag, unsigned char *value)
蓝牙波特率查询/设置。
dc_CreatMacDataECB
short USER_API dc_CreatMacDataECB(HANDLE icdev, unsigned char keytype, unsigned char enmode, int slen, unsigned char *sourcedata, int *rlen, unsigned char *retdata)
用工作密钥算MAC。
dc_decrement
short USER_API dc_decrement(HANDLE icdev, unsigned char _Adr, unsigned int _Value)
M1卡值块减值。
dc_cpy_procommand
short USER_API dc_cpy_procommand(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
dc_get_idsnr
short USER_API dc_get_idsnr(HANDLE icdev, unsigned char *_Data)
获取身份证UID。
dc_anticoll2
short USER_API dc_anticoll2(HANDLE icdev, unsigned char _Bcnt, unsigned int *_Snr)
第二级防卡冲突。
SD_IFD_Init
short USER_API SD_IFD_Init(HANDLE icdev)
外接密码键盘初始化。
dc_get_securityinfo
short USER_API dc_get_securityinfo(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
dc_ReadOutEeprom
short USER_API dc_ReadOutEeprom(HANDLE icdev, int offset, int length, unsigned char *data_buffer)
读外部EEPROM。
dc_changepin_4442
short USER_API dc_changepin_4442(HANDLE icdev, unsigned char *passwd)
修改4442卡密码。
dc_set_transactiontype
short USER_API dc_set_transactiontype(HANDLE icdev, unsigned char typecode)
保留。
dc_auth_ulc
short USER_API dc_auth_ulc(HANDLE icdev, unsigned char *key)
验证Mifare Ultralight C卡密码。
SD_IFD_PlayVoice
short USER_API SD_IFD_PlayVoice(HANDLE icdev, unsigned char _playmode)
外接密码键盘播放语音。
dc_cpuapduEXT
short USER_API dc_cpuapduEXT(HANDLE icdev, short slen, unsigned char *sendbuffer, short *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。
dc_readmagcardall
short USER_API dc_readmagcardall(HANDLE icdev, unsigned char ctime, unsigned char *pTrack1Data, unsigned int *pTrack1Len, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len)
读磁条卡。
dc_dispinfo_pro_T8
short USER_API dc_dispinfo_pro_T8(HANDLE icdev, unsigned char offset, char *data)
液晶显示。
dc_fuse_1604
short USER_API dc_fuse_1604(HANDLE icdev)
1604卡熔丝。
dc_write_afi_hex
short USER_API dc_write_afi_hex(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID)
保留。
dc_keypad_End
short USER_API dc_keypad_End(HANDLE icdev)
保留。
dc_KeypadOpen
short USER_API dc_KeypadOpen(HANDLE icdev, int number, char *version)
打开密码键盘。
dc_creat_mac
short USER_API dc_creat_mac(unsigned char KeyLen, unsigned char *Key, unsigned short DataLen, unsigned char *Data, unsigned char *InitData, unsigned char AutoFixFlag, unsigned char FixChar, unsigned char *MacData)
保留。
dc_CvLibUnload
short USER_API dc_CvLibUnload(HANDLE icdev)
摄像视觉库卸载。
dc_ParseTextInfoForForeigner
short USER_API dc_ParseTextInfoForForeigner(HANDLE icdev, int charset, int info_len, const unsigned char *info, unsigned char *english_name, unsigned char *sex, unsigned char *id_number, unsigned char *citizenship, unsigned char *chinese_name, unsigned char *expire_start_day, unsigned char *expire_end_day, unsigned char *birth_day, unsigned char *version_number, unsigned char *department_code, unsigned char *type_sign, unsigned char *reserved)
解析文字信息。
dc_getinputkey
short USER_API dc_getinputkey(HANDLE icdev, unsigned char disptype, unsigned char line, unsigned char ctime, unsigned char *rlen, unsigned char *ckeydata)
获取键盘输入。
dc_get_transactiontype
short USER_API dc_get_transactiontype(HANDLE icdev, unsigned char *typecode)
保留。
dc_MFPL1_switchtol3
short USER_API dc_MFPL1_switchtol3(HANDLE icdev, unsigned char *authkey)
升级Mifare Plus卡状态到3级（1级）。
dc_ScreenDisplayImage
short USER_API dc_ScreenDisplayImage(HANDLE icdev, int x, int y, int w, int h, int time_s, const unsigned char *image_data)
显示图像。
dc_pass_key_value
short USER_API dc_pass_key_value(HANDLE icdev, unsigned char timeout, char *value)
获取单个按键值。
dc_find_i_d_2
short USER_API dc_find_i_d_2(HANDLE icdev)
查找身份证。
dc_read_idcard
short USER_API dc_read_idcard(HANDLE icdev, unsigned char times, unsigned char *_Data)
读ID卡。
dc_MFPL3_authl3sectorkey_hex
short USER_API dc_MFPL3_authl3sectorkey_hex(HANDLE icdev, unsigned char mode, unsigned int sectorBNr, unsigned char *authkey)
验证Mifare Plus卡状态密码（3级）。
dc_init
HANDLE USER_API dc_init(short port, int baud)
打开设备。
dc_cpy_cpuapduInt
short USER_API dc_cpy_cpuapduInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer)
保留。
dc_SelfServiceDeviceCardMove
short USER_API dc_SelfServiceDeviceCardMove(HANDLE icdev, unsigned char time_s, unsigned char mode)
移动卡片。
dc_select_uid
short USER_API dc_select_uid(HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
dc_read1024
short USER_API dc_read1024(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *databuffer)
保留。
dc_i_d_query_id_number
char *USER_API dc_i_d_query_id_number(HANDLE idhandle)
获取公民身份号码。
dc_BtSignalStrength
short USER_API dc_BtSignalStrength(HANDLE icdev, unsigned char *state, short *value)
获取蓝牙信号强度。
dc_switch_linux
short USER_API dc_switch_linux(HANDLE icdev)
保留。
dc_Check_4442
short USER_API dc_Check_4442(HANDLE icdev)
检测4442卡。
dc_SetCpuVoltage
short USER_API dc_SetCpuVoltage(HANDLE icdev, unsigned char voltage)
设置接触式CPU卡电压。
dc_SelfServiceDeviceSensorStatus
short USER_API dc_SelfServiceDeviceSensorStatus(HANDLE icdev, unsigned char *value)
获取传感器状态。
dc_changekey_ulc
short USER_API dc_changekey_ulc(HANDLE icdev, unsigned char *newkey)
修改Mifare Ultralight C卡密码。
dc_WriteDeviceTypeName
short USER_API dc_WriteDeviceTypeName(HANDLE icdev, const char *name)
写入设备型号名称。
dc_command
short USER_API dc_command(HANDLE icdev, unsigned char cmd, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
保留。
dc_ReadDeviceCustomInfo
short USER_API dc_ReadDeviceCustomInfo(HANDLE icdev, unsigned char *info)
读取设备自定义信息。
SD_IFD_SetWorkKey
short USER_API SD_IFD_SetWorkKey(HANDLE icdev, unsigned char keysetmain, unsigned char keysetwork, unsigned char *enkeywork)
设置外接密码键盘工作密钥。
SD_IFD_LEDDisplay
short USER_API SD_IFD_LEDDisplay(HANDLE icdev, unsigned char line, unsigned char row, unsigned char *leddata, unsigned char timeout)
外接密码键盘液晶显示。
dc_printcharacter
short USER_API dc_printcharacter(HANDLE icdev, unsigned short length, unsigned char *character)
打印字符。
dc_i_d_query_department
char *USER_API dc_i_d_query_department(HANDLE idhandle)
获取签发机关。
dc_GlyProCommand
short USER_API dc_GlyProCommand(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
dc_check_auth_153
short USER_API dc_check_auth_153(HANDLE icdev, unsigned char *databuffer)
核对153卡认证。
dc_set_tradesecretkey
short USER_API dc_set_tradesecretkey(HANDLE icdev, unsigned char *secretkey)
保留。
dc_keypad_GetDecryptDataOfCBC
short USER_API dc_keypad_GetDecryptDataOfCBC(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
dc_down_102
short USER_API dc_down_102(HANDLE icdev)
102卡下电。
dc_getdevicetime
short USER_API dc_getdevicetime(HANDLE icdev, unsigned char *year, unsigned char *month, unsigned char *date, unsigned char *hour, unsigned char *minute, unsigned char *second)
获取设备时间。
dc_i_d_query_birth
char *USER_API dc_i_d_query_birth(HANDLE idhandle)
获取生日。
dc_MFPL0_writeperso_hex
short USER_API dc_MFPL0_writeperso_hex(HANDLE icdev, unsigned int BNr, unsigned char *dataperso)
Mifare Plus卡设置个人化数据（0级）。
dc_NfcFetch
short USER_API dc_NfcFetch(HANDLE icdev, unsigned char *response, int *response_len, int time_ms)
接收NFC手机数据。
DCDEV_CommandMcu_Hex
short USER_API DCDEV_CommandMcu_Hex(HANDLE icdev, unsigned char ctimeout, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
保留。
dc_NtagCommand
short USER_API dc_NtagCommand(HANDLE icdev, unsigned char type, unsigned char mode, unsigned int slen, const unsigned char *sdata, unsigned int *rlen, unsigned char *rdata)
NTAG标签交互。
dc_setbright
short USER_API dc_setbright(HANDLE icdev, unsigned char bright)
保留。
dc_read_1608_hex
short USER_API dc_read_1608_hex(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata)
读1608卡。
dc_led_T8
short USER_API dc_led_T8(HANDLE icdev, unsigned char cled, unsigned char cflag)
指示灯点亮/熄灭。
dc_init_auth_153
short USER_API dc_init_auth_153(HANDLE icdev, unsigned char *databuffer)
初始化153卡认证。
dc_load_voice
short USER_API dc_load_voice(HANDLE icdev, int flag, int slen, const unsigned char *sdata)
装载语音。
dc_readmagcard
short USER_API dc_readmagcard(HANDLE icdev, unsigned char ctime, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len)
读磁条卡。
dc_PinpadCommunication
short USER_API dc_PinpadCommunication(HANDLE icdev, int time_100ms, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata)
密码键盘模块通讯。
dc_verifypin_4442_hex
short USER_API dc_verifypin_4442_hex(HANDLE icdev, unsigned char *passwd)
验证4442卡密码。
dc_playvoice
short USER_API dc_playvoice(HANDLE icdev, unsigned char mode)
播放语音。
dc_ClearDeviceConfig
short USER_API dc_ClearDeviceConfig(HANDLE icdev)
清除设备配置。
dc_BtNameControl
short USER_API dc_BtNameControl(HANDLE icdev, unsigned char flag, char *value)
蓝牙模块名称查询/设置。
dc_send_sms
short USER_API dc_send_sms(HANDLE icdev, const char *phone_no, const char *sms_content)
发送短信。
dc_card_n_number
short USER_API dc_card_n_number(HANDLE icdev, unsigned char _Mode, char *_Snr)
保留。
dc_2dot4Apdu_hex
short USER_API dc_2dot4Apdu_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer)
2.4G APDU指令交互。
dc_pro_commandlinkInt
short USER_API dc_pro_commandlinkInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_Check_CPU
short USER_API dc_Check_CPU(HANDLE icdev)
检测CPU卡。
dc_request
short USER_API dc_request(HANDLE icdev, unsigned char _Mode, unsigned short *TagType)
寻卡请求。
dc_cpuapduInt
short USER_API dc_cpuapduInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。
dc_flash_card
short USER_API dc_flash_card(HANDLE icdev)
保留。
dc_tripledes_hex
short USER_API dc_tripledes_hex(unsigned char *key, unsigned char *src, unsigned char *dest, short m)
三DES加解密。
dc_check2dot4Gbaund
short USER_API dc_check2dot4Gbaund(HANDLE icdev, unsigned char *baund)
查询2.4G模块波特率。
dc_keypad_GetPressed
short USER_API dc_keypad_GetPressed(HANDLE icdev, int time_ms, unsigned char *value)
保留。
dc_writeprotect_4442_hex
short USER_API dc_writeprotect_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4442卡保护位。
dc_checkpass_102_hex
short USER_API dc_checkpass_102_hex(HANDLE icdev, short zone, unsigned char *password)
验证102卡密码。
dc_pro_commandhex
short USER_API dc_pro_commandhex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_TestCom
short USER_API dc_TestCom(HANDLE icdev, unsigned char number, const char *name, unsigned char *data_buffer, int *data_len)
测试串口。
dc_MFPL1_authl1key
short USER_API dc_MFPL1_authl1key(HANDLE icdev, unsigned char *authkey)
验证Mifare Plus卡状态密码（1级）。
dc_procommandInt_hex
short USER_API dc_procommandInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_change_addr
short USER_API dc_change_addr(HANDLE icdev, unsigned char saddr)
保留。
dc_checkpass_153
short USER_API dc_checkpass_153(HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password)
验证153卡密码。
dc_check_102
short USER_API dc_check_102(HANDLE icdev)
检测102卡。
dc_printenter
short USER_API dc_printenter(HANDLE icdev, unsigned char RowPitch)
进纸。
dc_BtDataTransmit
short USER_API dc_BtDataTransmit(HANDLE icdev, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata)
蓝牙数据透传。
dc_ScreenClearDisplay
short USER_API dc_ScreenClearDisplay(HANDLE icdev, int x, int y, int w, int h, int time_s)
清除显示。
dc_Check_4428
short USER_API dc_Check_4428(HANDLE icdev)
检测4428卡。
dc_down_153
short USER_API dc_down_153(HANDLE icdev)
153卡下电。
dc_readpincount_4442
short USER_API dc_readpincount_4442(HANDLE icdev)
读4442卡密码计数。
dc_get_trademerchantcode
short USER_API dc_get_trademerchantcode(HANDLE icdev, unsigned char length, unsigned char *merchantcode)
保留。
dc_config
short USER_API dc_config(HANDLE icdev, unsigned char _Mode, unsigned char _Baud)
保留。
dc_high_disp
short USER_API dc_high_disp(HANDLE icdev, unsigned char offset, unsigned char displen, unsigned char *dispstr)
液晶显示。
dc_BtPasswordControl
short USER_API dc_BtPasswordControl(HANDLE icdev, unsigned char flag, char *value)
蓝牙连接密码查询/设置。
dc_WakeDevice
short USER_API dc_WakeDevice(HANDLE icdev)
唤醒设备。
dc_read_4442_hex
short USER_API dc_read_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡。
dc_set_poweroff
short USER_API dc_set_poweroff(HANDLE icdev, unsigned int MsTimes, unsigned char TimerClock, unsigned char TimerReload)
保留。
dc_readpin_4442_hex
short USER_API dc_readpin_4442_hex(HANDLE icdev, unsigned char *passwd)
读4442卡密码。
dc_card_make_and_lock
short USER_API dc_card_make_and_lock(HANDLE icdev, unsigned char flag)
开卡与锁卡。
dc_cardstr
short USER_API dc_cardstr(HANDLE icdev, unsigned char _Mode, char *Strsnr)
寻卡请求、防卡冲突、选卡操作。
dc_changebaud_485
short USER_API dc_changebaud_485(HANDLE icdev, int baud)
保留。
dc_writeSD
short USER_API dc_writeSD(HANDLE icdev, int offset, int length, unsigned char *writebuffer)
写SD存储。
dc_ctlled
short USER_API dc_ctlled(HANDLE icdev, unsigned char cLed, unsigned char cOpenFlag)
指示灯控制。
dc_dispinfo_T8
short USER_API dc_dispinfo_T8(HANDLE icdev, unsigned char line, unsigned char offset, char *data)
液晶显示。
dc_WirelessTcpOpen
short USER_API dc_WirelessTcpOpen(HANDLE icdev, unsigned char type, const char *network_address, const char *network_port)
打开TCP链接。
dc_SetPinpadWithReaderBaudrate
short USER_API dc_SetPinpadWithReaderBaudrate(HANDLE icdev, unsigned char value)
设置reader与密码键盘串口波特率。
a_hex
short USER_API a_hex(unsigned char *a, unsigned char *hex, short len)
数据转换。
SD_IFD_Scan2DBarcodeExit
short USER_API SD_IFD_Scan2DBarcodeExit(HANDLE icdev)
外接密码键盘退出扫描二维码。
dc_card_b_hex
short USER_API dc_card_b_hex(HANDLE icdev, char *rbuf)
寻Type B卡并激活。
DCDEV_CommandMcu
short USER_API DCDEV_CommandMcu(HANDLE icdev, unsigned char ctimeout, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
保留。
dc_ReadRfTypeABATS
short USER_API dc_ReadRfTypeABATS(HANDLE icdev, int *ats_len, unsigned char *ats)
读取ATS数据。
dc_rf_application
short USER_API dc_rf_application(HANDLE icdev, unsigned char icc_slot_no, int length_of_command_apdu, unsigned char *command_apdu, unsigned char *response_apdu)
卡指令交互。
dc_BtBaudrateControl
short USER_API dc_BtBaudrateControl(HANDLE icdev, unsigned char flag, unsigned char *value)
蓝牙波特率查询/设置。
dc_ParseTextInfoForHkMoTw
short USER_API dc_ParseTextInfoForHkMoTw(HANDLE icdev, int charset, int info_len, const unsigned char *info, unsigned char *name, unsigned char *sex, unsigned char *reserved, unsigned char *birth_day, unsigned char *address, unsigned char *id_number, unsigned char *department, unsigned char *expire_start_day, unsigned char *expire_end_day, unsigned char *pass_number, unsigned char *sign_count, unsigned char *reserved2, unsigned char *type_sign, unsigned char *reserved3)
解析文字信息。
dc_encrypt
short USER_API dc_encrypt(char *key, char *ptrSource, unsigned short msgLen, char *ptrDest)
保留。
dc_passin2
short USER_API dc_passin2(HANDLE icdev, unsigned char ctime, unsigned char ucmode, unsigned char *cardno)
进入读键盘模式。
dc_readcount_102
short USER_API dc_readcount_102(HANDLE icdev, short zone)
读102卡密码计数。
dc_Check_24C02
short USER_API dc_Check_24C02(HANDLE icdev)
检测24C02卡。
dc_rw_rfreg
short USER_API dc_rw_rfreg(HANDLE icdev, unsigned char flag, unsigned char _Adr, unsigned char *_Data)
读/写射频寄存器。
dc_get_tradesecretkey
short USER_API dc_get_tradesecretkey(HANDLE icdev, unsigned char *secretkey)
保留。
dc_check_auth_153_hex
short USER_API dc_check_auth_153_hex(HANDLE icdev, unsigned char *databuffer)
核对153卡认证。
dc_down_4442
short USER_API dc_down_4442(HANDLE icdev)
4442卡下电。
dc_read_fuse_1608
short USER_API dc_read_fuse_1608(HANDLE icdev, unsigned char *value)
读1608卡熔丝。
dc_write_fm11rf005
short USER_API dc_write_fm11rf005(HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
写FM11RF005卡。
dc_displow_T8
short USER_API dc_displow_T8(HANDLE icdev, unsigned char rs, unsigned char cdata)
保留。
dc_command_hex
short USER_API dc_command_hex(HANDLE icdev, unsigned char cmd, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer)
保留。
dc_write1024_hex
short USER_API dc_write1024_hex(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writebuffer)
保留。
dc_exit
short USER_API dc_exit(HANDLE icdev)
关闭设备。
dc_write_dsfid
short USER_API dc_write_dsfid(HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID)
保留。
SD_IFD_GetEnPINPro
short USER_API SD_IFD_GetEnPINPro(HANDLE icdev, char *szPasswd, unsigned char yyflag, unsigned char modeflag, unsigned char timeout)
获取外接密码键盘密文数据。
dc_rf_poweron
short USER_API dc_rf_poweron(HANDLE icdev, unsigned char icc_slot_no, unsigned char *response)
卡上电。
dc_rf_getstatus
short USER_API dc_rf_getstatus(HANDLE icdev, unsigned char icc_slot_no)
获取卡状态。
dc_RequestMultiCard
short USER_API dc_RequestMultiCard(HANDLE icdev, unsigned char *uid_data)
获取多张Type A卡UID。
dc_init_auth_1608
short USER_API dc_init_auth_1608(HANDLE icdev, unsigned char *databuffer)
初始化1608卡认证。
dc_printOnedimensional
short USER_API dc_printOnedimensional(HANDLE icdev, unsigned char hight, unsigned char displayflag, unsigned char FontSize, unsigned short length, unsigned char *Onedimensional)
打印一维码。
dc_readval
short USER_API dc_readval(HANDLE icdev, unsigned char _Adr, unsigned int *_Value)
M1卡值块读值。
dc_write_4442_hex
short USER_API dc_write_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4442卡。
dc_ActivateCard
short USER_API dc_ActivateCard(HANDLE icdev, unsigned char uid_len, const unsigned char *uid)
选择一张Type A卡并激活。
dc_2dot4_command
short USER_API dc_2dot4_command(HANDLE icdev, unsigned int slen, unsigned char *senddata, unsigned int *rlen, unsigned char *recvbuffer, unsigned char timeout)
2.4G指令交互。
dc_WirelessGetStatus
short USER_API dc_WirelessGetStatus(HANDLE icdev, unsigned char *value)
查询网络状态。
dc_read_102_hex
short USER_API dc_read_102_hex(HANDLE icdev, unsigned char offset, unsigned char length, unsigned char *readdata)
读102卡。
dc_write1024
short USER_API dc_write1024(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writebuffer)
保留。
dc_check_write_hex
short USER_API dc_check_write_hex(HANDLE icdev, unsigned int Snr, unsigned char authmode, unsigned char Adr, unsigned char *_data)
检查之前写入的数据。
dc_read_hex
short USER_API dc_read_hex(HANDLE icdev, unsigned char _Adr, char *_Data)
读卡数据。
dc_WriteDeviceCustomSerialNumber
short USER_API dc_WriteDeviceCustomSerialNumber(HANDLE icdev, unsigned char number, const char *data)
写设备定制序列号。
dc_keypad_GetPinBlock
short USER_API dc_keypad_GetPinBlock(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *customer_data, int customer_data_len, unsigned char *out_data, int *out_data_len)
保留。
dc_WirelessWifiConfig
short USER_API dc_WirelessWifiConfig(HANDLE icdev, unsigned char type, const char *ssid, const char *password)
配置WIFI参数。
dc_read_random
short USER_API dc_read_random(HANDLE icdev, unsigned char *data)
保留。
dc_RfCrcModeConfig
short USER_API dc_RfCrcModeConfig(HANDLE icdev, unsigned char tx_crc, unsigned char rx_crc)
透传CRC模式配置。
dc_switch_unix
short USER_API dc_switch_unix(HANDLE icdev, int baud)
保留。
dc_GetInputPass
short USER_API dc_GetInputPass(HANDLE icdev, unsigned char ctime, unsigned char *rlen, unsigned char *cpass)
键盘密码输入。
dc_pro_commandlink_hex
short USER_API dc_pro_commandlink_hex(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG)
非接触式CPU卡指令交互。
dc_authentication_pass_hex
short USER_API dc_authentication_pass_hex(HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff)
验证M1卡密码。
dc_select
short USER_API dc_select(HANDLE icdev, unsigned int _Snr, unsigned char *_Size)
选卡操作。
dc_start_i_d
HANDLE USER_API dc_start_i_d(HANDLE icdev)
读身份证。
dc_disp_neg
short USER_API dc_disp_neg(HANDLE icdev, char *dispstr)
高层液晶显示。
dc_settime_hex
short USER_API dc_settime_hex(HANDLE icdev, char *time)
设置设备时间。
dc_write_24c64_hex
short USER_API dc_write_24c64_hex(HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写24C64系列卡。
dc_i_d_query_finger
unsigned char *USER_API dc_i_d_query_finger(HANDLE idhandle)
获取指纹原始数据。
dc_srd_eeprom_hex
short USER_API dc_srd_eeprom_hex(HANDLE icdev, short offset, short length, unsigned char *rec_buffer)
读EEPROM。
dc_mfdes_auth_hex
short USER_API dc_mfdes_auth_hex(HANDLE icdev, unsigned char keyno, unsigned char keylen, unsigned char *authkey, unsigned char *randAdata, unsigned char *randBdata)
Mifare Desfire卡认证。
dc_decrement_ml
short USER_API dc_decrement_ml(HANDLE icdev, unsigned short _Value)
ML卡减值。
dc_writeblock
short USER_API dc_writeblock(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char wlen, unsigned char *wbuffer)
保留。
SD_IFD_CreateMac
short USER_API SD_IFD_CreateMac(HANDLE icdev, unsigned char srclen, unsigned char *srcdata, unsigned char *macdata)
用外接密码键盘工作密钥算MAC。
dc_initval
short USER_API dc_initval(HANDLE icdev, unsigned char _Adr, unsigned int _Value)
M1卡值块初始化。
dc_Check_24C01
short USER_API dc_Check_24C01(HANDLE icdev)
检测24C01卡。
dc_CheckCard
short USER_API dc_CheckCard(HANDLE icdev)
检测卡。
dc_card
short USER_API dc_card(HANDLE icdev, unsigned char _Mode, unsigned int *_Snr)
寻卡请求、防卡冲突、选卡操作。
dc_printstatus
short USER_API dc_printstatus(HANDLE icdev, unsigned char *paperstatus, unsigned char *tempturestatus, unsigned char *zkstatus)
获取打印机状态。
dc_down_4428
short USER_API dc_down_4428(HANDLE icdev)
4428卡下电。
dc_NfcInit
short USER_API dc_NfcInit(HANDLE icdev)
初始化NFC。
dc_find_i_d_speed
short USER_API dc_find_i_d_speed(HANDLE icdev)
查找身份证。
dc_HL_read
short USER_API dc_HL_read(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int _Snr, unsigned char *_Data, unsigned int *_NSnr)
保留。
dc_MFPL3_readinplain
short USER_API dc_MFPL3_readinplain(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata)
读Mifare Plus卡数据（3级）。
dc_KeypadGetKeyValue
short USER_API dc_KeypadGetKeyValue(HANDLE icdev, int number, unsigned char *value)
获取键值。
dc_MultiFlashGetSize
short USER_API dc_MultiFlashGetSize(HANDLE icdev, unsigned char type, unsigned int *length_h, unsigned int *length_l)
多个FLASH容量大小获取。
dc_ScreenDisplayBgImageByColor
short USER_API dc_ScreenDisplayBgImageByColor(HANDLE icdev, const unsigned char *rgb, int x, int y, int w, int h)
填充背景。
dc_init_auth_1608_hex
short USER_API dc_init_auth_1608_hex(HANDLE icdev, unsigned char *databuffer)
初始化1608卡认证。
dc_checkpass_1604_hex
short USER_API dc_checkpass_1604_hex(HANDLE icdev, short zone, unsigned char *password)
验证1604卡密码。
dc_readpin_4442
short USER_API dc_readpin_4442(HANDLE icdev, unsigned char *passwd)
读4442卡密码。
dc_halt
short USER_API dc_halt(HANDLE icdev)
终止卡操作。
dc_increment
short USER_API dc_increment(HANDLE icdev, unsigned char _Adr, unsigned int _Value)
M1卡值块加值。
dc_RfReadChipRegister
short USER_API dc_RfReadChipRegister(HANDLE icdev, unsigned char *register_data)
保留。
dc_pro_commandsourceCRC
short USER_API dc_pro_commandsourceCRC(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char CRCSTU)
非接触式CPU卡指令交互。
dc_RfMarch
short USER_API dc_RfMarch(HANDLE icdev)
射频天线打开。
dc_GpsGetInfo
short USER_API dc_GpsGetInfo(HANDLE icdev, int time_ms, unsigned char *data_buffer, int *data_len)
获取GPS信息。
swr_alleeprom
short USER_API swr_alleeprom(HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写EEPROM。
dc_mfdes_auth
short USER_API dc_mfdes_auth(HANDLE icdev, unsigned char keyno, unsigned char keylen, unsigned char *authkey, unsigned char *randAdata, unsigned char *randBdata)
Mifare Desfire卡认证。
dc_cpy_cpuapduInt_hex
short USER_API dc_cpy_cpuapduInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer)
保留。
dc_FlashErase
short USER_API dc_FlashErase(HANDLE icdev, int sector)
Flash扇区擦除。
dc_HL_readhex
short USER_API dc_HL_readhex(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int _Snr, unsigned char *_Data, unsigned int *_NSnr)
保留。
dcdes
short USER_API dcdes(unsigned char *key, unsigned char *sour, unsigned char *dest, short m)
单DES加解密。
dc_read1024_hex
short USER_API dc_read1024_hex(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *databuffer)
保留。
SD_IFD_GetPIN
short USER_API SD_IFD_GetPIN(HANDLE icdev, char *szPasswd)
获取外接密码键盘明文数据。
dc_authentication_passaddr_hex
short USER_API dc_authentication_passaddr_hex(HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff)
验证M1卡密码。
dc_read_1608
short USER_API dc_read_1608(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata)
读1608卡。
dc_keypad_DeleteKey
short USER_API dc_keypad_DeleteKey(HANDLE icdev, int key_index)
保留。
dc_RestDevice
short USER_API dc_RestDevice(HANDLE icdev)
休眠设备。
dc_TcpGetInfo
short USER_API dc_TcpGetInfo(HANDLE icdev, unsigned char type, unsigned char *data_buffer, int *data_len)
获取TCP信息。
dc_i_d_query_photo_2
short USER_API dc_i_d_query_photo_2(HANDLE idhandle, unsigned char *photo)
获取相片原始数据。
dc_IdCardImageBuild
short USER_API dc_IdCardImageBuild(HANDLE icdev, int type, int text_len, const unsigned char *text, int photo_len, const unsigned char *photo, const char *front_file, const char *back_file)
生成身份证正面和背面图像。
dc_anticoll_mode
short USER_API dc_anticoll_mode(HANDLE icdev, unsigned char mode, unsigned char _Bcnt, unsigned int *_Snr)
防卡冲突。
dc_lock_afi
short USER_API dc_lock_afi(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID)
保留。
dc_passget
short USER_API dc_passget(HANDLE icdev, unsigned char *rlen, unsigned char *cpass)
获取键盘数据。
dc_setdevicetime
short USER_API dc_setdevicetime(HANDLE icdev, unsigned char year, unsigned char month, unsigned char date, unsigned char hour, unsigned char minute, unsigned char second)
设置设备时间。
dc_pro_halt
short USER_API dc_pro_halt(HANDLE icdev)
终止非接触式CPU卡操作。
dc_auth_ulc_hex
short USER_API dc_auth_ulc_hex(HANDLE icdev, unsigned char *key)
验证Mifare Ultralight C卡密码。
dc_HL_write_hex
short USER_API dc_HL_write_hex(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int *_Snr, unsigned char *_Data)
保留。
dc_Check_24C04
short USER_API dc_Check_24C04(HANDLE icdev)
检测24C04卡。
dc_lock_afi_hex
short USER_API dc_lock_afi_hex(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID)
保留。
dc_ctlbacklight
short USER_API dc_ctlbacklight(HANDLE icdev, unsigned char cOpenFlag)
LCD背光控制。
dc_cpuapdurespon
short USER_API dc_cpuapdurespon(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。
dc_CvOpen
short USER_API dc_CvOpen(HANDLE icdev, int number)
开启摄像头。
dc_SelfServiceDeviceConfigPlace
short USER_API dc_SelfServiceDeviceConfigPlace(HANDLE icdev, unsigned char mode)
设置停卡位置。
dc_readpin_4428
short USER_API dc_readpin_4428(HANDLE icdev, unsigned char *passwd)
读4428卡密码。
dc_ReadRfTypeABATS_hex
short USER_API dc_ReadRfTypeABATS_hex(HANDLE icdev, int *ats_len, char *ats)
读取ATS数据。
dc_i_d_query_name
char *USER_API dc_i_d_query_name(HANDLE idhandle)
获取姓名。
dc_cpuapduInt_hex
short USER_API dc_cpuapduInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer)
接触式CPU卡指令交互。
dc_reset_to_ready
short USER_API dc_reset_to_ready(HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
dc_lock_block_hex
short USER_API dc_lock_block_hex(HANDLE icdev, unsigned char flags, unsigned char block, unsigned char *UID)
保留。
dc_SetCpuCard616C
short USER_API dc_SetCpuCard616C(HANDLE icdev, unsigned char value)
设置接触式CPU卡616C配置。
hex_a
short USER_API hex_a(unsigned char *hex, unsigned char *a, short length)
数据转换。
dc_KeypadLoadKey
short USER_API dc_KeypadLoadKey(HANDLE icdev, int number, int set_index, int sub_index, int type, int mode, const unsigned char *key_data, int key_len, int flag, unsigned char *ex_data, int *ex_len)
装载密钥。
dc_read_24c64
short USER_API dc_read_24c64(HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读24C64系列卡。
dc_WriteNicMacAddress
short USER_API dc_WriteNicMacAddress(HANDLE icdev, const unsigned char *data_buffer, int data_len)
写网卡MAC地址。
dc_mfdes_baud
short USER_API dc_mfdes_baud(HANDLE icdev, unsigned char _Mode, unsigned char para)
保留。
dc_keypad_io_control
short USER_API dc_keypad_io_control(HANDLE icdev, unsigned char ctime, const unsigned char *request, int request_len, unsigned char *response, int *response_len)
保留。
dc_GetDeviceTradeNumber
short USER_API dc_GetDeviceTradeNumber(HANDLE icdev, char *number)
获取设备商户号。
dc_LedControl
short USER_API dc_LedControl(HANDLE icdev, unsigned char mode)
数码管显示设置。
dc_write_24c64
short USER_API dc_write_24c64(HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写24C64系列卡。
dc_read_walletbalance
short USER_API dc_read_walletbalance(HANDLE icdev, unsigned char *walletvalue)
保留。
dc_read_4428_hex
short USER_API dc_read_4428_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4428卡。
dc_attrib
short USER_API dc_attrib(HANDLE icdev, unsigned char *PUPI, unsigned char CID)
激活卡片。
dc_anticoll
short USER_API dc_anticoll(HANDLE icdev, unsigned char _Bcnt, unsigned int *_Snr)
防卡冲突。
dc_2dot4_command_hex
short USER_API dc_2dot4_command_hex(HANDLE icdev, unsigned int slen, unsigned char *senddata, unsigned int *rlen, unsigned char *recvbuffer, unsigned char timeout)
2.4G指令交互。
dc_card_status
short USER_API dc_card_status(HANDLE icdev)
检测接触式卡存在。
LibMain
void USER_API LibMain(int flag, void *context)
库入口。
dc_i_d_query_department_2
short USER_API dc_i_d_query_department_2(HANDLE idhandle, char *department)
获取签发机关。
dc_get_terminalnumber
short USER_API dc_get_terminalnumber(HANDLE icdev, unsigned char length, unsigned char *serieldata)
保留。
dc_getname
short USER_API dc_getname(HANDLE icdev, char *name)
获取名称。
dc_halt_shc1102
short USER_API dc_halt_shc1102(HANDLE icdev)
终止SHC1102卡操作。
dc_getfingerdata
short USER_API dc_getfingerdata(HANDLE icdev, int *length, unsigned char *data)
读身份证指纹。
dc_getlongver
short USER_API dc_getlongver(HANDLE icdev, unsigned char *sver)
获取设备长版本。
dc_changepass_1604_hex
short USER_API dc_changepass_1604_hex(HANDLE icdev, short zone, unsigned char *password)
修改1604卡密码。
dc_GlyProCommand_hex
short USER_API dc_GlyProCommand_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout)
保留。
dc_Scan2DBarcodeStart
short USER_API dc_Scan2DBarcodeStart(HANDLE icdev, unsigned char mode)
开始扫描二维码。
dc_stay_quiet_hex
short USER_API dc_stay_quiet_hex(HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
dc_CpuCardStatus
short USER_API dc_CpuCardStatus(HANDLE icdev)
检测接触式CPU卡。
dc_Config2DBarcode
short USER_API dc_Config2DBarcode(HANDLE icdev, const unsigned char *content, int content_len)
配置二维码工作模式。
dc_read_random_hex
short USER_API dc_read_random_hex(HANDLE icdev, unsigned char *data)
保留。
dc_setprint
short USER_API dc_setprint(HANDLE icdev, unsigned char FontSize, unsigned char Alignment, unsigned char LeftMargin, unsigned char RightMargin, unsigned char RowPitch, unsigned char PrintOutRate)
设置打印机参数。
dc_WirelessRecv
short USER_API dc_WirelessRecv(HANDLE icdev, unsigned char type, unsigned char mode, unsigned char time_100ms, unsigned char *data_buffer, int *data_len)
从网络端接收数据。
dc_MFPL3_readencrypted_hex
short USER_API dc_MFPL3_readencrypted_hex(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata, unsigned char flag)
加密模式读Mifare Plus卡数据（3级）。
dc_MFPL3_authl3sectorkey
short USER_API dc_MFPL3_authl3sectorkey(HANDLE icdev, unsigned char mode, unsigned int sectorBNr, unsigned char *authkey)
验证Mifare Plus卡状态密码（3级）。
dc_readpin_4428_hex
short USER_API dc_readpin_4428_hex(HANDLE icdev, unsigned char *passwd)
读4428卡密码。
dc_pro_command
short USER_API dc_pro_command(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_MFPL1_switchtol2
short USER_API dc_MFPL1_switchtol2(HANDLE icdev, unsigned char *authkey)
升级Mifare Plus卡状态到2级（1级）。
dc_setdevicebaud
short USER_API dc_setdevicebaud(HANDLE icdev, unsigned char baud)
设置串口设备通讯波特率。
dc_MFPL2_switchtol3
short USER_API dc_MFPL2_switchtol3(HANDLE icdev, unsigned char *authkey)
升级Mifare Plus卡状态到3级（2级）。
dc_SelfServiceDeviceReset
short USER_API dc_SelfServiceDeviceReset(HANDLE icdev)
复位自助设备。
dc_update
short USER_API dc_update(HANDLE icdev)
保留。
dc_Scan2DBarcodeExit
short USER_API dc_Scan2DBarcodeExit(HANDLE icdev)
退出扫描二维码。
dc_write_1604_hex
short USER_API dc_write_1604_hex(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writedata)
写1604卡。
dc_PassIn2
short USER_API dc_PassIn2(HANDLE icdev, unsigned char ctime, unsigned char ucmode, unsigned char *cardno)
进入读键盘模式。
dc_inventory
short USER_API dc_inventory(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char masklen, unsigned char *rlen, unsigned char *rbuffer)
保留。
dc_CreatSm4Data
short USER_API dc_CreatSm4Data(HANDLE icdev, unsigned char keytype, unsigned char enmode, unsigned char *sourcedata, unsigned char *retdata)
用工作密钥加解密。
dc_RfGetCardType
short USER_API dc_RfGetCardType(HANDLE icdev)
获取非接触卡类型。
dc_des_hex
short USER_API dc_des_hex(unsigned char *key, unsigned char *sour, unsigned char *dest, short m)
单DES加解密。
dc_readval_ml
short USER_API dc_readval_ml(HANDLE icdev, unsigned short *_Value)
ML卡读值。
dc_CardIssuingScript
short USER_API dc_CardIssuingScript(HANDLE icdev, unsigned int slen, unsigned char *sdata, unsigned char *TransactionIsInterrupted, unsigned char *TradingResult)
保留。
dc_card_b
short USER_API dc_card_b(HANDLE icdev, unsigned char *rbuf)
寻Type B卡并激活。
dc_set_terminalnumber
short USER_API dc_set_terminalnumber(HANDLE icdev, unsigned char length, unsigned char *serieldata)
保留。
dc_verifypin_4428
short USER_API dc_verifypin_4428(HANDLE icdev, unsigned char *passwd)
验证4428卡密码。
dc_read_1604
short USER_API dc_read_1604(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *readdata)
读1604卡。
dc_gettime
short USER_API dc_gettime(HANDLE icdev, unsigned char *time)
获取设备时间。
dc_write_1608_hex
short USER_API dc_write_1608_hex(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata)
写1608卡。
dc_rf_poweroff
short USER_API dc_rf_poweroff(HANDLE icdev, unsigned char icc_slot_no)
卡下电。
dc_setcpupara
short USER_API dc_setcpupara(HANDLE icdev, unsigned char cputype, unsigned char cpupro, unsigned char cpuetu)
设置接触式CPU卡参数。
dc_write_4428
short USER_API dc_write_4428(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4428卡。
dc_get55data
short USER_API dc_get55data(HANDLE icdev, unsigned int slen, unsigned char *sdata, unsigned char *PacketType, unsigned int *rlen, unsigned char *rdata)
保留。
dc_write_24c
short USER_API dc_write_24c(HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写24C系列卡。
dc_displcd
short USER_API dc_displcd(HANDLE icdev, unsigned char flag)
保留。
dc_WirelessTcpClose
short USER_API dc_WirelessTcpClose(HANDLE icdev)
关闭TCP链接。
dc_card_double
short USER_API dc_card_double(HANDLE icdev, unsigned char _Mode, unsigned char *_Snr)
寻卡请求、防卡冲突、选卡操作。
dc_auth_shc1102
short USER_API dc_auth_shc1102(HANDLE icdev, unsigned char *_Data)
验证SHC1102卡密码。
dc_load_key
short USER_API dc_load_key(HANDLE icdev, unsigned char _Mode, unsigned char _SecNr, unsigned char *_NKey)
装载设备密码。
dc_SelfServiceDeviceConfigBack
short USER_API dc_SelfServiceDeviceConfigBack(HANDLE icdev, unsigned char mode)
设置后端进卡模式。
dc_MFPL3_writeencrypted_hex
short USER_API dc_MFPL3_writeencrypted_hex(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata, unsigned char flag)
加密模式写Mifare Plus卡数据（3级）。
dc_BtUserControl
short USER_API dc_BtUserControl(HANDLE icdev, unsigned char flag, int offset, int length, unsigned char *value)
蓝牙用户自定义的配置命令。
dc_clr_control_bit
short USER_API dc_clr_control_bit(HANDLE icdev, unsigned char _b)
保留。
dc_KeypadSetKeyValue
short USER_API dc_KeypadSetKeyValue(HANDLE icdev, int number, unsigned char value)
设置键值。
dc_displcd_ext
short USER_API dc_displcd_ext(HANDLE icdev, unsigned char flag, unsigned char row, unsigned char offset)
保留。
dc_CvLibLoad
short USER_API dc_CvLibLoad(HANDLE icdev)
摄像视觉库加载。
dc_disp_mode
short USER_API dc_disp_mode(HANDLE icdev, unsigned char mode)
保留。
dc_MFPL3_writeinplain_hex
short USER_API dc_MFPL3_writeinplain_hex(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata)
写Mifare Plus卡数据（3级）。
dc_rw_rfreg_hex
short USER_API dc_rw_rfreg_hex(HANDLE icdev, unsigned char flag, unsigned char _Adr, unsigned char *_Data)
读/写射频寄存器。
dc_tripledes
short USER_API dc_tripledes(unsigned char *key, unsigned char *src, unsigned char *dest, short m)
三DES加解密。
dc_encrypt_hex
short USER_API dc_encrypt_hex(char *key, char *ptrSource, unsigned short msgLen, char *ptrDest)
保留。
dc_setusbtimeout
short USER_API dc_setusbtimeout(unsigned char ntimes)
保留。
dc_disp_str
short USER_API dc_disp_str(HANDLE icdev, char *dispstr)
液晶显示。
dc_GetCpuCard616C
short USER_API dc_GetCpuCard616C(HANDLE icdev, unsigned char *value)
获取接触式CPU卡616C配置。
dc_readwrotect_4442
short USER_API dc_readwrotect_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡保护位。
dc_pro_resetInt_hex
short USER_API dc_pro_resetInt_hex(HANDLE icdev, unsigned char *rlen, char *receive_data)
非接触式CPU卡复位。
dc_cpuapdusourceEXT
short USER_API dc_cpuapdusourceEXT(HANDLE icdev, short slen, unsigned char *sendbuffer, short *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。
dc_open_door
short USER_API dc_open_door(HANDLE icdev, unsigned char cflag)
保留。
dc_GetDeviceTerminalNumber
short USER_API dc_GetDeviceTerminalNumber(HANDLE icdev, char *number)
获取设备终端号。
dc_MFPL0_commitperso
short USER_API dc_MFPL0_commitperso(HANDLE icdev)
Mifare Plus卡提交个人化数据（0级）。
dc_fuse_102
short USER_API dc_fuse_102(HANDLE icdev)
102卡熔丝。
dc_cpuhotreset_hex
short USER_API dc_cpuhotreset_hex(HANDLE icdev, unsigned char *rlen, char *databuffer)
接触式CPU卡复位。
dc_lock_dsfid
short USER_API dc_lock_dsfid(HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID)
保留。
dc_GetMagFormat
short USER_API dc_GetMagFormat(HANDLE icdev, int *mode)
磁条卡数据自动上传数据模式获取。
dc_changepin_4442_hex
short USER_API dc_changepin_4442_hex(HANDLE icdev, unsigned char *passwd)
修改4442卡密码。
dc_cpuapduresponInt
short USER_API dc_cpuapduresponInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。
dc_keypad_GetRandomValue
short USER_API dc_keypad_GetRandomValue(HANDLE icdev, int length, unsigned char *value)
保留。
dc_config_port_name
void USER_API dc_config_port_name(short port, const char *name)
配置端口名称。
dc_checkpass_153_hex
short USER_API dc_checkpass_153_hex(HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password)
验证153卡密码。
dc_MFPL3_readencrypted
short USER_API dc_MFPL3_readencrypted(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata, unsigned char flag)
加密模式读Mifare Plus卡数据（3级）。
dc_NfcSimulateCardConfig
short USER_API dc_NfcSimulateCardConfig(HANDLE icdev, int mode)
NFC点对点数据透传（从服务端接收）。
dc_read_24c
short USER_API dc_read_24c(HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读24C系列卡。
dc_MFPL3_writeencrypted
short USER_API dc_MFPL3_writeencrypted(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata, unsigned char flag)
加密模式写Mifare Plus卡数据（3级）。
dc_read_4428
short USER_API dc_read_4428(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4428卡。
dc_reset_to_ready_hex
short USER_API dc_reset_to_ready_hex(HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
dc_fingerprint_io_control
short USER_API dc_fingerprint_io_control(HANDLE icdev, unsigned char ctime, const unsigned char *request, int request_len, unsigned char *response, int *response_len)
指纹模块通讯。
dc_cpureset
short USER_API dc_cpureset(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡复位。
dc_passcancel
short USER_API dc_passcancel(HANDLE icdev)
退出读键盘模式。
dc_dispmaininfo
short USER_API dc_dispmaininfo(HANDLE icdev, unsigned char offset, char *data)
液晶显示。
dc_getsnr_fm11rf005_hex
short USER_API dc_getsnr_fm11rf005_hex(HANDLE icdev, unsigned char *snrstr)
获取FM11RF005卡序列号。
SD_IFD_Scan2DBarcodeStart
short USER_API SD_IFD_Scan2DBarcodeStart(HANDLE icdev, unsigned char mode)
外接密码键盘开始扫描二维码。
dc_SetKbKeyID
short USER_API dc_SetKbKeyID(HANDLE icdev, unsigned char keyID)
设置当前密钥组。
dc_write_4442
short USER_API dc_write_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4442卡。
dc_getrcinfo_hex
short USER_API dc_getrcinfo_hex(HANDLE icdev, unsigned char *info)
保留。
dc_InstallKbKey
short USER_API dc_InstallKbKey(HANDLE icdev, unsigned char flag, unsigned char keylen, unsigned char *keydata, unsigned char mode)
设置密码键盘密钥。
dc_ScreenDisplayBgImage
short USER_API dc_ScreenDisplayBgImage(HANDLE icdev, int number, int x, int y, int w, int h)
显示背景图像。
dc_write_fuse_1608
short USER_API dc_write_fuse_1608(HANDLE icdev, unsigned char value)
写1608卡熔丝。
dc_get_signmessageparameters
short USER_API dc_get_signmessageparameters(HANDLE icdev, unsigned char length, unsigned char *parameters)
保留。
dc_end_i_d
void USER_API dc_end_i_d(HANDLE idhandle)
释放读身份证资源。
dc_ReadDeviceTypeName
short USER_API dc_ReadDeviceTypeName(HANDLE icdev, char *name)
读取设备型号名称。
dc_MultiFlashErase
short USER_API dc_MultiFlashErase(HANDLE icdev, unsigned char type, unsigned int sector)
多个Flash扇区擦除。
dc_pro_resetInt
short USER_API dc_pro_resetInt(HANDLE icdev, unsigned char *rlen, unsigned char *receive_data)
非接触式CPU卡复位。
dc_SelfServiceDeviceSetFrontSwitch
short USER_API dc_SelfServiceDeviceSetFrontSwitch(HANDLE icdev, unsigned char mode)
前门电闸门设置。
dc_ScreenDisplaySetConfig
short USER_API dc_ScreenDisplaySetConfig(HANDLE icdev, unsigned char tag, const unsigned char *config_data)
设置显示配置。
dc_2dot4Apdu
short USER_API dc_2dot4Apdu(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer)
2.4G APDU指令交互。
dc_TtsVoicePlay
short USER_API dc_TtsVoicePlay(HANDLE icdev, unsigned char type, const unsigned char *content, int content_len)
TTS语音播放。
dc_KeypadAlgorithm
short USER_API dc_KeypadAlgorithm(HANDLE icdev, int number, int set_index, int sub_index, int flag, int mode, const unsigned char *in_data, int in_len, unsigned char *out_data, int *out_len)
数据加解密。
dc_pro_reset
short USER_API dc_pro_reset(HANDLE icdev, unsigned char *rlen, unsigned char *receive_data)
非接触式CPU卡复位。
dc_dispmainmenu
short USER_API dc_dispmainmenu(HANDLE icdev)
显示主界面。
dc_HL_read_hex
short USER_API dc_HL_read_hex(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int _Snr, unsigned char *_Data, unsigned int *_NSnr)
保留。
dc_ConfigTempIpAddress
short USER_API dc_ConfigTempIpAddress(HANDLE icdev, const unsigned char *data_buffer, int data_len)
设定临时IP地址。
dc_CheckPinpadWithReaderBaudrate
short USER_API dc_CheckPinpadWithReaderBaudrate(HANDLE icdev, unsigned char *value)
查询reader与密码键盘串口波特率。
dc_pro_command_hex
short USER_API dc_pro_command_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_dispmap_T8
short USER_API dc_dispmap_T8(HANDLE icdev, unsigned char *mapdata)
保留。
dc_GetChipIdNumber
short USER_API dc_GetChipIdNumber(HANDLE icdev, char *number)
获取芯片唯一ID号。
dc_ParsePhotoInfo
short USER_API dc_ParsePhotoInfo(HANDLE icdev, int type, int info_len, const unsigned char *info, int *photo_len, unsigned char *photo)
解析相片信息。
dc_get_idsnr_hex
short USER_API dc_get_idsnr_hex(HANDLE icdev, char *_Data)
获取身份证UID。
dc_RefreshAndDisplayMainUI
short USER_API dc_RefreshAndDisplayMainUI(HANDLE icdev)
刷新返回主界面。
dc_BtReset
short USER_API dc_BtReset(HANDLE icdev)
蓝牙软件复位。
dc_stay_quiet
short USER_API dc_stay_quiet(HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
dc_write_shc1102
short USER_API dc_write_shc1102(HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
写SHC1102卡。
dc_write_random_hex
short USER_API dc_write_random_hex(HANDLE icdev, short length, unsigned char *data)
保留。
dc_MFPL3_writeinplain
short USER_API dc_MFPL3_writeinplain(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *writedata)
写Mifare Plus卡数据（3级）。
dc_readprotect_4428
short USER_API dc_readprotect_4428(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4428卡保护位。
dc_NfcDataReceiver
short USER_API dc_NfcDataReceiver(HANDLE icdev, int time_ms, unsigned char *flag, unsigned char *response, int *response_len)
接收NFC手机数据。
dc_2dot4_reset
short USER_API dc_2dot4_reset(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
2.4G复位。
dc_checkpass_1608
short USER_API dc_checkpass_1608(HANDLE icdev, unsigned char zone, unsigned char type, unsigned char *password)
验证1608卡密码。
dc_changepass_102
short USER_API dc_changepass_102(HANDLE icdev, short zone, unsigned char *password)
修改102卡密码。
dc_display_2dbarcode
short USER_API dc_display_2dbarcode(HANDLE icdev, int point_x, int point_y, const char *info)
LCD显示二维码。
dc_transfer
short USER_API dc_transfer(HANDLE icdev, unsigned char _Adr)
M1卡值块传递。
dc_MultiAntennaStartOrStop
short USER_API dc_MultiAntennaStartOrStop(HANDLE icdev, unsigned char flag, unsigned int *mask)
多天线启动或停止。
dc_SetCpuCardPps
short USER_API dc_SetCpuCardPps(HANDLE icdev, unsigned char mode)
接触式CPU卡PPS配置设置。
dc_verifypin_4428_hex
short USER_API dc_verifypin_4428_hex(HANDLE icdev, unsigned char *passwd)
验证4428卡密码。
dc_card_n
short USER_API dc_card_n(HANDLE icdev, unsigned char _Mode, unsigned int *SnrLen, unsigned char *_Snr)
寻卡请求、防卡冲突、选卡操作。
dc_cpuapdusourceEXT_hex
short USER_API dc_cpuapdusourceEXT_hex(HANDLE icdev, short slen, char *sendbuffer, short *rlen, char *databuffer)
接触式CPU卡指令交互。
dc_get_securityinfo_hex
short USER_API dc_get_securityinfo_hex(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
dc_cpy_setkey
short USER_API dc_cpy_setkey(HANDLE icdev, unsigned char *genkey, int keylen)
保留。
dc_read_shc1102
short USER_API dc_read_shc1102(HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
读SHC1102卡。
dc_DownloadFileData
short USER_API dc_DownloadFileData(HANDLE icdev, unsigned int file_type, unsigned int file_size, unsigned int flag, const unsigned char *data, unsigned int *data_size)
装载文件数据。
dc_set_hardwareserialnumber
short USER_API dc_set_hardwareserialnumber(HANDLE icdev, unsigned char length, unsigned char *hardwareserial)
保留。
dc_get_systeminfo_hex
short USER_API dc_get_systeminfo_hex(HANDLE icdev, unsigned char flags, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
dc_MFPL3_authl3key_hex
short USER_API dc_MFPL3_authl3key_hex(HANDLE icdev, unsigned int keyBNr, unsigned char *authkey)
验证Mifare Plus卡状态密码（3级）。
dc_SelfServiceDeviceGetFrontSwitch
short USER_API dc_SelfServiceDeviceGetFrontSwitch(HANDLE icdev, unsigned char *mode)
前门电闸门获取。
dc_pro_commandsource_hex
short USER_API dc_pro_commandsource_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_check_writehex
short USER_API dc_check_writehex(HANDLE icdev, unsigned int Snr, unsigned char authmode, unsigned char Adr, unsigned char *_data)
检查之前写入的数据。
dc_dispinfo
short USER_API dc_dispinfo(HANDLE icdev, unsigned char line, unsigned char offset, char *data)
液晶显示。
dc_init_485
HANDLE USER_API dc_init_485(short port, int baud)
保留。
dc_pass_key_value2
short USER_API dc_pass_key_value2(HANDLE icdev, unsigned char ctime, unsigned char *rlen, unsigned char *cpass)
获取多个按键值。
dc_down_1604
short USER_API dc_down_1604(HANDLE icdev)
1604卡下电。
dc_testdevicecomm
short USER_API dc_testdevicecomm(HANDLE icdev)
测试设备通讯。
dc_changepass_102_hex
short USER_API dc_changepass_102_hex(HANDLE icdev, short zone, unsigned char *password)
修改102卡密码。
dc_RfMultiRequest
short USER_API dc_RfMultiRequest(HANDLE icdev)
多重寻卡。
dc_WriteFlash
short USER_API dc_WriteFlash(HANDLE icdev, int offset, int length, const unsigned char *data_buffer)
写Flash。
dc_KeypadStartInput
short USER_API dc_KeypadStartInput(HANDLE icdev, int number, int mode, int set_index, int sub_index, const unsigned char *in_data, int in_len, int min_len, int max_len, int auto_end, int enable_beep, int time_s, unsigned char *out_data, int *out_len)
启动按键输入。
dc_getsnr_fm11rf005
short USER_API dc_getsnr_fm11rf005(HANDLE icdev, unsigned int *_Snr)
获取FM11RF005卡序列号。
dc_get_record
short USER_API dc_get_record(HANDLE icdev, unsigned char tablenumber, unsigned char recordnumber, unsigned char *recordquantity, unsigned char *recorddata)
保留。
dc_ReadNicMacAddress
short USER_API dc_ReadNicMacAddress(HANDLE icdev, unsigned char *data_buffer, int *data_len)
读网卡MAC地址。
dc_setmag
short USER_API dc_setmag(HANDLE icdev, unsigned char mode, unsigned char track1, unsigned char track2, unsigned char track3)
磁条卡参数配置。
dc_read_fm11rf005
short USER_API dc_read_fm11rf005(HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
读FM11RF005卡。
dc_i_d_query_expire_day
char *USER_API dc_i_d_query_expire_day(HANDLE idhandle)
获取有效期限。
dc_authentication_passaddr
short USER_API dc_authentication_passaddr(HANDLE icdev, unsigned char _Mode, unsigned char _Addr, unsigned char *passbuff)
验证M1卡密码。
dc_pro_receivecommandsource
short USER_API dc_pro_receivecommandsource(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
保留。
dc_check_auth_1608_hex
short USER_API dc_check_auth_1608_hex(HANDLE icdev, unsigned char *databuffer)
核对1608卡认证。
dc_select_uid_hex
short USER_API dc_select_uid_hex(HANDLE icdev, unsigned char flags, unsigned char *UID)
保留。
dc_readblock
short USER_API dc_readblock(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
dc_load_key_hex
short USER_API dc_load_key_hex(HANDLE icdev, unsigned char _Mode, unsigned char _SecNr, char *_NKey)
装载设备密码。
dc_VoicePlayAndDisplay
short USER_API dc_VoicePlayAndDisplay(HANDLE icdev, unsigned char mode, unsigned char type)
语音播放及显示。
dc_write_TS
short USER_API dc_write_TS(HANDLE icdev)
保留。
dc_changekey_ulc_hex
short USER_API dc_changekey_ulc_hex(HANDLE icdev, unsigned char *newkey)
修改Mifare Ultralight C卡密码。
dc_read_fm11rf005_hex
short USER_API dc_read_fm11rf005_hex(HANDLE icdev, unsigned char _Adr, char *_Data)
读FM11RF005卡。
dc_des
short USER_API dc_des(unsigned char *key, unsigned char *sour, unsigned char *dest, short m)
单DES加解密。
dc_get_hardwareserialnumber
short USER_API dc_get_hardwareserialnumber(HANDLE icdev, unsigned char length, unsigned char *hardwareserial)
保留。
SD_IFD_SelecetDes
short USER_API SD_IFD_SelecetDes(HANDLE icdev, unsigned char desmode)
设置外接密码键盘算法。
dc_MFPL3_readinplain_hex
short USER_API dc_MFPL3_readinplain_hex(HANDLE icdev, unsigned int BNr, unsigned char Numblock, unsigned char *readdata)
读Mifare Plus卡数据（3级）。
dc_set_trademerchantcode
short USER_API dc_set_trademerchantcode(HANDLE icdev, unsigned char length, unsigned char *merchantcode)
保留。
dc_get_systeminfo
short USER_API dc_get_systeminfo(HANDLE icdev, unsigned char flags, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
dc_lock_dsfid_hex
short USER_API dc_lock_dsfid_hex(HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID)
保留。
dc_write
short USER_API dc_write(HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
写卡数据。
dc_cardAB
short USER_API dc_cardAB(HANDLE icdev, unsigned char *rlen, unsigned char *rbuf, unsigned char *type)
寻Type A或Type B卡并激活。
dc_Check_24C08
short USER_API dc_Check_24C08(HANDLE icdev)
检测24C08卡。
dc_NfcActivate
short USER_API dc_NfcActivate(HANDLE icdev, unsigned char *atr, int *atr_len)
激活NFC。
dc_read_4442
short USER_API dc_read_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡。
dc_readmagcardallA
short USER_API dc_readmagcardallA(HANDLE icdev, unsigned char ctime, unsigned char *pTrack1Data, unsigned int *pTrack1Len, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len)
自动获取磁条卡数据。
dc_request_shc1102
short USER_API dc_request_shc1102(HANDLE icdev, unsigned char _Mode, unsigned short *TagType)
SHC1102卡寻卡请求。
dc_read_1604_hex
short USER_API dc_read_1604_hex(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *readdata)
读1604卡。
dc_MultiFlashWrite
short USER_API dc_MultiFlashWrite(HANDLE icdev, unsigned char type, unsigned int offset_h, unsigned int offset_l, unsigned int length_h, unsigned int length_l, const unsigned char *data_buffer)
多个Flash写数据。
dc_creat_mac2_hex
short USER_API dc_creat_mac2_hex(HANDLE icdev, unsigned short DataLen, unsigned char *Data, unsigned char *MacData, unsigned char flag)
保留。
SD_IFD_GetVersion
short USER_API SD_IFD_GetVersion(HANDLE icdev, char *version)
获取外接密码键盘的版本。
dc_PassCancel
short USER_API dc_PassCancel(HANDLE icdev)
退出读键盘模式。
dc_read_24c_hex
short USER_API dc_read_24c_hex(HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读24C系列卡。
dc_keypad_GetMACDataOfCBC
short USER_API dc_keypad_GetMACDataOfCBC(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
dc_GetBatteryValue
short USER_API dc_GetBatteryValue(HANDLE icdev, unsigned char *value)
获取电池电量。
dc_card_double_hex
short USER_API dc_card_double_hex(HANDLE icdev, unsigned char _Mode, unsigned char *_Snr)
寻卡请求、防卡冲突、选卡操作。
dc_writeprotect_4442
short USER_API dc_writeprotect_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4442卡保护位。
dc_i_d_query_birth_2
short USER_API dc_i_d_query_birth_2(HANDLE idhandle, char *birth)
获取生日。
dc_write_afi
short USER_API dc_write_afi(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char *UID)
保留。
dc_changepin_4428_hex
short USER_API dc_changepin_4428_hex(HANDLE icdev, unsigned char *passwd)
修改4428卡密码。
dc_resetdevice
short USER_API dc_resetdevice(HANDLE icdev)
复位设备。
dc_readcount_1604
short USER_API dc_readcount_1604(HANDLE icdev, short zone)
读1604卡密码计数。
dc_getver
short USER_API dc_getver(HANDLE icdev, unsigned char *sver)
获取设备版本。
dc_check_1608
short USER_API dc_check_1608(HANDLE icdev)
检测1608卡。
SD_IFD_ActWorkKey
short USER_API SD_IFD_ActWorkKey(HANDLE icdev, unsigned char keysetmain, unsigned char keysetwork)
激活外接密码键盘工作密钥。
dc_i_d_query_id_number_2
short USER_API dc_i_d_query_id_number_2(HANDLE idhandle, char *id_number)
获取公民身份号码。
dc_writeprotect_4428_hex
short USER_API dc_writeprotect_4428_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4428卡保护位。
dc_posbeep
short USER_API dc_posbeep(HANDLE icdev, unsigned char beeptime)
设备蜂鸣。
dc_BtDataResponse
short USER_API dc_BtDataResponse(HANDLE icdev, int *length, unsigned char *value)
获取蓝牙响应。
dc_pro_commandlinkEXT
short USER_API dc_pro_commandlinkEXT(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG)
非接触式CPU卡指令交互。
dc_ReadRfCfgReg
short USER_API dc_ReadRfCfgReg(HANDLE icdev, int type, int number, int *value)
保留。
dc_ReadIdCardInfo
short USER_API dc_ReadIdCardInfo(HANDLE icdev, int time_ms, int *rlen, unsigned char *rdata)
读ID卡。
dc_write_1608
short USER_API dc_write_1608(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata)
写1608卡。
dc_i_d_query_finger_bmp_buffer
short USER_API dc_i_d_query_finger_bmp_buffer(HANDLE idhandle, unsigned char *BmpBuffer, unsigned int *BmpLength)
保留。
dc_LcdDisplay
short USER_API dc_LcdDisplay(HANDLE icdev, unsigned char line, unsigned char offset, unsigned char mode, const char *data)
液晶显示。
dc_cpuhotreset
short USER_API dc_cpuhotreset(HANDLE icdev, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡复位。
dc_set_addr
short USER_API dc_set_addr(unsigned char saddr)
保留。
dc_swr_eeprom
short USER_API dc_swr_eeprom(HANDLE icdev, short offset, short length, unsigned char *send_buffer)
写EEPROM。
dc_CalculateDes
short USER_API dc_CalculateDes(HANDLE icdev, unsigned char keyindex, unsigned char enmode, unsigned short datalen, unsigned char *srcdata, unsigned char *desdata)
保留。
dc_keypad_GetDecryptDataOfECB
short USER_API dc_keypad_GetDecryptDataOfECB(HANDLE icdev, unsigned char mode, int key_index, const unsigned char *in_data, int in_data_len, unsigned char *out_data, int *out_data_len)
保留。
dc_WirelessPowerControl
short USER_API dc_WirelessPowerControl(HANDLE icdev, unsigned char value)
无线模块电源控制。
dc_card_exist
short USER_API dc_card_exist(HANDLE icdev, unsigned char *flag)
检测多卡状态。
dc_inventory_hex
short USER_API dc_inventory_hex(HANDLE icdev, unsigned char flags, unsigned char AFI, unsigned char masklen, unsigned char *rlen, unsigned char *rbuffer)
保留。
dc_pro_commandsourceCRChex
short USER_API dc_pro_commandsourceCRChex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout, unsigned char CRCSTU)
非接触式CPU卡指令交互。
dc_HL_writehex
short USER_API dc_HL_writehex(HANDLE icdev, unsigned char _Mode, unsigned char _Adr, unsigned int *_Snr, unsigned char *_Data)
保留。
dc_readprotect_4442
short USER_API dc_readprotect_4442(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡保护位。
dc_write_dsfid_hex
short USER_API dc_write_dsfid_hex(HANDLE icdev, unsigned char flags, unsigned char DSFID, unsigned char *UID)
保留。
dc_cpuapdusource
short USER_API dc_cpuapdusource(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer)
接触式CPU卡指令交互。
dc_getrcinfo
short USER_API dc_getrcinfo(HANDLE icdev, unsigned char *info)
保留。
dc_CreatDesData
short USER_API dc_CreatDesData(HANDLE icdev, unsigned char keytype, unsigned char enmode, unsigned char *sourcedata, unsigned char *retdata)
用工作密钥加解密。
dc_authentication_key
short USER_API dc_authentication_key(HANDLE icdev, unsigned char *data, unsigned char *desdata)
保留。
dc_WriteOutEeprom
short USER_API dc_WriteOutEeprom(HANDLE icdev, int offset, int length, const unsigned char *data_buffer)
写外部EEPROM。
dc_CvCapture
short USER_API dc_CvCapture(HANDLE icdev, int number, int mode, const char *file_name)
拍照。
dc_get_i_d_raw_buffer
short USER_API dc_get_i_d_raw_buffer(HANDLE icdev, unsigned char *rdata)
读身份证原始数据。
dc_CalculateMACCheck
short USER_API dc_CalculateMACCheck(HANDLE icdev, unsigned char keyindex, unsigned char macmode, unsigned int datalen, unsigned char *srcdata, unsigned char *macdata)
保留。
dc_Scan2DBarcodeGetData
short USER_API dc_Scan2DBarcodeGetData(HANDLE icdev, int *rlen, unsigned char *rdata)
获取二维码数据。
dc_readmag
short USER_API dc_readmag(HANDLE icdev, unsigned char *pTrack1Data, unsigned int *pTrack1Len, unsigned char *pTrack2Data, unsigned int *pTrack2Len, unsigned char *pTrack3Data, unsigned int *pTrack3Len)
获取磁条卡数据。
dc_i_d_query_nation_2
short USER_API dc_i_d_query_nation_2(HANDLE idhandle, char *nation)
获取民族。
dc_initval_ml
short USER_API dc_initval_ml(HANDLE icdev, unsigned short _Value)
ML卡值初始化。
dc_pro_sendcommandsource
short USER_API dc_pro_sendcommandsource(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char timeout)
保留。
SD_IFD_Scan2DBarcodeGetData
short USER_API SD_IFD_Scan2DBarcodeGetData(HANDLE icdev, int *rlen, unsigned char *rdata)
外接密码键盘获取二维码数据。
SD_IFD_SetMainKey
short USER_API SD_IFD_SetMainKey(HANDLE icdev, unsigned char keyset, unsigned char *oldkey, unsigned char *newkey)
设置外接密码键盘主密钥。
dc_cpy_procommand_hex
short USER_API dc_cpy_procommand_hex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
保留。
dc_ParseTextInfo
short USER_API dc_ParseTextInfo(HANDLE icdev, int charset, int info_len, const unsigned char *info, unsigned char *name, unsigned char *sex, unsigned char *nation, unsigned char *birth_day, unsigned char *address, unsigned char *id_number, unsigned char *department, unsigned char *expire_start_day, unsigned char *expire_end_day, unsigned char *reserved)
解析文字信息。
dc_writeprotect_4428
short USER_API dc_writeprotect_4428(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
写4428卡保护位。
dc_clearlcd_T8
short USER_API dc_clearlcd_T8(HANDLE icdev, unsigned char line)
LCD清屏。
dc_GetUsbMode
short USER_API dc_GetUsbMode(HANDLE icdev, unsigned char *ucmode)
获取USB模式。
dc_KeypadClearKey
short USER_API dc_KeypadClearKey(HANDLE icdev, int number, int set_index, int sub_index)
清除密钥。
SD_IFD_GetEnPIN
short USER_API SD_IFD_GetEnPIN(HANDLE icdev, char *szPasswd)
获取外接密码键盘密文数据。
dc_settime
short USER_API dc_settime(HANDLE icdev, unsigned char *time)
设置设备时间。
dc_write_hex
short USER_API dc_write_hex(HANDLE icdev, unsigned char _Adr, char *_Data)
写卡数据。
dc_i_d_query_name_2
short USER_API dc_i_d_query_name_2(HANDLE idhandle, char *name)
获取姓名。
dc_creat_mac2
short USER_API dc_creat_mac2(HANDLE icdev, unsigned short DataLen, unsigned char *Data, unsigned char *MacData, unsigned char flag)
保留。
dc_i_d_query_finger_len
unsigned int USER_API dc_i_d_query_finger_len(HANDLE idhandle)
获取指纹原始数据长度。
dc_keypad_ImportKey
short USER_API dc_keypad_ImportKey(HANDLE icdev, unsigned char *check_value, unsigned char check_mode, int key_index, int use_key_index, unsigned char enable, const unsigned char *key, int key_len)
保留。
dc_readprotect_4442_hex
short USER_API dc_readprotect_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡保护位。
dc_MulticardStatus
short USER_API dc_MulticardStatus(HANDLE icdev, unsigned char *type)
检测多卡状态。
dc_card_status2
short USER_API dc_card_status2(HANDLE icdev, unsigned char *pos)
检测卡片位置。
dc_MultiAntennaGetCardStatus
short USER_API dc_MultiAntennaGetCardStatus(HANDLE icdev, int *rlen, unsigned char *rdata)
多天线获取卡状态。
dc_i_d_query_nation
char *USER_API dc_i_d_query_nation(HANDLE idhandle)
获取民族。
dc_play_voice
short USER_API dc_play_voice(HANDLE icdev, unsigned char mode)
播放语音。
dc_authentication_2
short USER_API dc_authentication_2(HANDLE icdev, unsigned char _Mode, unsigned char KeyNr, unsigned char Adr)
验证M1卡密码。
dc_checkpass_1604
short USER_API dc_checkpass_1604(HANDLE icdev, short zone, unsigned char *password)
验证1604卡密码。
dc_readwrotect_4442_hex
short USER_API dc_readwrotect_4442_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4442卡保护位。
dc_SelectAntenna
short USER_API dc_SelectAntenna(HANDLE icdev, unsigned char number)
选择天线。
dc_write_1604
short USER_API dc_write_1604(HANDLE icdev, unsigned int offset, unsigned int length, unsigned char *writedata)
写1604卡。
dc_read_idcard_hex
short USER_API dc_read_idcard_hex(HANDLE icdev, unsigned char times, unsigned char *_Data)
读取id卡。
dc_exchangeblock_hex
short USER_API dc_exchangeblock_hex(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
dc_ParseOtherInfo
short USER_API dc_ParseOtherInfo(HANDLE icdev, int flag, const unsigned char *in_info, unsigned char *out_info)
解析其它信息。
dc_Scan2DBarcode
short USER_API dc_Scan2DBarcode(HANDLE icdev, unsigned short time_ms, char *message_data)
扫描二维码。
dc_i_d_query_photo_file
short USER_API dc_i_d_query_photo_file(HANDLE idhandle, const char *FileName)
生成相片图像文件。
dc_PassGet
short USER_API dc_PassGet(HANDLE icdev, unsigned char *rlen, unsigned char *cpass)
获取键盘数据。
dc_Check_24C16
short USER_API dc_Check_24C16(HANDLE icdev)
检测24C16卡。
dc_light
short USER_API dc_light(HANDLE icdev, unsigned short _OnOff)
指示灯点亮/熄灭。
dc_srd_eepromhex
short USER_API dc_srd_eepromhex(HANDLE icdev, short offset, short length, unsigned char *rec_buffer)
读EEPROM。
dc_find_i_d
short USER_API dc_find_i_d(HANDLE icdev)
查找身份证。
SD_IFD_GetPINPro
short USER_API SD_IFD_GetPINPro(HANDLE icdev, char *szPasswd, unsigned char yyflag, unsigned char timeout)
获取外接密码键盘明文数据。
dc_lock_block
short USER_API dc_lock_block(HANDLE icdev, unsigned char flags, unsigned char block, unsigned char *UID)
保留。
dc_pro_commandlinkEXT_hex
short USER_API dc_pro_commandlinkEXT_hex(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG)
非接触式CPU卡指令交互。
dc_SelfServiceDeviceConfigFront
short USER_API dc_SelfServiceDeviceConfigFront(HANDLE icdev, unsigned char mode)
设置前端进卡模式。
dc_startreadmag
short USER_API dc_startreadmag(HANDLE icdev)
启动读磁条卡。
dc_readblock_hex
short USER_API dc_readblock_hex(HANDLE icdev, unsigned char flags, unsigned char startblock, unsigned char blocknum, unsigned char *UID, unsigned char *rlen, unsigned char *rbuffer)
保留。
dc_passin
short USER_API dc_passin(HANDLE icdev, unsigned char ctime)
进入读键盘模式。
dc_WriteDeviceCustomInfo
short USER_API dc_WriteDeviceCustomInfo(HANDLE icdev, const unsigned char *info)
写入设备自定义信息。
dc_request_b
short USER_API dc_request_b(HANDLE icdev, unsigned char _Mode, unsigned char AFI, unsigned char N, unsigned char *ATQB)
寻卡请求。
dc_HL_authentication
short USER_API dc_HL_authentication(HANDLE icdev, unsigned char reqmode, unsigned int snr, unsigned char authmode, unsigned char secnr)
高层验证M1卡密码。
dc_MFPL1_authl1key_hex
short USER_API dc_MFPL1_authl1key_hex(HANDLE icdev, unsigned char *authkey)
验证Mifare Plus卡状态密码（1级）。
dc_cpuapduresponInt_hex
short USER_API dc_cpuapduresponInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer)
接触式CPU卡指令交互。
dc_changeb3_hex
short USER_API dc_changeb3_hex(HANDLE icdev, unsigned char _SecNr, const char *_KeyA, unsigned char _B0, unsigned char _B1, unsigned char _B2, unsigned char _B3, unsigned char _Bk, const char *_KeyB)
M1卡密码配置块操作。
dc_i_d_query_sex
char *USER_API dc_i_d_query_sex(HANDLE idhandle)
获取性别。
dc_GetLastResponseCode
short USER_API dc_GetLastResponseCode(HANDLE icdev, unsigned int *code)
获取最后响应码。
dc_readprotect_4428_hex
short USER_API dc_readprotect_4428_hex(HANDLE icdev, short offset, short length, unsigned char *data_buffer)
读4428卡保护位。
dc_SelfServiceDeviceShakeConfig
short USER_API dc_SelfServiceDeviceShakeConfig(HANDLE icdev, unsigned char mode)
抖动模式设置。
dc_changepin_4428
short USER_API dc_changepin_4428(HANDLE icdev, unsigned char *passwd)
修改4428卡密码。
dc_i_d_query_finger_file
short USER_API dc_i_d_query_finger_file(HANDLE idhandle, const char *FileName)
保留。
dc_mulrequest_b
short USER_API dc_mulrequest_b(HANDLE icdev, unsigned char _Mode, unsigned char AFI, unsigned char *cardnum, unsigned char *mulATQB)
保留。
dc_TestNic
short USER_API dc_TestNic(HANDLE icdev, const unsigned char *data_buffer, int data_len)
测试网卡。
dc_i_d_query_sex_2
short USER_API dc_i_d_query_sex_2(HANDLE idhandle, char *sex)
获取性别。
dc_BtCommand
short USER_API dc_BtCommand(HANDLE icdev, int slen, const unsigned char *sdata, int *rlen, unsigned char *rdata)
蓝牙模块通讯。
dc_pro_reset_hex
short USER_API dc_pro_reset_hex(HANDLE icdev, unsigned char *rlen, char *receive_data)
非接触式CPU卡复位。
dc_readreadersnr
short USER_API dc_readreadersnr(HANDLE icdev, unsigned char *snr)
获取设备序列号。
dc_CvClose
short USER_API dc_CvClose(HANDLE icdev, int number)
关闭摄像头。
dc_set2dot4Gbaund
short USER_API dc_set2dot4Gbaund(HANDLE icdev, unsigned char baund)
设置2.4G模块波特率。
dc_ReadDeviceCustomSerialNumber
short USER_API dc_ReadDeviceCustomSerialNumber(HANDLE icdev, unsigned char number, char *data)
读设备定制序列号。
dc_TestUsb
short USER_API dc_TestUsb(HANDLE icdev, const unsigned char *data_buffer, int data_len)
测试USB。
dc_pro_commandlinkInt_hex
short USER_API dc_pro_commandlinkInt_hex(HANDLE icdev, unsigned int slen, char *sendbuffer, unsigned int *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_checkprint
short USER_API dc_checkprint(HANDLE icdev, unsigned char *FontSize, unsigned char *Alignment, unsigned char *LeftMargin, unsigned char *RightMargin, unsigned char *RowPitch, unsigned char *PrintOutRate)
查询打印机参数。
dc_select2
short USER_API dc_select2(HANDLE icdev, unsigned int _Snr, unsigned char *_Size)
第二级选卡操作。
dc_cpy_procommandInt
short USER_API dc_cpy_procommandInt(HANDLE icdev, unsigned int slen, unsigned char *sendbuffer, unsigned int *rlen, unsigned char *databuffer, unsigned char timeout)
保留。
dc_write_random
short USER_API dc_write_random(HANDLE icdev, short length, unsigned char *data)
保留。
dc_checkcopy_m1
short USER_API dc_checkcopy_m1(HANDLE icdev, unsigned char mode)
保留。
dc_MFPL3_authl3key
short USER_API dc_MFPL3_authl3key(HANDLE icdev, unsigned int keyBNr, unsigned char *authkey)
验证Mifare Plus卡状态密码（3级）。
dc_i_d_query_finger_2
short USER_API dc_i_d_query_finger_2(HANDLE idhandle, unsigned char *finger)
获取指纹原始数据。
dc_i_d_query_expire_day_2
short USER_API dc_i_d_query_expire_day_2(HANDLE idhandle, char *expire_day)
获取有效期限。
srd_alleeprom
short USER_API srd_alleeprom(HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读EEPROM。
dc_read_153_hex
short USER_API dc_read_153_hex(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *readdata)
读153卡。
dc_check_write
short USER_API dc_check_write(HANDLE icdev, unsigned int Snr, unsigned char authmode, unsigned char Adr, unsigned char *_data)
检查之前写入的数据。
dc_decrypt
short USER_API dc_decrypt(char *key, char *ptrSource, unsigned short msgLen, char *ptrDest)
保留。
dc_GetCpuCardPps
short USER_API dc_GetCpuCardPps(HANDLE icdev, unsigned char *mode)
接触式CPU卡PPS配置获取。
dc_read_24c64_hex
short USER_API dc_read_24c64_hex(HANDLE icdev, short offset, short length, unsigned char *receive_buffer)
读24C64系列卡。
dc_CreatSm4DataECB
short USER_API dc_CreatSm4DataECB(HANDLE icdev, unsigned char keytype, unsigned char enmode, int slen, unsigned char *sourcedata, int *rlen, unsigned char *retdata)
用工作密钥加解密。
dc_pro_commandsourcehex
short USER_API dc_pro_commandsourcehex(HANDLE icdev, unsigned char slen, char *sendbuffer, unsigned char *rlen, char *databuffer, unsigned char timeout)
非接触式CPU卡指令交互。
dc_cpy_getkey
short USER_API dc_cpy_getkey(HANDLE icdev, unsigned char *respkey, int *resplen)
保留。
dc_MFPL0_writeperso
short USER_API dc_MFPL0_writeperso(HANDLE icdev, unsigned int BNr, unsigned char *dataperso)
Mifare Plus卡设置个人化数据（0级）。
dc_pro_commandlink
short USER_API dc_pro_commandlink(HANDLE icdev, unsigned char slen, unsigned char *sendbuffer, unsigned char *rlen, unsigned char *databuffer, unsigned char timeout, unsigned char FG)
非接触式CPU卡指令交互。
dc_CalculateSm4
short USER_API dc_CalculateSm4(HANDLE icdev, unsigned char keyindex, unsigned char enmode, unsigned short datalen, unsigned char *srcdata, unsigned char *sm4data)
保留。
dc_ScreenDisplayText
short USER_API dc_ScreenDisplayText(HANDLE icdev, unsigned char font_size, const unsigned char *fg_rgb, const unsigned char *bg_rgb, int x, int y, int time_s, unsigned char line_flag, unsigned char voice_flag, const char *text)
显示文字。
dc_card_hex
short USER_API dc_card_hex(HANDLE icdev, unsigned char _Mode, unsigned char *snrstr)
寻卡请求、防卡冲突、选卡操作。
dc_write_153
short USER_API dc_write_153(HANDLE icdev, unsigned char zone, unsigned int offset, unsigned int length, unsigned char *writedata)
写153卡。
dc_GetBankMagInfo
short USER_API dc_GetBankMagInfo(HANDLE icdev, int type, char *track1, char *track2, char *track3)
获取银行卡磁条信息。
dc_i_d_query_photo_bmp_buffer
short USER_API dc_i_d_query_photo_bmp_buffer(HANDLE idhandle, unsigned char *BmpBuffer, unsigned int *BmpLength)
生成相片图像数据。
dc_hltb
short USER_API dc_hltb(HANDLE icdev, unsigned char *PUPI)
保留。
dc_write_24c_hex
short USER_API dc_write_24c_hex(HANDLE icdev, short offset, short length, unsigned char *snd_buffer)
写24C系列卡。
dc_LedDisplay
short USER_API dc_LedDisplay(HANDLE icdev, unsigned char number, unsigned char mode, unsigned char value)
数码管显示。
dc_read
short USER_API dc_read(HANDLE icdev, unsigned char _Adr, unsigned char *_Data)
读卡数据。
dc_check_153
short USER_API dc_check_153(HANDLE icdev)
检测153卡。
dc_changeb3
short USER_API dc_changeb3(HANDLE icdev, unsigned char _SecNr, unsigned char *_KeyA, unsigned char _B0, unsigned char _B1, unsigned char _B2, unsigned char _B3, unsigned char _Bk, unsigned char *_KeyB)
M1卡密码配置块操作。
dc_i_d_query_photo
unsigned char *USER_API dc_i_d_query_photo(HANDLE idhandle)
获取相片原始数据。
dc_GetMag
short USER_API dc_GetMag(HANDLE icdev, unsigned char *mode, unsigned char *track1, unsigned char *track2, unsigned char *track3)
磁条卡参数获取。